none
Windows 7 Network File Sharing Permissions

    Question

  • In this case I'm working with two PC's . PC3 & PC2. Both are on the same Workgroup and were joined to a HomeGroup. PC3 has files that I'd like to share with my wife on PC2. There are other people on the network that shouldn't have access to these files. We both (Mike & Beth) have accounts on both computers with the same password on each.

    I initially tried to share just granting Mike & Beth permission using the Sharing Wizard hoping that would work since we were both on the Home group and had the same passwords. No joy. I then did some reading and found that if I linked password using Windows Live that I could better structure the permissions. I did so and now Windows Live Mike and Beth can see the Files but can't write or delete. Beth actually has trouble opening Excel spreadsheets even though she can see them.

    Advanced options showed that both the regular accounts and the Windows Live versions had full control. I turned off the Sharing Wizard thinking that maybe the simple sharing was overriding the advanced, but that didn't change the situation.

    I have tried turning on and off "Password Protected Sharing" and changing the settings under "Homegroup Connections" in Advanced Sharing Settings.  The only thing I've found that would work is to share the files with Homegroup with the Sharing Wizard. That defeats the purpose of permissions.

    Any help is appreciated,

    Mike

    Friday, January 14, 2011 12:52 PM

Answers

  • DMBrew wrote:

    I have previously turned off Homegroup on both computers and had the
    Firewall off on PC3, but I tried it again and turned off the firewall
    on PC2 as well.  IT didn't do any good. I still cannot write to the
    folder from PC2.

    So users from PC3 can write to their allowed shares on PC2, but users
    cannot do the same from PC2 to PC3?

    If that's true you have to look deeper into the configuration
    differences between those 2 PCs.

     

    I also changed the workgroup name just to try something and I checked
    that they are both set to "homenetwork" That didn't do any good
    either.

    That has to be changed to workplace network, to get fully advanced
    sharing possiblilties.


    Thanks for the effort. Any other ideas would be appreciated.

     

    Mike

     

     


    Wolfgang
    • Marked as answer by DMBrew Wednesday, January 19, 2011 6:40 PM
    Wednesday, January 19, 2011 1:47 AM

All replies

  • I hvae similar prob ... i have 4 pcs in my home network...and i need to share some files with some pcs ........ some files with pc1 ....some(other files) with pc 2.....   some (other other files) with pc3 .....    and ..... os : windows 7(all pc)
    Desktop: OS : Microsoft Windows 7 Ultimate Rating : 5.5 Laptop: OS : Microsoft Windows 7 Ultimate Rating : 5.5 ..............." Microsoft is not about greed. It's about innovation and fairness"
    Friday, January 14, 2011 8:49 PM
  • DMBrew wrote:

    In this case I'm working with two PC's . PC3 & PC2. Both are on the
    same Workgroup and were joined to a HomeGroup. PC3 has files that I'd
    like to share with my wife on PC2. There are other people on the
    network that shouldn't have access to these files. We both (Mike &
    Beth) have accounts on both computers with the same password on each.

    I initially tried to share just granting Mike & Beth permission using
    the Sharing Wizard hoping that would work since we were both on the
    Home group and had the same passwords. No joy. I then did some
    reading and found that if I linked password using Windows Live that I
    could better structure the permissions. I did so and now Windows Live
    Mike and Beth can see the Files but can't write or delete. Beth
    actually has trouble opening Excel spreadsheets even though she can
    see them.

    Advanced options showed that both the regular accounts and the
    Windows Live versions had full control. I turned off the Sharing
    Wizard thinking that maybe the simple sharing was overriding the
    advanced, but that didn't change the situation.

    I have tried turning on and off "Password Protected Sharing" and
    changing the settings under "Homegroup Connections" in Advanced
    Sharing Settings.  The only thing I've found that would work is to
    share the files with Homegroup with the Sharing Wizard. That defeats
    the purpose of permissions.

    Any help is appreciated,

    Mike

    Are you and your wife administrators of your PCs? If yes, then you most
    probably are faced with UAC remote restrictions. See
    http://support.microsoft.com/kb/951016/en-us which will possibly help
    in this situation. (Although not mentioned, you need to reboot after
    changing the settings, to get it to work). It is for Vista but works
    equally for Win7.


    Wolfgang
    Monday, January 17, 2011 9:09 PM
  • Hi Mike,

     

    Before going further, would you please let me know what error message is received when trying to access files.

     

    To share the files to a specific person, you can choose the folder and click Share with button in the toolbar from Windows Explorer. Please also add the following settings about the shared folder.

     

    Please right click folder -> Properties -> Advance Sharing -> check Share this folder, click Permission -> add your wife's account and click Ok. Go to Security Tab and also add the accounts.

     

    Regards,

    Niki


    Please remember to click "Mark as Answer" on the post that helps you, and to click "Unmark as Answer" if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Tuesday, January 18, 2011 8:07 AM
  • Thanks for the response Wolfgang,

    Until this morning, I was an administrator and my wife was a limited user. I needed to upgrade her because we have Office 2003 on that box and it won't run as a limited user so I did that this morning. I checked the registry for the value in the article and it was not present so I added it and restarted the computer. Still no luck. See the next response for more info. Thanks for the idea, I'm about ready to try anything.

    • Edited by DMBrew Tuesday, January 18, 2011 3:52 PM typos
    Tuesday, January 18, 2011 3:07 PM
  • Hi Niki,

    Both of us can see all of the files. I just tried to modify a spread sheet and it gave me this error: "**** is read only. To save a copy click OK, then give the workbook a new name." If I try to do that and save it in the same folder, I get: "Cannot save M:\Our documents\**** The folder is marked as read only.

    The root of the drive is shared to Everybody and the folder in question is Shared to both Mike and Beth as well as Windows Live linked Mike and Beth. I generally access the Share feature that you describe by right clicking  but it goes to the same place. In that box all users described have Read/Write access.

     

    "> Properties -> Advance Sharing -> check Share this folder, click Permission ->"    This piece I had been missing. I've added Mike and Beth there with full permissions. I was unable to add Windows Live linked Mike and Beth. Those passwords are linked on both computers. I was not able to write to the drive after doing this.

     

    "Go to Security Tab and also add the accounts. "    Mike & Beth as well as the linked Passwords are shown on this screen with full control for each of them and have been most of the time I've been trying this.

    I really don't understand the hierarchy of how these three screens work together, but I guess I don't need to as long as they all work. Unfortunately they don't. I do appreciate the ideas and I'll keep trying till I find something that works, but I need new ideas, I'm fresh out of things to try.

     

    Thanks, Mike

     


     


     

    Tuesday, January 18, 2011 3:51 PM
  • DMBrew wrote:

    Thanks for the response. Until this morning, I was an administrator
    and my wife was a limited user. I needed to upgrade her because we
    have Office 2003 on that box and it won't run as a limited user so I
    did that this morning. I checked the registry for the value in the
    article and it was not present so I added it and restarted the
    computer. Still no luck. See the next response for more info. Thanks
    for the idea, I'm about ready to try anything.

    If you want to use user and password restricted access it is necessary
    to turn off homegroup networking. Set your network to a workplace (or
    workgroup -  or whatever that is named in English - as I don't have an
    English version up in the moment) network and set your sharing
    properties to use username and password instead of homegroup networking
    connections. And remove your PCs from the homegroup. Then in advanced
    sharing mode you have to share your shared file-directories explicitly
    to the other user and set his security to full control or read-write.

    If that does not help disable the firewall completely on both PCs and
    see if that helps.


    Wolfgang
    Tuesday, January 18, 2011 4:48 PM
  • I have previously turned off Homegroup on both computers and had the Firewall off on PC3, but I tried it again and turned off the firewall on PC2 as well.  IT didn't do any good. I still cannot write to the folder from PC2.

     

    I also changed the workgroup name just to try something and I checked that they are both set to "homenetwork" That didn't do any good either.

     

    Thanks for the effort. Any other ideas would be appreciated.

     

    Mike

     

     

    Tuesday, January 18, 2011 6:28 PM
  • DMBrew wrote:

    I have previously turned off Homegroup on both computers and had the
    Firewall off on PC3, but I tried it again and turned off the firewall
    on PC2 as well.  IT didn't do any good. I still cannot write to the
    folder from PC2.

    So users from PC3 can write to their allowed shares on PC2, but users
    cannot do the same from PC2 to PC3?

    If that's true you have to look deeper into the configuration
    differences between those 2 PCs.

     

    I also changed the workgroup name just to try something and I checked
    that they are both set to "homenetwork" That didn't do any good
    either.

    That has to be changed to workplace network, to get fully advanced
    sharing possiblilties.


    Thanks for the effort. Any other ideas would be appreciated.

     

    Mike

     

     


    Wolfgang
    • Marked as answer by DMBrew Wednesday, January 19, 2011 6:40 PM
    Wednesday, January 19, 2011 1:47 AM
  • Wolfgang,

    There were no files on PC2 that we need to access. I try to keep everything centralized on PC3.

    Your suggestion to change to a workplace network resolved the problem! I have read many things over the past week and I have never even seen that setting mentioned. and its use is not well documented. I didn't even have to reboot or log out.

    Your help is greatly appreciated and I hope that you have a well deserved Bier this evening!

    Thanks again,

    Mike

    Wednesday, January 19, 2011 6:45 PM
  • DMBrew wrote:

    Wolfgang,

    There were no files on PC2 that we need to access. I try to keep
    everything centralized on PC3.

    Your suggestion to change to a workplace network resolved the
    problem! I have read many things over the past week and I have never
    even seen that setting mentioned. and its use is not well documented.
    I didn't even have to reboot or log out.

    Your help is greatly appreciated and I hope that you have a well
    deserved Bier this evening!

    Thanks again,

    Mike

    Good to hear - glad, that you got it working!

    Regards


    Wolfgang
    Thursday, January 20, 2011 11:21 PM
  • Wolfgang, I signed up just to reply to your thread. You have solved an issue I have been dealing with for a long time. I am not sure why file sharing has been turned in to something so convoluted with Windows 7. Also, I can't understand why there is such little documentation available and other people that have posted this issue get a more or less boiler plate response from Microsoft support personnel, but thank you a lot. Changing all of my computers to the "Work Network" instead of "Home Network" made it work beautifully! -Vic
    Friday, February 18, 2011 8:27 PM
  • Just to keep up with your status:

    - have you checked your IPv6 status (must be activated)

    the following services must also be started and running;
    - HomeGroup Listener
    - HomeGroup Provider
    - Peer Networking Resolution Protocol
    - Peer Networking Grouping
    - Peer Networking Identity Manager

    ...all of those are the minimum I think to get HomeGroup networking to function.

    Hope this points you in the correct direction.

    Friday, March 25, 2011 3:20 PM
  • I was looking for a solution for this problem too, and I found the solution.  All the computers on my network have password sharing and file & printer sharing turned on but I do not have rights to paste, change, or delete files on network computers. We are all joined on the same homegroup. Annoyed, I right-clicked the folders that I wanted to share and went to 'share with'.  This popup box varied between my computers.  Some simply said 'advanced sharing' while others said nobody, homegroup (read), homegroup (read/write), and 'specific people'. Even if I shared the folder by clicking homegroup (read/write), my other computers still did not have permissions.

    To change this, I right clicked the folder that I wanted to share, went to properties> sharing > advanced sharing.  I checked [x] 'share this folder' and then hit 'permissions'.  I could not add network users specifically because I run windows home instead of professional.  I could however add the user, HomeGroupUser$  and I clicked OK.  In then selected HomeGroupUser$ in the permissions window and checked [x] full control. Do these same steps for the Security tab of the folder you want to share.  Add HomeGroupUser$ to the security tab and give that user full control. After doing this, all the computers on my homegroup had full control of the shared directory.  I navigated to this directory by clicking network in the start menu.  You can also hit windowskey + R and type " \\InsertRemoteComputerName " to open a network computer.  Note, you can create a shortcut to a shared folder on another computer by right clicked that shared folder and creating a shortcut.  I usually pin my shortcuts the favorites heading on the left side of my windows explorer (folder window).

    If you have homegroup users that you do not want to have access to your files, id remove them from the homegroup and have them join their own.




    Wednesday, September 12, 2012 9:42 PM