none
Prompt for XPMUser password

    Question

  • I recently installed some applications onto my XP VM and now I'm getting a prompt for an XPMUser password.  How do I get rid of this or is there a standard password that I can input here?  I would hate to loose a days worth of work and have to restart theis VPC.  Pelase help!
    Tuesday, August 11, 2009 10:09 PM

Answers

  • Allright, so if you are sure that your password is blank, try this.
    1. Turn off/shutdown the vm.
    2. Open its settings, in Integration Features section, uncheck the checkbox that says automatically enable at start up(similar to that). click ok
    3. Now boot the vm. At the login prompt, enter user name as (the xpmuser as displayed in the setup wizard), and hit enter (password blank), this should log you in.
    4. Now, open command prompt, and execute "net user (username) (password)", if successfuly, your new xpm user password is reset to  (password), if you wish to change the whole profile, you can just add a new user account and make it a member of Administrators group.
    5. Now, open settings, go to "Credentials" page, and delete credentials. ALso, now go to integration features page, and enable "integration features at startup" checkbox.
    6. Shutdown vm. (if you like it quick, just kill "vmwindow.exe" process in taskmanager)
    7. Start the vm again, it should prompt for credentials, and you can enter the newly set credentials, and do remember to check the "Remember Credentials";

    Do reply if it helped.
    Thanks, Rashmi U.R
    • Marked as answer by Andy Song Monday, August 31, 2009 2:39 AM
    Monday, August 24, 2009 8:41 PM

All replies

  •   You must have entered this twice  when you set it up. (You also get the option to have the OS remember it). What did you enter? Have you tried the password you use to log on to Win  7?


     
    Bill
    Wednesday, August 12, 2009 12:56 AM
  • It's in the XP Virtual machine that is installed for the XP Mode in Windows 7.  I didn't enter anything.

    Wednesday, August 12, 2009 4:40 PM
  • Bill is correct. When you set up XP VM for first time, wizard asks you for password. You need to remember it. (password of user which logs you into the XP VM)
    Thanks, -Vinod -- "This posting is provided "AS IS" with no warranties, and confers no rights. You assume all risk for your use."
    Wednesday, August 12, 2009 5:05 PM
  • HUmm, I don't remember doing that.  Drat!  Thanks.
    Wednesday, August 12, 2009 5:38 PM
  • How would I set it to automatically login again?
    Wednesday, August 12, 2009 5:52 PM
  • I am afraid, this is not possible unless you know the password. Did you ever deleted the stored password using settings? I am wondering how you got into this situation?


    Thanks, -Vinod -- "This posting is provided "AS IS" with no warranties, and confers no rights. You assume all risk for your use."
    Thursday, August 13, 2009 6:24 AM
  • Well, same thing happened to me... I did NOT enter any password when installing WindowsXPMode_en-us, and it worked fine until I tried to start the application which didn't work in Win7 (hence the XP-mode). Before I installed the application, the XPMode logged me in automatically with the XPMUser and a password with 5 characters. All passwords I use are at least 8 characters...

    So when I tried to start the app in XP-Mode from the start menu in Win 7, I get prompted for the password for XPMUser. I have no clue whatsoever what that is, so now I have a completely useless Virtual XP Machine...

    Monday, August 24, 2009 11:22 AM
  • Allright, so if you are sure that your password is blank, try this.
    1. Turn off/shutdown the vm.
    2. Open its settings, in Integration Features section, uncheck the checkbox that says automatically enable at start up(similar to that). click ok
    3. Now boot the vm. At the login prompt, enter user name as (the xpmuser as displayed in the setup wizard), and hit enter (password blank), this should log you in.
    4. Now, open command prompt, and execute "net user (username) (password)", if successfuly, your new xpm user password is reset to  (password), if you wish to change the whole profile, you can just add a new user account and make it a member of Administrators group.
    5. Now, open settings, go to "Credentials" page, and delete credentials. ALso, now go to integration features page, and enable "integration features at startup" checkbox.
    6. Shutdown vm. (if you like it quick, just kill "vmwindow.exe" process in taskmanager)
    7. Start the vm again, it should prompt for credentials, and you can enter the newly set credentials, and do remember to check the "Remember Credentials";

    Do reply if it helped.
    Thanks, Rashmi U.R
    • Marked as answer by Andy Song Monday, August 31, 2009 2:39 AM
    Monday, August 24, 2009 8:41 PM
  • I just get prompted for a password when my VM is open in its normal window - not integerated apps mode) and my Win7 host is woken from hibenation. I took care to write down the password it told me (p2ssw0rd ) during setup - I did not specify it, but it doesn't work - maybe i wrote it down wrong. I have to shutdown the VM and invoke a XP mode app again to get it to log in (or use my backup admin account - which has different user setttings, so i end up restarting it anyway). I would rather not go thru Rashimi's reset intructions just yet, seeing as everything is working.

    Anyone seen this password (p2ssw0rd ) before or know if i did write it down wrongly?
    Hunter
    • Proposed as answer by c a m u s o Monday, September 28, 2009 6:07 PM
    Monday, September 07, 2009 12:16 AM
  • Sorry, I've misunderstood 'propose as  answer'. I simply wanted to answer, instead...

    This 'solution' worked for me:
    - closed the VM
    - launched an application labelled 'xp mode' (not the VM which boots and presents xp desktop but a 'normal' seven window as a 'native' seven application); I hope you've at least one installed within xp mode environment;
    - close the application
    - launch xp mode and .. voilà... no more password was requested to me
    • Proposed as answer by RobK858 Thursday, January 12, 2012 3:51 PM
    Monday, September 28, 2009 6:17 PM
  • I was having the same issue as well and like you I thought I never set a password for this. It turned out I did, after trying every possible password I would set for my operating systems, I tried a password that I set for my email account and I got in. 
    Friday, October 16, 2009 10:36 PM
  • Mine did the exact same thing.  The PW was 12345. 
    • Proposed as answer by Porter_26 Sunday, November 01, 2009 8:54 PM
    Sunday, November 01, 2009 8:53 PM
  • I didn't set one for mine either.  The PW was set to 12345.

    Sunday, November 01, 2009 8:54 PM
  • Man, glad to hear I'm not the only one hammered by this mysterious need for a password for XP mode.  But none of the above has resolved my issue of not being able to login as XPMuser.  Arrrrghh!

    I DID NOT (intentionally) set a password for XP Mode when setting it up.  The Install went well and I was able to install a couple of my XP legacy programs just fine and have been using them all week long.  I've been able to Hibernate and and restart the XP mode with out issue all week long.  But then all of a sudden this damn need for a password for XPMuser.   I did make a recent change to the Auto Publish feature, when trying to learn about how it worked.  I'm wondering if that change somehow triggered the problem.

    I've got to resolve it because I'd already started using and updating data.

    Any other ideas out there.  I'm pretty desperate.

    Cheers,
    Friday, January 22, 2010 10:57 PM
  • CAMUSO,
     
    Couild you elaborate on what you wrote above; "launched an application labelled 'xp mode' (not the VM which boots and presents xp desktop but a 'normal' seven window as a 'native'  seven application); '

    I'm not sure I'm tracking what you suggest.  The only thing is my START menu, all programs, is "windows Virtual PC" and when I click on that I get "Windows Applications XP Mode. and when I click on that I can see the links to the legacy programs I set up when it was working.   But when trying to launch them from teh WIN7 Start, all it does it re-start XP mode and I'm still confronted with the same XPMuser password issue.

    Thanks,

    Friday, January 22, 2010 11:12 PM
  • I have the exact same issue!  I installed the Windows XP Mode and was never even prompted for a password during installation.  It now defaults to XPMUser with no password.  I'm guessing a bad Windows Update.  HELP!
    Sunday, January 24, 2010 7:48 AM
  • I'm lighting up another XP test box right now...
    Sunday, January 24, 2010 7:49 AM
  • Found a work around but it's ugly...


    1.When on the windows xp logon with the XPMUser displayed, click "options" then "shutdowns".  It will install two windows updates.
    2. When it is done, select the windows xp virtual machine and click "settings", and make sure "integration features is UNchecked".
    3.  Log back on the windows xp virtual box and it will once again go to the XPMUser display.
    4.  Now click on "tools" and "install integration features."
    5. It will restart and log directly into the windows xp virtual machine. Once you get in, goto "local users and groups" and find the XPMUser. Right Click on the user and set the password. After that, it would be a good idea to create anther admin account on the box so as to ensure a backup plan.




    ***Tested and working!  I can now sign in as XPMUser after setting the password. 
    • Proposed as answer by Mentalshake Sunday, January 24, 2010 8:23 AM
    Sunday, January 24, 2010 7:54 AM
  • I know this has been long since settled. Seeing I had the same problem myself and kind of resolved it with a solution different to all that has been mentioned herein, I thought it might help if I shared my solution with all. I do not recall setting up an XPMUser password when I did configure my XP virtual machine, or if I did set a password, then I must have used the same password as for the native Windows 7 user, because all I had to do is try my Win7 password and it was accepted straight away, though I had previously tried the blank password for XPMuser with no success. This can only suggest 2 things, either XP mode assigns the password of the native Win7 user who is installing the XP virtual machine by default or it does actually ask for a password which one needs to recall for future use.

    I hope this helps or adds to the grief..... :D

     

    Saturday, April 03, 2010 2:26 PM
  • It actually asks for the password when setting up the VM -- it doesn't default to the host's password...
     
     

    Bob Comer - Microsoft MVP Virtual Machine
    Saturday, April 03, 2010 3:31 PM
  • Did not work for me.

    I had to go more "hadrcore":

    I used Hiren Boot Cd ISO, mounted it as CD drive in XP Mode machine, then boot from CD.

    There are come tools used to reset windows user password. 

    So reset password, then reboot VM.

    I was able to log in as XPMUser, without password.

    I set new pass and now is everything fine.

    • Proposed as answer by SarjanWebDev Thursday, July 22, 2010 2:58 PM
    Thursday, April 22, 2010 11:22 AM
  • Thanks Krzysztof for this tip. Nothing else would work for me either. For anyone else attempting this, by default the VM doesn't boot from CD but always harddrive first, i.e. XP. What one has to do is do a real (re)boot and then when the window opens and is still black, very quickly press the <DEL> key to get into the BIOS. If you see XP booting you were too slow and have to reboot. In the BIOS, the boot order has to be changed to CD-ROM first, then harddrive.

    As Krzysztof said, the ISO file for the CD can be mounted directly in the options for the VM. No need to burn a physical CD. As for where to find the ISO, try the usual places (*caugh*orrent*caugh*). It's called "Hiren's Boot CD" and is in version 10.4 now. Ironically, the part that we are using here is Linux-based and all free but there is other commercial stuff on it that we actually don't need. Can anyone recommend an alternative?

    ~Chris

    • Proposed as answer by luka10002 Tuesday, April 27, 2010 8:42 PM
    Friday, April 23, 2010 9:25 PM
  • RESTART XP MODE

    ( IF U CAN NOT go to your  install folder and delete Windows XP Mode.vsv then run XP mode)

    WHILE it is rebooting before windows XP LOGO press and hold F8 key then select SAFE MODE.

    Log in as administrator with no pass. now use manage or other way to reset admin pass and enable acc.

     

    RESTART and log in with new settings

    • Proposed as answer by luka10002 Tuesday, April 27, 2010 8:42 PM
    Tuesday, April 27, 2010 8:41 PM
  • Thank you!

    This worked perfectly.

    Best regards, Uli

    Wednesday, May 05, 2010 10:06 AM
  • After trying several solutions this is the one that worked for me.  Thank you luka10002!!!  I no longer have to start from scratch - all data is as it was and I have set a password and created a backup account as well - just in case.

    Thanks again.

    Stephen

    Monday, May 17, 2010 5:09 PM
  • Hi, 

    That was the perfect solution for me. Everything is all right now.

    Many Thanks,

    Best regards,

    Ahmad

    Monday, May 31, 2010 11:54 AM
  • I cannot find a file called Windows XP Mode.vsv nor any file with .vsv extension on my machine. I did get to boot into safe mode, but I was still prompted to enter the password for XMPUser. Am I missing something? 
    Sunday, June 13, 2010 1:57 PM
  • OOps.

    I did eventually find the .vsv file.

    Sunday, June 13, 2010 2:08 PM
  • I deleted the .vsv file but on going into safe mode I was still asked the XPMUser password.
    Sunday, June 13, 2010 2:13 PM
  • Hiren Boot Cd did the trick for me.  Thank you.
    Sunday, June 13, 2010 3:55 PM
  • login as administrator ,in safe mode u can delete user name and write another., u can do it with hiren aslo.
    Monday, June 14, 2010 11:53 AM
  • RESTART XP MODE

    ( IF U CAN NOT go to your  install folder and delete Windows XP Mode.vsv then run XP mode)

    WHILE it is rebooting before windows XP LOGO press and hold F8 key then select SAFE MODE.

    Log in as administrator with no pass. now use manage or other way to reset admin pass and enable acc.

     

    RESTART and log in with new settings

    This worked flawlessly, and is by far the best possible fix
    • Proposed as answer by Majeed Makooie Friday, August 31, 2012 1:39 PM
    Wednesday, June 16, 2010 3:49 PM
  • Simple and brilliant, thank you.

    I will note that Action, Restart from the VM menu doesn't work, I had to select "Restart" from the logon prompt.

    Once into Safe with a blank admin password, I just did Start, Run control userpasswords2, reset XPMUser and was back in business.

    I'll add to the list of people that do not remember setting the XPMUser password during initial setup.

     

    Sunday, June 27, 2010 3:28 AM
  • Did not work for me.

    I had to go more "hadrcore":

    I used Hiren Boot Cd ISO, mounted it as CD drive in XP Mode machine, then boot from CD.

    There are come tools used to reset windows user password. 

    So reset password, then reboot VM.

    I was able to log in as XPMUser, without password.

    I set new pass and now is everything fine.

    It worked for me too. Rashmi U R's solution will work only if you did not specify a password when creating the Windows XPMode instance. For others like me  who set a password and have forgotten, here you go.

    - Download latest Hiren's boot CD as a ZIP file from http://www.hirensbootcd.net/download.html on your Windows 7 and extract to a known location like D: or desktop.

     - Right click on "C:\Users\<USERNAME>\Virtual Machines\Windows XP Mode.vmcx" and goto settings

      -- DVD Drive > Open ISO Image and Browse the Hiren's Boot CD ISO file from the folder extracted above.

      -- Integration Features > UNCHECK Enable at startup

    -  Save the changes and close the settings dialog.

    - Double Click the Windows XP Mode.vmcx icon (or run WinXPMode from Start Menu) and keep punching DELETE key on keyboard until you see the BIOS Screen, Set the Boot Order Priority to CD FIRST. Press F10 to save and exit.

    - After reboot, you should see the Hiren's boot CD DOS based menu screen From which select MiniXP

    - When MiniXP loads, from the Desktop Run The Hirens CD Menu Program. This has only one menu and one button <BROWSE> From the menu select Password Tools > Windows Account Password reset Tool. The tool requires to specify a windows directory, choose your XPMode C:\Windows Directory. and then choose 'XPMode' as a user to reset the password for, specify a new password THAT YOU CAN REMEMBER (Mind well, passwords are never meant to be written down). Click Finish and you are done.

    - Now shut down the MiniXP that should also shutdown the XPMode.

    - Make sure you turn the Integration Features back on and start the Win XPMode again and key in the new password that you set to use the Win XPMode normally.


    ManMis
    • Proposed as answer by SarjanWebDev Thursday, July 22, 2010 3:13 PM
    • Edited by SarjanWebDev Thursday, July 22, 2010 3:16 PM Telling why the marked answer is incomplete.
    Thursday, July 22, 2010 3:13 PM
  • Hi Rashmi,

    I have the similar problem wherein i am stuck on the XPMUser window in my virtual machine. I have gone in the settings and unticked the enable integration flag and restarted the virtual machine but still no luck.

    Is there any way you can or someone can help. Please explain me step by step if possible. I ahve a software that is installed on my virtual machine which i cannot afford to loose.

    Your help will be much apprecaited.

    Thanks

    Jas

    Friday, August 06, 2010 11:57 PM
  • luka10002 this was spot on! Thanks for the post, this worked for me and is exactly what I needed to know: is there a 'backdoor' for XP Virtual Mode? (Honorable mentions to Rashmi and Krzysztof).

    Great job; it's much appreciated!

     

    Larry L.

    Sunday, August 22, 2010 10:17 PM
  • luka1002, YOU ARE GOD SENT!!! EXCELLENT AND EASY SOLUTION !!! CHEERS
    Wednesday, September 08, 2010 6:51 AM
  • Hi Rashmi,

    I have the similar problem wherein i am stuck on the XPMUser window in my virtual machine. I have gone in the settings and unticked the enable integration flag and restarted the virtual machine but still no luck.

    Is there any way you can or someone can help. Please explain me step by step if possible. I ahve a software that is installed on my virtual machine which i cannot afford to loose.

    Your help will be much apprecaited.

    Thanks

    Jas


    what is the problem?
    Monday, October 04, 2010 7:55 AM
  • I, too, was never prompted to enter a password during setup.

    However, I followed the camuso's suggestion, and it worked again.

    I did open a program via the Start Menu > Windows Virtual PC > Windows XP Mode Applications > In my case, I opened Mavis Beacon (My version will only run in XP mode).

    After running an application in XP mode and closing the program, I was able to Open the XP Virtual PC and was not prompted for a password.

    Everything's back to the way it was before.

    Thanks, camuso.

    Friday, October 15, 2010 6:34 AM
  • Well, my scenario is a bit different, but I think it will help. (Or just skip the scenario & try "XPMUser" as the User Name & Password {Capital X, P, M & U })

     

    I am running Windows 7 64bit Home Premium. Since XP mode, for some reason, is incompatible with my iteration of Windows 7, I was going to set up a Virtual XP 32bit manually.
    I went to the site to download it {http://www.microsoft.com/windows/virtual-pc/} but when you go to the download page, it only has a download option for 'XP Mode'.
    When I selected 'Home Premium 64-bit' it just gives me a "Give us more money" Anytime Upgrade link.
    Since I have 27 XP licenses (19 for Pro) and only 5 are in use (although a couple are OEM) I have no problem using my own license for Virtual XP. But since I don't want to get Virtual PC from some file sharing site, I tried selecting 'Professional 64-bit' and it does the whole validating thing, then come back with 3 download links; for XP Mode, Virtual PC, & the XP Mode Update.
    I downloaded them all, thinking that the XP Mode wouldn't work, but thinking that it would take less time to try than an install. & thinking it would be smaller since the download is 500MBs.
    After the install, of course, when I click on the 'Windows XP Mode' Shortcut it gives me a "Windows XP Mode is not available in  this edition of windows" message. No shocker.
    But when I try to run the Virtual Machine file it says that it can't write to the virtual hard drive.
    So I tried un-'read-only'ing it, but it won't let me, so I copied the .vhd file to another location, changed it's attributes, renamed the original, and copied it back. Poof! It's alive!
    I go through the setup, like I do on a standard install; time zone, keyboard, etc. Administrator Password, and afterwords, go to set up a user account for the credentials to run under & I see a disabled user named 'XPMUser' .
    I enable it, log-off and it requires a password.
    I do a Google Search (I did a Bing too but it wasn't very helpful) and find a link to this page, check it out, try a couple of defaults like "Password" & "admin" then I try the username with the same capitalization & Voila, I'm in.
    By this time I've activated it with MY product key & installed the plethora of updates. Taking my .VHD file from 1,184MB to 2,500ish. Now, after activating & logging on with the XPMUser account my .VHD file has grown to 3,378 MB.

    Now, it was my thought that the advertised features, like the advertised "Folder integration between host and guest -Access your Windows 7 Known Folders: My Documents, Pictures, Desktop, Music, and Video, from inside the virtual Windows environment, such as Windows XP Mode. " would be available if I used the XPMUser account. As far as I can tell it's just like a default Administrator account.

    I've started over with a new copy of the original .vhd file a few time because I discovered things; like how uninstalling windows components (like games, outlook express, MSN Explorer) actually cause my .vhd to get bigger instead of smaller or accidentally installing .NET with the updates and finding my .vhd to be 7,297MB. But it's easy, just make another copy of the original and rename it back to the original name after you make it not read-only .

    The problem I keep running into is the 'Folder integration' & I get an IP Address conflict with another device on the network & nothing I do fixes it.

    Sunday, October 24, 2010 12:54 PM
  • Same here - i never set a password, and 12345 works
    • Proposed as answer by GlenEv Tuesday, November 02, 2010 11:08 AM
    Wednesday, October 27, 2010 3:49 PM
  • I had exactly the same problem. I was never asked for a password until installing integration features. Then the window came up with ID as XPM user and asking for 'credentials'; otherwise, I was locked out.

    I eventually managed to get in by using the last password I had typed into the system - for another program within XP mode, earlier in the day.

     

     

    Tuesday, November 02, 2010 11:12 AM
  • I've read for HOURS trying to found out my problem -- somehow, someway, my XPMUser account was DISABLED so I could never use the Integrated Features as the credentials could never match an existing/active user account.

    I used the F8 method to get into my administrator account, dug deep into the password/user name confines, ENABLED the XPMUser account, and made sure to reset the passwords to match. FINALLY! I'm back in business!

    Wednesday, January 19, 2011 7:44 AM
  • I think I have a very simple solution and I have double checked that it works. 

     

    1.  Select 'Tools' - 'Settings' from the top menu while still in virtual PC.

    2.  Go to 'Integration Features' and deselect the 'Enable at Startup'

    3.  Select 'Tools' - 'Enable Integration Features'

     

    You will bypass the password screen immediately. 

    • Proposed as answer by One IT NZ Tuesday, April 26, 2011 9:12 PM
    Thursday, February 17, 2011 1:59 AM
  • Tried every method here without success until...

    Followed Sarjan's instructions as closely as I could.  I downloaded version 13.1 of Hiren's Boot CD and the menu items are slightly different.  Windows Account Password Reset tool is not there by that name, but tried the Password tool with the closest name and it worked beautifully. 

    I set XPMUser password according to my protocol, rebooted and everything worked as if I never had the problem.

    Thanks!

    Thursday, February 17, 2011 7:11 PM
  • Thanx. 
    Tuesday, March 15, 2011 2:03 PM
  • I think I have a very simple solution and I have double checked that it works. 

     

    1.  Select 'Tools' - 'Settings' from the top menu while still in virtual PC.

    2.  Go to 'Integration Features' and deselect the 'Enable at Startup'

    3.  Select 'Tools' - 'Enable Integration Features'

     

    You will bypass the password screen immediately. 

    I would just like to say that I accidentally stumbled upon this solution myself and it indeed does work.

    I had made a copy of my XP Mode VHD and created a new Virtual Machine for testing on.

    When I fired it up the first time it was prompting for the password.

    I came across this forum and tried the Disabling the Integration Features on Startup

    Then booted the VM and it still prompted for the password so I clicked Tools and Enable Integration Features again and it logged me straight in.

     

    Thanks Everyone for the ideas.

    Tuesday, April 26, 2011 9:14 PM
  • This is the only solution which will help you reset your password for XPM User & login successfully -


    Log On with Default Administrator Account

    It’s possible to try accessing Windows XP Mode with the default administrator account named “Administrator”, which has been made to only display in Safe Mode. By default, there is no password for Administrator account, so it can be used to reset the password of the password of other accounts.

    To do this, please perform the steps below:

    1. On Windows XP Mode window, click on Tools -> Disable the Integration Features.
    2. Restart the Windows XP Mode.
    3. When the Boot Menu appears at startup, press F8.

      Note: Keep pressing the F8 key until the Windows Startup menu appears.

    4. On the Windows Advanced Options Menu, select Safe Mode and press ENTER.
    5. Log into Windows by using the Administrator account and password.

      Note: The password is blank by default unless you already set a password.

    6. After logging into Safe Mode, click Start, go to Run, type in nusrmgr.cpl and press ENTER.
    7. Choose the user you want to modify and Click Reset Password.
    8. Set a new password.
    9. Click Advanced tab, Click Advanced button.
    10. Click Users.
    11. Choose the user you want to modify in the right pane. Right it and Click Properties.
    12. Check and tick the box of Password never expires.
    13. Click OK.
    14. Quit the settings and restart Windows XP Mode to the normal mode.
    15. When log on to Windows XP Mode, remember to check the box Remember my credentials so that you no need to enter the password again.
    Thursday, April 28, 2011 4:53 AM
  • This is the only solution which will help you reset your password for XPM User & login successfully -


    Log On with Default Administrator Account

    It’s possible to try accessing Windows XP Mode with the default administrator account named “Administrator”, which has been made to only display in Safe Mode. By default, there is no password for Administrator account, so it can be used to reset the password of the password of other accounts.

    To do this, please perform the steps below:

    1. On Windows XP Mode window, click on Tools -> Disable the Integration Features.
    2. Restart the Windows XP Mode.
    3. When the Boot Menu appears at startup, press F8.

      Note: Keep pressing the F8 key until the Windows Startup menu appears.

    4. On the Windows Advanced Options Menu, select Safe Mode and press ENTER.
    5. Log into Windows by using the Administrator account and password.

      Note: The password is blank by default unless you already set a password.

    6. After logging into Safe Mode, click Start, go to Run, type in nusrmgr.cpl and press ENTER.
    7. Choose the user you want to modify and Click Reset Password.
    8. Set a new password.
    9. Click Advanced tab, Click Advanced button.
    10. Click Users.
    11. Choose the user you want to modify in the right pane. Right it and Click Properties.
    12. Check and tick the box of Password never expires.
    13. Click OK.
    14. Quit the settings and restart Windows XP Mode to the normal mode.
    15. When log on to Windows XP Mode, remember to check the box Remember my credentials so that you no need to enter the password again.


    I hope that anyone that finds this page reads the MOST RECENT replies, because after trying a few of the firsts, THIS is the one that was the easiest and WORKS!!!!!!!!!

    Thanks you Bhavin, for posting this here- it helped me solve my mother's problem quickly and easily!!!

    KUDOS!!!!!

    Thursday, May 05, 2011 12:14 AM
  • Thanks this work for me

     

    Wednesday, May 11, 2011 1:27 AM
  • Thank you Bhavin!

    You saved me from having to delete the VPC and starting all over!

    Your procedure was easy and worked first time.

    I couldn't find the 'advanced' tab, so I ended up opening Control Panel, Administrative Tools, Computer Management, Local Users and Groups, Users, and verified that 'Password never expires' was checked.

    Rich.

    Wednesday, May 11, 2011 1:31 PM
  • This is the only solution which will help you reset your password for XPM User & login successfully -


    Log On with Default Administrator Account

    It’s possible to try accessing Windows XP Mode with the default administrator account named “Administrator”, which has been made to only display in Safe Mode. By default, there is no password for Administrator account, so it can be used to reset the password of the password of other accounts.

    To do this, please perform the steps below:

    1. On Windows XP Mode window, click on Tools -> Disable the Integration Features.
    2. Restart the Windows XP Mode.
    3. When the Boot Menu appears at startup, press F8.

      Note: Keep pressing the F8 key until the Windows Startup menu appears.

    4. On the Windows Advanced Options Menu, select Safe Mode and press ENTER.
    5. Log into Windows by using the Administrator account and password.

      Note: The password is blank by default unless you already set a password.

    6. After logging into Safe Mode, click Start, go to Run, type in nusrmgr.cpl and press ENTER.
    7. Choose the user you want to modify and Click Reset Password.
    8. Set a new password.
    9. Click Advanced tab, Click Advanced button.
    10. Click Users.
    11. Choose the user you want to modify in the right pane. Right it and Click Properties.
    12. Check and tick the box of Password never expires.
    13. Click OK.
    14. Quit the settings and restart Windows XP Mode to the normal mode.
    15. When log on to Windows XP Mode, remember to check the box Remember my credentials so that you no need to enter the password again.

    Thank you Thank you Thank you, Finally after trying everything this worked.

    Only thing The Advanced tab was not appearing in the password/user account window so I had to find a solution for this and this worked

    On the start/run window type     control userpassswords2    this brought up the screen where the Advanced button was.

    Like several people have noted, I also did not set a password when setting up XPMode.

    Sunday, May 22, 2011 11:48 PM
  • Thank you, this last solution is what worked for me too - same thing, I don't remember ever setting a password for XPMUser in the first place...

    However, I had a lot of trouble at the beginning, since the Menu item Tools DOES NOT appear in the toolbar when in Full Screen mode. Once I accidentally figured this out, the rest worked perfectly with the Virtual machine run in a window.

    Thanks again!

    Wednesday, May 25, 2011 7:40 PM
  • Agreed!  This worked perfectly!  Like many others I started from the top down and did most of them first (except use Hiren) with no success.  However, this is not all bad.  I am much more familiar with the XP Mode application now.  That is always a good thing!  Thanks Bhavin!

     

    Wednesday, July 13, 2011 10:43 PM
  • This didn't work for me.  I have been using the Virtual PC for over a month.  I NEVER SET UP A PASSWORD - Period.  Then today - Windows did an update as I was using FrontPage in virtual XP and suddenly I'm being asked for a password. You might want to do some research - there are hundred and maybe thousands of Windows 7 users with this problem and no fix in sight!
    Saturday, July 23, 2011 8:32 PM
  • Vinod - I had the same problem - THERE WAS NO PASSWORD - period.  I have been using the Virtual PC for over a month without an issue.  Then today - Windows did an update as I was using FrontPage in virtual XP and suddenly I'm being asked for a password. You might want to do some research - there are hundred and maybe thousands of Windows 7 users with this problem and no fix in sight!
    Saturday, July 23, 2011 8:34 PM
  • And if you never set a password Bob?  Why is this happening?  and how do you fix it?  Why not answer the question with a real solution

     

    Saturday, July 23, 2011 9:46 PM
  • >And if you never set a password Bob?  Why is this happening?
     
    I don't know, but I guess it was an update that changed RDP back to
    the original RDP requirement of a password.
     
    I always set a password so I never ran into it personally...
     
    >and how do you fix it?  Why not answer the question with a real solution
     
    I did -- set a password.  Sorry I'm no more help than that, I really
    don't have any inside information as to what changed.
     
    To set a password, first start the VM, select the menu option to
    disable the integration components, then go into the VM's settings
    "Logon credentials page" and click the "Delete saved credentials"
    button.
     
    Log into the VM and go the control panel / Users, select your use and
    then create password.  After that is all don't, shut down the VM, then
    start it again, key in the password on the prompt and click save, then
    okay.  It shouldn't ask for it again.
     
     
     

    Bob Comer - Microsoft MVP Virtual Machine
    Saturday, July 23, 2011 10:03 PM
  •   I can only agree with Bob. When you install XPMode it requests a password for XPMUser and will not proceed until you enter one. (I know that there are lots of posts claiming that this did not happen for them). All I can say is that I have installed XPMode on lots of different machines from the beta versions through to now and have always been prompted for a password (an have never been able to proceed until I entered a valid password twice). 

      If you are using saved credentials you will not have to enter it again (unless something screws up your saved credentials).

     


    Bill
    Sunday, July 24, 2011 12:20 AM
  • I have setup XP Mode on 2 different computers.  Neither time did a wizard prompt me for a password.  On both computers the requirement for a password for XPMUser has popped up.

    The first time out, I simply deleted the VM and started over since not much had been done with it yet.  On this computer, the situation is different.  I've already got stuff running in the VM and don't want to it lost.  Also, why would I want to uninstall the VM every time I run into this issue.

    TheOldMan

    Monday, August 08, 2011 5:20 PM
  • Worked like a champ.  Had to create a password though after the initial login.

    TheOldMan

    Monday, August 08, 2011 5:51 PM
  • Microsoft's default password for OSes is:

    P@ssw0rd

    That worked for me! Yeah! I am the best!
    Monday, August 15, 2011 5:44 PM
  • Best Answer Ever - Lost password for VM in Windows-7

    Steps:

    1)Reboot VM

    2)Hit F8

    3) login as "administrator" no password need - hit enter - leave password blank

    4) Safe Mode - change password settings etc

    5) Reboot and enjoy Virtual XP

    Monday, August 22, 2011 1:47 PM
  • Thanks a lot, i got the same problem as every body here is asking for help and your solution works perfect, it realy funtion on this situation.

    Leandro

    Brazil

    Wednesday, September 07, 2011 2:19 PM
  • RESTART XP MODE

    ( IF U CAN NOT go to your  install folder and delete Windows XP Mode.vsv then run XP mode)

    WHILE it is rebooting before windows XP LOGO press and hold F8 key then select SAFE MODE.

    Log in as administrator with no pass. now use manage or other way to reset admin pass and enable acc.

     

    RESTART and log in with new settings

    perfectly worked for me
    Monday, October 17, 2011 10:33 PM
  • Thanks a lot

     

    Thursday, October 20, 2011 10:28 AM
  • You Are the Number One!

    Thank to You Very Much.

     

    It Works Perfect!

     

    Juan Antonio

    Thursday, February 02, 2012 2:59 AM
  • Thank you Rashmi. This worked for me!
    Friday, March 30, 2012 8:32 PM
  • I got it right slightly differently. XP mode wanted to install windows genuine advantage when I did a microsoft software update and I think this caused the password issue. Just pressed F8 when XPMUser password was requested. Went straight into validation and XP Mode without a problem or entering password. XP Mode was validated and now appears to work fine
    Friday, April 06, 2012 9:44 AM
  • Thanks!

    This works just perfect!

    Friday, May 04, 2012 7:37 PM
  • I had to say something. I have been in tears trying to log into school unsuccessfully for one day! Here is what finally worked...Keep in mind I DID NOT CHOOSE TO PUT A PASSWORD ON THIS ACCOUNT!!! I have three possible passwords. The VM in XP mode chose one from my 3 for me. So when you log in after 3 tries it will default to XPuser or whatever, instead of your login name. Then you put in your password from email, or school or banking.
    • Proposed as answer by Superdom Thursday, November 15, 2012 9:24 PM
    Friday, October 05, 2012 10:33 PM
  • Hi, I have have the same issue on my VM after reinstallation of Windows 7 Ultimate. Windows put the password i have enter at the Win 7 installation for XPMUser.

    I never do this. Windows do it alone.


    SuperPapy

    Thursday, November 15, 2012 9:26 PM
  • RESTART XP MODE

    ( IF U CAN NOT go to your  install folder and delete Windows XP Mode.vsv then run XP mode)

    WHILE it is rebooting before windows XP LOGO press and hold F8 key then select SAFE MODE.

    Log in as administrator with no pass. now use manage or other way to reset admin pass and enable acc.

    RESTART and log in with new settings


    THANKS Luka, that was the first and only solution which WORKED! Thanks a lot!
    Thursday, December 20, 2012 2:04 PM
  • Recientemente he instalado algunas aplicaciones en mi XP VM y ahora estoy recibiendo un mensaje para una contraseña XPMUser. ¿Cómo me deshago de este o hay una contraseña estándar que puede introducir aquí? No me gustaría perder unos días el valor del trabajo y tenga que reiniciar theis VPC. Pelase ayudar!
    123456
    Friday, December 28, 2012 6:24 PM
  • Yes! I used the native password of Win7.

    Thanks

    Tuesday, April 16, 2013 4:51 PM
  • Thank for your help luka10002.

    This tip work fine.... is easy and quickly...

    Friday, June 21, 2013 3:31 PM
  • I have done this and still no work I really need to get into XP mode cause windows XP is the only program that my online classes will work in so is their any other way of getting into XP mode without knowing the PW
    Wednesday, July 17, 2013 2:19 AM
  • This is the only solution:

    Restart your Windows XP mode and while is rebooting before windows XP LOGO press and hold F8 key then select SAFE MODE.

    Log in as administrator with no pass. right click on m computer then click on Manage click on users. you will see our username then right click on it and click reset password . enter the new password and retype it.

     

    RESTART and log in with new password

    Faroukos Azrock

    Thursday, August 29, 2013 6:17 PM
  • Hi, there is no neccesary delete the file Windows XP Mode.vsv

    works anyway

    Saturday, April 26, 2014 1:28 PM
  • This is the only solution that works. Thanks luka10002
    Monday, May 05, 2014 1:52 PM
  • Rashmi,

    I followed all your instructions, but it was not working for me...

    still I couldnt inside the vitual mode, XPMUSER is keep prompting..

    Regards

    durai

    Monday, June 30, 2014 4:22 PM
  • this worked perfectly.
    Wednesday, August 13, 2014 1:11 PM