none
System icon rendering problem in Win7 Ult x64

All replies

  • Hi,

    I can not see the picture. Would you please upload the sfcdetails.txt to SkyDrive and provide us the link for analyzing

    http://cid-4b2f155953942dc9.skydrive.live.com/summary.aspx

    The above Windows Live ID is ONLY for collecting troubleshooting information. Please do NOT send your questions to it. For any new questions, please post in the forums so that more MSFT, MVP and community members can help you.

    When did the issue occurs? System restore can be under consideration if recently occured.

    As non-system icons were not affected, mostly, the icon issue is caused by cache corrupted issue. If any icon problem is encoutnered, try the following steps to troubleshoot the problem.

    Rebuild the Icon Cache

    ==================

    1. Boot the computer into Safe Mode.

    2. Launch Task Manager using the CTRL+SHIFT+ESC.

    3. In the Process tab, right-click on the Explorer.exe process and select End Process.

    4. From the File menu of Task Manager, select New Task (Run…)

    5. Type CMD.EXE and press Enter.

    6. In the Command Prompt window, run the commands one by one:

    CD /d %userprofile%\AppData\Local

    DEL IconCache.db /a

    7. In Task Manager, click File, select New Task (Run…)

    8. Type EXPLORER.EXE and press Enter.

    9. Restart the computer into Normal Mode. 

    Monday, January 11, 2010 5:18 AM
  • Alright, here's some additional details. When I first log in, the system icons in the tray are fine. I don't know the exact trigger, but going into a fullscreen application and then returning to the desktop is one way to create the problem.

    Specifications of my system: Windows 7 Ultimate x64 - all Microsoft Updates
    Dell Studio XPS 1645
    Intel Core i7 820QM
    ATI Mobility Radeon HD 4670 1GB - tested with driver version 8.650 and 8.682 (POST CATALYST 9.12)
    1920x1080 32-bit color 60Hz
    Aero is on
    117% DPI / 112dpi resolution

    I'm not sure where to find sfcdetails.txt - I can post it as soon as I figure that out.

    Will test a little more.
    Monday, January 11, 2010 6:00 AM
  • Hi,

    I can see the picture now.

    From your description, this issue only occurs after returnning from a fullscreen application to desktop. I would like to know if all full screen application can duplicate the issue. If so, what are they, examples?

    I suggest boot int9 Clean Boot as a test.
    =============
    This method will disable loading program or service from start up to avoid any conflict that cause this issue.
     
    1. Click "Start",and type "msconfig" (without the quotation marks) in the open box to start the System Configuration Utility.
    2. Click the "Services" tab, check the "Hide All Microsoft Services" box and click "Disable All" (if it is not gray).
    3. Click the "Startup" tab, click "Disable All" and click "OK".
    4. Click "OK" to restart your computer to Selective Startup environment.
    5. When the "System Configuration Utility" window appears, please check the "Don't show this message or launch the System Configuration Utility when Windows starts" box and click OK.
    6. Check whether or not the issue still appears in this environment.
    Tuesday, January 12, 2010 10:26 AM
  • You can test it yourself- it seems Microsoft didn't bother to test the UI with DPI's other than 96 and 120. The Windows icons render differently in all DPI - shouldn't they be the same? Also, Windows Media Player doesn't seem to recognize or render the options panels correctly with DPI set to 110%/108. This sucks, 96dpi is too small and 120 dpi is waaay too big, but some built-in Windows programs don't render correctly even though this is built right into the operating system.


    Edit: Anyway I changed from 117%/112DPI to 110%/108DPI because the icons render correctly in this resolution. But as with other resolutions, Windows Media Player options panel is screwed up. This shouldn't happen in a modern program designed to be compatible with high resolution displays. ;_;

    http://strags.com/i/110-percent-108dpi.png

    Friday, January 15, 2010 2:14 AM
  • Just out of curiosity, is there any evidence that it works in the two default cases?  96 and 120?  I'm just wondering if they set WMP's options correctly in any case but the 96.



    If this was helpful, please vote by clicking the green triangle. If it solves the issue, click Propose as Answer. Thanks!
    Friday, January 15, 2010 4:05 AM
  • Hi,

    It works fine on my PC.

    I was wondering if you are using Aero. If so, there might be conflict with the display card driver. So, I suggest disable Aero by choosing a Windows classic theme as a test.

    Tuesday, January 19, 2010 10:31 AM