none
0x80072ee4 error in Store for any app after Windows 8.1 Upgrade

    Question

  • Just in installed 8.1 directly from the Store (Win 8 Pro). Everything went smoothly.

    Now when I go into the Store and try and install (or update, as it says apps are broken) any app, it says

    "Something happened and your purchase can't be completed. Error code 0x80072ee4". No other details in Event log.

    Plus it now want me to switch over to a MS account to install anything. I prefer a local account.

    Thursday, October 17, 2013 6:00 PM

Answers

  • For anyone else with this, the solution was that the Temporary Internet Files folder was wrong in Internet Explorer. Run IE, go into Internet Options, click Settings in Browsing History section, click Move Folder and set to something valid like "c:\Users\<username>\AppData\Local\Microsoft\Windows".

    • Marked as answer by cdmisyt Thursday, October 17, 2013 6:47 PM
    Thursday, October 17, 2013 6:47 PM

All replies

  • You have an issue with the Internet connection:

    C:\Users\André>err 0x80072ee4
    # anonymous HRESULT: Severity: FAILURE (1), Facility 0x7, Code 0x2ee4
    # for hex 0x2ee4 / decimal 12004
      ERROR_INTERNET_INTERNAL_ERROR                                  inetmsg.h
      ERROR_WINHTTP_INTERNAL_ERROR                                   winhttp.h
      ERROR_INTERNET_INTERNAL_ERROR                                  wininet.h
    # 3 matches found for "0x80072ee4"

    Try again later. The Microsoft Servers are under heavy stress now.


    "A programmer is just a tool which converts caffeine into code"

    Thursday, October 17, 2013 6:14 PM
  • Try again later. The Microsoft Servers are under heavy stress now

    Thanks, That certainly could explain it, although a more user friendly message would be useful, especially saying is a temporary error rather than permanent one. However, I'd expect to see more people complaining of the same problem and hadn't come across any others.

    Oddly, it's downloading the app just fails to install them.

    • Edited by cdmisyt Thursday, October 17, 2013 6:22 PM
    Thursday, October 17, 2013 6:21 PM
  • For anyone else with this, the solution was that the Temporary Internet Files folder was wrong in Internet Explorer. Run IE, go into Internet Options, click Settings in Browsing History section, click Move Folder and set to something valid like "c:\Users\<username>\AppData\Local\Microsoft\Windows".

    • Marked as answer by cdmisyt Thursday, October 17, 2013 6:47 PM
    Thursday, October 17, 2013 6:47 PM
  • thanks for sharing the solution :)

    "A programmer is just a tool which converts caffeine into code"

    Thursday, October 17, 2013 6:56 PM
  • Just tried this several times and makes no difference sadly.

    Any other suggestions welcomed.

    Thanks

    Adam

    Thursday, August 07, 2014 2:30 PM