none
Microsoft Security Essentials won't update, error -0x80240022

    Question

  • I installed MSE then let it update and the update fails with error -0x80240022.



    I uninstalled and reinstalled, same error. Google gets lots of hits for Windows Defender, but none seem to apply. Any suggestion on how to resolve this?

    I'm running Windows 7 RC1 Build 7100 (I'll have my retail Pro version some time next week).

    I had Comodo Internet Security suite installed before this but uninstalled it as it interfered with Windows Backup, so I uninstalled it and installed MSE. If I can't get this fixed soon I'll have to go back to Comodo, which is no longer a concern as I tried Windows Backup and don't like it.
    Rich
    Tuesday, November 10, 2009 4:09 AM

Answers

All replies

  • Security Essentials Troubleshooting Tips, Help & How-To’s | Microsoft Security Essentials:
    http://www.microsoft.com/security_essentials/HelpTopic.aspx?mkt=en-us&assetId=07d9d0c8-b081-42a8-8856-f1b0ddc261d9#mainNav

    BTW, there is a separate forum dedicated to Microsoft Security Essentials.

    Microsoft Security Essentials:
    http://social.answers.microsoft.com/Forums/en-US/category/mse

    Ramesh Srinivasan, Microsoft MVP [Windows Desktop Experience]
    Wednesday, November 11, 2009 6:10 AM
    Answerer
  • In addition, you can check your current time setting as the error 0x80240022 may refer to:

    "The time service has detected that the system time needs to be changed by %1 seconds. The time service will not change the system time by more than %2 seconds. Verify that your time and time zone are correct, and that the time source %3 is working properly."

    Hope this helps!
    Sean Zhu - MSFT
    • Proposed as answer by GMHilltop Friday, April 16, 2010 9:22 PM
    Wednesday, November 11, 2009 7:44 AM
    Moderator
  • I have been fighting with this for a while -- Maybe this has something to do with it, because this worked for me.

    I had my windows updates set to:   "Check for updates but let me choose whether to download and install them"

    I am bandwidth limited and I didn't want an update to suddenly kill what I was trying to do 'at that moment'.

    As soon as I set it back to:   "Install updates automatically (recommended)"   It worked immediately.

    Hopefully this helps (everyone - users/developers) solve this frustrating problem.

    • Proposed as answer by BD72 Tuesday, May 17, 2011 6:00 PM
    Friday, April 16, 2010 9:28 PM
  • where exactly do you go to change the windows updates?
    Thursday, July 08, 2010 5:41 PM
  • To change the windows update go to My Computer and right click, Go to Properties and then go to automatic updates. Other way is to start the stopper automatic updates service from services window. If you are facing the Microsoft Security essentials update error please visit the under given URL on www dot itoperationz dot com:

    www.itoperationz.com/2010/03/microsoft-security-essential-update-error

    I hope this will you to resolve this issue

    Thursday, August 26, 2010 2:43 PM
  • Changing this setting worked for me.

     

    Thanks,

     

    Bruce

    Tuesday, May 17, 2011 6:01 PM
  • That worked for me. Thanks :) 
    Monday, April 30, 2012 9:22 AM
  • It doesn't work for me. I've tried 4 or 5 methods but I can't fix it. When trying to update win 7 or security essentials, the system just tells: error 0x80240022.

    Does it mean I got my computer infected? Malware?

    Thanks fellas

    • Edited by atagp Monday, July 16, 2012 10:45 PM
    Monday, July 16, 2012 10:42 PM
  • restarting the windows update and Background Intelligent Transfer services solved this issue for me running 2008 r2
    Monday, December 24, 2012 4:59 PM
  • restarting the windows update and Background Intelligent Transfer services solved this issue for me running 2008 r2
    That worked for me too! :)
    Monday, February 04, 2013 10:30 PM
  • That worked for me too! I'm also using a 2008 box.

    Thanks!


    • Edited by .COM Tuesday, July 16, 2013 4:52 PM Edit
    Tuesday, July 16, 2013 4:50 PM