none
Event Viewer Warning: "WLAN AutoConfig Service has successfully stopped"

    Question

  • I have recently installed a desktop with Windows 7 64bit OS.  I connect to the internet (wireless) thru Linksys Router WRT54G2, using an Atheros 802.11 a/b/g/n Dualband Wireless Network Module.   Everything is working fine  with no problems.  However, I am getting a WARNING on my Event Viewer each time I shut the pc down, as follows:  

    "Event 4001 WLAN AutoConfig Service has successfully stopped".  

    This is the only Warning or Error to appear repeatedly in my Event Viewer and it is very confusing to me.  If the service has stopped SUCCESSFULLY, why is it a warning - why isn't it just information?  I have "googled" for an answer, but find nothing.   I have tried disabling IPV6, thinking my router doesn't support it, but that has no effect.   Can someone please explain to me how to stop the warnings, or understand why they are not just information rather than warnings?  Thanks.
    Wednesday, February 24, 2010 7:29 PM

Answers

  • This event message is categorized as a warning because the WLAN-related functionalities stop working after the WLAN AutoConfig Service stops. You can consider it as informative if everything works fine. 

    Thanks,
    Yi
     

    Tuesday, March 02, 2010 1:31 AM

All replies

  • Hi,

     

    Based on my research, I would like to suggest the following:

     

    1.    Check status and the start type of the WLAN AutoConfig service.

     

    2.    Remove and reinstall the driver for the Atheros 802.11 a/b/g/n Dualband Wireless Network Module; if there is a new version of driver for Windows 7, please install it.

     

    3.    Boot the system to clean boot environment and check the issue:

     

    How to troubleshoot a problem by performing a clean boot in Windows Vista or in Windows 7

     

    Hope this helps. Thanks.


    Nicholas Li - MSFT
    Friday, February 26, 2010 10:23 AM
    Moderator
  • Thanks for reply - I need a little clarification on... 

    1.  What action do I take after I check status and start type of the WLAN AutoConfig service?  It is now "started" and set at "Automatic".

    2.  There is no new version of the driver for the Atheros 802.11 a/b/g/n Dualband Wireless Network Module.  Do you mean still to remove and reinstall the same driver for this even though no new version is found?

    3. I haven't tried this procedure yet, since I was unsure of the first two items.  Everything seems to be running properly and this warning in the event viewer only occurs once a day (at shutdown) with no consequences.   This is the ONLY error or warning I am getting on a daily basis.  It seems as thought this warning is maybe a little misclassified by the event viewer? 

    Appreciate your answers on these - and your help.  Thanks.
    Monday, March 01, 2010 10:04 PM
  • This event message is categorized as a warning because the WLAN-related functionalities stop working after the WLAN AutoConfig Service stops. You can consider it as informative if everything works fine. 

    Thanks,
    Yi
     

    Tuesday, March 02, 2010 1:31 AM
  • Thanks for input - just wish Microsoft has chosen to categorize this event as "information" not as "warning", but I will live with it that way and ignore the daily warning.   Appreciate your response.  Makes my event viewer have some activity, I guess.....lol.
    Tuesday, March 02, 2010 3:26 PM
  • Yi - one other thing - is there a site where I can contact and bring this to Microsoft's attention so it can be corrected (classified as informational rather than warning)  in future updates?
    Sunday, March 21, 2010 2:08 PM
  • I would like to know too because it's very troublesome getting all these warnings

     


    Of course, it's just my opinion....I could be wrong!
    Friday, June 11, 2010 3:08 AM
  • I am having this exact warning in my error log with the same wireless card, but I am dropping internet connectivity until I manually enable wireless autoconfig in services.msc, or enable wireless in device manager. I have already reinstalled the drivers, but that has not resolved the issue. I have just reciently disabled ip6 because I read elsewhere that might help. 

    Any ideas?

    Wednesday, May 11, 2011 3:42 PM