none
Disable mouse-over effect on taskbar?

    Question

  • So, I've put the taskbar on the old-fashioned simple smaller option where I get small icons and text instead of the big icons that tell you nothing. But I'm wondering if there's a way to get rid of the affect that makes it light up orange when you mouse-over a program? It used to light up orange when I got a new IM when I ran XP, so I keep thinking that people are talking to me and it's driving me nuts.
    Tuesday, January 12, 2010 3:08 AM

All replies

  • Hi,

    The highlight color of a taskbar button is decided from the most intense color in the application icon. (IE is blue, firefox is brown, Excel is green, etc..)

    They take some of the colours from the actual icon, if you do not want orange color, simply change the icon of the program. Sadly, the display icons of most programs are decided by the program not the system.

    In addition, I would like to make sure if the symptom makes you thinking someone talking to you as you just mouse-over the folder yourself.
    Wednesday, January 13, 2010 5:39 AM
  • Oh, I see. Interesting, but still kind of annoying and distracting. Now that I've been using Windows 7 for a bit longer I've realized it's not just a mouse-over effect, but the last window you moused-over actually stays lit up in the taskbar so the taskbar is constantly lit up on one window or another, one colour or another. Is there any way to turn that off altogether?
    Thursday, January 14, 2010 10:24 AM
  • Not a direct answer to your question, but consider setting the Taskbar to Auto-hide.  I find it a distraction except for when I'd like to choose another program.  I kind of already know what program is active.

    -Noel
    Thursday, January 14, 2010 11:21 PM
  • If the last program you moused-over is staying lit-up, a video driver update will probably cure that issue:  it happened to me several times and after updating my laptop's nVidia driver, it worked perfect.





    If this was helpful, please vote by clicking the green triangle. If it solves the issue, click Propose as Answer. Thanks!
    Friday, January 15, 2010 4:11 AM
  • From your description, it is strange fore taskbar to behave like that. When did the color freezing issue occur? Does it happen all the time, to all user account?

    I agree with Shawn B. Keene to update your graphic card driver as well as all the other device driver from Device manager->right click on the device-> properties->update the driver software to check the result.

    Friday, January 15, 2010 10:22 AM
  • To be clear, the active application's button on the task bar will be a little different than the others that are not active:  It should be a little lighter, more opaque.

    But no button should stay colored unless the mouse is on it.

    -Noel
    Friday, January 15, 2010 3:42 PM
  • Yes, nothing should stay lighted without mouse covering. Is it any specific application? Given this situation, I would like to know if disabling Aero will be of any help.
    Monday, January 18, 2010 3:09 AM
  • i have the same problem, the previous application usually stays highlighted and it's annoying.

     

    i've sinced changes themes to windows classic.

    Saturday, March 20, 2010 3:07 AM
  • I've been having the same problem since I upgraded to Windows 7.  I restart every day and I've noticed that the problem never exists at the start of the day. I can get through some days without the problem appearing.  I haven't been able to nail down exactly what causes the problem to appear.  I think it might have something to do with an interaction with a program that isn't pinned to the taskbar.  Something getting closed that was the active program, something grabbing your attention and not properly letting it go.  I'm not sure.  All I can tell is that the taskbar just stops registering that your mouse has left it.  It highlights the last thing your mouse was over and even triggers the mouseover tooltip.  I have Aero disabled and all my video card drivers are up to date.  The only solution I've been able to find is to restart.
    Tuesday, July 13, 2010 8:52 PM
  • This happened to me very often and was annoying me until I got the updated graphics drivers for my computer.  In my case, it was an nVideo GoForce 7700 driver.
    If this was helpful, please vote by clicking the green triangle. If it solves the issue, click Propose as Answer. Thanks!
    Tuesday, July 13, 2010 11:36 PM

  • 1.Click on Start button and type GPEdit.msc in Instant Search text box, then hit Enter.
    2.Navigate to User Configuration -> Administrative Templates -> Start Menu and Taskbar in left pane of Local Group Policy Editor.
    3.Locate and double click on Turn off taskbar thumbnails in right pane of Local Group Policy editor.


    4.Select Enabled radion button.
    5.Click OK to make the change effective.
    6.Logoff and logon again or restart computer if needed.
    7.To re-enable Taskbar preview feature in Windows 7, just set the value to Disabled or Not Configured.
    Alternatively, it’s also possible to manually set or configure the registry key to disable Taskbar thumbnails function.

    1.Click on Start button and type RegEdit in Instant Search text box, then hit Enter.
    2.In the Registry Editor, navigate to the following registry key:
    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

    Note: If Explorer registry sub-key does not exist, then right click on Policies and click New -> Key and name it as “Explorer”.

    3.In the right pane, right click on a blank spacce, and then select New -> DWORD (32-bit) Value.
    4.Type TaskbarNoThumbnail as the name for the new registry value data.
    5.Double click on TaskbarNoThumbnail to modify its value data.
    6.Type 1 and click on OK.


    7.Logoff and logon again or restart computer if needed.
    8.To re-enable Taskbar thumbnails again, just right click on TaskbarNoThumbnail and click Delete to remove the whole registry key, or set TaskbarNoThumbnail value data to 0.
    Above manual registry editing step can be done easily by simply downloading the following registry registration files, and then double click it to merge into system registry.

    To Disable Taskbar Thumbnails Preview: Disable-Taskbar-Thumbnails.reg
    To Enable Taskbar Thumbnails Preview: Enable-Taskbar-Thumbnails.reg

    Note: Unfortunately, the trick to disable and turn off Taskbar opened window thumbnail preview may or may not work and the setting is reserved for Windows Vista only, depends on build of Windows 7. Here’s few other alternative workarounds to disable thumbnail preview on Windows 7 Taskbar.

    Workaround 1 – Disable Windows Aero Theme

    Taskbar Thumbnail Preview only works when you have enable Windows Aero desktop effects in Windwos 7. Thus, when Windows Aero is disabled, the Taskbar thumbails will not be displayed, and will be replaced with a list view of opened windows with only text instead.

     

    To disable Windows Aero, just select a non-Windows Aero theme in Personalization of Control Panel. Of course, you will lose much fun of using Windows 7 by using this workaround.

    Workaround 2 – Delay Mouse Over Respond on Taskbar

    Another workaround is to set the system to respond very slow when user hovers or mouse overs the Taskbar, making not only the thumbnails not appearing, but also the usual list view of opened windows. Instead, only a tooltip showing the top window’s title will be shown during this time.

     

    Follow the guide to set the ExtendedUIHoverTime registry key for a longer delay time for mouse hover over effect.

     

    Thursday, July 15, 2010 4:16 PM
  • I've tried everything in this thread to no avail; the taskbar still glitches fairly regularly.  I have, however, managed to figure out what causes it.  Sometimes, when I minimize or maximize a program, it causes Windows to freeze for just a moment.  The freeze only lasts for a fraction of a second but if my mouse moves outside the taskbar during this time, the cursor will pop to the new location when it unfreezes.  That's when the taskbar seems to get confused and thinks the mouse is still there.  Unfortunately the only solution to the glitch, that I've been able to find, is to restart my machine.
    Wednesday, September 29, 2010 7:28 PM
  • One fix I've found is to start task manages with Ctrl+Shift+Esc go to the Processes tab and end the explorer.exe task. Then click File -> New Task(Run..) and type in explorer.exe and click Ok. This fixes it until whatever causes it to break breaks it again. Not the best solution but it works I guess. If someone familiar with batch files could make one I'd be pretty ok with it. Microsoft should fix this though. It's quite annoying.
    Friday, December 23, 2011 4:58 PM
  • Microsoft should fix this though. It's quite annoying.


    So far now, with Windows 7 on multiple systems in both 32 and 64 bit variants, I've not seen this problem once in over 2 years.  Of course, everyone uses Windows differently, has some differences in their hardware, and of course runs different software, but I don't think it's a systemic problem.  I only mention this to say that it CAN work - what you're seeing is likely to do with software or settings you have installed or changed, or latent bugs in drivers.

    You should never have to end Explorer and start a fresh copy.

    One thing I'd definitely suggest to start with is to visit the web page of the maker of your video card; find, download, and install their latest display driver release for your hardware and operating system.  Updated display drivers solve many display problems.

    -Noel

    Friday, December 23, 2011 6:49 PM