none
disable "Open File Security Warning"

    Question

  • Hi whenever I try to open a file from the local hardrive I get the "Open File Security Warning" asking me whether I want to open the file or not. This is getting rather annoying. I searched online but everything I found seems to be dealing with network shares and I am not using that. Just a file on the local hard drive in the computer I am using to the right of me. I remember in my last install I turned it off somehow, but for the life of me I can't figure out how I did it. Anybody have any ideas? Or is this here to stay?
    Tuesday, January 13, 2009 5:26 AM

Answers

  • The final answer!

    1. Go into internet options, through control panel or IE.

    2. Set the "Launching Applications and Unsafe Files" option to enabled.

    This will give you a retarded bar in IE that says your security settings are unsecure or something.

    To get rid of it:

    1. Start>Run>gpedit.msc>Enter

    2. Under Administrative Templates>Windows Components>Internet Explorer set the "Turn Off the security settings check feature" to enabled.

    If you don't have Internet Explorer under windows components:

    1.  right click Administrative Templates and click "Add/Remove Templates"

    2. Click Add button

    3. Navigate to "C:\WINDOWS\system32\GroupPolicy\ADM\"

    4. Hold shift and highlight all the files that start with "inet"

    • Marked as answer by Omego2K Sunday, January 18, 2009 7:19 PM
    Sunday, January 18, 2009 7:18 PM

All replies

  • the answer is to add a system environmental variable and set the value to 1.

    So add SEE_MASK_NOZONECHECKS and set it's value to 1. Make sure it's a system level variable or it will go away on reboot.
    • Marked as answer by Omego2K Tuesday, January 13, 2009 4:55 PM
    • Unmarked as answer by Omego2K Sunday, January 18, 2009 2:52 AM
    Tuesday, January 13, 2009 4:55 PM
  • Apparrently SEE_MASK_NOZONECHECKS doesn't get activated after a reboot even though I make it a system enironmental variable. I can see it listed in the list from the properties in my computer, but after I reboot and type "set s" it's not showing and it's affects are no longer visible.
    Sunday, January 18, 2009 2:54 AM
  • This is an IE security setting with IE7.  The files must to have come from the internet or an untrusted source. You can right click the file and choose "unblock" which will unblock the file. Unfortunately you cannot do it on more than one at once.

    Do you get it with every file or just a few?

    You can fool around with trusted sites. I have added my Domain to my trusted sites to eliminate this issue. Not sure with a local computer though.

    Cheers,
    Lara
    lforbes
    Sunday, January 18, 2009 6:17 AM
  • I get it on every file, what domain would I add to the trusted sites list then? Also why is the environmental variable not active on reboot?

    I also get these on files I haven't downloaded since I reinstalled, I have a backup drive which I put all my backup files on and when I run an exe from that drive I get the warning.
    Sunday, January 18, 2009 4:36 PM
  • The final answer!

    1. Go into internet options, through control panel or IE.

    2. Set the "Launching Applications and Unsafe Files" option to enabled.

    This will give you a retarded bar in IE that says your security settings are unsecure or something.

    To get rid of it:

    1. Start>Run>gpedit.msc>Enter

    2. Under Administrative Templates>Windows Components>Internet Explorer set the "Turn Off the security settings check feature" to enabled.

    If you don't have Internet Explorer under windows components:

    1.  right click Administrative Templates and click "Add/Remove Templates"

    2. Click Add button

    3. Navigate to "C:\WINDOWS\system32\GroupPolicy\ADM\"

    4. Hold shift and highlight all the files that start with "inet"

    • Marked as answer by Omego2K Sunday, January 18, 2009 7:19 PM
    Sunday, January 18, 2009 7:18 PM
  • Thankyou, i was lucky to find this.
    Had the dialog poppin up on a webbrowser i've developed for Windows 7, everytime an item was selected on the jumplist or if i selected an internet shortcut to open with my app.

    Is there a way this can be done in code.?
    Kevin
    Saturday, January 30, 2010 9:23 AM
  • Omego2K,

    Files that are downloaded can have a property setting that is triggering this issue as well.

    On the file, do a right click and then select Properties.

    See if there is a button that is named "Unblock".  It would be under the Advanced... button.

    If you see this, click the "Unblock" button and then click the Apply button.

    I know the goal is to make the machine have a global setting change, but in situations where a group policy is going to come back and reset the changes to one that locks the system back down, the above steps may help in avoiding the security dialog message when it is a file that is shared in a company or office setting.

    So either way, you can bless the file to be safe or the system, either way this one has more than one answer for some users out there.

    Monday, March 22, 2010 3:45 PM
  • Omego2K, I know this is an old post, but in your "fix", the last line says:

    4. Hold shift and highlight all the files that start with "inet"

    My question is, what do you do after that?


    Rich Why can't I be different and original like everybody else? - Vivian Stanshal
    Tuesday, April 13, 2010 2:18 AM
  • 1. Go into internet options, through control panel or IE.

    2. Set the "Launching Applications and Unsafe Files" option to enabled.

    worked for me on XP PRO 2002 version, SP3
    Sunday, June 06, 2010 4:47 PM
  • No such option is there in Win 7 ult and IE9.  Have yet found a way for that message to go away, and it is not with downloaded files, it is any exe file that I try to start, weither it is on a CD, DVD, my local Drives or my local sever.  NO option to unblock is on the properties window as well.  Even the TN support has not clue on this

     

    Glenn


    Glenn A Nicholson IT Specilist/Manager
    Friday, March 18, 2011 1:59 PM
  • WHich Tab, in Internet Options, contains the "Launching Applicationf and Unsafe Files " ???

    I can not find this "item" anywhere.

        THank you,

                   Michael

     

      

    Wednesday, July 13, 2011 4:09 PM
  • The "Launching Applications and Unsafe Files" customizable option is available (and different) for each of the 4 Zones in the Security tab.  The only time you get the IE warning that your security settings are unsafe is if you set this option in Zone 3, the "Internet" zone.  If you set this option in either the Intranet or the Trusted Sites zone, this won't happen.

    Problem is, you may still get the warning unless you set this option in the Internet zone, which can be unsafe.  So the next question is, why does only the Internet zone option work if the file is local?  For some, the answer is that the file is on a local LAN, and in that case, Iforbes answer is the correct one, assuming the drive letter was mapped using a NETBIOS based host name, such as "MyComputer".  In this case, if you right click on the file, select the General tab, click on Advanced button at the bottom, you should see an "Unblock" button which will unblock that particular file.

    But what if you can't find the "Unblock" button?  In that case, it is most likely because the computer thinks the file originates on the Internet - which can happen if the drive letter was mapped to a UNC share where the computer name is an FQDN style name, such as "My.Computer", and is also common in networks using DFS (distributed file sharing), where the "computer" name is actually the domain name, such as "mydomain.com".

    In this case, the best way to fix the problem is to add the FQDN-style host name (or DFS name) to the "Trusted Sites" zone without prefixing the name with http:\\ or https:\\ - so the entry would simply be something like "My.Computer" or "*.mydomain.com".  Make the change mentioned by Omego2K for that particular Zone, and that should be all you need to do.

    Wednesday, August 03, 2011 4:54 PM
  • Windows 7 - Launching unsafe files is in this path;

    IE -> Internet Options -> Security tab -> Custome Level -> Scroll down in Settings -> Look for radio button "Launching applications and unsafe files (not secure)".

     

    Don't know if it solves the problem or not but option is there.

    Tuesday, January 03, 2012 7:11 AM
  • Will it also work for Windows Server 2008 R2?

    Vipin Tyagi (MCSE 2003) Windows Admin

    Thursday, April 26, 2012 8:43 AM
  • It worked fine for me 

    thanks ManojMaurya
    Saturday, June 22, 2013 8:25 AM
  • Windows 7 - Launching unsafe files is in this path;

    IE -> Internet Options -> Security tab -> Custome Level -> Scroll down in Settings -> Look for radio button "Launching applications and unsafe files (not secure)".

     

    Don't know if it solves the problem or not but option is there.

    Great, on Windows 8 x64 this is an option I can find and set.

    It will generate a nasty warning in the system tray. And does not solve the problem:

    I have downloaded a warez archive and extracted it. The resulting .exe file is a wrapped program which will extract everything to my choosings. I've used it before. 

    When I try to run the program, all I get is: 

    Windows Security

    These files can't be opened

    Your internet security settings prevented one or more files from being opened. 

    Show details | Close

    I do not use IE, I use chrome. What is this strange behaviour?? :(

    Post-EDIT: I found this link with detailed steps for Windows 8, including screenshots.

    http://www.c-sharpcorner.com/UploadFile/e83792/how-to-disable-the-open-file-security-warning-in-windows-8/

    But this does not solve my particular problem :s

    ... Peace!

    Devvie

    ~~~ notemail@facebook.com ~~~

    Cuisvis hominis est errare, nullius nisi insipientis in errore persevare
    ——
    All spelling mistakes are my own and may only be distributed under the GNU General Public License! – (© 95-1 by Coredump; 2-013 by DevNullius)




    2nd POST-EDIT: I solved it with a little tool: streams! Read more here: http://scforum.info/index.php/topic,8543.msg22024.html#msg22024 and be done with this IE sheit. Who uses IE anyways and why is it important when I want to run a local file :| The future looks grimm :(


    • Edited by microzoft . net Monday, December 23, 2013 1:01 PM solved. Added solution
    Monday, December 23, 2013 12:31 PM
  • Check your system date.  Needs to be current or will cause this kind of error.

    The richest man wants nothing

    Wednesday, January 15, 2014 8:10 PM
  • Wont this let all .exe files run without asking for permissions?

    So people will get infected?

    Wednesday, July 09, 2014 3:27 PM