none
Default Gateway missing after re-start

    Pregunta

  • Every time I re-start, the Default Gateway information is missing from the Network connection. I have to re-fill in the information and reset to get the Internet connection back.

    ipconfig/all results below

    IP address should be 192.168.0.215
    Gateway should be 192.168.0.1

    Microsoft Windows [Version 6.0.6002]
    Copyright (c) 2006 Microsoft Corporation.  All rights reserved.

    C:\Users\Bob>ipconfig/all

    Windows IP Configuration

       Host Name . . . . . . . . . . . . : Desktop
       Primary Dns Suffix  . . . . . . . :
       Node Type . . . . . . . . . . . . : Hybrid
       IP Routing Enabled. . . . . . . . : No
       WINS Proxy Enabled. . . . . . . . : No

    Ethernet adapter Local Area Connection 4:

       Media State . . . . . . . . . . . : Media disconnected
       Connection-specific DNS Suffix  . : Belkin
       Description . . . . . . . . . . . : NVIDIA nForce Networking Controller #4
       Physical Address. . . . . . . . . : 00-50-8D-91-A2-83
       DHCP Enabled. . . . . . . . . . . : Yes
       Autoconfiguration Enabled . . . . : Yes

    Ethernet adapter Local Area Connection 3:

       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : NVIDIA nForce Networking Controller #3
       Physical Address. . . . . . . . . : 00-50-8D-91-A2-82
       DHCP Enabled. . . . . . . . . . . : No
       Autoconfiguration Enabled . . . . : Yes
       Link-local IPv6 Address . . . . . : fe80::e160:5968:41ca:98ea%11(Preferred)
       Autoconfiguration IPv4 Address. . : 169.254.152.234(Preferred)
       Subnet Mask . . . . . . . . . . . : 255.255.0.0
       Default Gateway . . . . . . . . . : 0.0.0.0
       DHCPv6 IAID . . . . . . . . . . . : 201347213
       DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-0D-C4-03-60-00-50-8D-91-A2-82

       DNS Servers . . . . . . . . . . . : 192.231.203.132
                                           192.231.203.3
       NetBIOS over Tcpip. . . . . . . . : Enabled

    Tunnel adapter Local Area Connection* 6:

       Media State . . . . . . . . . . . : Media disconnected
       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : isatap.Belkin
       Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
       DHCP Enabled. . . . . . . . . . . : No
       Autoconfiguration Enabled . . . . : Yes

    Tunnel adapter Local Area Connection* 9:

       Media State . . . . . . . . . . . : Media disconnected
       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface
       Physical Address. . . . . . . . . : 02-00-54-55-4E-01
       DHCP Enabled. . . . . . . . . . . : No
       Autoconfiguration Enabled . . . . : Yes

    Tunnel adapter Local Area Connection* 12:

       Media State . . . . . . . . . . . : Media disconnected
       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : isatap.{03D49CF9-3A8D-4619-B822-B7B39441E
    680}
       Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
       DHCP Enabled. . . . . . . . . . . : No
       Autoconfiguration Enabled . . . . : Yes

    C:\Users\Bob>

    • Cambiado Carey FrischMVP, Moderator viernes, 02 de julio de 2010 15:28 Moved to relevant forum (From:Windows Vista Service Packs/Windows Server 2008 Service Packs)
    viernes, 13 de marzo de 2009 22:07

Todas las respuestas

  • I assume the one you are using is  Local Area Connection 3.  It is getting an address from Autoconfiguration.

    It is not getting an address from a DHCP server.  If you normally gets the address from DHCP, such as from your broadband router, you can try ipconfig /release and then ipconfig /renew.  If this works, you can set the correct ip, gateway, and DNS addresses as an Alternate Configuration in the TCP/IP Properties page.

    When an Alternate Configuration is configured, it is supposed to use this if DHCP fails, and not use Windows Autoconfiguration.

    Otherwise, you can set static addresses in the IP v4 properties page.

    To open the IP v4 properties page, open the Network and Sharing Center in the Control Panel.  Then select "Manage Network Connections" on the left side.  In the next window, select "Local Area Connection 3" and chose "change settings..." or File\Properties.  Then select "...IP v4", and then the Properties button.
    viernes, 13 de marzo de 2009 23:21
  • Thanks for that but that is exactly the problem. I set up a static address in IP v4 properties and it works fine until I reboot, it then reverts to the ipconfig that I pasted and I have to re-set it again. I have seen a few other posts here with people having a similiar problem so I don't think it's only me. Sure I can do a release/enew but this never happened with Vista original or SP1, only since running SP2 so I am gussing it's an SP2 bug ??
    sábado, 14 de marzo de 2009 1:39
  • You could try editing the registry and add the IPAutoconfigurationEnabled dword value to the interface's key.  See:  Configuring IP Addressing and Name Resolution.

    There are reports that this doesn't work, however. 
    sábado, 14 de marzo de 2009 5:46
  •  I guess it is another idea, but it still doesn't answer why SP2 is doing this?
    sábado, 14 de marzo de 2009 8:07
  • Hi,

    Thanks for reporting this issue. Our engineers are trying to repro the issue internally and we'll contact you as and when needed.

    Thanks
    Arun
    We build Service Pack 2
    martes, 17 de marzo de 2009 6:11
  • Hi,

    Sorry that you are seeing this issue. Can you give following details which will help us understanding your scenario in better way: -

    1) Can you elaborate exact steps to reproduce this problem and also the workaround to resolve this issue.
    2) Also did you see this issue only after installing SP2. Was it working prefectly fine with SP1.
    3) Did you install any oher app/software and think could have triggered this scenario ?

    Thanks,
    Sachin
    miércoles, 18 de marzo de 2009 23:34
  • 1) Any reboot produces this problem. If I then look at TCP/IP properties, the Gateway address is blank. Filling in the Gateway address immediately doesn't work, I have to set up Auto IP address then go back and complete manual IP address, all is then OK to next reboot

    2) Only after SP2 install

    3) nothing that I can remeber or that seems relevant
    lunes, 23 de marzo de 2009 1:36
  • Yes.

    I had the exact same problem with SP2 Beta on Windows 2008 Server x64.

    I uninstalled the Service Pack and the problem went away.

    I did not have the problem after I installed the SP2 RC.

    But then I had activation and MGA problems.

    After a miserable time uninstalling the RC, I am now re-activated and at SP1 level.
    lunes, 23 de marzo de 2009 5:39
  • Thanks for that egads, but I'm afraid that everything is as it should be. We will wait and see if any of the MSFT come up with any answers
    martes, 24 de marzo de 2009 20:59
  • Good choice, Egads.
    martes, 24 de marzo de 2009 22:19
  •  Hi,

    Thanks for reporting this issue. We would like to delve more on to this issue.

    Please log a bug report using http://connect.microsoft.com/InvitationUse.aspx?ProgramID=2730&SiteID=749&InvitationID=CPP-G93D-QDHH
    Do post back the feedback ID for our reference.


    Thanks,
    Sachin

    miércoles, 25 de marzo de 2009 6:46
  • I had previously reported this to Microsoft Support.

    See:  1093400863.
    miércoles, 25 de marzo de 2009 19:30
  • Sachin,  Bug Report submitted ID- 427221

    Thanks
    jueves, 26 de marzo de 2009 21:30
  • Received a reply to the Bug report suggesting to remove Apple Bonjour as this could be causing the problem. Removed Bonjour but problem still the same
    sábado, 28 de marzo de 2009 0:14
  • I submitted information that you requested on March 31st. to the Bug report ID- 427221
    Since then I have never had any reply. Did you get the new info? Is there any news?
    sábado, 11 de abril de 2009 22:57
  • Is this on a SBS server (or SBS network?)

    Comment out the setup.exe line in the logon script and then give it a few reboots to test.

    viernes, 17 de abril de 2009 3:10
  • Thanks for your thoughts, the answer is no, this is a stand alone machine running Vista Ultimate. I've at last got kind of fed up messing around and removed SP2 and, as I expected, the problem disappeared. There is some kind of bug in the SP that caused it whatever it is. I would love to have had more time to get to the bottom of it, but time is precious. Thanks to all the repliers and if anyone has any better ideas, we'll have another go. Good luck to all
    • Propuesto como respuesta Brian Borg viernes, 24 de abril de 2009 18:00
    viernes, 24 de abril de 2009 10:02
  • Just a last word on the above issue. I upgraded from Vista to Windows 7 RC at the weekend and ended up with exactly the same issue. I guess there is something in this machine which is causing the problem, but, after much distress, I seem to have found a work around. If I set up my fixed IP in IPv4 configuration and also set up exactly the same as an Alternate Configuration, everything is now stable after many reboots. Exactly why, I don't know but maybe this will help someone else out if they experience the same problem

    (By the way, Windows 7 is running beautifully)
    lunes, 04 de mayo de 2009 5:55
  • I also had that problem with Vista SP2 and internet. I have added some named values to one registry key and now I have SP2 installed and a stable connection. After SP2 -installation I made the registry changes. The key is: HKLM/System/CurrentControlSet/Services/Tcpip/Parameters/Interfaces/X?
    X? means the ID for the concerned NIC.
    The named values are: AddressType       REG-Dword    0x00000000        and    IPAddress    Reg_Multi_SZ      192.168.2.20 (for example)     and    SubnetMask    Reg_Multi_SZ    255.255.255.0       and    DefaultGateway    Reg_Multi_SZ     192.168.2.1 (for example).Then I have renewed the persistent route in : HKLM/System/CurrentControlSet/Services/Tcpip/Parameters/PersistentRoutes by the value           0.0.0.0,0.0.0.0,192.168.2.1,-1   This value one can find with the help of   route print . In TCP/IP properties was to set the gateway. Before installing SP2 one could use the netsh-command to disable the autoconfiguration to avoid the APIPA for the workstation IP . In my case is internet over Wlan : netsh wlan set autoconfig enabled=no    After changing the registry  type:  netsh wlan set autoconfig enabled=yes  and the connection was established.Maybe it is a little bit helpful.

     

    lunes, 11 de mayo de 2009 18:42
  • I still haven't tried SP2 again.  I guess I don't want the hassle.
    martes, 12 de mayo de 2009 1:43
  • I have the same Problem:
    After updating from Vista SP1 to SP2 (Windows6.0-KB948465-X86) the PC gets an empty default gateway after rebooting.
    This behaviour is really annoying - especially when you install the SP2 over a remote connection.
    I can't understand why MS released the SP2 with this bug ..also it's known since two months.
    miércoles, 27 de mayo de 2009 7:56
  • I don't know if it is the same problem or a related one, but after installing SP2 last night, TCP/IPv4 was no longer bound to any of my network adaptors - it had simply dropped of the list of items the connection uses.  Furthermore, it was not available to install.
    miércoles, 27 de mayo de 2009 13:59
  • Good Morning,

    last night i update my Vista Home Premium with installed SP1 to SP2 offical release. And i get the same error, i can read in this thread. I can confirm, that Vista lose standardgateway entry if you use fix-ip setting (in my case IPv4) If i configure it manual again, it work until next reboot. If i use DHCP-Configuration all works fine.

    In this scenario (missing Standardgatway) network identification failure and you see only local connection can be use.

    (I use a w-lan connection)

    Is it possible, thats a general problem with SP2???

    I hope of an resolution as soon as possible. :-)

    Nice Day.
    jueves, 28 de mayo de 2009 5:19
  • There is a known issue with Apple and  Kaspersky NDIS filter driver who add 0.0.0.0 as default gateway. This causes loss of internet connectivity. There is a kb article http://support.microsoft.com/kb/970313 for the same. If you are seeing 0.0.0.0 address in your default gateway list you would need to delete that to get the connectivity back. You may change the bonjour service type to manual to stop seeing the issue thereafter. If you are getting an empty default gateway list that may be some other issue. In that case can you please provide the following info:
    1. ipconfig /all output before and after reboot.
    2. output of systeminfo

    Thanks in advance,
    Umesh

    jueves, 28 de mayo de 2009 12:17
  • Hello,

    I do had the same with three Vista Units... There is a known workaround available from NetSet Man... http://www.netsetman.com/support/viewtopic.php?pid=832#p832

    It help on my system(s)

    • Propuesto como respuesta Brian Borg lunes, 15 de junio de 2009 18:38
    jueves, 28 de mayo de 2009 17:55
  • I also had Internet connectivity problems after installing Vista SP2. DHCP is disabled on my router; the PC is configured with a static IP address. After the SP2 installation, the PC did not connect to the Internet. I was able to get it to connnect by toggling network connection properties, but I had to repeat the process after every reboot.

    To fix the problem, I had to reset the Internet Protocol as described in the http://support.microsoft.com/kb/299357 article. I did the following:

    1. Run a Command Prompt as Administrator and enter the following command (in step 2).
    2. netsh int ip reset
    3. Reboot.
    4. Go to Network and Sharing Center > Manage network connections and change the settings of the network connection by configuring the TCP/IPv4 properties with the IP address, default gateway, etc.
    • Propuesto como respuesta Brian Borg domingo, 31 de mayo de 2009 1:18
    viernes, 29 de mayo de 2009 23:51
  • i got the same problem with 2 vista units both lose there gateway setting on reboot.
     i use a static ipaddress for both oif them i have tried the workarounds that have suggested 
    but still the same problem .
    thank i will uninstall sp2  and wait unitl the is a new build of it
    • Editado whibbs lunes, 01 de junio de 2009 12:15 spelling
    lunes, 01 de junio de 2009 12:14
  • Hi Whibbs,
    Before uninstalling it .. could you please share the regsitry dump for following key
    "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces".
    Please send it to satyendra.mishra@live.com.sg

    Thanks,
    Satyendra

    lunes, 01 de junio de 2009 14:25
  • Hi

    Bit of a 'me too' post I'm afraid. I have the same issue on three laptops after installing SP2 last week. The defaulty gateway address vanishes after the restart. No matter how many times you put it back it still disappears on rebooting. So far as I am aware the 'bonjour' app has never been installed on these machines.

    Using Auto-acquire works around the problem but I would be very pleased to know of a solution that will enable the use of static IP addresses as we sometimes have scenarios where these are needed.

    Mnay thanks for any help

    Steve
    martes, 02 de junio de 2009 9:03
  • I agree with your conclusion.  I have removed SP2 and the persistant problem of the gatway disappearing at each reboot stopped.  I am not sure if there is a work around, I spend over two hours trying all combinations of trying to get the gateway address to stay (when static info is inserted) DHCP works fine, but I need to set static data, as I have a few persistant routes setup.

    I will wait for the patch for SP2 as well
    martes, 02 de junio de 2009 12:01
  • I re-installed my server, and then let Windows Update install SP2 (KB948462).

    Networking now works the way it should.  Manually configured settings stay set and don't revert to autoconfig or dhcp.
    martes, 02 de junio de 2009 17:29
  • I can confirm that one of my Windows Server 2008 Ent x64 servers also experienced this issue with lost gateway. The only thing  that helped was removing SP2, now it works ok.
    jueves, 11 de junio de 2009 8:25
  • Hello,

    I do had the same with three Vista Units... There is a known workaround available from NetSet Man... http://www.netsetman.com/support/viewtopic.php?pid=832#p832

    It help on my system(s)


    Thanks, that solves it.  It's clearly a case of SP2 corrupting a registry entry and the TCP/IP service not validating what it gets from the registry.

    lunes, 15 de junio de 2009 17:00
  • Rapid...THANK YOU FOR POSTING THIS!

    Been racking my brain trying to figure this out on my W2K8 SP2 virtual machines and only one of 6 had this happen.  Your link explaining the blank line entry and how to remove it worked like a CHARM!
    lunes, 15 de junio de 2009 18:55
  • I can confirm this a SP2 problem, at least in Windows Server 2008 Enterprise x64. I have downloaded the FULL OS ISO file with SP2 pre-installed directly from MS's licensing portal. After installing 4 clean copies in virtual environments I can confirm that all 4 instances lose the gateway upon the first reboot after configuring static TCP information including (ip, mask, gw, DNS1, DNS2).

    Upon reboot all four had blank gateways, not even "0"s. Following the tip from http://www.netsetman.com/support/viewtopic.php?pid=832#p832 I noticed that the reg keys "DefaultGateway" and "DefaultGatewayMetric" are completely missing from the following location:
    HKLM/System/CurrentControlSet/Services/Tcpip/Parameters/Interfaces/%CLSID%

    After manually adding the missing values all four servers rebooted fine and retained their gateways.

    NOTE: The commands "netsh int ipv4 reset, netsh int ipv4 uninstall, & netsh int ipv4 install", with reboots in between, did not help fix the problem.

    Hope this helps..

    • Propuesto como respuesta Brian Borg sábado, 12 de diciembre de 2009 0:01
    viernes, 19 de junio de 2009 15:45
  • So what now? Will we receive an official response from MS on this matter?? It is obvious something is wrong with the SP2..

    Also, I don't get it how can they miss such a flaw with all their extensive testing they always mention they do prior the release?
    sábado, 20 de junio de 2009 9:52
  • I have the same problem - solved by disable the network device and enable. (WIN7 RC1)
    sábado, 27 de junio de 2009 5:08
  • I have the same problem - solved by disable the network device and enable. (WIN7 RC1)

    Maybe, but does it last through reboot?
    sábado, 27 de junio de 2009 17:36
  • Thanks sooo much pigglety !!!  TCP/IP reset is the definite answer to the problem !!!
    http://support.microsoft.com/kb/299357
    • Propuesto como respuesta BeyondNovice miércoles, 08 de julio de 2009 1:18
    miércoles, 08 de julio de 2009 1:10
  • Doing the netsh commands didnt work for us either.  Adding the reg keys in manually worked though.  Thanks.

    Note that this hasnt effected all our SP2 installations, only specific ones.  I got round this before in vmware by removing and adding a new network adapter but in one case this didnt work so i ended up googling it and found this.

    MS really need to acknowledge this and fix the SP2 download for future installs then release a HF for existing installs.
    viernes, 10 de julio de 2009 3:28
  • The rebuilding of the TCP/IP stack works fine but... how do I do this on 400 domain computers without going to each computer? (geographically scattered throughout the province)

    jueves, 27 de agosto de 2009 1:35
  • if your computers are connected, create a batch script as follows:
    netsh int ipv4 uninstall
    netsh int ipv4 install

    place the script on some shared folder and use psexec tool to run it remotely. Something like this:

    psexec @computers.txt -i -u Domain\Administrator -p Admin password \\computer\folder\Scripts\your_script.bat

    How to use psexec read on http://technet.microsoft.com/hr-hr/sysinternals/bb897553(en-us).aspx
    GorkyLed
    miércoles, 09 de septiembre de 2009 12:51
  • I would like to "awake" this thread again because I have ran into the same problem. But mine is not that easy to solve.

    We are using VMware and are using the "Template" function (sysprep along with answer files) and the Customization Specifications Manager i vCenter to deploy our Windows 2008 Server VMs. After updating the template with SP2 we have ran into big problems. It seems like SP2 clears the Default Gateway.

    In the answer file a new ip is set and also joins the domain. Joining the domain works fine but when the server is deployed and I try to log into our domain I get the "No logon server available". If I log in locally I can see that the Default Gateway is blanked out. The IP, Subnet Mask, DNS is still there though. The problem can be solved with:
    netsh int ip reset, but I don´t  want to do that everytime a deploy a new server. Is there any solution that I can apply before I sysprep the server that will stick?

    Any suggestions what to do?

    martes, 15 de septiembre de 2009 18:42
  • how about a reg import of the relevant key Johan?
    jueves, 17 de septiembre de 2009 5:54
  • how about a reg import of the relevant key Johan?

    I don't think that will do it.

    The IP stack has to be reset.  Otherwise, it just uses the values in memory.
    jueves, 17 de septiembre de 2009 23:25
  • Correct, that do not do the trick....the problem still remains att it´s driving me nuts.
    viernes, 18 de septiembre de 2009 6:49
  • Just an update from our end.  In VMware, in contrast to what Johan found, if i use my templates with a new Customisation Specification then it keeps the network settings and it all works.  I converted my templates to VMs logged into them and checked their networks settings are ok and i can see them on the network, i then converted these back to templates, created a new Customisation Specification which sets the IP on the servers then deployed a couple to test and they both worked fine, appeared on the network after the Customisation Spec ran through.

    Now whats strange is that the customisation spec just runs a sysprep after the OS starts, now i had the lost default gateway after doing a sysprep manually after creating a VM (as i hadnt created a customisation spec yet), now ive created a customisation spec it seems fine... even though its doing the same thing and just running sys prep.... strange.
    viernes, 09 de octubre de 2009 1:52
  • I tried resetting it this way unfortunately I did not have any success.... Maybe this will help someone as I had to do it this way...

    Open Device Manager
    Click View/Show Hidden Devices
    Expand Non-Plug and Play Drivers
    Right click TCP/IP Protocol Driver and click Uninstall. Say no to the reboot.
    Right click TCP/IP Registry Compatibility and click Uninstall. Say yes to REboot...

    The computer may stall out a bit on reboot as it reinstalls these drivers...

    When you check your ipconfig it will still show 169.*.*.* however if you go to your connection to set the IP it will show it set to Static with all blank fields.. Set the values and click OK. Verify that the settings hold by doing a reboot... You will also notice the reg values now propogate...

    HKLM\SYSTEM\CURRENTCONTROLSET\Services\Tcpip\Parameters\Interfaces\"then the interface"

    Hope it helps... frustrating issue!
    • Propuesto como respuesta Lord Beetle lunes, 26 de octubre de 2009 13:16
    lunes, 26 de octubre de 2009 13:15
  • Add me to the list of victims to this particular bug. My position:

    A machine created on a VMware platform with Server 2008 R2, then with IIS+.Net installed, then sysprep'ed and cloned to three more machines. Note: ALL FOUR VM's, after getting Sysprep'ed, and then cloned, had this problem!

    When I first noticed it happening, I too was getting the conflicting information from the GUI and ipconfig. that gave me the idea to uninstall the Network Adapter from Device Manager, then reboot the system, and let the OS re-discover it. This worked on the first machine I tried it on. I think on the next two, I actually did not reboot, but after removing the network adapter, merely right-clicked on the root of the control panel hardware manager tree and selected "Scan for new hardware", and let it re-add the adapter. This might have been a mistake. However, after doing that, I then tried the removal of the network adapter and rebooting it; that still did not seem to fix the problem. WHY would the Default Gateway just disappear like that?

    I am now attempting to sysprep & restart the second machine. I am going to try "Lord Beetle"'s suggestion of blowing away the TCP/IP stack drivers. Who cares, they're dev VM's anyway. :D

    Schmeckendeugler
    viernes, 11 de diciembre de 2009 3:47
  • ok i typed in a bunch of stuff, then hit a link, tried to go back button and this form got reset. so i'm giving you a short version of what all I had typed.

    I had four VM's, two of which required me to remove the hardware interface in control panel then reboot.

    the 3rd, i had to do netsh int ip reset then reboot. Then manually set my IP  again.

    the worst, the 4th, I had to run netsh int ip reset THEN reboot,  then manually set the IP, which instantly broke as I watched the network interface attempt to connect. Then I ran regedit and browsed to HKLM/System/CurrentControlSet/Services/Tcpip/Parameters/Interfaces/{clsid}/DefaultGateway and I had to clear out a bogus entry in that registry key.

    This has been a frustrating 5-6 hours of my life, mostly because RDP'ing to my Terminal Server running VSphere and using a virtual console, heinous mouse lag and I can't even move the mouse pointer but 1 mph. So Annoying!


    viernes, 11 de diciembre de 2009 5:18
  • It may be a bit unrelated, but to get rid of that mouse lag, make sure that you've got the latest VMWare tools installed on the VM, then right-click on your desktop and go to personalize. Select "Display Settings". Click "Advanced Settings...", then go to the "Troubleshoot" tab. Click "Change settings" and set your hardware acceleration to "Full".
    viernes, 11 de diciembre de 2009 19:35
  • I too had this problem on a Windows 2008 SBS system running under Hyper-V.  By following this link:

    http://www.netsetman.com/support/viewtopic.php?pid=832#p832

    and deleting a blank line in the registry key prior to the defaut gateway value, it solved the problem.  Clearly this is a MS glitch and should have been resolved by now via Windows Update.
    lunes, 28 de diciembre de 2009 17:30
  • After 2 months of torture and finally having solved my corrupt photos issue, I am happy to say, "DON'T INSTALL SP2!".

    After uninstalling SP2 both my default gateway issue went away and my corrupt photos issue went away.  Now if my media center extender issue is fixed too well...  I'll be jumping for joy!

    ...kinda makes you want to ditch microsoft and move over to the dark side with Apple!
    lunes, 01 de febrero de 2010 4:39
  • Hi

    We want to deploy SP2 using WSUS and during our preleminary test we saw the same error.

    With SP2 installed we loose the gateway after every reboot.
    The Registry "trick" did solve the problem.

    But this is no solution for our complete range of computers.

    How do you expect business users to solve this?
    Deploy the update, the day after deploy a script/.reg to solve the issue?

    This leaves a few hundreds computers without network connection for some period.


    Is there any "useable" fix available for this?

    If not there will be no SP2 deployed here...
    lunes, 22 de febrero de 2010 10:06
  • Note: this is happening in Windows 7 now.  I'll try the solution tonight. I find it unacceptable that a Vista bug from early 2009 shipped with 7 and MS has not fixed it.
    lunes, 08 de marzo de 2010 18:09
  • I use Windows 7 and I recently disabled DHCP and manually configured the IP address. Everytime I restart the system, I find the Default Gateway value is missing and I have to enter it again.
    viernes, 12 de marzo de 2010 6:12
  • Ditto for my Windows 7 installation .

    I lose the connection to the internet and the troubleshooter can't find any problems but if I disable the network adapter and re-enable it, I get the gateway back.

     

    jueves, 25 de marzo de 2010 13:37
  • Windows 7 Professional 64 bit OEM suffers also from lost gateway address after reboot.
    jueves, 01 de abril de 2010 21:42
  • I am having the same issue with Windows 7 Ultimate 64 bit Retail.
    jueves, 01 de abril de 2010 22:49
  • I agree its unacceptable.  The problem goes back even futher than Vista - It has been a problem since Windows XP initial release.  Yes its now in Windows 7.   The Wireless LAN adaptor finds     an access point but can not connect because (as shown when you run IPCONFIG)  "Media Disconnected"  the only work arounds I have found are:

    WINDOWS XP:  netsh int ip reset reset.log  netsh winsock reset catalog - also in the registry HKLM/Serv/Ccset/TCPIP/Parm a new parameter DisableDHCPMediaSense with a Dword value of 1

    WINDOWS Vista and Windows 7  (run as administrator) netsh winsock reset catalog  netsh int ipv4 reset rest.log  netsh int ipv6 reset reset.log  The registry patch for XP works also.

     

    • Propuesto como respuesta Eldest_One sábado, 03 de abril de 2010 20:15
    sábado, 03 de abril de 2010 18:26
  • Thank you Grey_Tech that fixed my problem rebooted PC after doing as suggested then another reboot and the info was still there. :)
    sábado, 03 de abril de 2010 20:17
  • I agree its unacceptable.  The problem goes back even futher than Vista - It has been a problem since Windows XP initial release.  Yes its now in Windows 7.   The Wireless LAN adaptor finds     an access point but can not connect because (as shown when you run IPCONFIG)  "Media Disconnected"  the only work arounds I have found are:

    WINDOWS XP:  netsh int ip reset reset.log  netsh winsock reset catalog - also in the registry HKLM/Serv/Ccset/TCPIP/Parm a new parameter DisableDHCPMediaSense with a Dword value of 1

    WINDOWS Vista and Windows 7  (run as administrator) netsh winsock reset catalog  netsh int ipv4 reset rest.log  netsh int ipv6 reset reset.log  The registry patch for XP works also.

     


    I had a similar problem with W2K8 Standard with SP2.  The Default Gateway disappeared after each reboot.  I ran three commands suggested by Grey_Tech (see below) then rebooted the server, reinserted all IP settings, rebooted and all was good.  The DG stayed.

    netsh winsock reset catalog

    netsh int ipv4 reset rest.log 

    netsh int ipv6 reset reset.log 

    • Propuesto como respuesta Ozy_paul lunes, 14 de mayo de 2012 11:20
    jueves, 15 de abril de 2010 20:03
  • Please forgive me for replying again; I had not thought at the time that replying to your own post might be more productive.

    My problem is similar (but static not DHCP addressing) and quite grievous since I am about 120 miles away; after reboot I cannot reach the server.

    I am running Windows Server 2008 R2 64 bit on a production server (web edition, Dell R300). This is a multi-homed server and each time I add an IP address (IPV4) to the machine all other (IPV4) IPs disappear after reboot (though they are visible in the network properties dialog). No IP responds even, even to pings, until I use the TCP/IP reset:

    netsh int ip reset resetlog.txt

    Then I have to manually type all the ips again in the TCP/IP advanced dialog. When I look at the

    'HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\{MY_ADAPTERS_GUID}\IPAddress'

    key, the only one present is the last one I typed. Thus when I reboot that will be the only IP on the machine (but the IP shown in the IPV4 network dialog will be completely blank).

    The default gateway is kept, however, so the machine actually can communicate if I remember the last IP I added. But so far this has happened 3 times and each time I have to hire an IP KVM device to work with the server.

    Would the changes you described above fix this problem? (or, at least, do you think they might _cause_ problems if I try them on this operating system?)

    I dread applying security patches because it will require a reboot and all sites will be down (except the last IP I added) until I reset the TCP/IP and re-enter the addresses (though now I have a script to do it more quickly, as long as I remember to keep my text list current).

    Thanks in advance for any help you can offer.

    lunes, 19 de abril de 2010 22:03
  • I agree its unacceptable.  The problem goes back even futher than Vista - It has been a problem since Windows XP initial release.  Yes its now in Windows 7.   The Wireless LAN adaptor finds     an access point but can not connect because (as shown when you run IPCONFIG)  "Media Disconnected"  the only work arounds I have found are:

    WINDOWS XP:  netsh int ip reset reset.log  netsh winsock reset catalog - also in the registry HKLM/Serv/Ccset/TCPIP/Parm a new parameter DisableDHCPMediaSense with a Dword value of 1

    WINDOWS Vista and Windows 7  (run as administrator) netsh winsock reset catalog  netsh int ipv4 reset rest.log  netsh int ipv6 reset reset.log  The registry patch for XP works also.

     


    I had a similar problem with W2K8 Standard with SP2.  The Default Gateway disappeared after each reboot.  I ran three commands suggested by Grey_Tech (see below) then rebooted the server, reinserted all IP settings, rebooted and all was good.  The DG stayed.

    netsh winsock reset catalog

    netsh int ipv4 reset rest.log 

    netsh int ipv6 reset reset.log 


    It worked for me initially, however, later when I reboot, the same problem happened. Damn it!
    lunes, 03 de mayo de 2010 10:21
  • Taken from http://www.netsetman.com/support/viewtopic.php?pid=832#p832

    Solution

    1. Open the registry with regedit.exe
    2. Go to the path: HKLM/System/CurrentControlSet/Services/Tcpip/Parameters/Interfaces/
    3. Here you'll need to select the CLSID of your networkadapter where you change the settings. You'll probably recognize it by looking at the value IPAddress that will have the IP of this adapter.
    4. Open the value "DefaultGateway" by doubleclicking it. You will see a list of all the gateways that disappeared! (maybe in your case it will be only one, in my case there were due to lots of testing several addresses) Very likely, the first line will be empty. I'm not sure, how this little flaw can make such a big problem. However, if you manually remove this first empty line, click OK and reboot your system everything should be working fine again.

    After doing this, everything seemed normal to me. I could change the GW manually and by NSM. After a reboot everything was still there. Of course it needs to be verified in a long-term use if it fixes it forever or if the problem comes back at some point.

    Thank you Ilja Herlein!


    Tyler McLaughlin
    • Propuesto como respuesta Tyler McLaughlin miércoles, 05 de mayo de 2010 19:14
    miércoles, 05 de mayo de 2010 19:14
  • my default gateway always disappeared after reboot on windows 7 64bit, to reset TCP/IP fixed my problem,

    thanks to everybody for the help.

    i used the command netsh int ip reset c:\resetlog.txt in cmd admin mode. 

    http://support.microsoft.com/kb/299357/en-us : how to reset Internet Protocol (TCP/IP)


     

    miércoles, 16 de junio de 2010 21:58
  • Look for the Registry ke ubder interfaces EnableDeadGWDetect  Set it to 0.  This will resolve the issue.
    domingo, 20 de junio de 2010 14:13
  • do you installed Adobe Photoshop CS3 ?

    miércoles, 30 de junio de 2010 5:36
  • My resolve is :

    * 973243 Hotfix

    * hkey_local_machine\system\currentcontrolset\services\tcpip\parameters\interfaces\interface\

    click and type the unique gateway.

    • Propuesto como respuesta jajajavi75 sábado, 25 de septiembre de 2010 13:50
    jueves, 01 de julio de 2010 13:02
  • Finally! I'd been searching for this answer for a while. I had the same problem & could recreate it by just disabing & re-enabling the NIC. When I looked in the registry the default gateway was blank, when I opened te reg key it did have the manual IP Iput in there but there was a whole line above it. I removed that space & viola. Thanks for the post.
    sábado, 25 de septiembre de 2010 13:54
  • Thanks for feedback.

    viernes, 15 de octubre de 2010 11:46
  • Sorry to dredge up an old topic, but I just wanted to let everyone know this NetSetMan post rapidmove linked to fixed the problem for me, too.  Same exact problem on Vista 64-bit.  Easy fix.
    viernes, 07 de enero de 2011 7:40
  • The reg addr worked for me too. i found a carriage return in the reg entry with the gw and removed it so just showed the gw. it worked. whats up with this? maybe had something to do with hyperv that was installed on that box (w08r2).
    sábado, 12 de febrero de 2011 1:33
  • I am facing this problem on a Windows Server 2003 x64 R2 SP2 Virtual Maschine (VMWare 4.1) after a successfull restore test. The systems are configured with two NICs (both DHCP).

    Interface 1 (Frontend):
    Fixed DHCP Reservation
    METRIC 10

    Interface 2 (Backup):
    Dynamic DHCP
    Metric 500

    After a while (~1-2Hours) the system loses the default gateway on Interface 1 (entry in ipconfig is blank) and sets the default gateway onto the Interface 2. After a ipconfig /rewnew everything works fine again for a couple of hours.

     

     

    martes, 09 de agosto de 2011 8:49
  • Although my problem was very similar I was able to find the fix for our problem without changing registry.

    While making master images of Win2008 Ent for production server deployment I had hard coded the IP to get updates and so forth. I did not remove the IP prior to sysprep. This somehow left a "ghost" of it's GW setting. When the new machine would come up, you'd go into network sharing, manage interfaces and find the NIC. When you chose to set it's IP, there would be the previous GW already filled in, so if you filled in the rest of the IP information, it actually would not input the GW information. Missing reg keys and everything. You could set it again and it would take until the next reboot.

     

    My fix was to clean out that ghost ip info from the dialog box, then click DHCP for both IP and DNS. Click ok, then close the network interface dialog box. Go back into the properties of the NIC, and set the IP again and this time the ghost of the GW was gone. All works fine after this.

     

    Not sure why this happened but we're removing IP information prior to sysprep from now on.

    Hope somebody can find this info useful.

     

    Cheers

    lunes, 22 de agosto de 2011 19:07
  • Matty-CT, I had the same issue and tried your solution and it worked!  Looks like MS hasn't fixed it in their updates even 2 years after your post.  Thanks for posting it.
    • Propuesto como respuesta EEERRRR jueves, 19 de abril de 2012 19:51
    • Votado como útil EEERRRR jueves, 19 de abril de 2012 19:51
    jueves, 15 de diciembre de 2011 0:44
  • This article may discribe a fix. The hotfix referenced is actually for Vista but applies to SBS 2008 also.

    http://blogs.technet.com/b/sbs/archive/2010/04/22/you-may-lose-the-default-gateway-on-sbs-2008-every-time-you-reboot.aspx

    I am going to try it on my SBS2008 machine this weekend.

    It references a bug in netsh that inserts NULL characters into the registry entry for default gateway.

    jueves, 19 de abril de 2012 19:54
  • This article appears to reference a solution for this:

    http://blogs.technet.com/b/sbs/archive/2010/04/22/you-may-lose-the-default-gateway-on-sbs-2008-every-time-you-reboot.aspx

    the Hotfix is actually for Vista but should work on SBS 2008 as well.

    The article references a bug in netsh that inserts NULL characters in the registry entry for default gateway.

    These must be manually removed and the hotfix applied to prevent them reoccurring.

    jueves, 19 de abril de 2012 19:57
  • This worked for me.  Excellent. Thanks to all.

    With the number of issues i am regularly trying to fix on 4 Windows PC's at home, i am beginning to question whether we might be better off with Linix based OS or, dare i say it, a Mac.

    lunes, 14 de mayo de 2012 11:12
  • I also had this issue on Windows Server 2003 R2 with SP2.

    The server was already run for a long time, but this problem started in these 3 weeks.

    jueves, 25 de octubre de 2012 6:28
  • Worked for me, thank you so much. Windows 2008R2x64 Enterprise.

    • Editado ISMAXS martes, 25 de junio de 2013 6:20 Thanks
    martes, 25 de junio de 2013 6:19
  • I have been bashing me head against this wall for three months, having tried every fix, cure and panacea available without a prescription. I find it insulting, at this point, that no fix is has been proffered by you fellows, by this time, in the year 2014. Granted, I am using windows 7, SP1 x64, but I would have imagined the fix would be in before the product shipped. Please put me on the list to be notified when you/they find a cure. Amen
    miércoles, 05 de febrero de 2014 13:58