none
cannot map network drive to vpn connection

    Pregunta

  •  

    I am having trouble mapping a network drive to my vpn connection.   the vpn connects fine but when i go to map the drive it tells me the network path cannot be found.  i map the drive as \\Server\folder.   I am using xp sp3.  I also have a vista machine on the same network and it can map to the vpn connection just fine.  any advice?
    sábado, 12 de julio de 2008 16:36

Todas las respuestas

  • On the SP3 VPN client PC, please apply hotfix http://support.microsoft.com/kb/953761 and try again.  Let us know the result.

    sábado, 12 de julio de 2008 16:51
  • TonyD256,

     

    After experiment, I have been able to reproduce your reported symptoms.  It can be caused by either of two issues:

     

    1. Wrong NetBT node type;

    2. A firewall problem, new to SP3.

     

    To check the NetBT node type, start your VPN connection as usual, then open a Command Prompt window and type the command:

     

    ipconfig /all

     

    Look for the response line "Node Type".  Acceptable values are "Hybrid" or "Broadcast".  Other values will cause failure to resolve host names to IP addresses.  If the NetBT node type is wrong, then it can be corrected with a registry setting - come back if you need more info on this.

     

    To check whether your problem is caused by the firewall, try disabling the firewall for a short period while you issue your drive mapping.  If it works now, then the problem before was caused by the Windows Firewall.  Under SP3, it appears that if a UDP broadcast is made from a certain port number, the firewall then blocks directed UDP responses to the same port number.  So the NetBIOS broadcast for the ServerName goes out, but the replies from your VPN server are blocked in your client, and the server is "not found" for the drive mapping.

     

    Running with the whole firewall disabled is not a recommended solution.  You can try two less dramatic settings as follows:

     

    1. Disable firewall on the VPN connection only: in Windows Firewall, tab Advanced, find the name of the VPN connection and UNcheck it, then click OK.  But this is still a quite dangerous setting.

     

    2. Open UDP port 137 on the VPN connection only:

     

    - open Windows Firewall

    - click tab Advanced

    - select the name of the VPN connection, then click Settings...

    - in the Advanced Settings window, click Add...

    - in the Service Settings window:

    - in "Description of service" type "UDP 137" or anything else you prefer;

    - in "Name or IP address of the computer hosting this service on your network" type "127.0.0.1"

    - in "External Port number for this service", type "137"

    - in "Internal Port number for this service", type "137"

    - check the "UDP" radio button

    - click "OK"

    - back in the "Advanced Settings" window, ensure the new entry "UDP 137" is checked;

    - click "OK".

    - click "OK" to close Windows Firewall.

     

    This should be enough to get Server names resolved like they used to be.

     

    domingo, 13 de julio de 2008 22:24