none
Vista browsing in same window option missing

    Pregunta

  • Hi

    I want to open Word 2003 documents from our intranet in Word but they keep opening in IE 7

    does anyone know where the browse in same window option is in Vista that used to be in XP under File Types tab then Advanced button.

    The only similar option i can find is under the Associate File Type options in the control panel. When i go into the .doc options it has IE and Word as Recommended Programs and the check box down the bottom is greyed out. So i can't untick it to remove IE as an application to open Word files.

     

    Any help would be greatly appreciated.

     

     

    Thanks in advance.

    viernes, 14 de marzo de 2008 4:17

Respuestas

  • Open the Registry Editor by typing 'regedit' in the Start Search box.

     

    In the registry, navigate to:

     

    [HKEY_CLASSES_ROOT\Word.Document.8]

     

    In the right-hand pane, create a new REG_DWORD value named 'BrowserFlags' and give it a value of '8'

     

    Good Luck,

     

    Keith

     

    sábado, 15 de marzo de 2008 4:55

Todas las respuestas

  • Open the Registry Editor by typing 'regedit' in the Start Search box.

     

    In the registry, navigate to:

     

    [HKEY_CLASSES_ROOT\Word.Document.8]

     

    In the right-hand pane, create a new REG_DWORD value named 'BrowserFlags' and give it a value of '8'

     

    Good Luck,

     

    Keith

     

    sábado, 15 de marzo de 2008 4:55
  • Thanks very much for your help, it worked perfectly. It will save some time now.

     

    lunes, 17 de marzo de 2008 0:11
  • You're welcome.  Thanks for the feedback.  Thanks for flagging my response as a solution Smile

     

    Keith

     

    lunes, 17 de marzo de 2008 1:58
  • Hello,

    I need to do the opposite.

    I have a .NET application in which I have a webbrowser control and when I load an office document in it, I want it to be opened inside the control and not create a new window.
    In windows XP i tick the "browse in same window" option for the file association type and it works. In windows vista it always opens a new window.

    How do I change it?

    domingo, 15 de noviembre de 2009 16:47
  • For future reference, there are several Word.Document.n keys in the registry now. Try adding (DWORD)BrowserFlags=8 as a value to the one without a number on the end i.e. Word.Document

     

    It did it for me on Windows 7, Office 2007.

    miércoles, 20 de julio de 2011 8:39
  • I have a similar issue with hot links in Excel, everything works except when I link a jpg from a share I have on a server.I am able to get Word doc's and pdf's to open but when I try a jpg it opens it with IE8 and then cant find the file.I was also able to get it to work if I mapped it to my local drive.I am using Office 2010 and am on Windows 7 with IE8 if that helps.
    lunes, 12 de marzo de 2012 19:11