none
Windows 7 WDS answer file not working.

    Question

  • I have been tasked with deploying WDS (first time) and what a headache it has become.  

    I installed WDS on Server 2k8 R2 64-bit which I setup pretty quick. 

    Next, I successfully captured a Windows 7 32-bit OS.   I can deploy it to workstations successfully as well.  

    I have been attempting to create an answer file, but have had the worst time.  First, I found out that you cannot create a catalog file for 32-bit systems on a 64-bit server OS using Windows SIM.  So I installed Windows AIK on a 32bit versions of Windows 7.  I then tried to create the catalog file on there, but it failed as well.  So I then used the catalog file from the Windows 7 32bit DVD and created my answer file.  I associated the same answer file with the image and with WDS server properties > Client > Unattend file x86 architecture option. 

    However, when I go to deploy, all the prompts are still there and nothing is being automated.

    Am I missing something here?  


    • Modifié z00mer22 lundi 12 mars 2012 19:16
    lundi 12 mars 2012 19:13

Réponses

  • Thanks for the help.  What I ended up doing was using MDT 2010 and Lite Touch to deploy new images.  Created a deployment share, uploaded an operating system there using our Windows DVD and used Task Sequences for customization.  This automatically creates an answer file that I could make little tweaks to as I needed, which wasn't much.  This was a lot simpler than manually creating and editing an answer file.
    • Marqué comme réponse z00mer22 mardi 20 mars 2012 17:15
    mardi 20 mars 2012 17:15

Toutes les réponses

  • Deploying Windows 7 Using Windows Deployment Services (WDS): Step-by-Step – Part II

    http://blog.augustoalvarez.com.ar/2010/04/21/deploying-windows-7-using-windows-deployment-services-wds-step-by-step-part-ii/

    It mentions: Open the WDS console and expand “install images”, click on “captures” then right click on the image name “Ref_001”, and select properties.

    At the bottom of the properties window we’ll see “Allow image to install in unattended mode” check that. Now browse for the file created in the step above in “E:\RemoteInstall\WdsClientUnattend”. Apply and select ok.


    My blogs: Henk's blog and Virtuall | Follow Me on: Twitter | View My Profile on: LinkedIn

    lundi 12 mars 2012 20:13
  • I've actually followed that guide, but could not get it to work.  Here is my current WDS unattend file and OOBE unattend file:

    WDS unattend file...


    <?xml version="1.0" encoding="utf-8"?>
    <unattend xmlns="urn:schemas-microsoft-com:unattend">
        <settings pass="generalize">
            <component name="Microsoft-Windows-Security-SPP" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
                <SkipRearm>1</SkipRearm>
            </component>
        </settings>
        <settings pass="windowsPE">
            <component name="Microsoft-Windows-International-Core-WinPE" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
                <SetupUILanguage>
                    <UILanguage>en-us</UILanguage>
                </SetupUILanguage>
                <InputLocale>en-us</InputLocale>
                <SystemLocale>en-us</SystemLocale>
                <UILanguage>en-us</UILanguage>
                <UILanguageFallback>en-us</UILanguageFallback>
                <UserLocale>en-us</UserLocale>
            </component>
            <component name="Microsoft-Windows-Setup" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
                <WindowsDeploymentServices>
                    <Login>
                        <Credentials>
                            <Domain>testorg.com</Domain>
                            <Password>administrator</Password>
                            <Username>admin</Username>
                        </Credentials>
                    </Login>
                    <ImageSelection>
                        <InstallImage>
                            <Filename>Win7Pro32v2.wim</Filename>
                            <ImageGroup>Win7ImageGroup1</ImageGroup>
                        </InstallImage>
                        <InstallTo>
                            <DiskID>0</DiskID>
                            <PartitionID>1</PartitionID>
                        </InstallTo>
                    </ImageSelection>
                </WindowsDeploymentServices>
            </component>
        </settings>
        <cpi:offlineImage cpi:source="catalog://utl01wds/eboot images/windows 7/install_windows 7 professional.clg" xmlns:cpi="urn:schemas-microsoft-com:cpi" />
    </unattend>


    And the OOBE unattend file...




    <?xml version="1.0" encoding="utf-8"?>
    <unattend xmlns="urn:schemas-microsoft-com:unattend">
        <settings pass="specialize">
            <component name="Microsoft-Windows-Shell-Setup" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
                <ComputerName>*</ComputerName>
                <TimeZone>004</TimeZone>
                <ProductKey>XXXXX-XXXXX-XXXXX-XXXXX-XXXXX</ProductKey>
                <RegisteredOrganization>Test Org</RegisteredOrganization>
            </component>
        </settings>
        <settings pass="oobeSystem">
            <component name="Microsoft-Windows-International-Core" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
                <InputLocale>en-us</InputLocale>
                <SystemLocale>en-us</SystemLocale>
                <UILanguage>en-us</UILanguage>
                <UserLocale>en-us</UserLocale>
            </component>
            <component name="Microsoft-Windows-Shell-Setup" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
                <OOBE>
                    <HideEULAPage>true</HideEULAPage>
                    <HideWirelessSetupInOOBE>true</HideWirelessSetupInOOBE>
                    <NetworkLocation>Work</NetworkLocation>
                    <ProtectYourPC>1</ProtectYourPC>
                </OOBE>
                <UserAccounts>
                    <AdministratorPassword>
                        <Value>IQBUAHIAYQBhAEQAbQAxAG4AMQAxADAAJQBBAGQAbQBpAG4AaQBzAHQAcgBhAHQAbwByAFAAYQBzAHMAdwBvAHIAZAA=</Value>
                        <PlainText>false</PlainText>
                    </AdministratorPassword>
                    <LocalAccounts>
                        <LocalAccount wcm:action="add">
                            <Password>
                                <Value>IQBUAHIAYQBhAEQAbQAxAG4AMQAxADAAJQBQAGEAcwBzAHcAbwByAGQA</Value>
                                <PlainText>false</PlainText>
                            </Password>
                            <DisplayName>Admin</DisplayName>
                            <Group>Administrators</Group>
                            <Name>Administrator</Name>
                        </LocalAccount>
                    </LocalAccounts>
                </UserAccounts>
            </component>
        </settings>
        <cpi:offlineImage cpi:source="catalog://utl01wds/eboot images/windows 7/install_windows 7 professional.clg" xmlns:cpi="urn:schemas-microsoft-com:cpi" />
    </unattend>


    lundi 12 mars 2012 22:37
  • Yes, you are missing something here. You are missing the net user Administrator /active:yes option in the Specialize configuration pass (x86_Microsoft-Windows-Deployment component). In order to automate the oobe, you have to specify which account to keep active. Since OOBE asks what username you want to create to allow a profile to be made at login, in this case Administrator, then you need to specify to keep the Admin account active so that the prompts are not seen. I have modified only the OOBE.xml file to reflect the change... 

    OOBE.xml:

    <?xml version="1.0" encoding="utf-8"?>
    <unattend xmlns="urn:schemas-microsoft-com:unattend">
        <settings pass="specialize">
            <component name="Microsoft-Windows-Shell-Setup" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
                <ComputerName>*</ComputerName>
                <TimeZone>004</TimeZone>
                <ProductKey>XXXXX-XXXXX-XXXXX-XXXXX-XXXXX</ProductKey>
                <RegisteredOrganization>Test Org</RegisteredOrganization>
            </component>
            <component name="Microsoft-Windows-Deployment" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
                <RunAsynchronous>
                    <RunAsynchronousCommand wcm:action="add">
                        <Order>1</Order>
                        <Path>net user Administrator /active:yes</Path>
                    </RunAsynchronousCommand>
                </RunAsynchronous>
            </component>
        </settings>
        <settings pass="oobeSystem">
            <component name="Microsoft-Windows-International-Core" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
                <InputLocale>en-us</InputLocale>
                <SystemLocale>en-us</SystemLocale>
                <UILanguage>en-us</UILanguage>
                <UserLocale>en-us</UserLocale>
            </component>
            <component name="Microsoft-Windows-Shell-Setup" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
                <OOBE>
                    <HideEULAPage>true</HideEULAPage>
                    <HideWirelessSetupInOOBE>true</HideWirelessSetupInOOBE>
                    <NetworkLocation>Work</NetworkLocation>
                    <ProtectYourPC>1</ProtectYourPC>
                </OOBE>
                <UserAccounts>
                    <AdministratorPassword>
                        <Value>IQBUAHIAYQBhAEQAbQAxAG4AMQAxADAAJQBBAGQAbQBpAG4AaQBzAHQAcgBhAHQAbwByAFAAYQBzAHMAdwBvAHIAZAA=</Value>
                        <PlainText>false</PlainText>
                    </AdministratorPassword>
                    <LocalAccounts>
                        <LocalAccount wcm:action="add">
                            <Password>
                                <Value>IQBUAHIAYQBhAEQAbQAxAG4AMQAxADAAJQBQAGEAcwBzAHcAbwByAGQA</Value>
                                <PlainText>false</PlainText>
                            </Password>
                            <DisplayName>Admin</DisplayName>
                            <Group>Administrators</Group>
                            <Name>Administrator</Name>
                        </LocalAccount>
                    </LocalAccounts>
                </UserAccounts>
            </component>
        </settings>
        <cpi:offlineImage cpi:source="catalog:x:/sources/install_windows 7 professional.clg" xmlns:cpi="urn:schemas-microsoft-com:cpi" />
    </unattend>
    


    _JoeG
    Dell - Systems Integration Consultant
    Twitter: @8bits1byte 

    Please remember to click "Mark as Answer" on the post that helps you, and to click "Unmark as Answer" if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    mardi 13 mars 2012 00:24
  • Thanks for the help.  What I ended up doing was using MDT 2010 and Lite Touch to deploy new images.  Created a deployment share, uploaded an operating system there using our Windows DVD and used Task Sequences for customization.  This automatically creates an answer file that I could make little tweaks to as I needed, which wasn't much.  This was a lot simpler than manually creating and editing an answer file.
    • Marqué comme réponse z00mer22 mardi 20 mars 2012 17:15
    mardi 20 mars 2012 17:15