none
Windows Security Center service cannot start

    Question

  • I am running Windows 7 Ultimate. I have never had any issues with viruses or spyware on this machine. I have MSE installed and active. I keep getting a notification in the Action Center that the "Windows Security Center service is turned off". When I click the button to turn it on, nothing happens. I located the Security Center service and when I try to start it, it says "Windows could not start the Security Center service on Local Computer", and below that "Error5: Access Denied". The service is running under the 'Local Service' user, I tried changing it to Local System Account, but got a different error, so I assume Local Service is correct. What could be causing this? I am logged in as a domain admin, and I have full control.
    jeudi 10 décembre 2009 17:30

Toutes les réponses

  • type in the search box : services.msc  and press enter (it must be performed in the administrator account or run the Services.msc as admin)
    then look for safety center something like that and double click on it and look if its set to : start automatically(delayed) if not then choose this option and press start right below that option..
    hope this helps,
    RR
    jeudi 10 décembre 2009 20:38
  • Automatic (delayed start) was already and still is selected. No difference.
    jeudi 10 décembre 2009 20:52
  • Hi,

    I am have the same exact problem. Did you ever resolve it??

    TY!
    Joe
    jeudi 28 janvier 2010 18:57
  • Nope, just been ignoring it. Same issue still exists.
    lundi 1 février 2010 14:17
  • Hello Karl,

    Have you checked the "Dependencies" tab?

    You should have:

    -Remote Procedure Call (RPC)
        - DCOM Server Process Launcher
        - RPC Endpoint Mapper
    -Windows Management Instrumentation
        - Remote Procedure Call (RPC)
              - DCOM Server Process Launcher
              - RPC Endpoint Mapper

    Check to see if you have these services started as well.

    The path to the executable is:

    C:\Windows\System32\svchost.exe -k LocalServiceNetworkRestricted

    And yes it runs under Local Service.

    Aside from that I'll watch for a fix for you.

    Regards,

    williamdinbc
    mercredi 3 février 2010 20:12
  • William - Those dependencies are are there, are the services are started. Thanks.

    Tim - As much as I would like to think this is just a simple virus or malware issue, its not. My PC is completely clean of anything like that.
    • Proposé comme réponse Testtubebaby dimanche 9 mai 2010 00:29
    jeudi 4 février 2010 14:21
  • If you havent figured it out yet. Set it to auto, not delayed start.
    dimanche 9 mai 2010 00:30
  • Well, my hard drive crashed last month, and since rebuilding the PC this issue no longer exists. I just checked the service, and it is still set to 'delayed start', however I don't get the error like before. So perhaps an OS reinstall was in order? Can't verify that setting it to auto is the fix since I no longer experience the issue.
    lundi 10 mai 2010 13:24
  • Thanks for the help. I had same problem when I picked up malware. After cleaning it wouldn't start. I followed this procedure and it was disabled. I changed to delayed start and it worked when I turned it on. TY TY TY
    mercredi 7 juillet 2010 04:03
  • Thanks it works . People should follow this advice.

     Click start & type Services.msc then hit enter.

    Right click on the security center , click properties & choose automatic & start.

    Good luck ever body and good work  Evader.

    Feed back is always helpful.

    SAL

     

     

     

    • Proposé comme réponse aricakay vendredi 25 février 2011 21:08
    samedi 18 septembre 2010 23:37
  • Thanks it works . People should follow this advice.

     Click start & type Services.msc then hit enter.

    Right click on the security center , click properties & choose automatic & start.

    Good luck ever body and good work  Evader.

    Feed back is always helpful.

    SAL

     

     

     

    i try to do this but i don't find security center in the services...pls help
    vendredi 29 octobre 2010 17:00
  • I've had this problem for over a week now and have tried all of the above but still unable to start security center.  I sometimes get error 1079. And answer to someone above I believe it should be set to auto delayed to allow the dependencies to start first. Shame I can't do it myself.
    • Proposé comme réponse chinz_aja lundi 21 février 2011 12:47
    • Non proposé comme réponse chinz_aja lundi 21 février 2011 13:26
    mardi 2 novembre 2010 17:28
  • I have tried all of these, and I really hesitate to wipe and reload, everything else is working fine.  I even ran sfcscannow in attempts to repair the files/dependencies but still the red x.  Again, no virus (using MSE and SAS) and system is clean and has been.  Have a feeling it is some registry entry or maybe a "microsoft fix-it" could rectify this problem without having to invest in reloading...  still open to suggestions...
    eph61820
    dimanche 21 novembre 2010 14:05
  • I got frustrated with again yesterday, and did more digging and more people are frustrated by this than before... which means there are more solutions and suggestsions.  One that WORKED for me FINALLY was this one:

    http://windowsxp.mvps.org/wscsvcfix.htm

    I realize that the error code may not be the same, the os may not be the same, but all I know is that I ran this, and no more red x notification with Win 7 Ultmate Security Center notice...


    eph61820
    lundi 22 novembre 2010 10:39
  • type in the search box : services.msc  and press enter (it must be performed in the administrator account or run the Services.msc as admin)
    then look for safety center something like that and double click on it and look if its set to : start automatically(delayed) if not then choose this option and press start right below that option..
    hope this helps,
    RR
    Only thing you left out is.. one you go to run and type in services.mrs and press enter. i didn't see the setting to do this.. till I looked at the bottom and saw two tabs. (Extended and Standard) click on the standard tab and scroll down till u see Security Center.. not safety center..lol. and double click on that and set it to automatic with no delay, then hit the start button right under where u set to automatic. .. Thanks for the guidance to solving my problem! Hope this with help others like it helped me! 
    • Proposé comme réponse OwenLloyd dimanche 20 octobre 2013 03:49
    mardi 21 décembre 2010 03:27
  • man omfg thx alot about that i searched all morning about my trouble of not getting the security center on how u said it was disabled from the services thx again :D
    samedi 25 décembre 2010 09:24
  • I had the same problem and all my virus trojan scans came out clean....Microsoft Security Essentials wouldn't start and by chance I installed avg which found the cause of my problem a virus/trojan called rundll.exe  it quarantined it and everything is perfect ( It would even remove all my restore points)

    Hope this helps :-)

    mardi 28 décembre 2010 21:34
  • Even i have the same problem... issue I ve been facing is a big story....

    I had connected my external HDD to my laptop and unaware of the presence of DANGEROUS trojan..which eventually got into my laptop and was stored in my temp folder with DHWPCXXX name..

    I am running symantec antivirus and it used to prompt every now and then about the virus...it used to say quarantined and then i used to delete it.  However, the virus keeps coming back and some times i used to get around 300 notifications of all DHWPCXXXX trojans from my temp folder.

    After going through lots of microsoft forums , i have tried the Malware bytes, Super anti malware , super spyware...cleaned the registries and tried all the possible options .

    NO LUCK...so as per on of the solutions giving online..i tried to delete all the DHWPCXXXX files in my TEMP folder manually. Then started my actual problem.... :(

    MY WINDOWS SECURITY SERVICE CENTER WILL NOT STARTUP AUTOMATICALLY AND IS GETTING DISABLED BY ITSELF... I TRIED TO RESET TO AUTOMATIC SOME MILLION TIMES BUT IT GETS DISABLED AUTOMATICALLY... SOME THING IS CONTROLLING THE SECURITY ACCOUNT AND DISABLING THE SERVICE.

    Please some one from here, who had similar problem help me out....do we have a fix for this any solution which i can try out!!!!

    This Virus has disabled my:

    • Windows Update Service
    • System Restore
    • Windows Security Service

    and I am not even sure how many services are disabled by this annoying trojan.

    PLEASE FIX THIS..

    thanks a million!!

    • Proposé comme réponse chinz_aja lundi 21 février 2011 12:18
    lundi 24 janvier 2011 10:00
  • Some one Please Help me ..is there no other fix to this than to FORMAT.....
    mercredi 2 février 2011 09:22
  • Hey,

    I am having the same problem. I noticed that the dependencies that you indicated here are not available in the dependencies tab.

    The question is how can I add these dependencies here?

    And the path to the executable is also a little bit different

    C:\Windows\System32\svchost.exe -k netsvcs

    how can I change this one?

    jeudi 3 février 2011 02:47
  • Hey,

    I am having the same problem. I noticed that the dependencies that you indicated here are not available in the dependencies tab.

    The question is how can I add these dependencies here?

    And the path to the executable is also a little bit different

    C:\Windows\System32\svchost.exe -k netsvcs

    how can I change this one?

    I dont think they have a FIX for this!!!! Damn you Virus... I am planning to Format my Machine...:(
    vendredi 4 février 2011 05:17
  • I now have the same problem. "Windows Security Center Service can't be started". Tried all the options - Automatic, Automtic (delay) and Manual options. I get an error 1084. If there is a fix, I will really appreciate it.
    mardi 22 février 2011 07:43
  • i had this same problem. its a virus. download avast antivirus free edition and do a boot scan. it will find the virus. then you have to type Services.msc into the start menu, find the security center, turn it on to automatic. then turn on windows security essentials if you have that. avast is the only virus program that was able to detect it and get rid of it. hope this helps :)
    vendredi 25 février 2011 21:07
  • THANKS IT WORKS AND ITS SIMPLE THANK YOU VERY MUCH.
    mercredi 2 mars 2011 22:10
  • type Services.msc in the search box,

    check if security centre account is disabled

    right click security centre account,

    click properties,

    click automatic(delayed start). GOOD LUCK

    mercredi 2 mars 2011 22:17
  • well im running windows 7 ultimate and there is no "security center" or any variant even in the services.msc

    is it different, or has it been somehow removed. i am currently getting pop ups via a fake antivirus (unsure which virus this is)

    scans yield nothing, malwarebytes found a reg key that was infected cleaned it problem went away for approx 24 hrs. then randomly came back this time nothing found...

    security center will not enable

    HELP!

    dimanche 27 mars 2011 15:54
  • Your information worked and was helpful in getting rid of the "fix" message in the Windows Action Center.   Thank you.
    jeudi 31 mars 2011 07:18
  • I wanted to say that I did this and it finally took that annoying message away...thanks for the advice!
    samedi 2 avril 2011 19:09
  • I use Microsoft Security Essentials and I have not seen any issues. I recommend using it as its free with no expiry.

    If there is a problem, I am here and I can help.

     


    My MVP is for the Windows Desktop Experience, i.e. Windows XP, Vista and Windows 7 IT

    Remote Assistance is available for a fee.

    I am best with C++ and I am learning C# using Visual Studio 2010

    Developer | Windows IT | Chess | Economics | Hardcore Games | Vegan Advocate | PC Reviews

    samedi 2 avril 2011 21:59
  • I tried this but when it's about to start I get an error mesaage claiming that it did start but then shutted down again.. what to do?
    lundi 25 avril 2011 00:06
  • Go to my IT site and look at the security area of my forum

     

     


    My MVP is for the Windows Desktop Experience, i.e. Windows XP, Vista and Windows 7 IT

    Remote Assistance is available for a fee.

    I am best with C++ and I am learning C# using Visual Studio 2010

    Developer | Windows IT | Chess | Economics | Hardcore Games | Vegan Advocate | PC Reviews

    lundi 25 avril 2011 00:10
  • Hi Vegan,

    Can you pls help me with this? I am having the same problem as above. Cant run my window security...

    I look for for site and cant find the security area...i cant find info i needed. I am too noob on these. Pls advice.

    dimanche 5 juin 2011 18:20
  • Its on the bottom of the home page

     


    My MVP is for the Windows Desktop Experience, i.e. Windows XP, Vista and Windows 7 IT

    Remote Assistance is available for a fee.

    I am best with C++ and I am learning C# using Visual Studio 2010

    Developer | Windows IT | Chess | Economics | Hardcore Games | Vegan Advocate | PC Reviews

    dimanche 5 juin 2011 22:14
  • I check the security site, which should be helpful to me?

    "Go to my IT site and look at the security area of my forum"

    I just install avast to clean my com, but seems avast only block the pop up (virus/trojan), i dont think avast remove it even i run full scan the virus detection is 0.

    I also went http://security.symantec.com/sscv6/WelcomePage.asp as advice in the security forum but whenever i wanted to run online full scan my window explorer have an error icon shown at the bottom of the explorer (!) error of page.

    I still cant start my WSS. HELP~~~

    lundi 6 juin 2011 00:49
  • See if MSE will install, if it does run it

    See the IT home page for the link

     

    I plan a new security soon, once I have more tools developed

     


    My MVP is for the Windows Desktop Experience, i.e. Windows XP, Vista and Windows 7 IT

    Remote Assistance is available for a fee.

    I am best with C++ and I am learning C# using Visual Studio 2010

    Developer | Windows IT | Chess | Economics | Hardcore Games | Vegan Advocate | PC Reviews

    lundi 6 juin 2011 00:59

  • Btw, if my MSE cant run i can reinstall?

    lundi 6 juin 2011 01:07
  • i go uninstall my MSE and reinstall again k.
    lundi 6 juin 2011 01:16
  • it does not work. my mse cannot run at all now. >_<

    any one , pls help me to activate back my Window Security Service and Microsoft Security Essential. I cant stop the pop-up. whateva tabs i click it kept redirecting me to other pages

     

    lundi 6 juin 2011 01:37
  • Looks like too much damage from malware

     

    Backup what you can and format your disk and install Windows fresh

     


    My MVP is for the Windows Desktop Experience, i.e. Windows XP, Vista and Windows 7 IT

    Remote Assistance is available for a fee.

    I am best with C++ and I am learning C# using Visual Studio 2010

    Developer | Windows IT | Chess | Economics | Hardcore Games | Vegan Advocate | PC Reviews

    lundi 6 juin 2011 01:47
  • ya, system restore also being disable...i dont know what i can do now...damm sad
    lundi 6 juin 2011 02:49
  • i am also having the same problem. In my case, when i restart the PC (windows 7 ent.) security center service gets disabled and if i start manually, its gets stopped and my antivirus FCS  is also not running. then i need to stop the run.dll process on the task manger and i have start the security center service and FCS.

    has any one got the solution for this?

    lundi 20 juin 2011 04:50
  • Well i have the same problem, i fixed it with the solution to go to Services.msc it worked first time. Now my MSC starts and it closes at the moment he is shown on screen i reinstalled it and ran it from SAFE MODE(when your PC starts tap F8 and chose Safe Mode) i put my PC on scan and it found 7 trojans, Malwarebyts Anti-Malware found same number of malwares and i cleaned my PC so now i'm going restart my PC tap F8 while PC is booting and go to Repair Computer, then Startup Repair and see the results ;)


    I'm using Windows 7

    and i have problem starting Services.msc when im in Extended Bar:

     

    " One or more ActiveX controls could not be displayed because either:
    1)Your current security settings prohibit running ActiveX controls on this page OR
    2)You have blocked a publisher of one of the controls.
    As the result, the page might not display correctly"


     

    EDIT: Whoala, it worked :) and thank to my skill an user Progint and his link(http://windowsxp.mvps.org/wscsvcfix.htm)

    It worked..USE SAFE MODE! Wish you luck ;)

    • Modifié Todor Srbin mardi 28 juin 2011 22:41 Fixed!
    • Proposé comme réponse Todor Srbin mardi 28 juin 2011 22:48
    • Non proposé comme réponse Todor Srbin mardi 28 juin 2011 22:48
    mardi 28 juin 2011 22:33
  • I had the same exact problem with the Security Center automatic disabling issue on my XP Home Premium SP3 Dell tower. I too ran complete Malwarebytes and SuperAntispyware scans and cleaned everything found BUT the problem persisted.

    ALAS the fix!!! After 2 days of Googling and trying HijackThis and SpyBot here is what worked for me...

    You need to first download and install Microsoft Security Essentials and then download the latest MSE updates file separately becauase the virus does NOT allow the updates to MSE to be applied otherwise. In fact, this driver virus will NOT even allow MSE to start!! Once you have the updates applied reboot into Safe Mode and log into the Administrator account (God Mode!!). Then run an MSE scan and it will find and clean-up the bad drivers. The reason all the other tools do NOT work is because the virus is disguised as a Microsoft driver which gets loaded on boot-up BUT MSE is able to detect and clean that!! Once clean in Safe Mode reboot into normal mode and keep running MSE scans until you get a clean scan.

    Problem solved!!!

    ALAS Sir Malmare!!! You fought valiantly but revenge is SWEET!!!

    HappyFacePCs.com


    Regards, Donald V Paquette CEO www.HappyFacePCs.com
    dimanche 17 juillet 2011 12:06
  • I have tried many different solutions - and depending on what is affecting the WSC, depends on the fix.  For instance, a recent WSC corruption fix was to make sure that Security Center, WMI (under services) both were LOGON with LOCAL SYSTEM ACCOUNT and ALLOW....

     

    This is what fixed it for me after 2 weeks of trying everything...


    Respectfully Yours, Derek R. Iannelli-Smith IT Strategist, A+, Network +, Security+
    lundi 18 juillet 2011 18:09
  • First, turn on your computer and login as administrator, go to Run command and type "services.msc", look for "Security Center" and double click on it, on startup type choose "Automatic" and on Service status click "start", restart your computer and your Windows Security Center will be enabled again. Or if you want more ways to fix this problem visit this link: http://www.techyv.com/questions/how-fix-disabled-security-center-windows-xp

    vendredi 22 juillet 2011 13:40
  •  Tried to run it... Got an error saying "An error occurred during Phase 10" Clicked ok, followed by which got another error saying "An error occured during Phase 2 - 2147024891... Clicked of again and got another error saying "An error occured during Phase 3 - 2147024891... clicked ok and got another error saying "Some errors were encountered while fixing the security service center"

     

    Please advise !!!

    • Proposé comme réponse waled2012 mercredi 7 septembre 2011 13:45
    • Non proposé comme réponse waled2012 mercredi 7 septembre 2011 13:45
    samedi 20 août 2011 13:25
  • I am running Windows 7 Ultimate. I have never had any issues with viruses or spyware on this machine.

    • I have MSE installed but something has got it disabled automatically. I suspect it to be a virus or malware.
    • I keep getting a notification in the Action Center that the "Windows Security Center service is turned off". When I click the button to turn it on, I get a message that "WIndows Security Center Service can't be started."
    • I located the Security Center service under the services.msc and when I try to start it from there it does gets started but within a few seconds it gets disabled again. Next when I again attempt to start the service from services.msc it displayes an Error Code: 1058
    • Also the System Restore Utility has been turned off by whatever is causing this problem.
    • Untill recently, I used to get an unsusual annoying behaviour in all my web browsers, i.e. whenever I clicked on a link from any search engine, It would redirect me to a series of webpages almost ads, instead of opening the actual link.

    The browser trouble seems to be resolved after I used Kaspersky Pure to scan my computer and it found a DLL file named PERFDISKL.DLL under C:\Windows\SysWOW64. The service used to initiate itself whenever I opened a web browser.

    I have tried scanning my system multiple times using various anti-virus, anti-malware & anti-spyware, but none of them was a success. The programs that I used to scan are

    1. MSE in Safe Mode, (latest update file dwnlded and installed separately.)
    2. Kaspersky PURE
    3. Malwarebytes Anti-malware
    4. SpyBot Search & Destroy
    5. AVG Free 2012

    All these softwares are fully updated.

    • Also tried the SFCScannow, and everything is fine there.
    • Activated the Hidden Administrator account and ran COMBOFIX, but no success.

    Please help me. I don't want to do a fresh install on my laptop.

    lundi 20 février 2012 18:32
  • if you have the DVD handy, boot that and select repair


    Windows MVP 2010-11, XP, Vista, 7. Expanding into Windows Server 2008 R2, SQL Server, SharePoint, Cloud, Virtualization etc. etc.

    Hardcore Games, Legendary is the only Way to Play

    Developer | Windows IT | Chess | Economics | Vegan Advocate | PC Reviews

    lundi 20 février 2012 19:54
  • I use this ComboFix program  it work..!!   you can download it here http://www.bleepingcomputer.com/download/combofix/dl/12/ 

    • Modifié wich mardi 12 juin 2012 12:06
    mardi 12 juin 2012 12:05
  • In some cases restarting the Service does not work - if the service is missing from services.msc then follow the simple step by step instructions below to restore it:

    Windows 7 Security Centre Service Fix

    I hope this helps someone

    • Proposé comme réponse A. TheOne jeudi 19 juillet 2012 10:48
    jeudi 19 juillet 2012 10:47
  • No dont use Super anti-spyware use AVG-2012 or Malwarebytes i think those are the best my self

    :D

    jeudi 6 décembre 2012 07:32
  • This works..Many thanks!

    F16JetJock

    mardi 30 juillet 2013 17:49
  • thanks, I tried this but it doesn't really fix it. it removes that service from the registry
    dimanche 22 septembre 2013 20:20
  • That worked great for me thanks but I noticed that a previous blogger had a crash after this later so I thought I might just add the bit below to show how important having the firewall up is -

    After doing the above the problem that I was left with was that the Firewall was off and I could not get it back on through windows or ‘System Mechanic’ so I ran Microsoft Online Essentials virus search which found nothing I then ran their download virus detector which found nothing . So I then backed my system to a month back through System Mechanic registry backup and after all this Microsoft essentials found 2 viruses in win32 and they were Trojan Dropper and Trojan Downloader which I am now rid of . I don’t know what these guys get from putting these viruses about but they must have a very strange life style !

    vendredi 25 octobre 2013 13:25
  • that helped me solve the issue too ...thx man
    mardi 10 décembre 2013 09:26
  • Hi,

    I'm having the same issue. Under the dependecies tab I'm missing everything from "Windows Management Instrumentation" down. I'm guessing that's where my problem lies. Is there a solution to that?

    lundi 20 janvier 2014 13:23