none
Error Code: 2147500037

    Question

  • Hi!

    I want print a page (the homegroup key's page). When I click on the "Print Page" to get a Error Message. The Message says: "An error occurred while Windows was trying to print your homegroup password. (Error Code:2147500037)"

    Why get this? Whats I do?

    =====================================================

    ¡Hola!

    Yo quiero imprimir una página (la pagina de la clave del "HomeGroup". Cuando clico en "Print this Page" sale un Mensaje de Error. El mensaje dice: "An error occurred while Windows was trying to print your homegroup password. (Error Code:2147500037)"

    ¿Porqué sale esto? ¿Qué hago?
    mardi 7 avril 2009 17:27

Réponses

Toutes les réponses

  • You would need to capture a screenshot of the page, and print the image.
    Rating posts helps other users
    Mark L. Ferguson MS-MVP
    mercredi 8 avril 2009 13:36
    Modérateur
  • You would need to capture a screenshot of the page, and print the image.
    Rating posts helps other users
    Mark L. Ferguson MS-MVP
    Why I could this? (Upload the screenshot)

    =================================================

    ¿Cómo puedo hacerlo? (Subir la imagen del error)
    mercredi 8 avril 2009 15:07
  • Hi LGTCH,

     

    Could you please let me know if other print job works fine? Could you print a document from Word or NotePad?

     

    Thanks.

    • Marqué comme réponse J. García jeudi 9 avril 2009 09:36
    jeudi 9 avril 2009 08:08
  • Yes, I could
    jeudi 9 avril 2009 09:37
  • I've the same case with my Lexmark 4850.
    I think that is an authority probleme but I dont know how to authorize the print service?
    vendredi 8 mai 2009 06:35
  • My Lexmark 2690 got the same response.... will do the print screen until we can get a better answer; thanks.
    lundi 3 août 2009 07:13
  • In the final release software, installed yesterday, I have the same error code on trying to print my homegroup passwword.  I can print from word. My printer is there as the default.  This is not what I had hoped for in a release version when the problem has been around since RC1.

    Is there a solution yet?
    mardi 20 octobre 2009 07:59
  • In the final release software, installed yesterday, I have the same error code on trying to print my homegroup passwword.  I can print from word. My printer is there as the default.  This is not what I had hoped for in a release version when the problem has been around since RC1.

    Is there a solution yet?

    I have the same problem. No problem printing documents but unable to print the Homegroup password and instructions.

    jeudi 29 octobre 2009 17:43
  • I, too, have this problem.  I can use my Canon Printer for other applications.  My Canon is connected to my router.   How do I get a screen shot?
    dimanche 29 novembre 2009 04:25
  • I, too, have this problem.  I can use my Canon Printer for other applications.  My Canon is connected to my router.   How do I get a screen shot?
    I have just ran across this error myself and would like an an answer. I have added the address to an upload of a screenshot taken two minutes ago.
    http://cid-fb0513a7dd0a8cfd.skydrive.live.com/self.aspx/.Public/screenshot^_print^_error.png

    Any assistance would be greatly appreciated.

     
    samedi 5 décembre 2009 09:31
  • See Microsoft's response here http://support.microsoft.com/kb/269562 
    MCSE, MCSA, MCDST
    samedi 5 décembre 2009 19:26
  • As far as I can see, that has nothing to do with this problem.  Moreover, I tried to run "MQExplorer", as the above mentioned knowledge base article instructed, and there is no such program on my Windows 7 Home Premium computer.
    vendredi 11 décembre 2009 22:14
  • I get the same thing trying to print the Homegroup page, how do we submit this to Microsoft, it is obviously a small bug in W7 if lots of people have it.

    mardi 15 décembre 2009 23:32
  • Same problem here.  Brand new Windows 7 64-bit on Core i7 machine with 9GB ram.  Very little third-party software installed - so far.

    I'm able to print to both connected printers from notepad, etc.  Same exact error message everyone here is getting.
    • Proposé comme réponse ann25 dimanche 28 février 2010 04:43
    samedi 19 décembre 2009 17:04
  • You're absolutely right.  The number of the error code is the same, but it has no (visible) bearing on this specific issue.
    samedi 19 décembre 2009 17:05
  • I'm having the same problem.  Brand new Windows 7 Pro 64-bit on new laptop.  Almost no new software yet.  I DID install Firefox.  Interesting clue (?) - I couldn't save the Firefox exe to C:\Program Files because I got a notice that I don't have admin authority.  But I DO have all permissions, or so I thought.  I went into control panel and made some change (can't remember) to give myself all permissions.
    Like everyone else, I'm able to print to both connected printers from notepad, etc.  Same exact error message everyone here is getting.
    mardi 29 décembre 2009 03:02
  • There are thousands of people all over that have this problem and all of the solutions provided do not work.  Does anyone from Microsoft ever read these forums and give an answer?  Help
    vendredi 1 janvier 2010 17:36
  • Same here with an Epson R220
    lundi 4 janvier 2010 19:53
  • Set IE as your default browser and try again.
    • Proposé comme réponse DaveSchz jeudi 7 janvier 2010 01:40
    jeudi 7 janvier 2010 01:40
  • I had the same problem as everyone else in this thread. Setting IE as the default browser indeed solved it. Honestly this bug is not acceptable.
    • Proposé comme réponse JBHFL jeudi 14 janvier 2010 15:07
    jeudi 7 janvier 2010 20:22
  • I can confirm that setting IE as the default browser solved the problem...until I set Firefox back as default. I'll try not to lose the homegroup password again!
    • Proposé comme réponse JBHFL jeudi 14 janvier 2010 15:07
    dimanche 10 janvier 2010 08:14
  • Yes, same problem with update from Windows Vista Business to W7 Ultimate today on 1/14/2010!

    Most annoying -- MQ Explorer does NOT exist and the solution to set IE as the default works. I prefer Firefox.

    I believe the "bug" should have been fixed by now!
    jeudi 14 janvier 2010 15:10
  • A30N -

    But if you set IE back to the default later, you can print it again!
    vendredi 19 février 2010 15:18
  • In my case it was because my default browser was not Internet Explorer
    lundi 1 mars 2010 00:12
  • I just installed W7 on my laptop and got the above error. FireFox is my default browser. Does FireFox need a special plugin to prevent this error? I was able to print a screenshot - "fn" + "alt" + "home" [prt sc] keys, then paste into Word or whatever. That solved my problem.
    samedi 10 avril 2010 09:40
  •  

    Set IE as your default browser and try again.
    • Proposed As Answer by DaveSchz Thursday, January 07, 2010 1:40 AM
    •  

     

    Thanks for the solution perhaps you ought to add  MCSE, MCSA, MCDST to your sig lmao ;)

     

    @ GloriaK, No you need to open up explorer and go to tools/internet options and select the programs tab there click the default tab at the top,you can change it back later or after printing if you wish.

    samedi 10 avril 2010 09:48
  • It's not just firefox though. I had Google Chrome as my default, and got the same error when printing my Home Group password. Setting default browser to Internet Explorer solved the issue, though it's rather annoying to even have to do this. 
    lundi 12 avril 2010 06:04
  • Hi megaten,

    LExmark X4850 Printer Updated driver and software link download page

    Good Luck

    mercredi 9 juin 2010 14:47
  • DaveSchz,

    You are a genius!  How did you figure that out?  I searched and searched through MS sites and ended up installing MSMessage Queueing (MSMQ) in a vane attempt to get the error message to go away.  Your January post saved me a lot of grief (Mid-July now).  Thanks!   As soon as I "reset" IE as my default browser, I was immediately able to print and not get the error.

    Your the man!

    Tennessee33

    • Proposé comme réponse bmkmd lundi 13 décembre 2010 18:41
    dimanche 18 juillet 2010 23:44
  •  

    A simple solution which works!!!!  Really.

    As suggested by Microsoft in the HomeGroup set-up instructions, if the password won't print and the infamous Error

    code: 2147500037 shows up, just change the default browser back to Internet Explorer.!!!

    That's IE Browser/Tools/Internet Options/Programs/Default Web Browser  Internet Explorer.

     

    You ask, "What does the browser have to do with printing the Homegroup password?"

    I haven't the faintest idea, but it works, and I can go back to Firefox as soon as this is corrected.

     

    bmkmd

    lundi 13 décembre 2010 18:52
  • I think I have a faint idea... And it does not look pretty!

    This is part of the ongoing fight between MS and other browsers, and since MS can pull all the strings... you got the idea.

    To me, the proposed solution is NO solution at all. Why must I have to make IE my default browser when I do not like it, just to be able to print a freaky page? If anyone considers making a specific browser his/her default browser against my own will? If anyone still sees it as a "simple" and "genius" solution, I'll say no more.

    LY

    mardi 25 janvier 2011 11:08
  • ridiculous.  i had to fix this for a friend.

    thank goodness i am on mac and linux ;)

    lundi 7 février 2011 05:27
  • Dear Zhang:

    I think we got it now.  Forcing the use of IE is no solution.  It has the distinct smell of arrogance.   I refuse.  I just took a snap shot and pasted it.  Now I am busy trying to get stations with two versions of Windows 7 and XP professional talking to each other.  Three hours of billable time lost so far.

     

    I am sick of systems that don't really do anything different so some market programer can move the buttons, maybe fix the bugs in the old system and call it new.  Oh, new systems are not free are they?

    samedi 2 juillet 2011 00:28
  • Everybody that uses anything but MSIE as the default browser has this issue.  Its a legacy from the Microsoft "MSIE is the only browser" days.   If you really need the printout - i.e. don't own a pencil <lol> - change the browser default to MSIE and change it back again afterwards.
    • Proposé comme réponse johnk860 mercredi 29 février 2012 16:18
    mercredi 29 février 2012 16:17
  • A MODEST PROPOSAL

    My response to MS solution link here http://support.microsoft.com/kb/269562 ,  THIS IS NOT A SOLUTION. 

    Why the heck does it require a third party paid application for me to solve a by design restriction in the OS?   If MQExplorer is free, which it isn't, then you should include a link in the solution. 
    By design you can't do it, so some ID10T put in a button? Well, how about by design... remove the DAMN button...  Stupid Microsoft This problem is a precursor to another law suit.

    To the solution, Make IE your default browser?  OMG, Seems Microsoft ought to change it's motto to... remember Netscape.  30+ Million in fines for acting like a monopoly.  The real error is probably a null pointer error problem they've never resolved. "That's my story and I'm sticking to it."  Because some ID10T at MS forgot to set the iteration from 0 to 2 times, instead of 1 to 3 times, MS got caught "forgetting" to write out the downloaded Netscape filename link to the directory index. oops.  A lightning bolt can be traced, if it always follows the same path the first time.  Still it was worth the 30+M cause, I run Chrome, Firefox, Opera, and IE.  No, IE is not my default. ;-)

    That our history records unsuccessful attempts of Microsoft engaging in Monopolistic practices, when in fact they are not a monopoly.  The one thing I've always said about computers is that one application has the ability to make it's competetors look like idiots.  So MS implements changes to constrain the activities of certain areas by security zones.  Except for them.  They of course al *always* the exception to that rule.  And it will always be that way as long as we allow non-cooperative Democracy greed based, non ethical, business to run rampant.

    Here is the true solution.

    MICROSOFT:  REMOVE THE DAMN BUTTON!   Yes, it's a convenient action.  IF IT WORKED!!!  Yes, it's a security issue and one should probably not do it.  BUT WHO CAN MEMORIZE THAT!  So it has to be moved from the realm to the obscure.

    YOU: WRITE IT ON SOMETHING EDIBLE, BY HAND, THAT TASTES GOOD... USE IT....   THEN EAT THE DANG THING AND PROTECT YOUR SECURITY!!!

    A MODEST PROPOSAL 

    Chip

    • Proposé comme réponse Cyberchip jeudi 22 mars 2012 21:08
    jeudi 22 mars 2012 21:07
  • How about that.... it's fixed! :-)

    What we need a signature?

    dimanche 22 juillet 2012 09:15
  • I first got this error after I installed Windows 8 and set my default browser to the App version of IE10, not the Application version of IE10.  (Metro vs. Desktop Interface).  When I switched the default browser back to the desktop version of IE 10, I was able to print the password.  Strange bug that hasn't been fixed in all of this time!
    samedi 3 novembre 2012 14:29
  • Same error message trying to print the Homegroup password. It only works when IE is set as the default browser. This isn't even fixed for the new IE app in Win8! WTH?
    dimanche 8 septembre 2013 21:52
  • I have read the whole long thread.  I agree with everyone that it is an idotic, arrogant, or just downright sloppy bug in a piece of software by a corporation that should know better.  However, it does not seem to affect much else, and is probably way down at the bottom of the barrel as far as Microsoft is concerned in terms of where to put its software development horsepower.

    I have found a really fast, low tech solution.  Write the homegroup password down on a sticky note.  Pencil, pen or crayon will do.  Carry it to the device you want to configure (since you are going there anyways).  Use the info on the sticky note to actually hand type the password into the new member device of the homegroup.

    Compared with kicking IE into status as the default browser, printing, kicking IE our of default browser status, and then generally checking to make sure none of your other browsers got messed up in the process, this saves time in the long run.  One can even post it in a secure place, like under the desk along with all that chewing gum.  It is, after all, a sticky note.

    lundi 7 octobre 2013 15:20
  • Set Internet Explorer as your Default Browser:

    Start > Control Panel > Default Programs > Internet Explorer > Set this Program as Default

    Print password and instructions

    Start > Control Panel > Default Programs > Google Chrome (or FireFox) > Set this Program as Default

    • Proposé comme réponse 1nd1g0 jeudi 21 novembre 2013 03:59
    jeudi 21 novembre 2013 03:58
  • Great rational response.  Some people need to get a reality check and worry about bigger issues.  Also easier to attach the sticky note to the bottom of the desk than an 8 1/2 X 11 sheet of paper.
    jeudi 28 novembre 2013 16:51
  • I have read the whole long thread.  I agree with everyone that it is an idotic, arrogant, or just downright sloppy bug in a piece of software by a corporation that should know better.  However, it does not seem to affect much else, and is probably way down at the bottom of the barrel as far as Microsoft is concerned in terms of where to put its software development horsepower.

    I have found a really fast, low tech solution.  Write the homegroup password down on a sticky note.  Pencil, pen or crayon will do.  Carry it to the device you want to configure (since you are going there anyways).  Use the info on the sticky note to actually hand type the password into the new member device of the homegroup.

    Compared with kicking IE into status as the default browser, printing, kicking IE our of default browser status, and then generally checking to make sure none of your other browsers got messed up in the process, this saves time in the long run.  One can even post it in a secure place, like under the desk along with all that chewing gum.  It is, after all, a sticky note.

    Yes absolute arrogance from Microsoft. It is now June 2014 and people are having the same issue.

    Make IE your default browser :-) - I have already pointed out that this is 2014

    MS Joke

    dimanche 8 juin 2014 20:15
  • I've been having the same troubles as everyone else on here. I try to print out my password for my Home Group and I instantly get an error code: 2147500037

    Well, you fixed my lil red wagon; so-to-speak.

    I thank you very kindly for your response in setting IE (Internet Explorer) as my default web browser, and voila!

    As soon as I did this--I went to print out the password again and it printed instantly!

    All I had to do was open up IE and go to the TOOLS tab then click on Internet Options. Then I went to the tab that said programs and right up top it tells you whether or not IE is your default web browser, and if not, all you have to do is click on "Make Default". That's it. I have Windows 7, so I'm not sure if the steps are the same with different (OS) Operating Systems.

    But I am grateful for this reply!

    Cheers!

    jeudi 12 juin 2014 21:03
  • That's a workaround. We shouldn't have to use the trash browser IE. I think these issues are attempts to force MS programs like IE and the virus Bing on us.
    dimanche 3 août 2014 02:33
  • I agree.Shy should we have to use a peice of crap software that picks up viruses and infects our computers. I refuse to have IE as my default browser because if I do I get viruses. Why would I do something so stupid. Come Microsoft - you think you are the KING of software then STOP giving us software with bugs in it and we might just start using it.
    jeudi 14 août 2014 22:07