none
Vista 64 bit SP2 still cannot install Reverting Changes unknown error 645

    שאלה

  • I have tried the system readiness checker, it completes fine, turned off everything but MS in msconfig, uninstalled AV, disconnected usb drive, pulled CD sata cable, tried Windows Update, download and install 5 language, all language still no luck. Reinstalling OS is really not a good option as I only have the original release on the recovery partition. That means losing everything, then installing SP1 and THEN MAYBE SP2 will install. The one weird thing I noticed is the FIXIT for Update reports my system as an AMD X64, it is a dual core pentium... maybe something there ?
    שבת 28 ינואר 2012 20:08

כל התגובות

  • I have tried the system readiness checker, it completes fine, turned off everything but MS in msconfig, uninstalled AV, disconnected usb drive, pulled CD sata cable, tried Windows Update, download and install 5 language, all language still no luck. Reinstalling OS is really not a good option as I only have the original release on the recovery partition. That means losing everything, then installing SP1 and THEN MAYBE SP2 will install. The one weird thing I noticed is the FIXIT for Update reports my system as an AMD X64, it is a dual core pentium... maybe something there ?


    More info: The system is an HP a6637c with Vista Home Premium, it has an Intel E5200 that DOES show up on System Properties. When I look at the CBS.log file the 2nd line is where it seems to be loading c:\windows\winsxs\amd64_microsoft-windows-servicingstack_31bf3856ad364e35_6.0.6002.18005_none_676975d87cc9b6e6\cbscore.dll . I cannot find the word intel anywhere in the log file... What should the file look like for an intel based system ?

     

    I am considering deleteing the log and persistence files, restoring to a couple of weeks ago and restarting the system readiness tool...   Most unhappy with HP on this one. I remember back to an XP machine I helped a friend with when it would go into endless bootloop from using the HP recovery disks to do a CLEAN install - turns out it was a known issue with them but they would only provide the solution via paid support ! Their version loaded a driver for the wrong manufacturer CPU, and you have to go in and manually delete file from a safe mode command prompt starup. I am thinking the same programmer still works at HP...

     

     

     

    יום ראשון 29 ינואר 2012 14:26
  • After 3 days of trying success !! I restored to oldest date available, reran Norton uninstaller, turned off everthing but MS in msconfig ( left intel matrix storage running) left all other drives disconnected. Ran readiness tool (kb947821 aug 2011), then installed from windows update instead of standalone .... voila. what a p.i.a. ... seems the amd archetecture is just a nomenclature thing -
    יום ראשון 29 ינואר 2012 21:30