none
Printing issues when using remote desktop connection

    Domanda

  •  I have a computer we'll called XPHOME. XPHOME has XP loaded on it. It is on a home network with ethernet etc. It has a USB Samsung CLP315 printer attached to it, which we will call SAMSUNG.  XPHOME prints to SAMSUNG without any problems. SAMSUNG is shared and has the latest drivers.

    Configuration on XPHOME
    Driver # is 3.04.85:44 
    Port: USB001 Virtual Printer Port for USB 
    Sharing Additional Drivers Installed  Intel Environment Windows 2000 or XP

    Using remote desktop connection, I connect to my computer at work, which we will call WORK which has Windows 7 on it and is part of a LAN. When using Word for instance on WORK, I should be able to print to SAMSUNG on XPHOME. However SAMSUNG on XPHOME does not show up as an available printer. I can however print from WORK to printers locally connected or shared on the LAN to WORK. Unfortunately this is of limited use to me as I cannot physically obtain the paper printed, nor know if the page printed correctly until the next day I get to work.

    I have the following Options settings on the Remote Desktop Connection when I connect Remotely from XPHOME to WORK. I believe this correctly follows the info I found on the knowledgebase.

    Under the General tab, I have the correct Computer and user name. I have "Allow me to save credentials" unselected.

    Local Resources tab, "Local Devices and Resources Printers" and "Clipboard" are selected. Under "More", "Smart Cards" and "Serial Cards" are selected. Likewise "Drives" and "Supported Plug and Play Devices" and their suboptions are all selected.

    Programs Tab   Nothing is Specified

    If there is other information in the options which may be germane, please advise and I will detail further.

    Previously XPHOME used to connect via Remote Desktop Connection to a different WORK computer which ran XP. When I would be doing things on WORK and wanted to print to SAMSUNG on XPHOME, SAMSUNG showed on the list of available printers and would print jobs from WORK

    On the LAN at the office, WORK is connected and prints to a shared printer on a showroom computer (running XP) that is identical to SAMSUNG for model # and driver. So by my thinking the driver is already loaded and functioning.

    Any assistance would be appreciated.

    martedì 23 novembre 2010 04:57

Risposte

  • Hi,

    There is a known KB you can refer:

    Printers that use ports that do not begin with COM, LPT, or USB are not redirected in a remote desktop or a terminal services session

     

    When you use Remote Desktop Connection or the Terminal Services Client version 4.0, 5.0 or 6.0 to connect to another Windows-based computer from a computer, your local printers are not redirected. As a result, your local printers are not available in the remote desktop or terminal services session.

    You can use this KB methods to fix your problem.

    Furthermore, if you want to use your printer to print documents that are stored on the remote computer. You need to set this up just before you connect. The setting will be saved so that you won't need to change it the next time you connect.

    1. Open Remote Desktop Connection by clicking the Start button, clicking All Programs, clicking Accessories, and then clicking Remote Desktop Connection.
    2. Click Options, and then click the Local Resources tab.
    3. Under Local devices and resources, select the Printers check box.
    4. Click Connect to start the session.

    This link maybe also helpful to you:

    http://blog.hundhausen.com/CantPrintLocallyWhenUsingRemoteDesktopToMyServer.aspx

     

    Please Note: Since the website is not hosted by Microsoft, the link may change without notice. Microsoft does not guarantee the accuracy of this information.

     

    Regards,

    Leo   Huang


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    giovedì 25 novembre 2010 08:41
    Moderatore

Tutte le risposte

  • Hi,

    There is a known KB you can refer:

    Printers that use ports that do not begin with COM, LPT, or USB are not redirected in a remote desktop or a terminal services session

     

    When you use Remote Desktop Connection or the Terminal Services Client version 4.0, 5.0 or 6.0 to connect to another Windows-based computer from a computer, your local printers are not redirected. As a result, your local printers are not available in the remote desktop or terminal services session.

    You can use this KB methods to fix your problem.

    Furthermore, if you want to use your printer to print documents that are stored on the remote computer. You need to set this up just before you connect. The setting will be saved so that you won't need to change it the next time you connect.

    1. Open Remote Desktop Connection by clicking the Start button, clicking All Programs, clicking Accessories, and then clicking Remote Desktop Connection.
    2. Click Options, and then click the Local Resources tab.
    3. Under Local devices and resources, select the Printers check box.
    4. Click Connect to start the session.

    This link maybe also helpful to you:

    http://blog.hundhausen.com/CantPrintLocallyWhenUsingRemoteDesktopToMyServer.aspx

     

    Please Note: Since the website is not hosted by Microsoft, the link may change without notice. Microsoft does not guarantee the accuracy of this information.

     

    Regards,

    Leo   Huang


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    giovedì 25 novembre 2010 08:41
    Moderatore

  • Printing to a local Windows 7 or Windows XP  printer while initiating a Remote Desktop  logging into a remote host Host

    1. Unfortunately Remote Desktop by default will only display printers configured on serial and parallel ports, below is a work around I have personally found works.
    2. When you setup the Remote Desktop configuration be sure you click the Tab labeled Local Resources and at the bottom of the screen, see Local Devices and resources make sure that Printers and Clipboard are selected.
    3. Make the Local Printer you wish to print to on the machine initiating the Remote Desktop the default printer and be sure you can print to it (I have found this even works with shared networked printers)
    4. Install proper printer driver at the  Host End  (The site you're logging onto)  that matches the printer on the remote end (The end you’re initiating the Remote Desktop from). When you 1st install this printer on the Host End just select LPT1 as the port for now.
    5. On the Host end go to Devices and Printer and select the printer you  plan to print to, Click on printer properties, Select ports look for port labeled TS001, this should be the default printer on your local Remote Computer, Check this port and run a print test. (Unfortunately these TS??? Ports aren’t described by the operating system, the 3 systems I have checked this out on the port was labeled TS001 which was my default printer on the end initiating the remote desktop, but it certainly could be different on your system so it might take some trial and error to select the proper port.)
    sabato 17 marzo 2012 17:27