none
Black screen in Windows Virtual PC - XP Mode

    Domanda

  • WIN7 64bit Professional
    I start:
       Windows Virtual PC

                  Windows XP Mode

     The program takes a while but the green bar goes across, "Starting the virtual machine",  and a box comes up

     It says; "Could not enable integration features". I retry - same results. I "Continue" and get a black screen "Windows XP Mode - Windows Virtual PC" indicating that I have the program running.

     Click "Tools". "Enable Integration Features" is grayed out. Click "Settings" - box comes up with lots of choices but they are all grayed out.

     Click "Ctrl+Alt+Del" and it suggests "Ctrl+Alt+End" = nothing happens.

     Click "Action > Close and the program hibernates, but I never get the green screen saying I am running the program as a desktop.

     What to do?

     Thanks Rusty Nail 2

    Thanks  :-)R

    mercoledì 10 marzo 2010 17:23

Risposte

Tutte le risposte

  • When start up the VM, press SHIFT+ESC, this will open the console window and should let you see what's happening.
    giovedì 11 marzo 2010 18:14
  • Hi Rusty,

     

    If your BIOS is out of date, I would like to suggest you update it to check if it can fix the “could not enable integration features” issue.

     

    You may also test the issue in Windows 7 Clean Boot.

     

    If the issue persists, I also would like to suggest you uninstall and reinstall Windows XP Mode.

     

    Regards,


    Arthur Li - MSFT
    venerdì 12 marzo 2010 02:30
    Moderatore
  • Thank you Arthur . . . .
    I took your advice and did the uninstall and reinstall. It works fine now. I believe that (maybe), I was just starting the XP Mode when an automatic WIndows Update came down. I don't know that it caused the problem, but I am suspect. Anyway, thanks for the tip and smjain's tip is good too. Thanks and a salute to both of you! :-) R
    sabato 13 marzo 2010 15:29
  • Hello Arthur,

     

    Having same general problem as Rusty.  First installed Windows XP Mode on Windows 7 machine in December.  Worked OK for a few weeks, then the integration problem.  Used "Restore Previous Version" option which worked.  However, integration features disabled problem just occurred again as Rusty described.  Now the "Restore Previous Version" option did NOT work.  If I uninstall and reinstall Windows XP Mode, will I lose all my files?

    Is Microsoft working on a better solution to this problem?

    Thanks, Dawn200

    domenica 11 aprile 2010 16:47
  • Arthur, I just tried one other thing that fixed the problem, at least temporarily.  My Windows XP Mode was hibernating.  I shut it down, then restarted.  This time it worked and all my programs and files were there.  Possibly before when I did the "Restore Previous Version," the previous version was not restored because I only hibernated the Windows XP Mode, not turned it off.

    Now that I can use Windows XP Mode again, I also just made a new Restore Point.  However, I expect the integration problem to happen again.  I still want to know when Microsoft is going to correct this software incompatibility between Windows XP Mode and Windows 7, or whatever is causing the problem.  Our only other long term solution might be to switch to Apple Mac.  Please let me know if Microsoft can fix the bugs.

     

    Thanks, Dawn200

    domenica 11 aprile 2010 18:36
  • FWIW, I am seeing the same problem.  Very disappointed.  I will try to uninstall/reinstall, but right now I think I just wasted 90 bucks to upgrade to Windows 7 Professional.
    sabato 8 maggio 2010 00:58
  • Same thing here.  I feel like I need to power cycle on the virtual machine - it's in a screwy state and just hibernates and comes back in that dead state that Ctrl+Alt+Del or _End does nothing.  This is rather annoying to say the least.
    mercoledì 12 maggio 2010 20:50
  • Also seeing this issue, haven't fixed it yet. I'm going to try uninstalling and re-installing, after backing up the VHD file, and maybe that will retain my files, but i don't know...
    • Proposto come risposta frazou venerdì 28 maggio 2010 07:25
    venerdì 14 maggio 2010 19:53
  • Well...i did it something quite simple. Go to the virtual machine's settings and at the option close select shut down. Next time you'll try to 
    close the machine(that terrible black screen) it will tell you it can't shut down but it can be turned off.Click OK. Next time i opened the virtual everything was ok.I hope that helps

     

     

    • Proposto come risposta RuitBier venerdì 11 giugno 2010 15:26
    venerdì 28 maggio 2010 07:29
  • Thanks frazou!!  I was about to reinstall but changing the 'close' option to 'shut down' did the trick!
    venerdì 11 giugno 2010 15:26
  • Wow, thanks! I wasted a few hours trying to fix this and was just about ready to re-install when i tried this. This suggestion needs to be WAY HIGHER in the MSFT Knowledgebase.
    lunedì 30 agosto 2010 18:27
  • Thank you thank you thank you! Worked like a charm!
    giovedì 2 giugno 2011 14:54
  • you're a life saver! simple fix!
    venerdì 15 luglio 2011 11:55
  • Thats the answer

    Thanks Frazou

     

    venerdì 9 settembre 2011 19:23
  • Thanks Frazou

    That's a superb and perfect solution!

    giovedì 3 novembre 2011 10:47
  • Thanks Frazou

    You saved my day. Wonderful solution.

    venerdì 9 dicembre 2011 19:32
  • Frazou thanks a lot , i have spent more than 5hour trying to resolve the black screen / blue screen error. changing the close option to shot down did the trick. Thanks a million.

    you saved my week Good solution

       
    domenica 19 febbraio 2012 03:55
  • Frazou thank you;

    If I haven't scroll down this page, my day is gone.. You saved my day..

    Fareez

    domenica 27 maggio 2012 10:50
  • "Well...i did it something quite simple. Go to the virtual machine's settings and at the option close select shut down. Next time you'll try to 
    close the machine(that terrible black screen) it will tell you it can't shut down but it can be turned off.Click OK. Next time i opened the virtual everything was ok.I hope that helps"

    ^^Thanks Frazou worked for me too

    mercoledì 30 maggio 2012 05:45
  • frazou,

    What a shame I can only give you one "helpful" vote.  I went to Settings -> Close and then selected "Shut Down" as you instructed.  I then followed your instructions to use the "close" option (under the Action menu) and saw the message you described about not being able to shut down and clicked OK.  But I then had to select the "close" option a second time--something that wasn't in your original post, but may be what you did--and shut down Virtual PC.

    On my next startup, all was well.

    I have a lot of legacy XP software on that Virtual PC installation frazou.  Your post was extremely helpful.

    Many thanks.


    giovedì 19 luglio 2012 08:08
  • DO THIS AND DO A FORCE SHUTDOWN.  SET YOU OPTION TO SHUTDOWN.  YES FORCE SHUTDOWN AND IT WILL WORK AGAIN!! THANKS.  LOTS OF MONEY MAKING DATA i HAVE IN MY XPMODE.
    venerdì 21 dicembre 2012 07:48

  • My VM in XP Mode now comes up as an empty black screen after displaying a message stating that integration features have been disabled.  Yesterday I was able to load a normal-looking VM desktop but have been unable to ping the host from the VM. 

    Now I am unable to close the black screen, which is what Windows recommends I do in order to reenable integration features.  Clicking the Ctl-Alt-Del button at the top of the screen has no effect, nor does typing Ctl-Alt-End. 

    The "Close" item on the Action menu brings up a popup asking me to choose between Hibernate, Shut Down and Turn Off.  "Shut Down" has no effect.  "Hibernate" works, but when I next run VM in XP Mode, I get the same failure to enable integration and the same black screen.

    Man, can I use some help!

    Thanks in advance.


    Sheldon Penner

    venerdì 26 luglio 2013 21:46
  • Thanks it working now 100%
    mercoledì 21 agosto 2013 08:23
  • Well...i did it something quite simple. Go to the virtual machine's settings and at the option close select shut down. Next time you'll try to 
    close the machine(that terrible black screen) it will tell you it can't shut down but it can be turned off.Click OK. Next time i opened the virtual everything was ok.I hope that helps

     

     

    Thanks it working now 100%
    mercoledì 21 agosto 2013 08:24
  • Thanks! It works. This solutions needs to be way on the top.
    lunedì 9 dicembre 2013 13:37
  • Hi can you tell me how to get into settings please as all I have is a blank blue screen
    sabato 11 gennaio 2014 21:27
  • You open the Windows Virtual PC folder from the start menu, then right mouse click on the XP Mode icon and select settings from the menu.


    Bob Comer Microsoft MVP -- Hyper-V

    lunedì 13 gennaio 2014 14:25
  • Thank you Frazou. Saved my bacon nearly 4 years later.
    domenica 23 febbraio 2014 01:44
  • Yep, I 'Turn Off' vs. 'Shut Down' and that fixed my issue. Thanks a ton.
    giovedì 27 febbraio 2014 14:28