none
Disabling switch user, log off and lock from Shut down button

    질문

  • Is it possible to disable the switch user, log off and lock features from the Shut down button, so only restart and sleep appear?
    2009년 12월 5일 토요일 오후 5:20

답변

  • To disable Log off

     

    1. Type regedit in Start menu search box and then hit enter

    2. Navigate to the following key:

     

    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

     

    3. In the right-pane, create a new DWORD value named StartMenuLogOff and set value to 1.

     

    To disable switch user

     

    4. Navigate to the following key:

     

    HKEY_LOCAL_MACHINE\SOFTWARE \Microsoft\Windows\CurrentVersion\Policies\System

     

    5. In the right-pane, create a new DWORD value named HideFastUserSwitching and set value to 1.

     

    To disable Lock

     

    6. Under HKEY_LOCAL_MACHINE\SOFTWARE \Microsoft\Windows\CurrentVersion\Policies\System, create a new DWORD value named DisableLockWorkstation and set value to 1.

     

    Then, please restart the computer.

     

    Hope it helps.

     

    Thanks.

    2009년 12월 7일 월요일 오전 7:02

모든 응답

  • You want this for which OS?


    Thanks, -Vinod -- "This posting is provided "AS IS" with no warranties, and confers no rights. You assume all risk for your use."
    2009년 12월 6일 일요일 오후 7:00
    중재자
  • Sorry, for 7 home premium edition.
    2009년 12월 6일 일요일 오후 8:01
  • To disable Log off

     

    1. Type regedit in Start menu search box and then hit enter

    2. Navigate to the following key:

     

    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

     

    3. In the right-pane, create a new DWORD value named StartMenuLogOff and set value to 1.

     

    To disable switch user

     

    4. Navigate to the following key:

     

    HKEY_LOCAL_MACHINE\SOFTWARE \Microsoft\Windows\CurrentVersion\Policies\System

     

    5. In the right-pane, create a new DWORD value named HideFastUserSwitching and set value to 1.

     

    To disable Lock

     

    6. Under HKEY_LOCAL_MACHINE\SOFTWARE \Microsoft\Windows\CurrentVersion\Policies\System, create a new DWORD value named DisableLockWorkstation and set value to 1.

     

    Then, please restart the computer.

     

    Hope it helps.

     

    Thanks.

    2009년 12월 7일 월요일 오전 7:02
  • Thanks, Robinson. It couldn't disable log off (but I could with the other two). I only have this key available:

    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies

    so I'm missing the Explorer folder. Any suggestions?

    • 답변으로 제안됨 bluedog707 2010년 10월 21일 목요일 오후 10:07
    2009년 12월 8일 화요일 오전 6:46
  • Thanks, Robinson. It couldn't disable log off (but I could with the other two). I only have this key available:

    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies

    so I'm missing the Explorer folder. Any suggestions?


    Manully create it will resolve this problem. :)
    2009년 12월 9일 수요일 오전 2:29
  • Hello Zhang

    I have tried the steps you described and even tried changing it in the group policy editor and it still does not disable the switch user, for reference it is windows 7 Professional on a domain

    Any suggestions ?

    Thanks

    Mike

    2010년 4월 5일 월요일 오후 4:22
  • I am also having the same problem.  I cannot disable the switch user for Windows 7 Ultimate on domain.

    Mark

    2010년 4월 15일 목요일 오후 2:22
  • cannot disable lock or switch user !
    • 답변으로 제안됨 bluedog707 2010년 10월 21일 목요일 오후 10:10
    2010년 10월 21일 목요일 오후 10:09
  • cannot disable lock or switch user !

    2010년 10월 21일 목요일 오후 10:11
  • 1. Type gpedit.msc in RUN or Startmenu Searchbox and press Enter. It'll open Group Policy Editor.

    2. Now go to: Local Computer Policy -> Administrative Templates -> System -> Logon

    3. In right-side pane, double-click on "Hide entry points for Fast User Switching" option and set it to Enabled.

    Or you can disable it this way through the registry.

    1. Type regedit in RUN or Startmenu Searchbox and press Enter. It'll open Registry Editor.

    2. Now go to: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System

    3. In right-side pane, create a new DWORD value HideFastUserSwitching and set its value to 1

    4. That's it. Now "Switch User" option will be disabled from Welcome screen as well as from Shutdown menu.

    • 답변으로 제안됨 stetl10 2010년 11월 13일 토요일 오후 1:30
    2010년 11월 13일 토요일 오후 1:29
  • Yes you can.

    Here is the "switch user" disabling.

    run-> gpedit.msc

    Local Computer Policy -> Computer Configuration ->Administrative Templates -> System -> Logon

    -> "Hide entry points for Fast User Switching" - enable

    Now "Switch User" option will be disabled from Welcome screen as well as from Shutdown menu.

    2010년 11월 15일 월요일 오후 12:38
  • Thxs Travallor, I was searching this one.

    To modify the key in C#, the key in the registry is : HKLM\Software\Microsoft\Windows\CurrentVersion\Policies\System\HideFastUserSwitching

    regKeyRootMachine.SetValue("HideFastUserSwitching", 1, RegistryValueKind.DWord);

    Regards.

    2010년 12월 7일 화요일 오후 7:07
  • I have tried to disable the switch user option using both the policy editor and de Registry key. From the start menu, users indeed can't select "Switch user"  as it is greyed out.

    However in the login screen the Switch User option still remains. How can this completely be disabled? The machines are members of a domain.

    Any advice is highly appreciated.

     

    2011년 1월 4일 화요일 오후 6:50
  • An unintended side effect of this policy is that users cannot lock the computer anymore.  We have chosenn to leave switch user on so that if one staff member locks the computer and walks away (our classrooms are shared by many teachers), a new teacher can logon with killing the power to the computer to forceably log the first user off.  Since switch user is the only way to prevent a hard power off, turn off switch user also disables the Lock option.
    2011년 8월 2일 화요일 오후 10:18
  • Hi,

    Have you got any solution to remove/disable all items together (shutdown, Restart and Logoff, lock) from Start Menu. I tried these all settings from GP but never worked.

    Any idea?


    Regards Suman B. Singh

    2012년 5월 2일 수요일 오후 4:12
  • Hi, looking for the same thing.... 
    2012년 5월 4일 금요일 오후 12:36
  • This doesn't work for Windows 7 Starter Edition. Especially the Logoff button stays. Is there any way to remove the LogOff button or preventing the user logoff programaticaly in starter edition.



    Oğuz Köroğlu
    http://oguzkoroglu.net

    2012년 8월 30일 목요일 오전 9:54
  • I use a program called 'Classic Shell Start Menu' [http://classicshell.sourceforge.net/] that allows you to customise as you will, even, I believe, the 'Starter/Home' edition - although I cannot attest first hand to this.

    2012년 9월 10일 월요일 오후 7:25
  • thanks a lot!



    Oğuz Köroğlu
    http://oguzkoroglu.net

    2012년 9월 13일 목요일 오전 7:09
  • To disable Log off

    1. Type regedit in Start menu search box and then hit enter

    2. Navigate to the following key:

    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

    3. In the right-pane, create a new DWORD value named StartMenuLogOff and set value to 1.

    To disable switch user

    4. Navigate to the following key:

    HKEY_LOCAL_MACHINE\SOFTWARE \Microsoft\Windows\CurrentVersion\Policies\System

    5. In the right-pane, create a new DWORD value named HideFastUserSwitching and set value to 1.

    To disable Lock

    6. Under HKEY_LOCAL_MACHINE\SOFTWARE \Microsoft\Windows\CurrentVersion\Policies\System, create a new DWORD value named DisableLockWorkstation and set value to 1.

    Then, please restart the computer.

    Hope it helps.

    Thanks.

    The Trick why the logoff doesn't work is because of this

    1. Type regedit in Start menu search box and then hit enter

    2. Navigate to the following key:     Note This One    ***HKEY_LOCAL_MACHINE***     Not HKEY_CURRENT_USER

    HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

    3. In the right-pane, create a new DWORD value named StartMenuLogOff and set value to 1.


    This will fix the issue of why it didn't work
    • 편집됨 Robert Helton 2013년 1월 17일 목요일 오후 1:39
    2013년 1월 17일 목요일 오후 1:39
  • No, it does not fix the issue for me.

    Log off and lock still exists.

    2013년 4월 16일 화요일 오전 8:38
  • Try use SendMessageTimeout send WM_SETTINGCHANGE to HWND_BROADCAST.

    • 편집됨 MAXZRV 2013년 4월 24일 수요일 오전 5:45
    2013년 4월 24일 수요일 오전 5:44
  • I am having the same problem disabling log off button from the start menu.  I have successfully disabled shutdown, switch user, lock workstation from start menu.  I just have the pesky "log off" hanging on.  I have tried both gpedit and registry tweaks.  I stopped with registry tweaks because more of these were disabled.  

    I would try switching to classic start menu to utilize the gpedit feature "ADD Logoff to the start menu" and set to Disable to hopefully remove it from the start menu; however ...

    the odd thing about "gpedit.msc" User Configuration > Administrative Templates > Start Menu & Task Bar >  "ADD Log off to the start menu" states the following

    description States : This policy only applies to the classic version of the start menu and does not affect the new style start menu.

    so now I am chasing my tail to enable classic start menu on Win 7 which apparently doesn't exist in start menu properties or any where else. However you can download a 3rd party app called "Classic Shell" from source forge.  I don't want third party software to enable something that is obviously hidden on the existing OS..

    Any suggestions greatly appreciated.  

    Windows 7 (64bit) all recent updates as of 06/04/2013.  except IE10 / Registry tweak to auto login a domain user / Registry Tweak to remove shutdown, switch user, lock workstation from start menu.  

    2013년 6월 5일 수요일 오후 11:17