none
Windows 7 Backup and Restore - Backup failing

    질문

  • I'm getting an error in the backup and restore..when backing up, it fails with the error "Windows Backup encountered a problem while determining additional locations of one of the users included in the backup. the parameter is incorrect" error code 0x81000038. It worked fine previously, the only change i've made is i set the SATA ports to AHCI instead of IDE. I found a similar issue on another microsoft.com forum and ran a repository repair from that, didn't work. Any ideas?
    2009년 11월 13일 금요일 오후 9:28

답변

  • I suggest use IDE(IDE mode). This lets the Sata drive run without any special drivers. You loose hot swap and native command queuing.

    ACHI(Advanced Controller Host Interface) is for things like hot swap and native command queuing(more useful for servers).

    If you plan to hot swap drives later then ACHI is a good option. But an issue with AHCI is that if you install the OS without enabling AHCI in the BIOS, enabling it after installation will render your OS unusable. This is because Windows disable the AHCI driver since it is not needed during the installation. You may need to change it after windows is installed. If it is in that case, here we have a workaround to fix it.

    For every user on your machine,
    1. Login as the user
    2. Run -> regedit.exe
    3. Navigate to HKEY_CURRENT_USER\Sofware\Microsoft\Windows\CurrentVersion\Explorer\Shell Folders
    4. Observe the value of Appdata and LocalAppdata.

    If it has an empty value or a value of the type %Appdata%, this is the culprit. Can you verify that this is the case with your machine?

    If so, the workaround is the following:
        a. Open a command prompt
        b. Type set Appdata / LocalAppdata depending on which registry entry has the wrong value. If Appdata is wrong, type set Appdata and if Local Appdata is wrong, type set LocalAppdata.
        c. Copy the value after the = sign. Example if the output is: APPDATA=C:\Users\John\Appdata\Roaming, copy the value C:\Users\John\Appdata\Roaming
        d. Paste the value in the wrong registry value. Either replace the %<<<>>>% value or fill the empty value.


    Then try backup again. Good luck

    2009년 11월 16일 월요일 오전 6:20

모든 응답

  • I suggest use IDE(IDE mode). This lets the Sata drive run without any special drivers. You loose hot swap and native command queuing.

    ACHI(Advanced Controller Host Interface) is for things like hot swap and native command queuing(more useful for servers).

    If you plan to hot swap drives later then ACHI is a good option. But an issue with AHCI is that if you install the OS without enabling AHCI in the BIOS, enabling it after installation will render your OS unusable. This is because Windows disable the AHCI driver since it is not needed during the installation. You may need to change it after windows is installed. If it is in that case, here we have a workaround to fix it.

    For every user on your machine,
    1. Login as the user
    2. Run -> regedit.exe
    3. Navigate to HKEY_CURRENT_USER\Sofware\Microsoft\Windows\CurrentVersion\Explorer\Shell Folders
    4. Observe the value of Appdata and LocalAppdata.

    If it has an empty value or a value of the type %Appdata%, this is the culprit. Can you verify that this is the case with your machine?

    If so, the workaround is the following:
        a. Open a command prompt
        b. Type set Appdata / LocalAppdata depending on which registry entry has the wrong value. If Appdata is wrong, type set Appdata and if Local Appdata is wrong, type set LocalAppdata.
        c. Copy the value after the = sign. Example if the output is: APPDATA=C:\Users\John\Appdata\Roaming, copy the value C:\Users\John\Appdata\Roaming
        d. Paste the value in the wrong registry value. Either replace the %<<<>>>% value or fill the empty value.


    Then try backup again. Good luck

    2009년 11월 16일 월요일 오전 6:20
  • Is there a simpler answer?  I have the same error message and must do a system backup to an external hard drive prior to a hard drive reformatting due to a RAID bios problem.  I have tried changing the Windows Backup settings and rerunning multiple times.  I have Windows 7, 32 bit.
    2010년 1월 20일 수요일 오전 6:05
  • Same here! My backup schedule last run successfully on 7th February 2010. Now for no apparent reason it will not run at all, whichever drive I try to use as the destination! Like Victor534 I have also tried changing the settings and running it several times. Help???!!!!
    HP Pavillion a6632uk, AMD Phenom(tm) 8550 Triple-Core Processor, 3GB RAM, Windows 7 Home Premium
    2010년 2월 14일 일요일 오후 8:32