sticky
Windows Vista Service Pack 2 and Windows Server 2008 Service Pack 2 CPP Program Launched

    일반 토론

  • Windows Server 2008 Service Pack 2 and Windows Vista Service Pack 2 Beta is an update to Windows Vista and Windows Server 2008. It provides customer and partner feedback driven fixes into a single service pack, minimizing deployment and testing complexity. In addition to all previously released updates, SP2 will contain changes focused on addressing reliability and performance issues, supporting new types of hardware, and adding support for several emerging standards.

     

    For more information about this update, including how to obtain the software, please visit these sites:

     

    Please use this forum to discuss the issues in this Service Pack and let us know what you think.

     

    Sincerely,

     

    -Tony Mann

    2008년 12월 2일 화요일 오후 11:58

모든 응답

  • i ve got this update for my laptop yesterday..... i was experincing many problems as slow wifi internet transfere by the way many people ve got this problem and they try to do more things to fix but thhey always fail but after installing the update the problem doesnt exist anymore also the total system performance is great till now ...... thank for the update developing team
    2008년 12월 12일 금요일 오후 12:48
  • Hello.

    Since installing Vista SP2 CPP my 3Dconnexion Space Mouse with drivers version 6.6.4 is regularly reported as an unknown USB device upon wake from sleep.

    This did not occur under SP1.
    2008년 12월 14일 일요일 오후 4:48
  •   After installing sp2 I've had problems with IE freezing up. Also my WiFi card crashes a lot it pops up with an error like a program plus sometimes my computer really lags bad videos will play all choppy and the hard drive spins a lot like its loading something but its not I wonder whats doing that the only way I can get it right is to shut down unplug my laptop and then start it back up its not an issue that happens after a long time of use just really random.
    2008년 12월 19일 금요일 오전 7:06
  • Adrian Hudson said:

    Hello.

    Since installing Vista SP2 CPP my 3Dconnexion Space Mouse with drivers version 6.6.4 is regularly reported as an unknown USB device upon wake from sleep.

    This did not occur under SP1.



    Hi Adrian,

    Thanks for trying SP2. In order to diagnose your problem further, we would need some information from your machine.

    Can you please gather the following and send them to us?
    1. setupapi*.log from %windir%\inf
    2. cbs*.log from %windir%\logs\cbs
    3. setup*.log from %windir%\Panther
    4. System Information (execute msinfo32.exe and use File--> Save)
    5. Event viewer Logs (execute eventvwr.exe, open "windows logs", and save Application, Security and System Events)

    Please compress the logs together and send them to shashank<dot>bansal<at>microsoft<dot>com

    Thanks
    Shashank
    2008년 12월 19일 금요일 오전 8:34
  • Installed SP2 on system running 32-bit Vista SP1 with IE8 beta 2.

    Installed happily with NO problems ?!?!?

    BO-ring . . . . now what?  I'm not used to flawless installs.  :->

    Good job, Microsoft.  I'll give ya a week before I put SP2 on my 64-bit monster machine and 64-bit laptop.
    Jacqueline Tregre
    2008년 12월 20일 토요일 오후 7:41
  • Okay, now I have a WTF?

    When I first loaded the Service Back, it said "Buidl 6002"

    Now, after downloading and installing 3 updates, its says "Windows Vista (TM) Evaluation Copy.  Build 6002".

    I have a legal, authentic copy!  What did you do?
    Jacqueline Tregre
    2008년 12월 21일 일요일 오전 12:16
  • Now I have two issues: 

    One, after autoinstalling 3 updates, my perfectly legal copy of Vista nows has "Evaluation Copy.  Buidl 6002" on the Desktop?  What's up with that? 

    Two, I went to Technet downloads at https://technet.microsoft.com/en-us/subscriptions/securedownloads/default.aspx to download training.  I received a "VBScript:  Microsoft File Transfer Manager" Window that announced "There was a error launching File Transfer Manager.  If you are running . .  . "  yada, yada . . .   If the Gold IE Information Bar is present, please click the bar and select the option to "Install ActiveX". 

    No Gold Bar, no option to install, and the ActiveX control isn't installed.

    Not good, guys -- cannot download from your own site, and turning real Vista into Evaluation copies.

    jrt
    Jacqueline Tregre
    2008년 12월 21일 일요일 오전 12:37
  • I have just tried to install Vista SP2 and it went through the motions (nearly 2 hours) and then failed and auto-uninstalled itself.

    My desktop is showing 'Evaluation Copy. Build 6001'

    Any ideas?

    edit - I have just tried again as I did not get to make a note of the error message before.

    Error:ERROR_EVR_CONFIGURATION_ERROR(0x80073aa2)
    2008년 12월 21일 일요일 오후 4:49
  • Maybe you should have read this MS Post:
    "

    Service Pack Information

    SP2 Beta is pre-release code which will change before the final release of SP2

    Windows Server 2008 SP2/Windows Vista SP2 Beta is time-limited software that will operate until May 1st, 2010 - Un-install Windows Server 2008 SP2/Windows Vista SP2 Beta before May 1st, 2010

    After SP2 installation your desktop may display the text "Evaluation Copy". This does not mean that your system is no longer "Genuine", only that you have installed a test version of software which is time-limited

    After installing the service pack, the "Evaluation Copy" text may show up on the 2nd boot

    After un-installing the services pack, the "Evaluation Copy" text may remain during the first boot, but will disappear after the next reboot

    Starting any Windows Server 2008 SP2 or Windows Vista SP2 installations will result in Microsoft collecting information about the installation process
    "

    Cheers,

    2008년 12월 22일 월요일 오전 2:28
  • Thanks for that, I am fully aware of that, but it does not explain why the install has failed.
    2008년 12월 22일 월요일 오전 7:32
  • Trying again on another laptop running Business this time after using the SP2CPPRK script and downloading SP2 via Update.

    edit - Installed fine. Now running SP2 v.113
    2008년 12월 22일 월요일 오후 3:06
  • Well, <annoyed>, I certainly missed THAT little gem of info.

    Microsoft, that sucks!  If you are going to do that (turn licensed copies into eval copies) on SPs you invite people to test, and with your record of "uninstalls", you are going to have less "real" users. 

    Also, the "eval" doesn't happen on either laptop or workstation 64-bit machines.

    In the meantime -- anyone have any ideas about downloading the training?

    Merry Christmas!
    Jacqueline Tregre
    2008년 12월 24일 수요일 오후 1:39
  • I have three show systems running vista 64 and 2 running the 32 bit version. Installed sp 2 on all 5.

    Increased speed and performance overall notable on every one.

    The only problem iVe noticed is a few sluggish issues with IE 7 but that could of just been the net at that time of day.

    Those of you who dont understand the reason for the "Evaluation copy" should doublecheck the word BETA in your dictionary and read the release notes before the install.

    Also- a friend of mine had issues, but he had never done any driver updates and it turned out to be a driver fault, not an issue related to sp2.

    My only beef at this point is that in older apps that are no longer maintained that we have to use in our buisiness, we still are struggling with the read only file issue. Even after taking full ownership of everything we could and changing allowances for every concieveable user, we are at about 98% functionality on external drives.

    The problem is, even though the software can now read and write to the drives properly,which we have proven time and time again it still "Sees" the read-only files and tells itself that it cannot function properly this way, therefore it cannot "Save" any file changes.

    It would make our lives and several thousand others sooooo much easier if we could just lock the "read only" status out of all non OS drives. We currently are running 3tb of file storage in each computer and as long as it is a Vista or ms program there is no problem.

    When we use the software that runs our machinery and lighting and sound systems is when we have problems. The biggest factor is that in order to change our software, we would have to make several thousands of dollars worth of modifications to our equipment, as the company that built our systems, is no longer writing software for it and is now out of business. It was written and designed around XP servicepack 2.
     
    Just let me permanently disable read only on all files except program and operating system and vista will be perfect in my book.

    looking forward to the final release. MJS
    2008년 12월 31일 수요일 오전 1:12
  • It was clearly stated in the disclaimer... I believe it said 180 day eval. Betas should expire.
    2009년 1월 8일 목요일 오전 3:45
  • Is there any documentation about list of bug fixes in SP2?
    "I use VC++ 8.0"
    2009년 1월 16일 금요일 오후 4:25
  • Great install of Sp 2 on my premium 64-bit. Now if all of these 'techies' would understand the concept of Beta downloads and know that they are time limited (read the EULA) and theat as Bertas they will be buggy to the point of crud installs (if at all) (read the EULA) And quit the whinning!!!!!!. Or.... don't download/install Betas













    The seeds of today are the flowers of tomorrow
    2009년 1월 18일 일요일 오전 4:49
  • Installed Sp2 on (2) machines in a Domain. Had no problems with the installation; however both machines have been unstable since the installation and required frequent reboots. have experienced the following problems.

    1. Windows explorer hangs from several seconds to several minutes while accessing both local and network shares.

    2. Network file copies sometimes hang before completion.

    3. Vista machines can access all network shares however XP machines cannot access Vista Domain shares.

    4. Firefox is unstable and hangs randomly while accessing the internet, especially with many tabs active. This requires a reboot  since the Firefox process hangs and cannot be terminated.

    5. random application hangs.

    Ran for about a month with these problems. Removed SP2 and both machines are now stable.

    G T Simon
    2009년 1월 20일 화요일 오전 6:51
  • Ms Tregre:
    What is your problem? Do you truly not understand Beta? Nor Evaluation? There is no cause to get so nasty and testy because YOU chose to install something and then did not like it. Grow up! (I doubt that you will see this post).
    Dave Crowder
    2009년 1월 21일 수요일 오전 5:10
  • Since my SP2 install, I have few issues.

    • Display bug in Outlook 2007 SP1 - Second toolbar does not redraw properly and often shows whatever window/application is open behind it.
    • Outlook 2007 does not exit properly.  And therefore I can't start it again.  I have to use Task Manager to End Task Outlook then it will restart properly.

     

    2009년 1월 27일 화요일 오후 3:18
  • 2009년 1월 29일 목요일 오후 9:59
  • mahmoodn said:

    Is there any documentation about list of bug fixes in SP2?


    "I use VC++ 8.0"



    http://technet.microsoft.com/en-us/library/dd335033.aspx
    We build Service Pack 2
    2009년 1월 29일 목요일 오후 9:59
  • I have tried installing Vista SP2 several times now.  Install is to completion.  After pc reboots as soon as windows comes up it just reboots it self.  I can get into windows using safemode and access the logs.  Main thing I can see are references to DCOM erros and WMI  errors.  One of which is error 0x80041003.  Ltos of references in the internet but nothing that solves my issue.  I have an AMD 6000 cpu with 4 Gig of memory.  Windows Ultimate 32 bit and an Invidia 8800 GP.  I suspect a driver or hardware issue with the SP2 beta but dont see anything obvious.  I also have all logs ready to upload if anyone wants them.
    At the moment Windows 7 is extremely more stable then the Vista SP2 beta.

    Thanks

    Jess

    2009년 2월 8일 일요일 오후 10:41
  • Major improvement (at least to me) on my Vista Prem. The only thing is I seem to be experiencing alot of the the same software app issues that I do with Win 7- stuff says wrong version or unsupported version of window. This is especially true with most AV programs.Obviously, software vendors will need to rewrite for Sp2 and Win 7 both. Otherwise, great release
    2009년 2월 15일 일요일 오전 3:20
  • I have 2 questions:  
    1. Will I get a genuine SP2 update when it's officially released even I'm running evaluation copy of it?  
    2. How I can uninstall SP2 beta without use restore point (I don't think I'll need to remove it until it's expiration, but restore point will be too old by then) 

    2009년 2월 22일 일요일 오후 8:24
  • I just did a new install of Windows Server 2008 SP2 Beta, Standard Edition and get a footnote in the bottom right corner saying "Windows Server (R) 2008 Standard/Evaluation copy. Build 6002".

    I understood that the SP2 part was beta and figured I was eventually going to have to uninstall SP2 beta and install the real SP2 but I sure hope I don't need to install the whole 2008 server all over again.

    Two questions:

    #1. Is this whole server 2008 install actually an evaluation copy? And I'll have to reinstall the whole thing rather than replace just the final bits of SP2? Hopefully the answer is "no" and I will have to just uninstall the SP2 beta part and then install the final SP2.

    #2.  Is KB948491 the SP2 beta part? Is that what we uninstall when the real SP2 shows up? Do we uninstall KB955430 as well? These are the only two "updates" at all on my brand new 2008 server system!

    Thanks, Dave
    Dave
    2009년 2월 26일 목요일 오전 8:18
  • Your original install is good. Only will need to remove the Beta (Evaluation) by Apr of 2010. or when you go to the actual full relese of Sp2. Otherwise all is well with your O/S (As I have experienced in the past)
    Dave C
    2009년 3월 2일 월요일 오후 5:51
  • Thanks. Can anyone verify the KB # that shows for the 2k8 SP2 beta in add/remove programs?
    Dave
    2009년 3월 3일 화요일 오후 7:58
  • I can't understand some people.

    Ms. Tregre sounds new to the Beta process.

    Everytime I upgrade or install a Beta or Evaluation copy of ANY software, I always do a full backup of my machine first, then do the install - you never know what might happen; especially if you are talking about a service pack.  In the old days (back in the OS/2 world) this was a necessity because patches were so awful.  The same can be said for some Beta installs.

    Take note, backup or even better, install into a VM to test.

    J.
    2009년 3월 4일 수요일 오후 8:25
  • What is the difference (if any) between the SP2 RC1 that was available for download 3-3-09 and the Evaluation Copy that I downloaded a couple of months ago? They both show "Evaluation Copy Build 6002" in the lower right hand corner but the downloads had different numbers.
    2009년 3월 4일 수요일 오후 11:59
  • When I try to install SP2 on my Vista Ultimate SP1 32-bit system I get this error;

    The data area passed to the system call is too small.

    error: ERROR_INSUFFICIENT_BUFFER(0X8007007a)

    Any ideas? Search engines don't turn up too much in relation to SP2 installs for this error.
    2009년 3월 5일 목요일 오전 3:12
  • I could use a little guidance in removing this thing. (32 bit Windows Server 2008; KB948465 does not show as an installed update).

    Thanks.
    M A Reeds MD PhD
    2009년 3월 5일 목요일 오후 5:12
  • If you look at "installed updates" in control panel, remove programs, look for "Service Pack for Microsoft (or Windows)" and then uninstall it.
    2009년 3월 5일 목요일 오후 6:02
  • Guess this would be a more suitable posting location.  :-)
     
    No problems with the install process, but right off the bat, the Live Messenger won't even start at all, and my Trend Internet Security 16.6 is broken. 

    The "Trend Micro Unauthorized Change Prevention Service" is unable to start, which prevents the Trend Firewall service from starting.  I followed a Trend technot for re-installed the tmcomm.inf file and rebooted with no success.

    Live Messenger won't start, auto or manually, let alone log in.

    Quick scan through my other programs and they seem to be working...

    K.

     
    2009년 3월 6일 금요일 오전 1:57
  • Hello. After installing Vista SP2 RC to the Home Premium, the start up goes really SLOW, so I decided to uninstall it and wait for the final version.

    Greets.
    2009년 3월 6일 금요일 오전 3:23
  • See http://social.technet.microsoft.com/Forums/en-US/winservergen/thread/964945ee-c3e7-4e92-bac5-bb103010e784 for closure on my question regarding upgrading from SP2 beta to SP2 RC when integrated with the 2k8 server install.
    Dave
    2009년 3월 6일 금요일 오전 5:20
  • Dave, thanks a million. This was clear and helpful. Bright, thanks for your comment, too. Sadly, the update did not appear at all. (Why I posted.)

    I tend to be rather compulsive about retaining all downloads. My resolution on one test machine demonstrates why this may be a good idea. I reinstalled the (already installed) sp and then did an uninstall. (Of course, I'll be the first to admit that this is also a preturnaturally effective way of corrupting the install database.)

    Absent the release of sp2 rtm, I would like to think that all my attention will go to that fine product 2008 R2 and always on 64-bit systems.

    Mike
    M A Reeds MD PhD
    2009년 3월 7일 토요일 오전 3:04
  • failed to install:error 0xc004f013 rc1 for vista ultimate 64 sp1

    2009년 3월 8일 일요일 오후 1:49
  • I have found how to fix my problems; I installed the Game Spy with again compatibilite mode XP SP2, did reapply the latest patch, in this instance 1.41 of EA Games and games is running smooth online and single mode with the usual ULA warning.

    I don't know why people freak out about ULA in VISTA, to be honest I love the system and if the software developer can't adapt to a true secure OS from MS, well there is other in the market what will cut themself in 4 part to sell their solution to ME. i.e. PerfectDisk always supported the new version of MS Windows and even logitech, to be honest the worst in the hardware are MS, well at least in the gaming, but I saw some very expensive hardware i.e. keyboard that do not advertise VISTA support in MS Store.

    I will want to say the installation when very smooth for me for the VISTA SP2 RC on my Gateway quad core and no issue, the game is more then expected as it wasn't updated for VISTA and they won't I guess it will never happen. Oh well one day I will make a Dual Boot for VISTA and XP for the PC games and legacy software that I need in the odd time.

    Conclusion; so far I am very impress with your "BETA" and glad that you expose to us the normal user so that I could experiment and find right away what will be compatible what will not be and could make my own FAQ and note for future installation that will surely come with some change.

    Have a great day.

    A happy user, even when the game BF2 wasn't working for the online part precedent post.


    I have intalled the VISTA SP2 RC, When I try to play online with BF2 with all the latest patch including punkbuster also, all with compatiblility mode on the file itself prior to installation in the properties, so I have done my homework for that installation as I have done before for VISTA prior to SP1 and SP1 also and now SP2, I my game will play fine in single mode but as soon I am playing with multiplayer online my game will just crash, no blue screen or black screen or anything else it will just close on me after I log on anyserver, I did try to play the game after the installation of SP2 and it will play fine on single mode but if I try to play online it will load the game and connect to the server but after it finish to load the game in online mode the game will just close on me and bring me  back to the desktop no error are display to me, it just close on me?

    Anyone have experienced this kind of behavior.

    PS I get the the usual warning and give the usual authorization to start the game and all fine after no more prompt of slight delay for login, but nothing different then before for the login in my account online with EA games or activison.

    I did not install spy arcade only the BF2 and punkbuster with update and patch as I said this is a new behavior under SP2, even with compatibility mode apply from properties.

    2009년 3월 8일 일요일 오후 8:15
  •  Hi Anthony, under what name in window update the sp2 will be listed under, right now it don't stand up and it seem it just a #, no reference to SP2 or something like that.

    Want to make sure I will uninstall by the end of April and not been stuck with a no working PC.
    2009년 3월 9일 월요일 오전 12:35
  • roddyc said:

    Maybe you should have read this MS Post:
    "

    Service Pack Information

    SP2 Beta is pre-release code which will change before the final release of SP2

    Windows Server 2008 SP2/Windows Vista SP2 Beta is time-limited software that will operate until May 1st, 2010 - Un-install Windows Server 2008 SP2/Windows Vista SP2 Beta before May 1st, 2010

    After SP2 installation your desktop may display the text "Evaluation Copy". This does not mean that your system is no longer "Genuine", only that you have installed a test version of software which is time-limited

    After installing the service pack, the "Evaluation Copy" text may show up on the 2nd boot

    After un-installing the services pack, the "Evaluation Copy" text may remain during the first boot, but will disappear after the next reboot

    Starting any Windows Server 2008 SP2 or Windows Vista SP2 installations will result in Microsoft collecting information about the installation process
    "

    Cheers,



    Can I get an official link that has this part of the statement: 

    "After SP2 installation your desktop may display the text "Evaluation Copy". This does not mean that your system is no longer "Genuine", only that you have installed a test version of software which is time-limited"
     

    I see nothing of the sort on the official download page, though I don't doubt the validity of the statement - http://www.microsoft.com/downloads/details.aspx?familyid=dca54ecc-362a-4b4d-b62b-22780e839a7e&displaylang=en#Overview. I frequent another site and would like to post this but I also link having official links. 

    Again, I don't doubt the validity of this statement, but...

    Thanks.

    Err never mind, found it here - http://support.microsoft.com/Default.aspx?kbid=948465

    Sorry :)
    2009년 3월 9일 월요일 오전 3:35
  • I had the same problem, but got an error: 800700b7.
    2009년 3월 13일 금요일 오후 11:16
  • I have tried disabling some services and start up programs but still cannot install SP2. After going through a lengthy installation process, reaching 100%, it just hangs there for a
    long period and then a message appears: Service Pack Did Not Install-Reverting changes. (No reason given).
    After rebooting, a box appears saying that "Installation Was Unsuccessful" On clicking a link below, I got the message:

    ERROR_ALREADY_EXISTS  0x800700b7.

    Why does it have to go through to almost a complete installation before reverting changes, why could not have done this earlier?

    Does anyone have any clues as to what the problem is?

    2009년 3월 15일 일요일 오전 12:05
  • Dude, attempt system restore... if it still works hah
    2009년 3월 16일 월요일 오후 8:03
  • bday said:

    When I try to install SP2 on my Vista Ultimate SP1 32-bit system I get this error;

    The data area passed to the system call is too small.

    error: ERROR_INSUFFICIENT_BUFFER(0X8007007a)

    Any ideas? Search engines don't turn up too much in relation to SP2 installs for this error.



    Feedback ID 424046 submitted through the MS Connect site along with FDC data and screenshot.
    2009년 3월 16일 월요일 오후 8:15
  • Obviously, your 1 goal in life is to cause trouble for people. Do you get thumped by people on the street? Or do you never get out and interact with real people????? IBut in response-I would use the RC for Vista. I seems to run well on 2 of my builds
    2009년 3월 27일 금요일 오전 3:21
  • egads: Don't know. If you realize that I also am running Ubuntu on one of my rigs and SUSE on the other in addition to all of the MSFT stuff, you would realize a thing or 2. However, you obviously have a burr under your saddle about me specifically or positive posts about Vista and Win7. Sorry you have those issues. I know a good shrink in Venezuela named Hugo who you could visit, he is highly recommended for having a high cure rate

    2009년 3월 28일 토요일 오후 12:29
  • yo only one thing is important

    DOES THIS SOLVE THE LAG  SPIKES ON WIRELESS? You failed to do it so far so i doubt you give a fukc about it, and if you did not solve i still hope you get the worst cancer an angry god can give.
    2009년 3월 31일 화요일 오전 7:17
  • I already have a beta of SP2 on my vista, and got the KB960351 with windowsupdate to remove the beta of the SP2 first, but somehow it can't get the SP2 removed.
    It starts uninstalling, and after a reboot it runs through another 3 fases, and right at the end it says something went wrong and it starts reverting the deinstallation.
    Any ideas on what is going wrong?
    Where could i look to find possible problems?
    2009년 4월 4일 토요일 오후 12:09
  • Hey Jacqueline, I'm having so much trouble with installing SP2 on a 32-bit system. Can you pleeeease help me.

    2009년 4월 8일 수요일 오후 2:19
  • After installing SP 2, start up took 4min 45sec. Uninstalled and start up is 2min 10sec
    2009년 4월 15일 수요일 오후 4:49
  • you need to give it a chance.... it will take longer on the first boot after a service pack install for it to initiate all the services for the first time. i installed, rebooted, ran windows for 30mins, rebooted and its fine.

    only problem im having is WMP not playing music as it should just gives me a random clicking sound as it goes through each track.

    uninstalling tonight due to the fact i listen to music allot and prefer WMP over Winamp and any other Players.

    2009년 4월 21일 화요일 오후 12:21
  • The links to the download bits on the "Windows Client TechCenter on Technet" page don't work...

    Sorry, no results found for: downloads details aspx FamilyId 9E77AE84 BB5A 4A3F A481 68826B34C893 displaylang en


    John
    Number2
    2009년 4월 28일 화요일 오후 6:33