none
What do I have wrong in setting up this pipe?

    Întrebare

  • To whom it may concern,

    I have been trying to setup Windbg to work with Windows virtual XP MODE.

    I am using com1 and the The SETTING before Windows XP Mode starts is:

    button checked for Named pipe

    name of pipe string is: \\.\pipe\com_1

    Boot.ini file has options set for: /debug /debugport=com1 /baudrate=115200

    When running Windows XP Mode I am attempting to connect the com1 by using this instruction:

    windbg -y -k com:pipe,port=\\Windows XP Mode\pipe\com_1,resets=0,reconnect

    After executing that command I get this error:

    Could not create process 'com:pipe,port=\\Windows XP Mode\pipe\com_1,resets=0,reconnect' , Win32 error On2

    The system cannot find the file specified.

    What do I have wrong with that command?

    Thank you for your help.



    19 februarie 2012 00:18

Răspunsuri

  • Hi,

    The debugger runs well when I remote debug a normal virtual machine. Please try remote debug a normal virtual machine other than a virtual XP mode to isolate the issue. If the error still occurs, it indicates the basic configuration is incorrect; If the error doesn't occur, then the issue is reated to the virtual XP mode.

    Best Regards,

    Ruby Cheng


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    2 martie 2012 09:39

Toate mesajele

  •  

    Hi,

    If possible, please try with another pc in the same domain.

    Usually, when remote debugging, you need the same user account, password for the account, the same version of remote debugger monitor on the remote machine. To ensure that, please copy the corresponding remote debuger monitor on your local machine to the remote machine. It is located on <VSInstallationDir>\Common7\IDE\Remote Debugger.

    Here are some tutorials of implementing that, you need to configure all the settings correctly. Hope it could help you:

    How to debug a virtual machine on a host computer that is running Virtual Server 2005 or Virtual PC 2004, part 1 of 2

    http://support.microsoft.com/kb/871171

    How to debug the Virtual Server service on a computer that is running Virtual Server 2005 or Virtual PC 2004, part 2 of 2

    http://support.microsoft.com/kb/871170

    I find a similar thread in our forum talking about remote debugging issues in Virtual PCs, hope it could help:
    http://social.msdn.microsoft.com/forums/en-US/vsdebug/thread/9743e68c-85ab-4028-841e-ceb6daac7d57

    Here is a demostrate/walkthrough of remote debugging in Windows XP Embeded edition development:
    http://msdn.microsoft.com/en-us/library/aa459154.aspx

    If you have other questions, please don't hesitate and feedback here.

    Best regards,
    Ruby Cheng

    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    21 februarie 2012 10:16
  • Dear Ruby Cheng,

    Thank you for your reply. I am attempting to use the windbg with Windows XP Mode. The computer has 8 gig of sdram and 1 tb of hard drive space.

    There is only 1 computer. This computer has only the administrator with no other users and is not password protected.

    I have since changed the way I attempt to get the kernel bugging to work. Here it is:

    I am using com1 and the The SETTING before Windows XP Mode starts is:

    button checked for Named pipe

    name of pipe string is: \\.\pipe\com1

    Boot.ini file has options set for: /debug /debugport=com1 /baudrate=115200

    I am starting the windbg by double clicking the icon.

    I then click on file then kernal debug and set the values as follows:

    Baudrate is 115200

    port is com1

    resets is 0

    pipe is clicked on

    reconnect is clicked on

    I then click OK and when the question "Save information for workspace? "comes on I select no.

    At this point I get the following:

    Microsoft (R) Windows Debugger Version 6.12.0002.X86

    Copyright (C) Microsoft Corporation. All rights reserved.

    Opened \\.\com1

    Waiting to reconnect ...

    At this point it waits here FOREVER!!!

    What do I need to do to continue???

    21 februarie 2012 23:39
  •  

    Hi,

    It seems a read failure or write failure occurs when connect the pipe or the named pipe is not detected when the debugger is started. Please try to close the debugger, then restart to see if you can hit the break and if the connect sequence will begin. If the issue persists, please try to restart the server and try again.

    Best regards,
    Ruby Cheng

    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    22 februarie 2012 08:44
  • The window that says "Waiting to reconnect ..." also says at the bottom of it "debuggee not connected".

    When I press Ctrl break it does nothing.

    Restarting the server results in the same results.

    What do I need to do to get this to work?

    22 februarie 2012 17:43
  •  

    Hi,

    I understand that you now see “Waiting to reconnect…” in the WinDbg command output pane. In WinDbg, either hit the “Break” button at the top of the screen, or type Ctrl+Break to cause the debugger to break into the debug target. And you see “Debuggee not connected” at the bottom of the screen will change to a command input box. Additionally, the debug target appear to hang (as execution will halt when the kernel debugger breaks in). If this occurs, the debugger is properly hooked up. Type the letter ‘g’ in the command input box at the bottom of the screen, then hit Enter to allow the debug target to try to resume this execution.

    Best Regards,

    Ruby Cheng


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    23 februarie 2012 10:54
  • Dear Cheng,

    I pressed Ctrl+Break and tried the "Break" button at the top of the screen. Neither one of them does anything.

    I still see the message "debuggee not connected" at the bottom of the screen. No change occurs.

    What do I need to do to get this to work?

    Thank you for your help.

    23 februarie 2012 18:09
  • What happens if you lower the baud rate, I think that speed may be to high for VPC.
    23 februarie 2012 19:13
  • The baud rate has no affect. I tried 300 and 115200. There is no difference.

    Any other ideas?

    23 februarie 2012 20:52
  • Has ANYBODY got this to work using 1 computer via named pipes?
    23 februarie 2012 20:53
  • Try it without the baudrate specified.

    It has worked on older versions of VPC. http://blogs.msdn.com/b/virtual_pc_guy/archive/2005/10/20/482413.aspx

    23 februarie 2012 23:02
  • It makes no difference if baud rate is specified or not.
    23 februarie 2012 23:23
  • If this worked on older version then it is now BROKEN!
    23 februarie 2012 23:24
  • I would like to know If I have my evironment setup correctly.

    To debug using Windbg it is run from inside Windows Virtual PC correct?

    23 februarie 2012 23:33
  • Did anybody out there try to get Windbg to work with Windows Virtual PC via named pipes?

    25 februarie 2012 17:33
  • Hi,

    Have you tried type the letter ‘g’ in the command input box at the bottom of the screen, then hit Enter to allow the debug target to try to resume this execution when the debugger is properly hooked up?

    Best Regards,

    Ruby Cheng


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    28 februarie 2012 10:36
  • Dear Ruby Cheng,

    It says at the bottom of that window "debuggee not connected" and ignores any typing on the keyboard

    Have you tried to get Windbg to work with Windows Virtual PC via named pipes on your computer?

    28 februarie 2012 16:38
  •  

    Hi,

    Please try wait for about 30 minutes to check if the "debuggee not connected" status can be changed. Based on my experience, it takes a period of time for debug to response. And also, please try with a 64bit debugger to see if it helps.

    Best Regards,

    Ruby Cheng


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    29 februarie 2012 10:52
  • Dear Ruby Cheng,

    I waited about 1 hour and tried setting up the debugger with and without the baudrate being specified. In both cases it NEVER connected.

    You stated "Based on my experience, it takes a period of time for debug to response". Did you try this by using it the way I have my system setup?

    1 martie 2012 21:04
  • Hi,

    The debugger runs well when I remote debug a normal virtual machine. Please try remote debug a normal virtual machine other than a virtual XP mode to isolate the issue. If the error still occurs, it indicates the basic configuration is incorrect; If the error doesn't occur, then the issue is reated to the virtual XP mode.

    Best Regards,

    Ruby Cheng


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    2 martie 2012 09:39