none
How do I disable "Network password" in Windows 7 when accessing computers with previous Windows versions in the same workgroup?

    Întrebare

  • Hi

                I have bought a computer with Windows 7 and I put it in the same workgroup as the other computers of my family. And I have had a lot of trouble with sharing folders over the home network. There's a computer with XP that Windows 7 can see and some days, I can access the shared folders on that computer, but some other days it keeps asking for the Network password . I don't even think I have a network password, whatever I tried to input there, it didn't work(I tried the user and password of the other computer, the ones on my computer, no password, it just says it's wrong and asks for the network password again). I actually never set a network password. Then there's another computer running on Vista. Here, the same problem. Windows 7 can always see Vista, but some days he asks for the network password, some days he doesn't and there's nothing that I can do to control that. The XP and Vista can both see my computer and access the shared folders with no problem.
               I have checked on http://windows.microsoft.com/en-US/windows7/Networking-home-computers-running-different-versions-of-Windows the ports, even if I have Windows Firewall and the necessary ports are open(except for the ones for domain, which I opened, checked to see if anything changes, same problem, closed them back).
               In the network settings, the network detection is on, the folder and printer sharing is on, public folder sharing is on, ask password for sharing id off.
               I really don't know what to do anymore. Can anyone please help me?
    25 noiembrie 2009 11:25

Răspunsuri

  • If you enable the Guest account in Windows XP Professional, the issue should be resolved.
    Arthur Xie - MSFT
    8 decembrie 2009 04:41
  • Hi Alexandra,

    How does it work when you access the Windows 7 computer from the Windows XP or Windows Vista computer? How does it work if you temporarily disable the firewall in Windows 7?

    Since the issue occurs when you access other computers from Windows 7, we may need to check the settings on the other computers. Please let us know:

    1. What is the version of the Windows XP computer. If it is Windows XP Professional, if the Guest account and Simple File Sharing is enabled.
    2. If “Password protected sharing” is disabled in Windows Vista.
    3. If the issue occurs when you access a specified shared folder.
     
    The best way to resolve such issues is disabling “Simple File Sharing” in Windows XP (Professional), enabling “Password protected sharing” in Windows Vista and Windows 7, and creating the same username\password on each computers. If Windows XP the is Home Edition, you can enable Guest on it.

    Another way is enabling “Simple File Sharing” and Guest account in Windows XP (Professional), disabling “Password protected sharing” in Windows Vista and Windows 7, then give the permission to the Guest account for the shared folders.


    Arthur Xie - MSFT
    1 decembrie 2009 05:04

Toate mesajele

  • Having a similar issue...windows 7 network assigned a password when I set the permissions...it tells you to keep it to use on your network.  But now, every time I try to access my files from a Vista or XP around the house...that's every time you shut down and reboot, or sleep and re-wake, it asks you for this 10 digit password....it's infuriating...can't get any work done...so even though this doesn't answer your query, it adds to the thread so maybe we can get a comprehensive answer to both issues....
    25 noiembrie 2009 19:09
  • Hi,

     

    Please be sure that you use the same workgroup name for all of the computers on your network which is also emphasized on Networking home computers running different versions of Windows.

    At this time, please try Safe Mode with networking to check the issue.

     

    1. Restart your computer and start pressing the F8 key on your keyboard. On a computer that is configured for booting to multiple Operating Systems, you can press the F8 key when you see the boot menu.

    2. When the Windows Advanced Options menu appears, select Safe Mode with networking, and then press Enter.

    3. Log onto the default administrator account or any user account with the administrator privileges.

     

    Note 1: In Safe Mode with networking, your system display and desktop will look and perform differently than in Normal Mode. This is only temporary. To go back to Normal Mode, we just need to restart the computer.

     

    Note 2: If after keeping pressing F8, nothing happens. It is because the settings have been changed by the computer manufacturer. Please refer to the user manual or contact the computer manufacturer for the information how to enter Safe Mode with networking.

     

    If the issue persists, let’s first troubleshoot the issue between Windows XP and Windows 7 to avoid any confusion, please take the following steps on your XP machine.

     

    Go to Start –> Run –> compmgmt.msc

     

    From the left hand pane, select Local Users And Groups –> Users

     

    In the right hand pane, right click Guest and go to properties.

     

    Check “Account is disabled” option.

     

    For more troubleshooting steps, please refer to Set up your computer for home networking

     

     

     

     

     


    Judy :)
    27 noiembrie 2009 09:29
  • Hi Judy

    Thanks for answering. I tried what you said, but the problem persists. The computers are all in the same workgroup and there is no more guest account on the xp pc.
    I'm not sure what I was supposed to do while in safe mode with networking. I logged on the windows 7 computer that way and then tried to access the xp computer but it asked for that network password again.
    This problem didn't always occur at the beginning, but these days it just persists.
    28 noiembrie 2009 10:57
  • G'day Alexandra N

    Open "Control Panel >
    Open "Network & Sharing Centre >
    Select "Advanced Sharing settings >
    Expand "Home / Work Network >
    Scroll to "Password protection >
    Select "Turn Off Password Protect Sharing.

    Only do this for your Home/Work Network , do not do it to the Public Network.

    Check out the other setting (Home/Work Network) to see if they are set the way you want them.

    Get back if you require more info.
    "Computing is great experience, as long as we remember, that it is a machine the requires human input to operate correctly< Bobsan
    • Propus ca răspuns de Shilohbob 28 noiembrie 2009 12:00
    28 noiembrie 2009 11:59
  • Hi Shilohbob The sharing with password was turned off. I don't know why this happens, but I noticed that when I change something on the home profile, the same modification appears on the public profile, too.
    28 noiembrie 2009 12:23
  • Have you tried reconnecting your network on W7 PC to a "new connection/network" or "connect to a network" as some times I have found that this works, and as you realize you should not have to do anything to the PCs that were previously connected to the workgroup, assuming they were working OK before.

    I have recently set up 4 other W7 home networks with no problems.

    My setup is 2 W7 PCs, 1 Vista PC & 2 XP PCs, no password and even with W7 Beta & RC they all setup OK.

    One thing that maybe worth checking is that none of the PCs have a password associated with a network connection!!!!!!!!!

    You seem to have covered all points,sorry if none of my suggestions work, I will follow thread a see if anyone else can help.

    "Computing is great experience, as long as we remember, that it is a machine the requires human input to operate correctly< Bobsan
    28 noiembrie 2009 13:06
  • Thanks, Shilohbob . Well, something is not ok, 'cause it's still not working. I even changed the name of the XP computer. Now the xp doesn't show the other computers in the workgroup, but it can access them if I type the path. From the windows 7 the xp computer doesn't show anymore, but if I try to access it by typing the path, it still asks for that network password. I have also noticed something in that box that pops to ask for the password. Under the username, it there is a domain with the name of the windows 7 computer. I can't figure out why it shows there.
    28 noiembrie 2009 15:04
  • No one has asked the obvious question:  Are you trying to connect wirelessly?  Are you getting any network access at all?

    I ask because the "Network Password" may be the password to your wireless network.

    Sorry if this is off base, but I thought I'd ask.

    -Noel
    29 noiembrie 2009 01:22
  • Hi Noel. Yes, I'm trying to connect wirelessly. There are two xp machines in the workgroup, I can access one of them all the time, but not the other(most of the times). Both xp machines can access the computer with windows 7. There is also a vista that I can't access most of the times because of the network password.
    The wireless connection does have a password, but I tried it and it doesn't help. The dialog box that pops asks just for the network password, but there is also a place where I can input the username. If I input a username and a password it says they're incorrect. I actually don't even know what username to put there.
    29 noiembrie 2009 13:00
  • I got almost the same problem with you Alexandra.

    Here is my problem:
    I got 2 computers, each of them using Win 7 Pro. Computer A has printer, Canon iP1980. Computer B need a network printer from computer A.
    Each time Computer B need to add printer, it keep asking about NETWORK PASSWORD. But Computer B don't have any since I didn't give it.

    Here is my troubleshooting, and it works for me, and I hope works to you too:
    At computer A, Control Panel > Network & Sharing Center > Advanced Sharing Setting > Home/Work Network > Password Protection > Turn Off Password Protect Sharing

    Now, try to re-add printer using browse network printer from Device and Printers. Open the computer which has printer installed. Insya Allah there won't be any question about NETWORK PASSWORD
    That's it!

    If it works, shout, "Wooohooo.....!!! \(^o^)/"

    )|( Dimas A )|(
    30 noiembrie 2009 07:27
  • Hi Alexandra,

    How does it work when you access the Windows 7 computer from the Windows XP or Windows Vista computer? How does it work if you temporarily disable the firewall in Windows 7?

    Since the issue occurs when you access other computers from Windows 7, we may need to check the settings on the other computers. Please let us know:

    1. What is the version of the Windows XP computer. If it is Windows XP Professional, if the Guest account and Simple File Sharing is enabled.
    2. If “Password protected sharing” is disabled in Windows Vista.
    3. If the issue occurs when you access a specified shared folder.
     
    The best way to resolve such issues is disabling “Simple File Sharing” in Windows XP (Professional), enabling “Password protected sharing” in Windows Vista and Windows 7, and creating the same username\password on each computers. If Windows XP the is Home Edition, you can enable Guest on it.

    Another way is enabling “Simple File Sharing” and Guest account in Windows XP (Professional), disabling “Password protected sharing” in Windows Vista and Windows 7, then give the permission to the Guest account for the shared folders.


    Arthur Xie - MSFT
    1 decembrie 2009 05:04
  • Hi Dimas, hi Arthur

    Dimas, I can't shout "Wooohooo" for this yet. The other computer is XP.
    Arthur, the Windows XP is Professional, the Guest Account is off, Simple File Sharing is on. Password protected sharing is disabled in Vista. The issue occurs when I double-click the icon of the computer I'm trying to access, I don't even get to see the shared folders.

    Alexandra.
    7 decembrie 2009 11:45
  • If you enable the Guest account in Windows XP Professional, the issue should be resolved.
    Arthur Xie - MSFT
    8 decembrie 2009 04:41
  • Hi,

    Something similiar happened to me. Trying to connect from the W7 PC to a Vista PC kept popping up that network password window. In my case, my issue was that I kept entering the autogenerated password, wireless password and even the Vista PC account password until I realized that I had no password set in the Vista account, I had disabled it about a month ago. Nevertheless, the pop-up window kept requesting it. Solution: entered the account id and then OK (empty password). DUH!
    9 decembrie 2009 22:42
  • I had same issue and I just change the Networks from Home or Work -> Public and change back to Work network or Home network.  and it worked.
    13 decembrie 2009 07:12
  • Hi

                I have bought a computer with Windows 7 and I put it in the same workgroup as the other computers of my family. And I have had a lot of trouble with sharing folders over the home network. There's a computer with XP that Windows 7 can see and some days, I can access the shared folders on that computer, but some other days it keeps asking for the Network password . I don't even think I have a network password, whatever I tried to input there, it didn't work(I tried the user and password of the other computer, the ones on my computer, no password, it just says it's wrong and asks for the network password again). I actually never set a network password. Then there's another computer running on Vista. Here, the same problem. Windows 7 can always see Vista, but some days he asks for the network password, some days he doesn't and there's nothing that I can do to control that. The XP and Vista can both see my computer and access the shared folders with no problem.
               I have checked on http://windows.microsoft.com/en-US/windows7/Networking-home-computers-running-different-versions-of-Windows the ports, even if I have Windows Firewall and the necessary ports are open(except for the ones for domain, which I opened, checked to see if anything changes, same problem, closed them back).
               In the network settings, the network detection is on, the folder and printer sharing is on, public folder sharing is on, ask password for sharing id off.
               I really don't know what to do anymore. Can anyone please help me?

    To access win 7 from a non-win 7 rig OR A WIN7 RIG (VIA OTHER THAN HOMEGROUP) - there is a trick that bypasses the win 7 rescrictions - it will open up any folder you want to access (as long as you share it properly after doing this manuver).

    Get WINDOWS RESOURCE KIT for WINDOWS SERVER 2003 - install the kit

    (here is a download link: http://www.mediafire.com/?k9n39mu95zr84z6 )

    Then: Start - All Programs - Windows Resource Kit Tools - *COMMAND SHELL*

    enter:

    ======================BELOW:=======================

    net user guest  /active:yes

    ntrights  +r  SeNetworkLogonRight  -u  Guest

    ntrigfhts  -r  SeDenyNetworkLogonRight  -u  Guest

    exit

    restart - and you should be able to make any folder accessible to Vista /XP...

    =============================================

    Cheers

    22 august 2010 06:36
  • The default Network Password is 123456. I found this info on the internet when I was working on similar problem. I am sorry I don't remember the details. Bob_in_PGI
    31 august 2010 12:44
  • u have a creat a password to ur computer first

    3 decembrie 2010 03:09
  • hi,
    i have problem with network sharing. i have a pc w7 an other pc wXP. w7 act as a server to the other computer. when i log into fileserver from winXP there's no problem at all but when log into the fileserver on 'server pc' itself i'd been asked to enter password and username. the 1st time i using the file sharing whether from w7 or wXP there's no problem at all. but after several days i need to enter user name and password to log into fileserver when using w7 itself. i did'nt get it. but the problem is'nt occur in win xp when log into w7 fileserver. last time i checked i did'nt change any setting on the network. i also checked that password protected sharing is already turn off. i even don't hv password to log into the windows how possible i hv password for network since i don't even create it.
    hope i'll find the best answer to resolve it.
    TQ,.........
    8 martie 2011 11:23
  • Following the KISS principle, I find the best way to keep networking quite seamless within a small home (non-domain) network is to use the exact same username and password for all computers, and have that username be an administrator.  I've been running workgroup networks of mixed computers (even including Macs) for years without any problems.

    I've also found in this case (same usernames/passwords everywhere) that disabling the "oversimplification" of Windows 7 HomeGroup networking can be helpful as well.

    -Noel

    8 martie 2011 18:30
  • Surprisingly this (the same username) was my hindrance for a long time of testing around. I've had access from Windows XP to my Windows 7 shared folders, but after every logon/reboot it kept asking me to logon with not certainly set/existing user-data. Strangely enough I could just use any random username, so I've wondered why it's prompting me to login, when I'd have access anyway. Messing around with the Advanced Sharing Settings, Network Adapter, or User Accounts brought no solution.

    The only way (in my case) to solve this "retarded" behaviour of asking again and again for logon-info was to either save a freely chosen username as permanent logon-data (the lazy "I don't care why, it just has to run somehow" way), or to set a new/different username with "control userpasswords2" at one of the PCs (which was the last thing to think of trying). Okay, I have to admit that I should've attempt the "exactly same usernames and exactly same passwords" method earlier, cos this also fixed the described minor issue. I guess I was just confused about the fuss caused by two identical usernames (but different passwords); never had this "trouble" while working (in network-groups) with two Windows XP machines. Thanks for the hint.

    19 martie 2011 03:24
  • Thank you Shilohbob!!!  Thank you, thank you.  Changing Password Protection in Windows 7 solved the problem.  Phew, have several other problems with Windows 7 but thankfully this one didn't take too long to research/solve: thanks to this forum and your help.  Weird thing is I've had the new Windows 7 machine for 4 months and this is the first time the problem happened.  Why now?  Weird.
    24 martie 2011 20:56
  • I had the same problem.  I removed the Linked OnlineID that I had on the W7 computer.  Solved my problem.
    6 februarie 2012 16:39
  • Solution: entered the account id and then OK (empty password). DUH! THANKS Tomaspc! worked a treat.
    13 februarie 2012 14:09
  • BTW K2

    “” well if we’re going to turn off password protected sharing automatically through cmd  don't have software it how?? thnks …….

    31 iulie 2012 07:02
  • here is step by step solution of your problem (copy paste this link in to the browser '  https://www.youtube.com/watch?v=oGJ03yvghKw   '  )
    12 decembrie 2013 04:26