none
How to make Windows 7 work with older Windows versions for networking and file sharing.

    การสนทนาทั่วไป

  • This process will make the network a little less secure but it works well because a password isn’t used and everyone is allowed access.

    1. First, know what the Computer name is and what Workgroup it belongs to.

    The Workgroup name needs to be the same on all PC’s that are being networked; no matter the OS on each system. This is already setup, even if only by default, in the setup process while installing each OS.

    Verify what the Windows 7 computer and workgroup names are by going to Control Panel > System and Security > System > and read information under “Computer name, domain, and workgroup settings” (The third category down).

     If the names need to be changed go to Change settings in that category or Advanced System Settings in left pane. Then, Computer Name Tab > Change, type the Computer Name and Workgroup Name. > OK. Make the computer name meaningful to aid recognition. The computer should restart.

    2. Second, adjust Win7 settings to allow for sharing with older OS on other networked systems.

    Now go to Control Panel > Network and Internet > Network and Sharing Center > Change Advanced Sharing Settings (side panel). Make sure Network Discovery, File and Printer Sharing, and Public Folder Sharing are all set to “on” and Password Protected Sharing is set to “off”.

    Note: I recommend leaving Media sharing set to “on” and under Windows HomeGroup connections select “Allow Windows HomeGroup to manage homegroup connections (recommended)”.

    3. Third, choose which folders to share on the network and adjust properties to do so.

    Drag any folders to be shared to the Public folder.

    Or…

    To share a specific Windows 7 folder or additional drives on the system, right-click it > Properties > Sharing Tab > Advanced Sharing > tick box for Share this folder > Apply > OK > Close. You only need to share the highest level folder, not every sub-folder. Two little people should appear on the icons of the folders that are shared.

    4. Now, you MUST follow this step or the folders will not be shared despite previous steps followed!!!

    Because Password Protected Sharing turned off, the security permissions have to be changed on the folder(s) to allow Everyone access. Right-click the shared folder > Properties > Security Tab > Edit > Add and type “Everyone” (not the quotes) into the box and select OK. Tick the boxes next to the permissions you want to allow (e.g. Read or Write, etc.) then Apply > OK.  Some messages may appear: “An error occurred while applying…” This is not unusual and can be ignored by clicking Continue.

    5. Windows firewall is normally set to allow file and printer sharing but if you have a third-party firewall make sure file and printer sharing are enabled so that each machine can talk to the other(s). Do not disable the Windows firewall if it’s the only one running.

    6. To see or copy files, click the Windows Orb (Start) > Network and the computers/folders/files should appear. Use two windows to drag files from one PC to another.

     

    8 กุมภาพันธ์ 2552 20:11

ตอบทั้งหมด

  •  

    I’m not looking for the plaudits but you could have used your own terminology! Your article is using phrases I have posted many times on the web, most notably on my favourite Canadian website run by Kerry Brown http://www.vistahelp.ca/phpBB2/viewtopic.php?f=7&t=1887&p=11253&hilit=used+and+everyone+is+allowed+access#p11253

    9 กุมภาพันธ์ 2552 8:55
  • I have followed your instructions and worked for me..

    W7 and XP pro on the network.. backing up XP to external drive connected to W7 machine as i type..


    Thank you for your time
    9 กุมภาพันธ์ 2552 13:56
  • BurrWalnut said:

     

    I’m not looking for the plaudits but you could have used your own terminology! Your article is using phrases I have posted many times on the web, most notably on my favourite Canadian website run by Kerry Brown

    http://www.vistahelp.ca/phpBB2/viewtopic.php?f=7&t=1887&p=11253&hilit=used+and+everyone+is+allowed+access#p11253


    BurrWalnut,

    I extend, first, my gratitude for your many helpful posts. Admittedly, I’ve personally come across many of your problem solving contributions. In my own troubleshooting, I came across many resources that summed up my final working result to PC issues. A post of yours, from this site, was one of many posts from several sites that helped. I started my research directly from the Microsoft Windows 7 Beta site.

    Because so much of my time was spent and wasted on unhelpful articles, I decided to repay the communities I found help in, by typing up an easy to read, step-by-step, post to help with this seemingly popular issue.

    After putting together many steps, I found that your post summed up what needed to be said in the last few steps included in my article. I gave credit to you most everywhere that I posted; along with my gratitude and praise…one such post can be found:

    http://social.technet.microsoft.com/Forums/en/w7itpronetworking/thread/9255b515-51d9-4947-b2c5-386562743e84

    I was not writing an essay, or anything close to it, and thus did not include any references to my findings. If I have offended you or any of my other resources, please accept my sincere apology. I did not mean to step on any toes or seek any glory by stealing any person’s thunder.

    It was my opinion that we were all here to help one another and I made the assumption it would be okay to include some of the information I found earlier in your post. While most of my article is in fact my own wording, my own phrasing, and my own direction, I did in fact copy the steps 5 and 6 of my article from one of your posts. Please feel free to request I edit my article if any offence remains. I would be happy to do so and put those needed steps into my own words. Again, my apologies…my aim is to be helpful.


    10 กุมภาพันธ์ 2552 5:32
  • SOrry for the question, but when it comes to networking I am a noob.  In step 2 you say "adjust Win7 settings to allow for sharing with older OS on other networked systems."  Where in Win7 do I adjust this setting?  I can not seem to find it in the network and sharing center.  Thanks for your time.
    28 กุมภาพันธ์ 2552 4:33
  • ceejay4591 said:

    SOrry for the question, but when it comes to networking I am a noob.  In step 2 you say "adjust Win7 settings to allow for sharing with older OS on other networked systems."  Where in Win7 do I adjust this setting?  I can not seem to find it in the network and sharing center.  Thanks for your time.



    No worries... never be afraid to ask.... we all have to learn somehow. In step 2...... "adjust Win7 settings...." was just the title line for what one was doing in that step..... the directions on the "how to" follow that red title line.

    Here you go...

    Now go to Control Panel > Network and Internet > Network and Sharing Center > Change Advanced Sharing Settings (side panel). Make sure Network Discovery, File and Printer Sharing, and Public Folder Sharing are all set to “on” and Password Protected Sharing is set to “off”.

    Note: I recommend leaving Media sharing set to “on” and under Windows HomeGroup connections select “Allow Windows HomeGroup to manage homegroup connections (recommended)”.



    Hope that answers your question.... let me know if you need any more help.... may not be avail again until tomorrow. Best wishes!

    28 กุมภาพันธ์ 2552 5:02
  • OK, I have that done then and I have made progress.  I have this computer presently running W7 and two other computers presently running XP Home.  I have gotten to where I can share folders and file both directions with one of them, however the third I do not have access to right now.  With what I have learned so far I feel I can get that part going with the third computer.

    A problem has arisen though.  Trying to share my laser printer attached to this computer with the others.  I try to add a printer to the XP computer via the wizard and I get through to browsing for the printer.  I add the Networl printer name eg. \\  TAZZ\Canon MF3110 (space added after double backslash only here) I click next, and I come up with a box asking for user name and password.  There are no usernames and passwords applied.  I have Password  Protected sharing off in file and printer sharing.  I do not have Homegroup setup I have Workgroup instead.  Should I rename this to Homegroup on all computers or will workgroup suffice?  As you can tell I am a Networking novice to be sure.  In the past I have always used the Windows Setup Network Wizard.
    28 กุมภาพันธ์ 2552 6:29
  • ceejay4591 said:

    OK, I have that done then and I have made progress.  I have this computer presently running W7 and two other computers presently running XP Home.  I have gotten to where I can share folders and file both directions with one of them, however the third I do not have access to right now.  With what I have learned so far I feel I can get that part going with the third computer.

    A problem has arisen though.  Trying to share my laser printer attached to this computer with the others.  I try to add a printer to the XP computer via the wizard and I get through to browsing for the printer.  I add the Networl printer name eg. \\  TAZZ\Canon MF3110 (space added after double backslash only here) I click next, and I come up with a box asking for user name and password.  There are no usernames and passwords applied.  I have Password  Protected sharing off in file and printer sharing.  I do not have Homegroup setup I have Workgroup instead.  Should I rename this to Homegroup on all computers or will workgroup suffice?  As you can tell I am a Networking novice to be sure.  In the past I have always used the Windows Setup Network Wizard.



    I'm glad you've made progress and that it is begininning to work out for you. As far as your workgroup goes....using the name "workgroup" is just fine..... the important thing is to be sure it is the same on all three computers. renaming it homegroup would not make any differance on the PC's running XP. The homegroup option and features are new and unique to Win7....so homegroups only work with other computers running Win7. Don't confuse homegroups with workgroups.... they are two completely different things.

    Be sure that all your sharing options are turned on, on all three PC's. be sure and follow through all the steps on the guide posted above for the Win7 PC. restart all the PC's. You shouldn't have to use a the networking or "add a printer" wizards on any of the pc's. No password  or usernames should be needed. once the file sharing options are all turned on in the WIN7 PC.... the printer should be visable on the network to the other PCs automatically. Be sure, when adjusting the sharing options on the WIN7 PC, that the password protection is turned off..... just turning sharing "on" isn't enough.... password must be set to "off" as well. The only thing you may have to do, rather then running a wizard on the PC's with XP, is  go to your control panal, go to your devices and printers, and look at the printers available... you should see the printer on your Win7 PC sharred on the network there, but you may have to right click on the printer's icon, go to properties, and select it as the default printer.

    I hope this helps.... if not... and it remains an issue.... post again. I'll continue to try and help as best as I can. There are lots of other great peeps here with lots of knowledge.... don't shy from looking and/or posting on other threads.... but please come back and post your results here.... I'm sure anyone reading this thread would love to here what your resolve comes to be.

    My best! :)
    28 กุมภาพันธ์ 2552 7:01
  • I finally got it figured out.  I am now fully connected with all 3 computers communicating with each other, That took redoing the work group names on the other computers twice each to straighten it out.and all 3 computers can use my Canon MC3110, and the HP 842 on one of the XP Machines.  Not the fault of networking but My Win7 Machine cant print to the HP P1000 on the other XP machine.  This is because Win7 doesnt accept the driver  for that printer even in compatibility mode.  The Printer is seen by Win7 and Identified correctly but can't print on it because of the driver.  Printer sharing from the Win 7 Machine was fixed in Devices and Printers.  Highlight the printer to share then right click that printer at the bottom of the window and you get the menu choice for sharing it.  Simple as that.  THe P1000 will be different unless I can find a work around for it.  THen again it was rescued from the trash bin so it wouldnt be too much of a problem just to say bye bye to it and get a newer photo printer.

    Thank you for your help and I have saved your set of directions to share with a friend who is having similar Networking problems.
    3 มีนาคม 2552 7:05
  • Thanks for this post. I struggled with adding my W7 PC to my network for hours, and with getting folders shared between this and my XP machine. This post sorted it all out for me.
    20 มีนาคม 2552 12:04
  • Hi. Thanks for your post. I use networking since win98, but here I can't find anything...

    Now, thanks to your post, I can share files and folders, but I still cannot share the Internet connection.

    I remember on W98 or XP (I never used Vista) I go to configuration and play with the TCP/IP configuration to do that, but here I can't find how to.

    I have a desktop PC with Windows 7 and another desktop with XP. When I do cmd ---> ipconfig, the XP says:

    IP address: 169.254.57.192
    subnet mask: 255.255.255.0 (of course)

    My XP is in spanish, so I give you the idea of the statemets.

    The null "default gateway" means I can't connect to internet on tis PC.

    On XP I should go to TCP/IP configuration and force the addresses like 127.0.0.1, 127.0.0.2, etc and the same with the default gateway. How can I do this on W7?


    Sorry for my bad english.
    20 มีนาคม 2552 18:22
  • Hi there. Forgive me, but I am quite literally going nuts here. I have followed the instructions for making windows 7 work with XP SP3 and it doesn't work. Everything on 7 is set for the wonderful little dummed down network settings so it will work with XP. I even have all the folders access set for Everyone as you said. I also have Windows XP updated to SP3, but it doesn't work. No matter what I do, I cannot get the two computers to network. Yet, when they both had 7 on them, they networked beautifully. It's the same hardware as when I had 7 on the second computer which now has XP, but it doesn't network between the two computers. I can get on the 'net just fine from both, but tat is as far as this goes.

    If it helps any, I am using a cable modem with an external DNS server and if I override then I lose my internet connection.
    31 ตุลาคม 2552 8:59
  • DrGerry

       If you have a 169.254.x.y IP address you will not be able to reach the Internet or network with other machines (unless they are also using APIPA addresses).

       APIPA adresses are what you get if you leave the network settings at the default (obtain an IP automatically) but there is no DHCP server to supply the network config. The system generates  these APIPA addresses to allow local networking but the addresses are not routable. They do not give you a default gateway.

      How does your network connect to the Internet? Do you have a router which includes a DHCP server?

    Bill
    31 ตุลาคม 2552 9:36
  • I have the two computers which connect to a switch and the switch connects to the cable modem and then on out to the internet. Nothing special no routers, none of that over-hyped jazz. Sorry, used a router a few times and can't stand 'em. Too much work. ;)
    31 ตุลาคม 2552 17:01
  • I have this:

    - ASDL modem --> network card on PC with W7
    - second network card on PC with W7 --> switch
    - switch --> network card on PC with Windows XP.

    With XP - XP it always worked. With W7 I have Internet on both computers, I can access the shared folders on my W7 machine from my XP machine, but I can't access the shared folders on my XP PC from my W7 PC.

    I tried everything: automatic IP addresses, fixed IP addresses, etc. With XP - XP all of this work, with W7 - Xp no.

    Thanks.

    PS: I know: if I use a router I have no more problems, but sometimes I need to fix net problems to my family o friends PCs and I can't foce they to buy a router.

    31 ตุลาคม 2552 17:30
  • ShockDoctor7

    This process will make the network a little less secure but it works well because a password isn’t used and everyone is allowed access.

    1. First, know what the Computer name is and what Workgroup it belongs to.

    The Workgroup name needs to be the same on all PC’s that are being networked; no matter the OS on each system. This is already setup, even if only by default, in the setup process while installing each OS.


    Why would workgroup name need to be the same on 2 PCs for file sharing to work? Is this a W7 restriction (although I sincerely doubt), because in XP you could have browsed files on network PC that was part of different workgroup.?
    1 พฤศจิกายน 2552 0:22
  • I'm having a bit of a problem.  My Win 7 machine has 2 drives.  From my XP laptop I have full access to drive D, and I can see drive C when I open \\mywin7machine folder.  But when I try and access drive C I get 'Access is denied' message.   On the win 7 machine the sharing settings for drive C and D appear to be identical (Everyone, full access).   Any suggestions?
    5 พฤศจิกายน 2552 11:11
  • I was having a problem connecting to shared folders on a Windows 7 machine from an XP machine.  The reverse worked just fine (I could get into XPs shared folders from Win7).

    Changing the Windows 7 network type from 'Home' to 'Work', disabling simple file sharing on the XP machine, and following the guide at the top of the page got it to work.
    16 มกราคม 2553 14:47
  • That fixed it... Thanks for the advice!
    17 มกราคม 2553 0:01
  • I'm having similar problems as ceejay. Here's the setup:
    • High-speed cable internet via Linksys WRT160N wireless router.
    • Win XP SP3 desktop connected to router via cable.
    • Win 7 Home laptop connected to network via WLAN.
    • Canon Photosmart printer connected to XP desktop.
    • Neither machine have the user accounts password protected. And they are both have ADMIN privileges.
    I follow the steps above, as well as other websites (e.g. ), regarding setting up home network. I DO have them in the same workgroup. I DO have folder sharing "on" and password protected sharing "off". I HAVE gone onto both machines and selected a test folder on each to share. On XP machine I have gone into secpol.msc > Local policies > User rights Assignment and verified "everyone" is in list for "access this computer from the network".

    The problem:
    • I can successfully read and edit files - located on the Win7 laptop - from the XP desktop. No problems sharing FROM Win7 TO XP.
    • I have designated the printer as shared, but I cannot "see" it on the laptop.
    • I cannot access folders nor files - located on XP desktop - from the Win7 laptop. On the laptop I can see the hostname in the network computer list, but when I double-click on computer I receive the error "Logon failure: unknown user name or bad password". It then prompts me to enter a user name and password. I have tried to enter user name with password blank. I have tried adding the "domain" to the user name (i.e. username = "xpname\user"). I have tried adding passwords to the accounts. I have tried removing all passwords from the accounts. I have tried turning antivirus and Windows firewall off. None have solved the problem.
    The bottom line is that while I CAN access laptop files from the XP desktop, I CANNOT access the printer or desktop files from the laptop.

    Any help would be GREATLY appreciated! Thanks.

    Philip
    9 กุมภาพันธ์ 2553 18:09
  • I think win 7 account must have passwords

    In the Advanced sharing settings page of Network and sharing center, you need to have it set as Work/Home profile.  Try

    -Enable network discovery
    -Use user accounts and passwords to connect to other computers

    9 กุมภาพันธ์ 2553 18:39
  • Figured it out after seeing willis' comment.

    I had to disable simple file sharing then add a password to the admin account on the XP machine. Now when I access from Win7 laptop I can enter username and password and access!
    9 กุมภาพันธ์ 2553 18:50
  • I have followed all of these steps and suggestions.  None of it works!

    20 กุมภาพันธ์ 2553 14:52
  • True. Maybe we have to wait to Windows 8... or 9 or....
    25 กุมภาพันธ์ 2553 17:31
  • in win 7 go to control panel>Administrative Tools>Local Security Policy>local policies>security options>"Network security:LAN manager authentication level">>>>>>>>>>set it on "send LM &  NTLM - use NTLMv2 session security if negotiated">>>>Apply>>>ok>>>  now close "Local Security Policy">>> go to "start>All programs>Accessories>Command promp">>>now type this  "gpupdate/force"  if happen nothing  >>logoff and logon again

    i'm sorry for my bad english

    i hope it dosen't need user & pass

    24 มีนาคม 2553 9:07
  • Hi all, my first post on Technet.

    Windows 7 has a similar sharing regime to Windows 2000, I wish Microsoft had told me they'd done this, but now I know, I must say I approve.

    Setting up a share isn't enough unless the *security settings* on the *folder* are also set.

    Try it, share a folder let's say 'd:\downloads\' from your Win7 box.

    If you're like me, XP can see the share but can't actually read anything from within the share.

    Now try right clicking on the d:\downloads folder in Win7 and going to the security settings.  Give everyone read rights.

    Now try opening the folder from XP :O)

    Don't get too carried away with handing rights around to root directories, it's a recipie for getting haxed. ;O)

    HTH.

     

    23 เมษายน 2553 9:19
  • I had a prob that others haven't mentioned.  I followed the post at the top.  Step 4 allowed me to copy files from Win7 to XP by drag and drop.  But I couldn't draganddrop files from XP to Win7.  Error message was "Cannot copy (file): Access is denied.  Make sure disk is not full or write protected and that the file is not currently in use."  I double checked the step 4 instructions and mistakenly went to Sharing instead of Security.  Only "read" was checked so I checked "Full Control" and "Change" as well to Allow these permissions.  This fixed the problem.  

    I don't like the idea of allowing everyone access to my shared drive on Win7 because at the moment it is the entire drive.  If there aren't any other suggestions, I'll set up a second partition for the data I want to share so that I can limit possible damage if something bad happens.

    Good thread guys!  A shame it was needed because almost everyone will want to share files in their home networks. 

    25 เมษายน 2553 17:46
  • If a Windows XP computer cannot access shares on a Windows 7 computer, check out my response here:

    http://superuser.com/questions/47382/system-error-58-while-accessing-shares-on-windows-7-from-xp/146437#146437

    28 พฤษภาคม 2553 18:03
  • This is the best, clearest advice I have ever received on networking problems that have plagued me since I started using Windows 95.  Well done and much appreciated!!!
    28 พฤษภาคม 2553 19:23
  • Also, be sure that your Windows 7 machine does not have any potentially "problematic" characters in its name. 

    I wasted the better part of my Memorial Day holiday trying to get our kids XP machines to see our new WIN7 Home Theater  / Backup Server machine.  Using "View workgroup computers", the XP Machines could see both my WIN7 (named "Parents") computer and the new WIN7 Home Theater  / Backup Server machine (named DVR-PC).  From within XP, clicking on the "Parents" link, I could see the various shares on that WIN7 machine.  However, (again from within XP) clicking on the "DVR-PC" link, would deliver an error message stating "DVC-PC is not accessible. You might not have permission to use this network resource. ..."

    After trying virtually every online solution/suggestion/fix (including this one), I was still having no joy. 

    Then, on a hunch, I renamed our new WIN7 Home Media Server from "DVR-PC" to simply "DVR" (considering the possibility that WIN7 was more tolerant of the hyphen/dash than XP might be.  After the requisite re-boot of new WIN7 Home Media Server, the XP machines could finally see and access the shares on the WIN7 Home Media Server.

     

    Sometimes it ends up being the most stupid thing......

    I sure hope this helps someone avoid the aggravation I had this holiday.

    1 มิถุนายน 2553 2:18
  • Thanks for the guide, i tried for several hours to get my files that are not in the public folder to work, they would show up on my xp machine but i could not access them, all it was was to word everyone that sorted it lol, glad i found your guide, cheers, giz1495
    1 มิถุนายน 2553 23:28
  • Ok, I'm just at a total loss.  At one point, my Win7 and XP machine were sharing files fine.  Then, it just quit for no reason.  I have an XP PC and Win7 laptop.  I cannot seem to even get a network to set up between the 2 now, they don't recognize eachother?  You seem to know your stuff, any ideas?  I guess maybe I just don't understand how to set up the network between the 2.  Somehow I made it work before, by setting up a home network from the PC.  The PC is the one that is connected to the internet, the laptop is wireless through the router.  My PC is the one that has a majority of my files on it, and those are the ones I would like to access from my laptop.  HELP!  :)
    18 มิถุนายน 2553 17:08
  • ShockDoctor7,

    It seems that you really know your networking issues, and I have a question for you, but rather then retyping it, I have posted at another forum. 

    It would be great if you could take a look.

    http://en.community.dell.com/support-forums/network-internet-wireless/f/3324/p/19337620/19716797.aspx#19716797

    5 กรกฎาคม 2553 17:01
  • Good instructions, worked for me :)
    25 กรกฎาคม 2553 10:02
  • Very good info.... My question is, with the setup you've outlined, if one of the PCs in the "Homegroup" connects to a remote domain via a VPN connection, are the PCs on the homegroup secure from the domain users?

    Thanks in advance..

    29 กรกฎาคม 2553 21:50
  • After hours and hours of searching on the Internet and numerous failed experiments to set up file sharing among my Vista and Windows 7 machines, I came across your instructions which finally worked. For some incomprehensible reason every other web site (I checked out much more than a dozen) that claimed an "easy" solution, failed to mention your step 4 of typing in "Everyone" which did the trick. All the guru solutions web pages with the author's picture and their silly grins turned out just to be silly and not helpful.

    Thank you for finally getting it right.

    11 สิงหาคม 2553 19:34
  • I cannot connect between an old laptop (XP Pro 2002 SP3) (also a second home desktop) to a new Win 7 (Home Premium) notebook to share files.

    I have read and followed a lot of help files. I thank everybody for trying to make this issue go away.

    Specifically, I’ve followed the advice here in “how to make Windows 7 work with older Windows versions for networking and file sharing.”

     

    Both machines are in same workgroup “RANCHGROUP”

    Both machines connect to the network and internet without problem

     

    On Win 7 the network is a “work” network

    Firewalls are disabled for private networks

    Win 7 Advanced network settings

              Network discovery = on

              File and printer sharing = on

              Public folder sharing = on

              Password protected sharing = off

              Allow windows to manage Homegroup connections

    On folder advanced setting security, “everyone” is added

    On folder advanced setting sharing

    Network File and Folder Sharing is “Shared”

    “People without a user account and password for this computer can access folders shared with everyone.”

    In View Internet Status / See full map, this and both XP computers are shown. For a long time, there was a big "?" in the connection line of the Win 7 to the router.

    In Windows Explorer, the XP machines are not shown

     

    In the XP machine:

    Simple file sharing is turned off.

    In Windows explorer under Network, I cannot see the Win 7 machine. I can see the other XP machine and share with it.

     

    I see some other advice about diving into the registry. I'm about to try this advice:

    http://social.technet.microsoft.com/Forums/en-US/w7itpronetworking/thread/8f21d25d-8189-48e7-8d7f-d6211ac63d31

     but thought I'd better make sure I've gotten the advice posted here all right before I go off in that direction.

     

    Any help?

    thanks / Kozmo

    12 สิงหาคม 2553 16:49
  • I can now see the XP machines in W Explorer on the W7 machine though not vice versa. When I try to access an XP machine from the W7 machine, I get an error "cannot access \\LAP (xp machine). When I go to control panel / Network and Internet / See full map, I see all machines on my network but there is a large "?" shown in the connection line between the W7 and the router.

    13 สิงหาคม 2553 15:47
  • hello,

     

    i have a similar problem that i just can't seem to work out, even my friend is stumped.  i'll describe my network a bit and go from there.

     

    i have 3 pc's on my network.

    a netgear wireless router

    cable modem access

     

    pc 1 is a windows 7 pc 64 bit and is the only pc connected to the router via wire.

     

    pc 2 is windows xp 32bit wireless access

     

    pc 3 is vista 32bit wireless card

     

    pc 1 can access both pc 2 and 3 (although i'd thought the copying speeds of files would be faster, getting about 1.2megs on one and 1.5-2.1 on the other to copy large sized files, seems to be even slower for a bunch of small files)

     

    pc 2 and 3 can access each other too.

     

    neither can accss pc 1 says access is denied.  i've gone through all the steps outlined here and nothing worked.  i've changed workgroup names and nothing worked.

     

    no matter what i seem to do i can't get pc 2 or 3 to access pc 1, and if it wasn't for one folder i need to share with them and printing i'd have given up.

     

    both pc's can see the pc 1 on the network but just can't access anything.

     

    now pc shows the things as shared, i've done all the steps even step 4 and antoehr version of step 4 where you give access to the network group.

     

    and here's a funny thing.  from pc 2 or 3 i can ping pc 1 from the cmd window and the ping works just fine, it pings and returns a response.

     

    i've gone crazy trying to figure this out any help would be apperciated.

     

     

    24 กันยายน 2553 1:03
  • Shockdoctor 7 ..U r the Real Hero....Thank u  verymutch..
    27 กันยายน 2553 16:05
  • Thank you thank you thank you - for rescuing me from still more wasted hours trying to marry my win7 & xp. I have read countless instructions without avail, but at last these instructions cut the mustard.
    23 ตุลาคม 2553 16:48
  • Thank you very much sir. You have saved me much trouble, and your time contributed to the making of this article is greatly appreciated. 

    Great work. :]

    6 พฤศจิกายน 2553 20:27
  • as for #4. NO it doesn't work that way. the 'ORB" doesn't work that way.

    in fact none of this works.

    the Windows 7 computers are not seen by the rest of the workgroup.

    a printer attached to a Windows 7 systems cannot be accessed by an XP machine.

    sharing is one way only. the windows 7 system can see everything on the net but nothing can be accessed by the XP systems that is on or attached to the Windows 7 system.

    20 different trys with 20 different methods and simply none of them work correctly.

    A domain server can be seen.

    XP systems can be seen, but nothing sees this pile of dung OS.

    It has cost loads of time and money to make this work and it simply doesn't.

    13 พฤศจิกายน 2553 17:28
  • I am frustrated like Mark. Nothing seems to make it work for me, and I have wasted countless hours reading help files/forums/emails, and trying everything except maybe candles and chants.

    In my situation, I have had a 300N Airlink router for some time. I have two Vista and one XP systems hardwired to the router, and I have two XP laptops connecting via wireless WEP. Everything has been working great for internet, as well as file and print sharing. My three printers are on the one wired XP systems. So now I add a new wireless Windows 7 laprtop and the headaches begin. It can access the internet fine, but file sharing is bazzar. My two wireless XP systems can see and work with ALL systems, including the new wireless Windows 7 laptop. The new system does not "see" anything except itself, "most" of the time. "Sometimes" the other systems show up under its Network, but will not open them. It can open and access the two wireless XP systems if I open them using \\node-name or \\ip-address. It cannot open anything on the hard wired side of the router except to the internet modem connection. All of the hard wired systems can access everything, except the Windows 7 system. A Ping will not work  (in either direction) between the Windows 7 wireless system and the wired XP system owning all the printers. This is the critical problem.

    Very strange, and so far no one has a solution.


    Wayne
    15 พฤศจิกายน 2553 6:22
  • SOLVED... (For my wireless to wired LAN issue.)   It seems to be an Airlink router problem.

    I have been fighting file and print sharing ever since I bought this Windows 7 laptop. I could not get this Windows 7 wireless system to access anything on the wired LAN, but it could access other wireless XP systems. And my wireless XP systems could access the wireless Windows 7 system, and everything else on the wired LAN. Seemed like an issue with the Airlink 101 router. I talked with Airlink earlier, and told them it seemed like there was some parameter in their internal wireless to wired bridge that was not allowing new Windows 7 protocols to pass. They said it was a Windows problem (as most vendors do). However, when I decided to replaced their router with a similar Linksys router just for for, presto... everything started working just fine. Seems like Airlink has some firmware updates they need to work on.


    Wayne
    16 พฤศจิกายน 2553 23:23
  • Hi..can anyone help me regards this issue..

    I have file sharing on windows xp pro system by using Workgroup name: WORKGROUP. When i using Windows 7 to access the file inside, it came out this message : you do not have access, and/or permission to access the computers files...

    My windows 7 is join in Domain... I don't want to change to Workgroup...what should i do for access the file in windows xp?

    29 พฤศจิกายน 2553 16:49
  • First let me say thank you for the information.  You provided instructions that I could relate to and follow.

    Second let me say that I remain unsuccessful and wonder where I went wrong.

    In step 1, I was a little confused by the focus on Computer Name and the possibility that it needed to be changed.  I did understand the statement that Workgroup name has to be the same on my XP Pro as it is on my Win 7 64bit and verified that but assume that the two each have a distinct computer name.

    Step 2 seems entirely straightforward and I don't think I messed up there.  It seemed to be focused entirely on the Win 7 machine and I did nothing in this step on my XP.

    Step 3 I just picked a couple of folders on the Win 7 machine and followed your instructions.

    Step 4 gave me a little more pause because dummy as I am I typed "Everybody" instead of "Everyone" but ultimately got past that!  Didn't get any error message and went on to step 5.

    Step 5 terminology from BurrWalnut did leave me a little confused too.  I guess we are talking about Windows firewall on both the Win 7 machine and the XP Pro.  On my XP->Control Panel->Windows Firewall I found it ON as recommended and the tab->Exceptions has a check in the box for "File and Printer Sharing".  On my Win 7->Control Panel->System and Security->Windows Firewall->Check Firewall Status I found "Home or work (provate) networs" :  Connected and Public networks:  Not Connected and the warning "These settings are being managed by vendor application NORTON FIREWALL PROVIDER.  The tab "Advanced settings"->Inbound Rules displays 26 different categories of "File and Pringter Sharing - -  " settings.  Some were for "Private" and some for "Domain" but I set all 26 to enabled YES. 

    And, for the third party firewall issue, on both machines I want to the Norton Security Suite->Settings->Firewall-> where I find "Automatic File/Printer Sharing Control" : OFF and selecting the tab for ->Traffic Rules, I found the rule for "Default Allow Windows File Sharing (Shared Networds)" set to ALLOW, Direction: Inbound, Computer: Any, Communications: Specific, Protocol: TCP and UDP, Tracking: Creaqte a log entry....BUT I also found the rule for "Default Block Windows File Sharing" set to ALLOW, Direction: Inbound, Computer: Any, Communications:
    Specific, Protocol: UDP.  

    Step 6 neither computer sees the files or folders on the other computer.

    So where did I fall off the turnip truck??

    8 ธันวาคม 2553 4:49
  • Hi, Only had a quick look over this, but by doing this, will i be able to backup xp to win7 machine?
    21 ธันวาคม 2553 23:18
  • Thank you so much!!! I have a problem with because Password Protected Sharing turned off, the security permissions have to be changed on the folder(s) to allow Everyone access. I did not know that. And this excellent guide make working solution to my home network! 
    13 มกราคม 2554 12:56
  • Shock Doctor,

    Thank you for the great guide.  It is easy to add a bit of password security to all of this: 

    1. Create matching accounts on each PC in the WORKGROUP.  ie. user1, user2 etc...

    2. Note that Windows 7 wants to connect using the form of computer\user.  ie. PC1\user1

    3. Create a share on PC1 and assign the Everyone group Full Control on the share.

    4. For NTFS permissions, rather than give Full Control to the Everyone group, give user1 read only, or modify.

    5. Map a drive from PC2 to the share on PC1, \\PC1\share

    6. Make sure that when you map the drive you click the link to "Connect Using Different Credentials " and specify PC1\user1

    7. You should now have a mapped drive limited to Read Only.

    The key to this is, where XP would just realize that you were logged on as User1 on the other machine and pass on the currently logged on user, Windows 7 needs you to prove that you are authenticating with a local user account.  In Windows 7 you can do that using the computername\username format.  I hope this helps someone else.


    Mersild
    1 กุมภาพันธ์ 2554 14:43
  • Ooorrraaahhh!!

    My multi MS OS network is functioning again.

    In step 4., second sentence, where you,

    Right-click the shared folder > Properties > Security Tab > Edit > Add and type "Everyone" (not the quotes) into the box and select OK.

    I did this;

    Instead of typing in an "object" name to select, use >advanced, to take you to a more detailed "Select Users and Groups" Window. In this window on the right select >Find Now, and then >scroll, down to find the object, Everyone, in the list, >hi lite Everyone, and >OK. Now see, Everyone, in the enter object names to select box, now >OK again to place the object name, Eveyone, into the Group or Users Names: listing box and select >OK.

    Pete

    11 มีนาคม 2554 19:52
  • Thank you VERY much for your article.  The process worked and the instructions were simple and easy to follow.  I am very grateful.
    18 มีนาคม 2554 15:04
  • Drive C, which is normally the boot/OS Drive, will have it's access restricted to local accounts only, while drive D is considered an external drive with open access.  The XP computer needs an account name that matches one of the local accounts on the Windows 7 computer.  If you don't have matching accounts on both computers then create an account on the XP computer where the name and password match the Windows 7 account.  If you do have matching accounts make sure the passwords match.

    Hope this helps,

     

    5 เมษายน 2554 12:27
  • Thank you VERY much for your article.  The process worked and the instructions were simple and easy to follow.  I am very grateful.

    Chris Buchtmann www.jillys.com.au


    14 เมษายน 2554 8:44
  • Thanks for the great instructions; however, this does not work with my dilemma.  I am trying to network Win 7 Pro with Vista.  Both of the workgroups are the same. The network is working fine, internet access etc; however, I can not see other Win 7 computers from Vista computers or vice versa . . .
    20 พฤษภาคม 2554 16:31
  • Okay,

    Hopefully someone is still checking this post (i.e. SharkDoctor7, BurrWalnut, etc.;-), as I'm spinning my wheels trying to find a way around this mess (although I do have some ideas).

    Basically, I have 2 Win7-Pro (x86) systems and a new Win7 Home Premium (x64) system - all on the same workgroup (MEDIOFFICE) - all with 'File and Printer sharing - ON' and 'Password Protection - OFF'

    I have a medical program that auto-installs a default folder on the root the C: drive named 'clinicesx' on my 'main' Win7-Pro system, which I've shared via 'Everyone - Full control'.

    I've installed the med program on my 'second' Win7-Pro, and it too auto-installs a same named folder on the root of C: - BUT - I map a drive to the to the shared one on my 'main' system (as they both need to use a single 'DB') and it all works fine with those system - BUT (again and you probably guessed it)...

    In comes the new Win7 Home-Premium system - same program - same auto-installed folder - now for the mapped drive, WHICH IT LET'S ME DO (as it does see the mapping and the folder in the Network), but then immediately after I've mapped the drive, it pops up with a "You do not have permission - contact network admin - access denied" error. - I've even disabled ALL firewalls, AV's, etc. - still no joy.  I'm very confused and getting frustrated as I NEED this to work ASAP as it's a medical program.

    I'm concerned this may be a Win7 Pro to Home Premium (or vice-versa) network incompatibility issue, but as it 'sees' the share on the network, I'm hopeful it's just a "well - is my face red cuz I missed the obvious" scenario (so you have permission to laugh at me - just as long as you have a solution - and you don't gloat TOO much ;-).

    I've been through this entire post and tried multiple items (although not all - yet), but any further help would be very much appreciated.

    (Thanks in advance)

    28 มิถุนายน 2554 4:50
  • ... and now to reply to my own post...

    I may have missed a step as I just (finally) read this part:

    "As you don’t have Password Protected Sharing turned on, you have to change the security permissions on your folder(s) to allow Everyone access. Right-click the shared folder > Properties > Security Tab > Edit > Add and type ‘Everyone’ (not the quotes) into the box and OK. Tick the boxes next to the permissions you want to allow (e.g. Read or Write, etc.) then Apply > OK, etc."

    ...so, going with my "is my face red" - I'm going to go back to the office and try this, so I'll re-post as to whether it worked or not.

    Of course, if anyone feels this won't work and knows it's actually something else - please don't hesitate to throw in ;-)


    28 มิถุนายน 2554 17:54
  • As promised...

    My face is definitely red - the step in quotes above was the trick that corrected the access denied errors, so...

     

    Cheers, kudos, many thanks, 'We're not worthy', and whatever other praise that can be passed, all to the network guru's out there who tirelessly (and kindly without personal gain) post on these forums with their immense knowledge.

    Thanks to you all.

    29 มิถุนายน 2554 15:02
  • well what can i say?? I got rid of all obstacles by simply selecting user"Everyone" to access my windows 7 folders from my xp machine. I just want to give you my heartily thanks for this useful tip as i was browsing for the solution from 5 months and searched almost all sites.
    5 กรกฎาคม 2554 14:01
  • Hi i own a dell dimension 2400, 4600, running XP service pack 3, an inspiron 1150 running XP professional and 2 computers running windows 7. An inspiron 1545 and a gateway netbook. What I would like to ultimately do is network these computers so i can access edit and view files on all of my computers at my leisure. on the windows 7 PC's i have had alittle more luck i can move files between these two computers but not retitle them once they're moved. in short i would like to be able to access all of these pc's files videos pics ect. from where ever i am in my house move and edit them from any computer. any help would be greatly appreciated.
    17 สิงหาคม 2554 17:37
  • Thank you - I needed to move many GB of files from my XP laptop to Win7 machine. This was a great help!
    31 สิงหาคม 2554 2:40
  • All this is a waste of time. I've doing this several times ever since w7 came out. Nothing seems to work when sharing the old way back in wxp neither the search engine in w7.

    I miss a lot wxp simple way of doing things.

    I don't want either give all the people with network access to my files as suggested by the "Everyone" advised tip.

    I have to wait for yet another really helping tip from somewhere else.

    Thanks

    10 กันยายน 2554 17:32
  • This process will make the network a little less secure but it works well because a password isn’t used and everyone is allowed access.

    Now go to Control Panel > Network and Internet > Network and Sharing Center > Change Advanced Sharing Settings (side panel). Make sure Network Discovery, File and Printer Sharing, and Public Folder Sharing are all set to “on” and Password Protected Sharing is set to “off”.


    I'm confused about disabling password protection. This is for my home wireless network. Does this mean anyone can get to my files?

     

    I live in an apartment in NYC so there are many wireless networks within range. I have one Windows 7 computer, one XP sp3, and my router is an Apple Airport Express. The Airport is set up to require a password.

    How does the password being disabled in the above instructions relate to the Airport's password protection?

     

    Thanks. These instructions were very helpful, though I did need to also use this site to get it to work: http://windows.microsoft.com/en-us/windows7/help/sharing-files-and-printers-with-different-versions-of-windows

    • แก้ไขโดย trottel1 25 ตุลาคม 2554 23:00
    25 ตุลาคม 2554 22:57
  • Although I perfectly followed this great guide, troubleshoot persisted. After a long time I discovered another condition; when you have home network the important point is to have the same Subnet Mask on all computers. For example PC with 255.0.0.0 doesn´t see PC on 255.255.255.0 .
    Might help someone as desperate as me few minutes ago.
    feo
    3 พฤศจิกายน 2554 23:55
  •  

    I’m not looking for the plaudits but you could have used your own terminology! Your article is using phrases I have posted many times on the web, most notably on my favourite Canadian website run by Kerry Brown

    http://www.vistahelp.ca/phpBB2/viewtopic.php?f=7&t=1887&p=11253&hilit=used+and+everyone+is+allowed+access#p11253


    Yea you are, or you wouldn't of said anything.
    25 ธันวาคม 2554 21:38
  • I would just like to add how I fixed my same problem. I found that my problem was not Simple File Sharing, but it was the way I was trying to connect to the shared folder on the Windows XP computer.  I was on the desktop of the Windows 7 computer trying to create a shorcut to the shared folder on the Windows XP computer. I was trying to access the folder by typing '\\computerName\folderName'.  My problem was solved when I changed the computer name to the actual IP address of the computer like '\\192.168.1.1\folderName'.   I would like to add that Simple File Sharing was turned off on the XP computer, and on the Windows 7 computer Password Protecting Sharing was also turned off.
    Auburn University Student IT/MIS Intern War Eagle!
    6 มกราคม 2555 14:05
  • One last thing that I'm not sure has been mentioned yet: if connecting across a wireless network, make sure your network is set as a public network, and not a Work or Home (Private) network! On the Windows 7 computer, go to Control Panel==>Network and Sharing Center==>View Your Active Networks. This was the last thing blocking my Windows 7 and XP computers from playing nicely across my network.
    25 กุมภาพันธ์ 2555 22:01
  • thanks ! this worked for me  and it also worked setting up scan to folder option on Ricoh MP C3000 color

    multifunction unit!!!

    again thanks

    19 มีนาคม 2555 22:48
  • Great guide ! and I would like to add, most people that are getting problems in sharing is because of that password thing in advanced sharing settings > under public heading, turn off password security ( normally the home settings are opened by default and screen is scrolled down so you never see that password option unless u scroll up and choose public heading, same happened with me and I did whatever I could it didn't work finally I stumbled upon it and now it works.

    1 เมษายน 2555 12:01
  • This process will make the network a little less secure but it works well because a password isn’t used and everyone is allowed access.

    1. First, know what the Computer name is and what Workgroup it belongs to.

    The Workgroup name needs to be the same on all PC’s that are being networked; no matter the OS on each system. This is already setup, even if only by default, in the setup process while installing each OS.

    Verify what the Windows 7 computer and workgroup names are by going to Control Panel > System and Security > System > and read information under “Computer name, domain, and workgroup settings” (The third category down).

     If the names need to be changed go to Change settings in that category or Advanced System Settings in left pane. Then, Computer Name Tab > Change, type the Computer Name and Workgroup Name. > OK. Make the computer name meaningful to aid recognition. The computer should restart.

    2. Second, adjust Win7 settings to allow for sharing with older OS on other networked systems.

    Now go to Control Panel > Network and Internet > Network and Sharing Center > Change Advanced Sharing Settings (side panel). Make sure Network Discovery, File and Printer Sharing, and Public Folder Sharing are all set to “on” and Password Protected Sharing is set to “off”.

    Note: I recommend leaving Media sharing set to “on” and under Windows HomeGroup connections select “Allow Windows HomeGroup to manage homegroup connections (recommended)”.

    3. Third, choose which folders to share on the network and adjust properties to do so.

    Drag any folders to be shared to the Public folder.

    Or…

    To share a specific Windows 7 folder or additional drives on the system, right-click it > Properties > Sharing Tab > Advanced Sharing > tick box for Share this folder > Apply > OK > Close. You only need to share the highest level folder, not every sub-folder. Two little people should appear on the icons of the folders that are shared.

    4. Now, you MUST follow this step or the folders will not be shared despite previous steps followed!!!

    Because Password Protected Sharing turned off, the security permissions have to be changed on the folder(s) to allow Everyone access. Right-click the shared folder > Properties > Security Tab > Edit > Add and type “Everyone” (not the quotes) into the box and select OK. Tick the boxes next to the permissions you want to allow (e.g. Read or Write, etc.) then Apply > OK.  Some messages may appear: “An error occurred while applying…” This is not unusual and can be ignored by clicking Continue.

    5. Windows firewall is normally set to allow file and printer sharing but if you have a third-party firewall make sure file and printer sharing are enabled so that each machine can talk to the other(s). Do not disable the Windows firewall if it’s the only one running.

    6. To see or copy files, click the Windows Orb (Start) > Network and the computers/folders/files should appear. Use two windows to drag files from one PC to another.

     

    After spending several days trying to get my old desktop XP-SP3 computer to open the drives on my new Win7 Samsung Laptop computer and show/read/modify them, I *finally* found this forum and the entry above.  Before that, I was about ready to give up.  I'm using a wireless network, BTW, with a TP-Link modem/router connecting all machines together and providing internet accesss.  The XP machine has a wired connection to the router.  The Win7 laptop has a wireless connection.

    From reading lots of other forums, I had become familiar with ownership and permissions in Win7 and I thought I had opened all of them up for sharing, but when I tried to access the drives on my new Samsung Win7 computer from my old XP computer, I kept getting that darned "access denied" and "you don't have the necessary permissions" error messages.   

    I could *see* the Win7 computer in "My Network Places" on my XP computer.  I could also see the workgroup (Mshome) and each computer in the workgroup in "My Network Places" on my XP computer.  And when I clicked on the little + sign next to the Samsung Win7 computer, I could see each drive on the Samsung Win7 machine.  I just couldn't open them.  All I got was "access denied" errors.  Also suggestions to see my Administrator (hah!).

    Then I tried the suggestion above from ShockDoctor7.  I added "Everyone" as a user, just as ShockDoctor7 suggested.  I'm sorry to say I didn't try to access my Win7 drives right after that.  Instead, I went one step further, and I've written the last step below.  After I did it, both Win7 drives opened up immediately from my XP machine, and I had full access to both Win7 drives on the Samsung immediately.  No rebooting or anything!  They just opened right up!  Here it is step by step: 

    1.  After right clicking on each Win7 drive, I right clicked on Properties> Security> Clicked on the Edit Button> Then added "Everyone" as a user> and clicked on the "Full Control" tickbox at the bottom of the window.  Then I clicked on "OK".  Now "Everyone" had full control of the drive.  This is the last thing ShockDoctor7 suggested.

    2.  But I went one more step.   In the same "Properties>Security" window, there is an "Advanced" button near the bottom of the window.  It's under the "Edit" button which is closer to the top of the window.  I clicked on the "Advanced Button" which brought up a window with 4 tabs.  I clicked on the "Effective Permissions" tab.   Then I added "Everyone" as a user and gave "Everyone" full control by clicking on the "Full Control" tickbox near the bottom of the screen.  Then I clicked "OK" or "Apply".  The machine ground around for a while as it went through all the subfolders and files on the drive. (Watch each screen for a little tickbox which applies your changes to all subfolders and files.  If you see one, be sure to select it.)

    3.  As soon as I had finished this operation on both Samsung Win7 drives, I went back to "My Network Places" again on my XP machine, found the Samsung computer, clicked on the + next to it, found the drives on the Samsung, clicked on them and was *immediately* able to open them and see and change each file on each drive!!  I *finally* had the necessary permissions to access those darned drives!

    4.  Note:  I went back to "Effective Permissions" again to write this post but found it empty again.  Since the Samsung Win7 computer obviously made some changes after I used "Effective Permissions" to give "Full Control" to "Everyone", I'm guessing that window just resets itself to clear each time after someone uses it.  But I think the "Effective Permissions" changes were still there.

    5.  I should also note that there is an "Owner" tab in the same window that has the "Effective Permissions" tab.  One other thing I did was click on the "Owner" tab for each Win7 drive on the Samsung computer and change the Owner to my User/Administrator account.  (I use only one account with full Administrator privileges.)

    6.  So here's a summary of the main things I did: 

    a) I set the Win7 machine to use the "Work" workgroup for networking; 

    b) I put both machines (XP and Win7) into the same "Mshome" workgroup; 

    c) I turned off password protected sharing on the Win7 machine; 

    d) I went to Properties for both Win7 drives and set them for full sharing (of course); 

    e) I gave ownership of both drives to my user account on the Samsung;

    f)  I added "Everyone" as a user under "Security" and edited permissions to give "Everyone" full control of both drives as ShockDoctor7 described above;

    g) I went to "Effective Permissions" as described above, entered "Everyone", and also gave it full control; and,

    h) I also turned off "Simple File Sharing" on my XP machine.  In any folder window click Tools>Folder Options>View.  Then drop down to the bottom of the list and un-check "Simple File Sharing".  Then click "Apply To All Folders" and then click "OK".  I don't know if this change is necessary, but it's part of what other people suggested and what I did.  And now the Win7 drives are mapped and working on my XP machine.  I guess I'll go back later and try to figure out which parts of what I did were actually necessary and which parts weren't.  Maybe.  Someday.

    After all these changes, I went to "My Network Places" on my XP computer and found I finally had full access to both drives on the Win7 computer.  That included mapping both Win7 files as "Z" and "Y" files on my XP machine.

    P.S.  When I tried to access "Samsung" in "My Network Places" I got the "access denied" error again, so I repeated the above on the "Samsung" file in C:\Documents and Settings on the Win7 machine.  I also applied the same changes to the "Documents and Settings" folder of the Win7 machine.  Now I have full access to them, too, from my XP machine.

    P.S.2  As delivered, "TrustedInstaller" or "System" owned a lot of the drives and/or folders on the Samsung C drive.  I've gone through and changed most of them so that now ownership belongs to my main User account.  I didn't delete the "TrustedInstaller" user, though.  It's part of the automatic update process.  If you delete it, automatic updates probably won't work right.  

    P.S.3  There's a neat little program that places a menu item in your right click menu of a Win7 computer which lets you make ownership changes quickly. Here's a link to that program: http://cdn2.blogsdna.com/wp-content/uploads/2009/01/takeownership.zip   It's 2 programs, actually.  One to change ownership to you and one to undo the change.

    One last thing ......

    MICROSOFT, YOU SHOULD BE ASHAMED OF YOURSELF.   FIRST FOR MAKING THIS XP-WIN7 DRIVE MAPPING SO DIFFICULT, AND SECOND FOR OFFERING BASICALLY NO HELP TO PEOPLE TRYING TO FIGURE IT OUT.    

    AND THANKS A MILLION TO THE PEOPLE IN THIS FORUM!!  I WORKED ON THIS PROBLEM FOR ALMOST 3 DAYS AND THIS IS THE ONLY PLACE I FOUND THE INFO I NEEDED!! I hope my small additional post is helpful. 



    • แก้ไขโดย grega711 24 กุมภาพันธ์ 2556 11:05 adding more detail/improving syntax
    24 กุมภาพันธ์ 2556 10:43
  • If you have an issue getting from a Windows 7 box to a Windows XP box, and if you are running Norton 360 on the Windows XP box, and if you are using the firewall of Norton 360 on the Windows XP box, and you followed all of the steps above, then turn off the Norton 360 firewall for 15 minutes to see if the firewall is the issue.  You can turn off the Norton 360 firewall on the Windows XP box temporarily by right clicking on the Norton 360 tray icon and clicking on Disable Smart Firewall.  If your access to your Windows XP share from your Windows 7 box works immediately, then you can turn back on the firewall and proceed to follow the instructions here because you have found the issue.  If this is not your issue, the rest of this posting does not apply.

    Bring up Norton 360 by double clicking on the tray icon.  Click on PC Security, the panel on the far left.  Click on Manage Firewall.  A new dialog box appears called Settings.  Click on the Traffic Rules tab.  Scroll down to the setting called Default Block Windows File Sharing and click on it.  This activates a button below called Modify.  Click on this Modify button.  A Modify Rule dialog appears.  Pick the radio group for Allow.  Click Ok to set the setting and close the Modify Rule dialog box.

    Scroll down more on the Settings dialog box until you get to Default Block Microsoft Windows 2000 SMB.  Click on this option and set this to Allow just as you did in the prior paragraph.  Windows 7 behaves like Windows 2000 for file sharing.

    Click the Apply button from the Setting dialog.  Your Windows 7 box should immediately be able to access your shared folder on your Windows XP box.

    10 มีนาคม 2556 7:06