none
Mac OS X RDP kills all the app on windows 7 machine

    问题

  • i am having very weird issue windows 7 ultimate machine. i can able to do RDP from Mac OS X but when RDP quits or disconnects, all the running application gets killed on windows 7 remote machine. what makes RDP client to kills my all applications on remote machine . Thank you.!



    • 已编辑 XMKK 2012年6月10日 5:25
    2012年6月10日 2:00

答案

全部回复

  • 1. Have you used latest RDC client for Mac 2.1.1 ?

    http://www.microsoft.com/mac/downloads?pid=Mactopia_RDC&fid=68346E0D-44D3-4065-99BB-B664B27EE1F0#viewer

    2. For troubleshooting I recommend

    http://www.microsoft.com/mac/support

    Regards

    Milos

    2012年6月10日 6:37
  • Hi, Milos,

    Thanks, i tired RDC client for Mac 2.1.1 and also tried CoRD. Noticed following events in event views. maybe this could reveal the cause.

    Log Name:      Application
    Source:        Microsoft-Windows-User Profiles Service
    Date:          6/10/2012 2:54:41 PM
    Event ID:      1530
    Task Category: None
    Level:         Warning
    Keywords:     
    User:          SYSTEM
    Computer:      ai1000ws-PC
    Description:
    Windows detected your registry file is still in use by other applications or services. The file will be unloaded now. The applications or services that hold your registry file may not function properly afterwards. 

     DETAIL -
     1 user registry handles leaked from \Registry\User\S-1-5-21-1600458229-1572561972-2708864519-1000:
    Process 1440 (\Device\HarddiskVolume2\Windows\System32\svchost.exe) has opened key \REGISTRY\USER\S-1-5-21-1600458229-1572561972-2708864519-1000\Printers\DevModePerUser

    Event Xml:
    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
      <System>
        <Provider Name="Microsoft-Windows-User Profiles Service" Guid="{89B1E9F0-5AFF-44A6-9B44-0A07A7CE5845}" />
        <EventID>1530</EventID>
        <Version>0</Version>
        <Level>3</Level>
        <Task>0</Task>
        <Opcode>0</Opcode>
        <Keywords>0x8000000000000000</Keywords>
        <TimeCreated SystemTime="2012-06-10T05:54:41.283544300Z" />
        <EventRecordID>10401</EventRecordID>
        <Correlation />
        <Execution ProcessID="1476" ThreadID="1848" />
        <Channel>Application</Channel>
        <Computer>ai1000ws-PC</Computer>
        <Security UserID="S-1-5-18" />
      </System>
      <EventData Name="EVENT_HIVE_LEAK">
        <Data Name="Detail">1 user registry handles leaked from \Registry\User\S-1-5-21-1600458229-1572561972-2708864519-1000:
    Process 1440 (\Device\HarddiskVolume2\Windows\System32\svchost.exe) has opened key \REGISTRY\USER\S-1-5-21-1600458229-1572561972-2708864519-1000\Printers\DevModePerUser
    </Data>
      </EventData>
    </Event>

    ---------------------------------------------------

    Log Name:      Application
    Source:        Desktop Window Manager
    Date:          6/10/2012 12:57:09 PM
    Event ID:      9009
    Task Category: None
    Level:         Information
    Keywords:      Classic
    User:          N/A
    Computer:      ai1000ws-PC
    Description:
    The Desktop Window Manager has exited with code (0x40010004)
    Event Xml:
    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
      <System>
        <Provider Name="Desktop Window Manager" />
        <EventID Qualifiers="16384">9009</EventID>
        <Level>4</Level>
        <Task>0</Task>
        <Keywords>0x80000000000000</Keywords>
        <TimeCreated SystemTime="2012-06-10T03:57:09.000000000Z" />
        <EventRecordID>10384</EventRecordID>
        <Channel>Application</Channel>
        <Computer>ai1000ws-PC</Computer>
        <Security />
      </System>
      <EventData>
        <Data>0x40010004</Data>
      </EventData>
    </Event>


    • 已编辑 XMKK 2012年6月10日 7:14
    2012年6月10日 7:02
  • I agree with Milos. You'd better contact the proper support.

    Meanwhile you may boot in Clean Boot Mode and see if it helps.

    How to troubleshoot a problem by performing a clean boot in Windows Vista or in Windows 7
    http://support.microsoft.com/kb/929135


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”

    2012年6月11日 7:21
    版主