none
Shared desktop location and GPO for shortcuts on desktop

    السؤال

  • I am having an issue creating shortcuts for students.  We are a smaller community college and we are redirecting student desktops and documents.  The computers are all Win 7 and our servers are 2008 R2.  We are redirecting all the students desktops to a single shared location and then we restrict that location for their group to just read, list, and execute.  We didn't want them to be able to save items on their desktop due to some replication and login delays at some of our remote campuses.  Some students were saving 100's of MB files on their desktops.  So after changing the redirection we thought we were good.  We have a GPO that creates a few shortcuts for them and they started failing due to access denied since students cannot write to the desktop.  I made sure that the GPO for creating these shortcuts is not set to run under the users context.  For most of the shortcuts we are ok because I just created shortcuts in the shared folder but we have some that are item level targeted to just certain groups.  So my question is this, does anyone know how to get group policy to apply the shortcuts to the shared location when the students do not have the ability to write to that location?  I could do computer policy but different students use the same computers and should not have all of the same shortcuts. 
    Joe M
    17/جمادى الثانية/1432 09:22 م

الإجابات

  • Hi Joe,

     

    According to your description, you have removed the user write permission on his\her own personal folder of the network share, so that the user cannot save items on Desktop. In this situation, if you define Shortcut group policy preferences (GPP) under User Configuration, the Shortcut GPP cannot be applied on the clients, and the “access is denied error” is logged in Event Log. This is by design and cannot be changed.

     

    If you want all the users or groups of users receive the same Desktop, you can redirect their Desktop to a certain network folder with proper permissions or consider using mandatory user profile. If you remove the write permission due to replication and login delays, you can consider enabling disk quota. Refer to:

     

    Right click on the drive which contains the share folder on server, go to Quota tab, enable quota management. Check “Deny disk space to users exceeding quota limit”. Click Quota Entries… Choose Quota, New Quota Entry, enter domain user name, limit disk space as you want.

     

    Just for your information, it will be simple by using FSRM to create quotas. To create an Auto Apply Quota via Quota Management. Refer to:

     

    1. In Quota Management, click Quotas. Right click to create new quotas.

    2. Under Quota path, browse to the parent folder that the quota will be applied to. You can create your own Quota Template and use it as you want.

    3. Click Auto apply template and create quotas on existing and new subfolders.

    4. Under Derive properties from this quota template, select the template you want. Click Create.

     

    I hope the above information will be helpful.

     

    Best Regards,

     

    Nina Liu

    TechNet Subscriber Support in forum

    If you have any feedback on our support, please contact tngfb@microsoft.com.  


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    20/جمادى الثانية/1432 06:37 ص
    المشرف

جميع الردود

  • Hi Joe,

     

    According to your description, you have removed the user write permission on his\her own personal folder of the network share, so that the user cannot save items on Desktop. In this situation, if you define Shortcut group policy preferences (GPP) under User Configuration, the Shortcut GPP cannot be applied on the clients, and the “access is denied error” is logged in Event Log. This is by design and cannot be changed.

     

    If you want all the users or groups of users receive the same Desktop, you can redirect their Desktop to a certain network folder with proper permissions or consider using mandatory user profile. If you remove the write permission due to replication and login delays, you can consider enabling disk quota. Refer to:

     

    Right click on the drive which contains the share folder on server, go to Quota tab, enable quota management. Check “Deny disk space to users exceeding quota limit”. Click Quota Entries… Choose Quota, New Quota Entry, enter domain user name, limit disk space as you want.

     

    Just for your information, it will be simple by using FSRM to create quotas. To create an Auto Apply Quota via Quota Management. Refer to:

     

    1. In Quota Management, click Quotas. Right click to create new quotas.

    2. Under Quota path, browse to the parent folder that the quota will be applied to. You can create your own Quota Template and use it as you want.

    3. Click Auto apply template and create quotas on existing and new subfolders.

    4. Under Derive properties from this quota template, select the template you want. Click Create.

     

    I hope the above information will be helpful.

     

    Best Regards,

     

    Nina Liu

    TechNet Subscriber Support in forum

    If you have any feedback on our support, please contact tngfb@microsoft.com.  


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    20/جمادى الثانية/1432 06:37 ص
    المشرف
  • Hi,

     

    Any update on this issue? If there is anything that I can do for you, please feel free to let me know.

     

    Thanks.

    Nina


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    23/جمادى الثانية/1432 09:37 ص
    المشرف