none
Problem RDPing from a virtual desktop session

    Dotaz

  • Hello,

    I have  a problem doing RDP from a RDP file on a virtual desktop session.

    Scenario:

    Windows 7 XenDesktop

    RDP file is on this virtual desktop with necessary connection settings.

    If I run mstsc.exe from [start-> run], I can RDP the servers and PCs -> No problem

    Problem:

    If I try to run the RDP file from the desktop by double clicking, I get the error message as follows and I can not connect:

    [your administrator has set policy that prevents the launching of this RDP file. the remote connection cannot be started.]

    Could you please show me how to get rid of this problem, since this is required for day to day operation for IT colleagues.

    Best Regards,

    Tom


    28. června 2012 2:03

Odpovědi

  • Hi Tom,

    Please make sure Allow .rdp files from unknown publishers group policy setting is Not Configured or Disabled.  This setting may be found under the following paths in gpedit.msc:

    Computer Configuration\ Administrative Templates\ Windows Components\ Remote Desktop Services\ Remote Desktop Connection Client

    User Configuration\ Administrative Templates\ Windows Components\ Remote Desktop Services\ Remote Desktop Connection Client

    It is probably being set via a domain GPO.

    Thanks.

    -TP

    28. června 2012 4:10

Všechny reakce

  • Hi Tom,

    Please make sure Allow .rdp files from unknown publishers group policy setting is Not Configured or Disabled.  This setting may be found under the following paths in gpedit.msc:

    Computer Configuration\ Administrative Templates\ Windows Components\ Remote Desktop Services\ Remote Desktop Connection Client

    User Configuration\ Administrative Templates\ Windows Components\ Remote Desktop Services\ Remote Desktop Connection Client

    It is probably being set via a domain GPO.

    Thanks.

    -TP

    28. června 2012 4:10
  • Hello TP,

    Thank you very much for clarifying the issue.

    Yes, it looks like this GPO has been disabled on the OU level.

    BR,

    Tom

    3. července 2012 1:37