none
Windows Time Sync Issues: The computer did not resync because no time data was available.

    Frage

  • Hi All,

    I'm trying to configure our Win2008 Domain Controller to sync against an external time server and I'm getting the following error when I resync

    C:\Windows\system32>w32tm /resync /rediscover
    Sending resync command to local computer
    The computer did not resync because no time data was available.


    Eventually the following error will also appear in the event viewer:

    Time Provider NtpClient: No valid response has been received from manually configured peer time.windows.com,0x1 after 8 attempts to contact it. This peer will be discarded as a time source and NtpClient will attempt to discover a new peer with this DNS name. The error was: The peer is unreachable.

    I've followed KB816042 "Configuring the Windows Time service to use an external time source" (including running the fix) and can confirm that registry settings are correct.
    Also, the group policy settings for 'Windows Time Service' are all set to 'Not Configured' (as per kb929276).

    There are no connectivity issues as "w32tm /stripchart /computer:time.windows.com /dataonly" gives me a valid output. I've also tried other, geographically closer, time servers with the same result.

    Unregistering/re-registering/re-configuring the w32tm service also gave the same result.

    I've also reviewed most of the posts with the same error msg on here.

    Any ideas on what else I can look at?

    Thanks

    Donnerstag, 19. August 2010 08:25

Antworten

  • Please take a look at this thread.

    Time.Windows.com is a not very reliable service and it is not very well suited to be used as timesource for critical systems. You can search for an alternative NTP server here.

     

     


    MCP/MCSA/MCTS/MCITP
    • Als Antwort markiert jmcmullen Montag, 23. August 2010 15:07
    Donnerstag, 19. August 2010 08:46

Alle Antworten

  • Please take a look at this thread.

    Time.Windows.com is a not very reliable service and it is not very well suited to be used as timesource for critical systems. You can search for an alternative NTP server here.

     

     


    MCP/MCSA/MCTS/MCITP
    • Als Antwort markiert jmcmullen Montag, 23. August 2010 15:07
    Donnerstag, 19. August 2010 08:46
  • Hello,

    make sure the firewall has oprt 123 UDP open. Is that domain controller the PDCEmulator in the domain? See my blog about some details:

    http://msmvps.com/blogs/mweber/archive/2010/06/27/time-configuration-in-a-windows-domain.aspx


    Best regards Meinolf Weber Disclaimer: This posting is provided "AS IS" with no warranties or guarantees , and confers no rights.
    • Als Antwort vorgeschlagen SenneVL Donnerstag, 19. August 2010 08:49
    • Nicht als Antwort vorgeschlagen jmcmullen Donnerstag, 19. August 2010 09:46
    Donnerstag, 19. August 2010 08:47
  • Hi SenneVL - I've tried a couple of different time servers with the same result unfortunately. As 'w32tm /stripchart' gives me a response I'm guessing it's a problem with the server rather than time.windows.com itself.
    Donnerstag, 19. August 2010 08:52
  • Thanks for the response Meinolf.

    I can confirm that the dc is the PDCEmulator (I've just checked that after reading your blog post).

    The firewall is also open, the network admins can see the connection going out to the ntp servers, I can also query the ntp servers using an application (NTPQuery).

    Donnerstag, 19. August 2010 08:59
  • Hello,

     

    Is your DC in virtual environment? did you configure the GP policies for "Time Zone"?

     

    Regards,

    Donnerstag, 19. August 2010 10:11
  • Hi Anas

    Yes the server is in a virtual environment, I'm aware that there are some issues with this so I've set it not to synchronize with the ESX server.

    We don't have any GP for time zone. Could that be significant? The local machine is set to GMT.

     

    thanks

     

    Donnerstag, 19. August 2010 10:34
  • Hello,

    did you use this way without working manual in the registry:

    w32tm /config /manualpeerlist:PEERS /syncfromflags:manual /reliable:yes /update

    Please set for PEERS the time source as listed above, either with it’s ip address or DNS name. If more then one is needed separate them with a space in between and don't forget the quotes: "time.domain.com time1.domain.com"

    Internet Time servers you can find here: http://www.pool.ntp.org/


    Best regards Meinolf Weber Disclaimer: This posting is provided "AS IS" with no warranties or guarantees , and confers no rights.
    Donnerstag, 19. August 2010 13:04
  • Thanks for the suggestion Meinolf. I hadn't tried this although I don't think the problem is related to a registry setting as I have also run the 'fix it' tool in KB816042 to confirm the settings were correct.

     

    I've just tried running the update with that command and I'm getting the same result:

     

    C:\Windows\system32>w32tm /configure /manualpeerlist:"time.windows.com" /syn
    cfromflags:manual /reliable:yes /update
    The command completed successfully.


    C:\Windows\system32>net stop w32time
    The Windows Time service is stopping.
    The Windows Time service was stopped successfully.


    C:\Windows\system32>net start w32time
    The Windows Time service is starting.
    The Windows Time service was started successfully.


    C:\Windows\system32>w32tm /resync /rediscover
    Sending resync command to local computer
    The computer did not resync because no time data was available.

    Donnerstag, 19. August 2010 13:49
  • Hi,

    Try again see if can help, copy and paste the command:

    w32tm /config /manualpeerlist:"0.pool.ntp.org 1.pool.ntp.org 2.pool.ntp.org" /syncfromflags:manual /reliable:yes /update

    net stop w32time && net start w32time


    Hope you find the info useful
    Freitag, 20. August 2010 18:36
  • Thanks for the help all.

    I think SenneVL had it right first time.

    I changed the time server to a different geographically close time source, left it over the weekend, and now the manual sync works

    C:\Windows\system32>w32tm /resync
    Sending resync command to local computer
    The command completed successfully.

     

    It's odd that this didn't work initially when I tested it with a local time source but it may have been a case of bad luck in that both that and time.windows.com were unreliable/busy.

     

     

    Montag, 23. August 2010 15:07
  • I had a similar issue and found that - as mentioned by Meinolf Weber - our firewall was blocking UDP 123.  Once this was opened the update/sync worked.

    Very true that the Microsoft time server is not very useful.  Better to find a good NTP server for your region.


    • Bearbeitet C Durkin Samstag, 9. Juni 2012 06:19
    Samstag, 9. Juni 2012 06:17