none
Cannot Access 'http://localhost' with Windows Server 2003 SP1 and IE7

    Question

  • Hi all, first time to the TechNet forums... Be kind hey? ;) I have searched the forums under General and Security for that same scenario, but I couldn't find anything on the exact issue I'm having...

    I work for a point-of-sales software company, and we're having an issue with one of our customer's computers that I can't figure out. First off, I must warn you that I am not too familiar with Windows Server 2003. For the most part, Windows XP has been more than sufficient for our product's needs, but one of our customers upgraded to Windows Server 2003 for Small Businesses out of his own choosing.

    One of our applications runs as a service in Windows, and the control panel for this app is accessed through a web browser by means of 'http://localhost:8080'. I could get around this quite easily by installing Firefox to bypass the Internet Security setup, but (understandably) our customer is not satisfied with that as a solution.

    When trying to access the page, a message pops up stating that the page has been blocked and provides an option to add the address to the list of Trusted Sites for Internet. Now the fun starts; the address "http:/localhost" already existed under the Trusted Sites for Intranet, but whether it is under Intranet or Internet doesn't seem to make any difference. Content Adviser was enabled, but even after disabling it the messages persists.

    The end result, to satisfy our application's needs and the customer's security needs, is that I would like to allow access to "http://localhost" on port 8080 and 8081 only. Is this possible, and if so, how would I configure that?
    Thursday, July 02, 2009 7:46 AM

Answers

  • Hi,

    If you would like to disable Internet Explorer Enhanced Security Configuration, try these steps: open Control Panel, click Add or Remove Programs, and then click Add/Remove Windows Components. Uncheck Internet Explorer Enhanced Security Configuration, Click Next.

    You can also configure Internet Explorer Enhanced Security Configuration to apply to specific users. Please refer to "Apply Internet Explorer Enhanced Security Configuration to specific users" of the article below.
    http://support.microsoft.com/kb/815141

    Thanks.

    This posting is provided "AS IS" with no warranties, and confers no rights.
    • Marked as answer by Andre Greeff Monday, July 06, 2009 6:13 AM
    Friday, July 03, 2009 9:05 AM

All replies

  • HI thanks for posting on technet....i gone thru your problem but i understood it partially and also i would need some more info on ur issue....
    firstly..do you have IIS installed and configured???if yes check on which port is it configured and if you have any firewall rules to block that port....also check if you have configured any proxies to connect to the service as you have said that you can connect to the app  thru firefox....please do have a check on them and pls do post back....
    Regards, KOWSHAL H.M. a.k.a W@R10CK
    Thursday, July 02, 2009 10:49 AM
  • Hi Kowshal, thanks for the speedy reply.

    No proxies are set up to my knowledge. IIS is installed however, no firewalls are active however (Eset NOD32 antivirus installed, but no firewall and Windows Firewall is disabled).

    I have to admit, I know very little of setting up IIS... However, I suspect I may be able to get around this issue by disabling the Internet Explorer Enhanced Security Configuration, not so? That seems to be the component that is preventing me from accessing 'http://localhost:8080'. If so, then what would be the best way to do that?
    Thursday, July 02, 2009 11:41 AM
  • The customer has also just agreed that the Internet Explorer Enhanced Security Configuration idea is a bit overboard. How can I work around that then? Simply using the Content Adviser to password protect unknown websites is more than sufficient.
    Thursday, July 02, 2009 11:46 AM
  • Generally IE7 runs under LORIE(i.e. Low rights internet explorer) so just give it a try by running it as an administrator by right clicking on the IE icon and then run it as administrator and may be that should clear of the security content as the process would run under administrator access...please give it a try and do post back....i suggested this coz as you said if it would work under firefox it should work this way.....
    Regards, KOWSHAL H.M. a.k.a W@R10CK
    Thursday, July 02, 2009 1:41 PM
  • Thanks for the ideas, it's afternoon already this side of the world, and the customer has requested that I rather try this in the morning before their store opens for trading. So I will try that first thing tomorrow morning and reply when I see how it goes.

    Thanks again for the help.
    Thursday, July 02, 2009 1:44 PM
  • Sure you are welcome.....and here its 7pm(indian standard time)....:)
    Regards, KOWSHAL H.M. a.k.a W@R10CK
    Thursday, July 02, 2009 1:45 PM
  • Hi,

    If you would like to disable Internet Explorer Enhanced Security Configuration, try these steps: open Control Panel, click Add or Remove Programs, and then click Add/Remove Windows Components. Uncheck Internet Explorer Enhanced Security Configuration, Click Next.

    You can also configure Internet Explorer Enhanced Security Configuration to apply to specific users. Please refer to "Apply Internet Explorer Enhanced Security Configuration to specific users" of the article below.
    http://support.microsoft.com/kb/815141

    Thanks.

    This posting is provided "AS IS" with no warranties, and confers no rights.
    • Marked as answer by Andre Greeff Monday, July 06, 2009 6:13 AM
    Friday, July 03, 2009 9:05 AM
  • Thanks to both Kowshal and Mervyn for the help, it is very much appreciated.

    I did end up removing IEESC, and that did resolve the issue I was having. I'll go learn more about it for next time though..
    Monday, July 06, 2009 6:13 AM