none
Cannot add Clickonce as RemoteApp

    Question

  • In the RemoteApp Wizard, I browse for my 'appref.ms' refference.

    Default extentions include *.exe, *.com, *.scr, *.bat, and *.cmd; I browse for *.*

    I add my appref.ms to the RemoteApps list.

    Click Next;

    Wizzard responds:

      Adding 1 program

      Program list:

      DirectBuy Client.appref-ms
        Path:
         RemoteApp available through TS Web Access: Yes
        Allow command-line arguments: No

     

    I click finish.

     

    However, the application does not appear in my RemoteApps Manager, RemoteApps list!

     

    How can Clickonce Publish?

    Wednesday, July 11, 2007 9:37 PM

Answers

  • We are not correctly grabbing the path for clickonce publications and I will file a bug on this issue, so it can be addressed before release.  As a work around, create a .cmd file that opens your Clickonce publish application.  So for example, if your clickonce program is c:\MyApp.appref-ms, Create a cmd file such as MyApp.cmd and add the following line:

    start c:\MyApp.appref-ms

     

    Then publish the CMD file instead of the ClickOnce application.

     

    Cheers.

    Friday, July 13, 2007 1:11 AM

All replies

  •  

    Thanks for reporting this issue. I'll find out if there is a workaround and get back to you.

    Thursday, July 12, 2007 6:02 PM
  • We are not correctly grabbing the path for clickonce publications and I will file a bug on this issue, so it can be addressed before release.  As a work around, create a .cmd file that opens your Clickonce publish application.  So for example, if your clickonce program is c:\MyApp.appref-ms, Create a cmd file such as MyApp.cmd and add the following line:

    start c:\MyApp.appref-ms

     

    Then publish the CMD file instead of the ClickOnce application.

     

    Cheers.

    Friday, July 13, 2007 1:11 AM
  •  I tried to use this workaround... In my case there is online ClickOnce application, which is launched by
    file://server/App.application kind of url...

    If I create cmd file like
    start file://server/App.application
    and run it... it opens application...
    But when I create rdp shortcut to this cmd and run it it just opens blank screen of command promt for a moment and closes then

    Any solutions?
    Wednesday, August 20, 2008 5:08 AM
  • Has anyone come up with a solution to this yet?

    There's a similar question on StackOverflow about it, too:

    http://stackoverflow.com/questions/106164/clickonce-online-only-application-as-a-ts-remoteapp

    This was marked as a "bug" in 2007, apparently, so why does this issue still persist in 2010?
    Tuesday, February 23, 2010 3:32 PM
  • Configure the remoteapp as C:\windows\Explorer.exe C:\MyApp.appref-ms
    Tuesday, May 21, 2013 5:19 AM