none
Installer encountered an error: 0x8007065e

    Question

  • 1 )   I am getting the error "Windows Update Standalone Installer - Installer encounetered an error: 0x8007065e. Data of this type is not supported." while installing service pack 2 (windows server 2008 - Windows6.0-KB948465-X64.exe) on server core.

    2)   Automatic update error -

    C:\Windows\System32>cscript scregedit.wsf /AU 4
    Microsoft (R) Windows Script Host Version 5.7
    Copyright (C) Microsoft Corporation. All rights reserved.

    C:\Windows\System32\scregedit.wsf(777, 3) (null): 0x80240037

                   and getting

    C:\Windows\System32>cscript scregedit.wsf /AU /v
    Microsoft (R) Windows Script Host Version 5.7
    Copyright (C) Microsoft Corporation. All rights reserved.

    SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate\Auto Update AUOptions
    Value not set.

    Appreciate advices.

    Thanks,
    Sat

    Wednesday, June 03, 2009 1:56 PM

Answers

  • Hi,

     

    Problem #1

    --------------

    It seems that the Windows6.0-KB948465-X64.exe file has a data corrupt. I recommend that you download the file again from Microsoft’s site to test whether the same error occur.

     

    Service Pack 2 for Windows Server 2008 and Windows Vista

    http://technet.microsoft.com/en-us/windows/dd262148.aspx

     

    I also include the following Microsoft Knowledge Base for you. Please follow the steps in the article to troubleshoot this issue if the installation still fails.

     

    947366  How to troubleshoot Windows Vista and Windows Server 2008 service pack installation issues

    http://support.microsoft.com/default.aspx?scid=kb;EN-US;947366

     

     

    Problem #2

    --------------

    Based on my research, this problem should caused by group policy. If Automatic Updates has been configured via policy and when you try to configure it again via scregedit.wsf, it will returns an error code 0x80240037. If Automatic updates have not previously been configured and when you querying the value of Automatic updates, it will return value not set.

     

    Policy and the scregedit.wsf script work on 2 different areas of the registry:

     

    When you use scregedit.wsf to configure Automatic updates it set the AUOptions Value under : HKLM\Software\Microsoft\Windows\currentversion\windowsupdate.

    When you use Group Policy it configures the Value under : HKLM\Software\Policies\Microsoft\Windowsupdate

     

    I recommend that you run gpresult  command in the Server Core to dump the group policy information to see whether the Automatic updates setting is configured. If so, it is expected. If the current setting is not what you want, you may either change the GPO or set the setting as "Not Configured" in GPO and then modify it via scregedit.wsf script.

    Note: Please check the GPO related to WindowsUpdate.

     

    In addition, if the problem continues, please run the command gpresult /z >c:\gpresult.txt to save the result as a txt file, and then send me the gpresult.txt for the further research.

     

    You can send the file to tfwst@microsoft.com, please keep “To Vincent Hu” in the subject

     

     

    Best regards,

    Vincent Hu

    Thursday, June 04, 2009 10:38 AM

All replies

  • Hi,

     

    Problem #1

    --------------

    It seems that the Windows6.0-KB948465-X64.exe file has a data corrupt. I recommend that you download the file again from Microsoft’s site to test whether the same error occur.

     

    Service Pack 2 for Windows Server 2008 and Windows Vista

    http://technet.microsoft.com/en-us/windows/dd262148.aspx

     

    I also include the following Microsoft Knowledge Base for you. Please follow the steps in the article to troubleshoot this issue if the installation still fails.

     

    947366  How to troubleshoot Windows Vista and Windows Server 2008 service pack installation issues

    http://support.microsoft.com/default.aspx?scid=kb;EN-US;947366

     

     

    Problem #2

    --------------

    Based on my research, this problem should caused by group policy. If Automatic Updates has been configured via policy and when you try to configure it again via scregedit.wsf, it will returns an error code 0x80240037. If Automatic updates have not previously been configured and when you querying the value of Automatic updates, it will return value not set.

     

    Policy and the scregedit.wsf script work on 2 different areas of the registry:

     

    When you use scregedit.wsf to configure Automatic updates it set the AUOptions Value under : HKLM\Software\Microsoft\Windows\currentversion\windowsupdate.

    When you use Group Policy it configures the Value under : HKLM\Software\Policies\Microsoft\Windowsupdate

     

    I recommend that you run gpresult  command in the Server Core to dump the group policy information to see whether the Automatic updates setting is configured. If so, it is expected. If the current setting is not what you want, you may either change the GPO or set the setting as "Not Configured" in GPO and then modify it via scregedit.wsf script.

    Note: Please check the GPO related to WindowsUpdate.

     

    In addition, if the problem continues, please run the command gpresult /z >c:\gpresult.txt to save the result as a txt file, and then send me the gpresult.txt for the further research.

     

    You can send the file to tfwst@microsoft.com, please keep “To Vincent Hu” in the subject

     

     

    Best regards,

    Vincent Hu

    Thursday, June 04, 2009 10:38 AM
  • Hi,

     

    Have you tried the suggestions? I want to see if the information provided was helpful. Your feedback is very useful for the further research. Please feel free to let me know if you have addition questions.

     

     

    Best regards,

    Vincent Hu

    Monday, June 08, 2009 2:44 AM
  • Hi Vincent,

    Thank you so much for your valuable suggessions.

    I am really sorry that I couldnt check this as I am away from office for few days. I will check this in another couple of days and definitely inform you the update.

    Thanks once again.

    Best Regards,
    Satheesh S Kumar
    Monday, June 08, 2009 11:22 AM