none
Sharing inheritance do not apply to files inside folders

    Question

  • Hello,

    I have a 2003 windows server with active directory.

    I have the below problem:

    1- i have a shared folder for a specific group, and the same sharing permission is inherited to all sub folders.

    2- all affected users can see and open these folders normally

    3- the problem is that files inside these folders are not affected by permission inheritance.

        in other word, the user can see the file and when trying to open, it gives access denied.

     

    for me to resolve this problem i have to select these files and go to sharing proprieties and add the affected group again.

    it is too complicated because i have 500 folders and thousands of files inside

     

    I tried to remove the sharing and inheritance and apply it again, with no success

     

    can someone guide me what could be the reason why these files are not being shared based on the folder settings?

    thank you

     

    Wednesday, November 30, 2011 3:37 PM

Answers

  • Hi,

    For shared folders we should configure SHARE permissions and NTFS permissions. I would like to confirm that what is in the share folder, it the folder is for roaming profile and folder redirection, the access should be denied.

    If the shared folder is a common folder. Please make sure the following permissions:

    SHARE permissions:

    Everyone: Read, Change, Full control(According to your requirement)

    NTFS permissions:

    Everyone(or the specific group) Read, List, and so on according to your requirement.

    Check "Include inheritable permissions from this object's parent"

    In addition, please in the advanced security settings tab, click edit, then check out whether the permission is apply to This folder, subfolders and files.

    Have you ever configured the child folders permissions? If so, I would like suggest you check the checkbox " Replace all child object permissions with inheritable permissions from this object".

     

    Best Regards,

    Yan Li

     


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Thursday, December 01, 2011 5:40 AM
  • On the root Share go to NTFS security Permission-->Advance button-->Permission tab add the group or user and select the check box
    Inherit from parent permission..
    Replace permission entirs on all child object...
    Apply and OK

    Reference link:
    http://technet.microsoft.com/en-us/library/bb727008.aspx
    http://sourcedaddy.com/windows-xp/applying-permissions-subfolders-through-inheritance.html

    Hope this helps

    Regards,
    Sandesh Dubey.
    -------------------------------
    MCSE|MCSA:Messaging|MCTS|MCITP:Enterprise Adminitrator
    My Blog: http://sandeshdubey.wordpress.com
    This posting is provided AS IS with no warranties, and confers no rights.

    Thursday, December 01, 2011 7:15 AM

All replies

  • Hi,

    For shared folders we should configure SHARE permissions and NTFS permissions. I would like to confirm that what is in the share folder, it the folder is for roaming profile and folder redirection, the access should be denied.

    If the shared folder is a common folder. Please make sure the following permissions:

    SHARE permissions:

    Everyone: Read, Change, Full control(According to your requirement)

    NTFS permissions:

    Everyone(or the specific group) Read, List, and so on according to your requirement.

    Check "Include inheritable permissions from this object's parent"

    In addition, please in the advanced security settings tab, click edit, then check out whether the permission is apply to This folder, subfolders and files.

    Have you ever configured the child folders permissions? If so, I would like suggest you check the checkbox " Replace all child object permissions with inheritable permissions from this object".

     

    Best Regards,

    Yan Li

     


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Thursday, December 01, 2011 5:40 AM
  • On the root Share go to NTFS security Permission-->Advance button-->Permission tab add the group or user and select the check box
    Inherit from parent permission..
    Replace permission entirs on all child object...
    Apply and OK

    Reference link:
    http://technet.microsoft.com/en-us/library/bb727008.aspx
    http://sourcedaddy.com/windows-xp/applying-permissions-subfolders-through-inheritance.html

    Hope this helps

    Regards,
    Sandesh Dubey.
    -------------------------------
    MCSE|MCSA:Messaging|MCTS|MCITP:Enterprise Adminitrator
    My Blog: http://sandeshdubey.wordpress.com
    This posting is provided AS IS with no warranties, and confers no rights.

    Thursday, December 01, 2011 7:15 AM