none
An attempt to resolve the DNS name of a domain controller in the domain being joined has failed.

    Question

  • The following error occurred attempting to join the domain "egl-underground.mainframe":

    An attempt to resolve the DNS name of a domain controller in the domain being joined has failed. Please verify this client is configured to reach a DNS server that can resolve DNS names in the target domain.

    I am running windows server 2008 R2 trying to connect with a windows 7 computer.
    I have already set the DNS in my computer to the Server running DNS Server (same as DC server)
    I can ping the server, i can nslookup the FQDN aswell with no problems.

    Any help?

    Friday, August 06, 2010 9:32 PM

All replies

  • Are you sure there is no DNS records for your DNS zone that are missing?

    Friday, August 06, 2010 9:38 PM
  • Are you sure there is no DNS records for your DNS zone that are missing?


    This is my result for DCDiag /test:dns

    Directory Server Diagnosis
    Performing initial setup:
      Trying to find home server...
      Home Server = HomeServer
      * Identified AD Forest.
      Done gathering initial info.
    Doing initial required tests
      Testing server: EGLSite\HOMESERVER
       Starting test: Connectivity
         ......................... HOMESERVER passed test Connectivity
    Doing primary tests
      Testing server: EGLSite\HOMESERVER
       Starting test: DNS
         DNS Tests are running and not hung. Please wait a few minutes...
         ......................... HOMESERVER passed test DNS
      Running partition tests on : ForestDnsZones
      Running partition tests on : DomainDnsZones
      Running partition tests on : Schema
      Running partition tests on : Configuration
      Running partition tests on : egl-underground
      Running enterprise tests on : egl-underground.mainframe
       Starting test: DNS
         Test results for domain controllers:
          DC: HomeServer
          Domain: egl-underground.mainframe
    
            TEST: Delegations (Del)
             Error: DNS server: homeserver.egl-underground.mainframe. IP:<Unavailable> [Missing glue A record]
            TEST: Dynamic update (Dyn)
             Warning: Failed to delete the test record dcdiag-test-record in zone egl-underground.mainframe
         Summary of DNS test results:
                          Auth Basc Forw Del Dyn RReg Ext
          _________________________________________________________________
          Domain: egl-underground.mainframe
            HomeServer          PASS PASS PASS FAIL WARN PASS n/a
         ......................... egl-underground.mainframe failed test DNS
    Friday, August 06, 2010 9:56 PM
  • There is a missing A record for homeserver.egl-underground.mainframe.

    Make sure that the DNS primary server for you DC (I suppose here that the DNS server is also your DC) is 127.0.0.1 and then restart the server and check if the prob is solved or not.

    If it is not try to create manually this record.

    Friday, August 06, 2010 10:26 PM
  • <form id="aspnetForm" action="edit" enctype="application/x-www-form-urlencoded" method="post">

    <script src="http://i2.social.microsoft.com/Forums/GlobalResources/Scripts/omni_rsid_social.js?cver=607%0d%0a" type="text/javascript">
    Directory Server Diagnosis
    
    Performing initial setup:
      Trying to find home server...
      Home Server = HomeServer
      * Identified AD Forest.
      Done gathering initial info.
    
    Doing initial required tests
    
      Testing server: EGLSite\HOMESERVER
       Starting test: Connectivity
         ......................... HOMESERVER passed test Connectivity
    
    Doing primary tests
    
      Testing server: EGLSite\HOMESERVER
    
       Starting test: DNS
    
         DNS Tests are running and not hung. Please wait a few minutes...
         ......................... HOMESERVER passed test DNS
    
      Running partition tests on : ForestDnsZones
    
      Running partition tests on : DomainDnsZones
    
      Running partition tests on : Schema
    
      Running partition tests on : Configuration
    
      Running partition tests on : egl-underground
    
      Running enterprise tests on : egl-underground.mainframe
       Starting test: DNS
         Test results for domain controllers:
    
          DC: HomeServer
          Domain: egl-underground.mainframe
    
    
            TEST: Dynamic update (Dyn)
             Warning: Failed to delete the test record dcdiag-test-record in zone egl-underground.mainframe
    
            HomeServer          PASS PASS PASS PASS WARN PASS n/a
         ......................... egl-underground.mainframe passed test DNS

    still the same error on the client computer after attempting to log in.

    </script> <noscript></noscript></form>
    • Edited by TonyEGL Friday, August 06, 2010 11:05 PM
    Friday, August 06, 2010 10:55 PM
  • OK. Try to re-create your zone and check if the problem is the same.
    Friday, August 06, 2010 11:02 PM
  • OK. Try to re-create your zone and check if the problem is the same.

    Is there a reason the netlogon is not creatiing these zones automatically? I checked netlogon.dns and they are all listed there. Yet no zones are being created..
    Friday, August 06, 2010 11:19 PM
  • The zones are created but there is a problem with some records. It is for that I recommended to you to delete your zones and to re-create them manually and then all your records will be re-created manually (I recommend to you to restart the server after creating your new zones)
    Friday, August 06, 2010 11:34 PM
  • The zones are created but there is a problem with some records. It is for that I recommended to you to delete your zones and to re-create them manually and them all your records will be re-created manually (I recommend to you to restart the server after creating your new zones)

    Manually created the zones again. THe records were recreated. I restarted the server. Still getting the same client error. Also had to manually recreate the homeserver host again.
    Friday, August 06, 2010 11:45 PM
  • OK. what is the result now of the command: DCDiag /test:dns?
    Friday, August 06, 2010 11:48 PM
  • OK. what is the result now of the command: DCDiag /test:dns?


    Directory Server Diagnosis

    Performing initial setup:
       Trying to find home server...
       Home Server = HomeServer
       * Identified AD Forest.
       Done gathering initial info.

    Doing initial required tests

       Testing server: EGLSite\HOMESERVER
          Starting test: Connectivity
             ......................... HOMESERVER passed test Connectivity

    Doing primary tests

       Testing server: EGLSite\HOMESERVER

          Starting test: DNS

             DNS Tests are running and not hung. Please wait a few minutes...
             ......................... HOMESERVER passed test DNS

       Running partition tests on : ForestDnsZones

       Running partition tests on : DomainDnsZones

       Running partition tests on : Schema

       Running partition tests on : Configuration

       Running partition tests on : egl-underground

       Running enterprise tests on : egl-underground.mainframe
          Starting test: DNS
             Test results for domain controllers:

                DC: HomeServer
                Domain: egl-underground.mainframe


                   TEST: Dynamic update (Dyn)
                      Warning: Failed to delete the test record dcdiag-test-record in zone egl-underground.mainframe

                   HomeServer                   PASS PASS PASS PASS WARN PASS n/a
             ......................... egl-underground.mainframe passed test DNS

     

    same as before.

    Friday, August 06, 2010 11:56 PM
  • OK. Now it is OK for the A record. Which message is shown now by the client computer?
    Saturday, August 07, 2010 12:06 AM
  • OK. Now it is OK for the A record. Which message is shown now by the client computer?

    The following error occurred attempting to join the domain "egl-underground.mainframe":

    An attempt to resolve the DNS name of a domain controller in the domain being joined has failed. Please verify this client is configured to reach a DNS server that can resolve DNS names in the target domain.

     

    Now i did some testing, i tried to connect with my windows XP Virtual machine and it let me connect to the domain....is there a known problem with windows 7?

    Saturday, August 07, 2010 12:07 AM
  • No, the problem is not with the Windows 7 client computer. It is with the DNS server.

    There is no DNS error message that is registered?

    Saturday, August 07, 2010 12:25 AM
  • No, the problem is not with the Windows 7 client computer. It is with the DNS server.

    There is no DNS error message that is registered?


    Where would i find this error message?
    Saturday, August 07, 2010 12:35 AM
  • You can use server manager to display errors related to the DNS service.
    Saturday, August 07, 2010 12:40 AM
  • The DNS server was unable to create a resource record for 6ed81986-5868-4900-89dc-441ade09279a._msdcs.egl-underground.mainframe. in zone egl-underground.mainframe. The Active Directory definition of this resource record is corrupt or contains an invalid DNS name. The event data contains the error.

     

    is the only error my dns server is getting.

    Saturday, August 07, 2010 12:45 AM
  • OK, this record if a domain controller record that is missing. Have you tried to delete and re-create the zone _msdcs.egl-underground.mainframe. in zone egl-underground.mainframe?
    Saturday, August 07, 2010 12:57 AM

  • The following record, if it were to exist, can be found under _msdcs.egl-underground.mainframe

    6ed81986-5868-4900-89dc-441ade09279a._msdcs.egl-underground.mainframe. in zone egl-underground.mainframe

    You can manually create it to satisfy it
    Saturday, August 07, 2010 1:02 AM
  • Have you created it?

    Its creation should solve your problem.

    Saturday, August 07, 2010 1:20 AM
  • It was there.

    http://img194.imageshack.us/img194/4160/dnsm.png

    The screenshot has all the folders expanded aswell.

    Saturday, August 07, 2010 1:23 AM
  • It looks to already be there. Unless i am looking at the wrong record.
    Saturday, August 07, 2010 1:31 AM
  • OK, as I see all is OK with your DNS server. All records are OK. Try to restart your DNS server and your client computer and check if the problem is solved or no. If not check if there is DNS error messages.
    Saturday, August 07, 2010 1:37 AM
  • So? what is the result?
    Saturday, August 07, 2010 1:49 AM
  • I've restarted both computers. No errors on the DNS this time but the windows 7 machine is still getting thesame error.

     

    Why is it i can connect with windows XP but not windows 7?

    Saturday, August 07, 2010 1:50 AM
  • Ok try to do this on your client computer

    1-    edit file hosts. Default location is :

    MyComputer/Local C/Windows/System32/Drivers/etc/hosts(open with notepad and use the option run as an administrator to open it)

    -       Remember if you logon as user/administrator you cannot edit this file.

    4-     End of line:-

    127.0.0.1           localhost

    ::1                    localhost

    Ip_address       homeserver.egl-underground.mainframe

     

    Ip_address = the IP address of your domain controller

    Saturday, August 07, 2010 1:55 AM
  • done, same error.
    Saturday, August 07, 2010 2:10 AM
  • Are you sure that your Win7 server is using the correct DNS server and is able to ping it?

    If it is OK, click on start>run>services.msc and check if DNS client service is enabled.

    If this does not solve your problem, there is no other solution than re-installing your client computer operating system.

    Saturday, August 07, 2010 2:16 AM
  • Are you sure that your Win7 server is using the correct DNS server and is able to ping it?

    If it is OK, click on start>run>services.msc and check if DNS client service is enabled.

    If this does not solve your problem, there is no other solution than re-installing your client computer operating system.


    ping egl-underground.mainframe

    Pinging egl-underground.mainframe [192.168.1.99] with 32 bytes of data:
    Reply from 192.168.1.99: bytes=32 time=1ms TTL=128
    Reply from 192.168.1.99: bytes=32 time=2ms TTL=128
    Reply from 192.168.1.99: bytes=32 time=1ms TTL=128
    Reply from 192.168.1.99: bytes=32 time=1ms TTL=128

    Ping statistics for 192.168.1.99:
        Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
    Approximate round trip times in milli-seconds:
        Minimum = 1ms, Maximum = 2ms, Average = 1ms

    nslookup
    Default Server:  homeserver.home
    Address:  192.168.1.99

    > set type:all
    > egl-underground.mainframe
    Server:  homeserver.home
    Address:  192.168.1.99

    Name:    egl-underground.mainframe
    Address:  192.168.1.99

     

    It is pinging just fine, this is a fresh instal of Windows 7 as well. I dont understand why i would get a DNS error if i can ping and nslookup the server. Furthermore, i dont understand why XP can connect and Windows 7 cannot. Frustrating.

    Saturday, August 07, 2010 2:21 AM
  • Are you using the DHCP service?
    Saturday, August 07, 2010 2:27 AM
  • No, should i be?
    Saturday, August 07, 2010 2:29 AM
  • No, it is because many persons faced this problem when they used the DHCP service.

    Now let's try this: disable the server and the client computer firewalls and antivirus and check the result.

    Saturday, August 07, 2010 2:44 AM
  • I recommand to you to delete what you added in the hosts file.
    Saturday, August 07, 2010 2:46 AM
  • Both firewalls were already disabled. I have already tried with Microsoft Security essentials disabled and recieved the same results.

    Saturday, August 07, 2010 2:48 AM
  • OK. Have you installed all the updates for your client computer operating system?
    Saturday, August 07, 2010 2:54 AM
  • I have, Windows update tells me my computer is up to date.

    Saturday, August 07, 2010 2:57 AM
  • Run these commands on the client computer

    netsh int ipv4 set dns "Local Area Connection" static 192.168.1.120 primary

    nltest /dsgetdc:egl-underground.mainframe /force

     

    If this passes, then you are all set to join the server core machine to your domain

    Saturday, August 07, 2010 2:59 AM
  • If it does not work try this:

    You have to disable or lower the NTLM security.
    From windows 7, click start, type local and open the Local Security Policy
    Manager.

    Select Local Policies -> Security Options, in the right find Network
    Secuity: LAN Manager Authentication Leven, and set to Send LM & NTLM - use
    NTLMv2 session security if negotiated.
    Saturday, August 07, 2010 3:02 AM
  • here are my results

    netsh int ipv4 set dns "Local Area Connection" static 192.168.1
    .120 primary

    nltest /dsgetdc:egl-underground.mainframe /force
          DC: \\HomeServer
          Address: \\192.168.1.99
         Dom Guid: a6d43fd6-a1fc-4579-b7e6-b96190cda743
         Dom Name: egl-underground.mainframe
         Forest Name: egl-underground.mainframe
         Dc Site Name: EGLSite
         Our Site Name: EGLSite
            Flags: PDC GC DS LDAP KDC TIMESERV GTIMESERV WRITABLE DNS_DC DNS_DOMAIN
    DNS_FOREST CLOSE_SITE FULL_SECRET WS
    The command completed successfully

    was the ip supposed to be 192.168.1.120 for the netsh command?

    Saturday, August 07, 2010 3:05 AM
  • No, sorry I forgot to mention that you should specify your DNS server IP address.

    Correct the first command and re-execute the second one and if the command completed successfully try to integrate your client computer in your domain.

    Saturday, August 07, 2010 3:11 AM
  • So what was the result?
    Saturday, August 07, 2010 3:23 AM
  • Did whatyou mentioned in both posts, still no good.

    Saturday, August 07, 2010 3:23 AM
  • OK. This is really strange. If this will not work there still no solution for your problem (I found much people facing the same prob with windows Vista and 7)

    You have to disable or lower the NTLM security.

    From windows 7, click start, type local and open the Local Security Policy

    Manager.



    Select Local Policies -> Security Options, in the right find Network

    Secuity: LAN Manager Authentication Leven, and set to Send LM & NTLM - use

    NTLMv2 session security if negotiated.
    Saturday, August 07, 2010 3:26 AM
  • Ive already done that, with no progress. So are we sure this problem is my client and not my server? If so should i reintalled windows 7?
    Saturday, August 07, 2010 3:29 AM
  • I am sure that your DNS server is OK. The problem is with the client computers. Much people are facing the same one with Vista and 7. Try to re-install your OS with another DVD.

    At least we have corrected the configuration of the DNS server.

    Saturday, August 07, 2010 3:31 AM
  • I am sure that your DNS server is OK. The problem is with the client computers. Much people are facing the same one with Vista and 7. Try to re-install your OS with another DVD.

    At least we have corrected the configuration of the DNS server.

    Is this a known problem? If so, do you think there will be an update?
    Saturday, August 07, 2010 3:44 AM
  • I don't think it is a known problem because I found no possible reslution for it. There should be an update if many users are facing the same problem. In your case your configuration is all OK now and like I told you try to re-install with the use of another DVD. I'll be back tomorrow so let me know if there something new with it.

    Best regards.

    Saturday, August 07, 2010 3:49 AM
  • Thank you for your help

     

    Wow......installed a windows 7 OS on a virtual machine on the client computer.....connected like it was nothing....same disk and everything...

    Saturday, August 07, 2010 4:09 AM
  • aha I see. This means that no problem with the server. Re-install with another DVD and check is the prob is the same.
    Saturday, August 07, 2010 1:30 PM
  • Has your problem been solved?
    Sunday, August 08, 2010 4:14 PM
  • Was this ever resolved? I am having the same problem with Windows 7 connecting to SBS2011!
    Tuesday, July 12, 2011 2:55 AM
  • Was this ever resolved? I am having the same problem with Windows 7 connecting to SBS2011!

    Most likely an incorrectly configured IPV6 issue.

    Verify IPV6 config and DNS settings IPV6 or disable IPV6 on host machines.

    • Proposed as answer by Mark Wolzak Friday, October 07, 2011 9:36 AM
    Wednesday, September 21, 2011 7:13 PM
  • I had this same issue and discovered a an external DNS record in the top record and the correct DNS in the second slot. Failover was not occurring since the first address actually had DNS services.   I reversed the order for DNS and the system joined right up.

     

    Mike


    /mike
    Monday, September 26, 2011 4:30 AM
  • From my understanding, this has to do with the way Windows Vista/7 resolve the DNS server. They don't use NetBIOS like older OS's do. Try this:

    First, on whatever client you're trying to get to connect to the DC, be sure that under it's adapter settings you set it to "Use the following DNS server address" and then enter the IP of the DNS server you are trying to get it to connect to in the "Preferred DNS:" box. 

    Then, go into the MMC console and expand "DHCP", expand "Scope," right click on "Scope Options", and click "Configure Options", then check the boxes for "Router" (while you have the "Router" option selected, be sure and add the IP of whichever Router/Default Gateway you're using in the boxes below, and then click "Add" Then check the box for "DNS Servers" (while you have the "DNS Servers" option selected, also be sure and add the DNS IP and then click "Add") This fixed my problem, hopefully it will yours also.


    • Edited by USAF Network Admin Saturday, November 26, 2011 4:12 AM
    • Proposed as answer by Brian Igo Thursday, March 15, 2012 4:33 PM
    • Unproposed as answer by Brian Igo Thursday, March 15, 2012 4:35 PM
    Wednesday, November 23, 2011 5:08 PM
  • If it does not work try this:

    You have to disable or lower the NTLM security.
    From windows 7, click start, type local and open the Local Security Policy
    Manager.

    Select Local Policies -> Security Options, in the right find Network
    Secuity: LAN Manager Authentication Leven, and set to Send LM & NTLM - use
    NTLMv2 session security if negotiated.

    Run these commands on the client computer

    netsh int ipv4 set dns "Local Area Connection" static 192.168.1.120 primary

    nltest /dsgetdc:egl-underground.mainframe /force

     

    If this passes, then you are all set to join the server core machine to your domain

    Are you sure that your Win7 server is using the correct DNS server and is able to ping it?

    If it is OK, click on start>run>services.msc and check if DNS client service is enabled.

    If this does not solve your problem, there is no other solution than re-installing your client computer operating system.

    firewall OFF on client and OFF on server

    Microsoft Windows [Version 6.1.7600]
    Copyright (c) 2009 Microsoft Corporation.  All rights reserved.


    C:\Windows\system32>netsh int ipv4 set dns "Local Area Connection" static xxx.xxx.xxx.xxx primary




    C:\Windows\system32>nltest /dsgetdc:serverName.domain /force
    Getting DC name failed: Status = 1355 0x54b ERROR_NO_SUCH_DOMAIN


    C:\Windows\system32>nslookup
    Default Server:  server.domain.local
    Address:  xxx.xxx.xxx.xxx


    > set type=all
    > _ldap._tcp.dc._msdcs.domain.local
    Server:  server.domain.local
    Address:  xxx.xxx.xxx.xxx


    _ldap._tcp.dc._msdcs.domain.local      SRV service location:
              priority       = 0
              weight         = 100
              port           = 389
              svr hostname   = server.domain.local
    server.domain.local internet address = xxx.xxx.xxx.xxx
    server.domain.local internet address = xxx.xxx.yyy.yyy
    >
    C:\Windows\system32>netsh int ipv4 set dns "Local Area Connection" static xxx.xxx.xxx.xxx primary




    C:\Windows\system32>nltest /dsgetdc:sbsserver.spitalultimisoa.local /force
    Getting DC name failed: Status = 1355 0x54b ERROR_NO_SUCH_DOMAIN


    C:\Windows\system32>

    i've got that error but i joined the domain .... now i will restart and will let you know if it works,


    • Edited by s3rj3 Thursday, March 01, 2012 1:13 PM correction
    Thursday, March 01, 2012 1:12 PM
  • It is working

    I don't know if the nslookup command made it working or not because i only tryed it to put it in the domain after i've run the other 2 command as well ....

    if you do all the steps i did and it's working for you post here so we know this 

    Thursday, March 01, 2012 1:27 PM
  • This worked for me. Disabled IPv6 on two new Dells and both joined the domain without any problems. Thanks!
    • Proposed as answer by Adam Yasir Thursday, April 05, 2012 3:08 AM
    Thursday, March 15, 2012 4:37 PM
  • well i had the same proble, with my setup, i can easily joing the XP mechines but not the widows 7 mechines. so i did some reaserch and i found that windows 7 meching todnot take Server, DNS Ip Address Autometically, but XP machine takes it autometically. So that gives me clue where the problem is with the Windows 7 client machines

    to solve the problem what i did was

    Go go Winodows client 7 machine > Network and Sharing Center > change Addepter Setting > Right Click Local Network Connection and Click Properties

    Double Click TPC/IPv4 

    from there  click use the following DNS Server Address

    1. type the IP address of your Server as prefered DNS server (Not the DNS  Address of Your Server, your Sever will be like 127.0.0.1 not this one just IP Address of Your Server)

    2. Type Alt DNS as your Preference what i typed is 8.8.8.8 it is universal opened DNS

    Clik ok now try the machin it will be able to join the netwerk server

    for me it worked

    • Proposed as answer by tomvining Monday, June 11, 2012 9:48 AM
    Thursday, April 05, 2012 3:21 AM
  • I was able to resolve this issue by restarting the DNS Server service on my server. Hope this helps someone else.
    Friday, October 12, 2012 2:07 PM
  • if you are changing both username and domain at the same time, prefer to make it in two steps instead of one

    first change the name of the machine, restart it and then add the machine to the domain.

    Wednesday, December 05, 2012 10:56 AM
  • This worked for me. Disabled IPv6 on two new Dells and both joined the domain without any problems. Thanks!

    Indeed it worked with me as well. Disabling IPv6 and it works like a charm...

    • Proposed as answer by LouieGerard Wednesday, February 20, 2013 11:08 AM
    Wednesday, February 20, 2013 11:07 AM
  • Thanks

    First, on whatever client you're trying to get to connect to the DC, be sure that under it's adapter settings you set it to "Use the following DNS server address" and then enter the IP of the DNS server you are trying to get it to connect to in the "Preferred DNS:" box. 

    This resolved my problem..

    Thursday, August 15, 2013 12:07 PM
  • Thought I'd share what worked for me; I followed pretty much all the steps in this thread (other than resinstalling the O/S on a fresh from Dell laptop).

    I turned off IP6, and still wasn't able to ping the FQDN of the DNS server/DC; but, after manually assigning the DNS server (and rebooting), I was able to join.

    Rather frustrating for a simple, mundane task like this to take an hour....

    Thanks, all, for your comments.

    Regards,

    ~Dan

    Friday, August 23, 2013 1:31 PM
  • Might be a DNS record is missing

    Create a A Record of your DNS Server 

    Might be it help for you

    Wednesday, February 12, 2014 6:00 PM
  • Had the same problem, what worked for me:

    Setting up the primary DNS server with the IP of the machine that holds the Active Directory and disabling IPv6.

    Hope this helps.


    LC


    • Edited by Liviu13 Saturday, May 31, 2014 10:26 AM
    Saturday, May 31, 2014 10:26 AM