none
Internet Explorer 10 for windows 7 error 0x80070643

    Question

  • Trying to install IE10 with WSUS and getting:

    Installation Failure: Windows failed to install the following update with error 0x80070643: Internet Explorer 10 for Windows 7.

    Clients are Win7 sp1 x32

    From the IE10_main log:

    00:03.151: INFO:    Windows 7 operating system detected.
    00:03.151: INFO:    Service pack major: 1
    00:03.229: INFO:    Service pack minor: 0
    00:03.229: INFO:    Service pack name:  Service Pack 1
    00:03.307: WARNING: Checking version for C:\windows\System32\api-ms-win-downlevel-user32-l1-1-0.dll.  The file does not exist.
    00:03.307: INFO:    Version Check for (KB2639308) of C:\windows\System32\Ntoskrnl.exe: 6.1.7601.18113 >= 6.1.7601.17727 (True)
    00:03.417: INFO:    Version Check for (KB2533623) of C:\windows\System32\api-ms-win-security-base-l1-1-0.dll: 6.1.7601.17965 >= 6.1.7601.17617 (True)
    00:03.604: INFO:    Version Check for (KB2731771) of C:\windows\System32\kernel32.dll: 6.1.7601.17965 >= 6.1.7601.17932 (True)
    00:03.604: INFO:    Checking for correct version of C:\windows\Fonts\segoeui.ttf.
    00:03.604: INFO:    Version Check for (KB2786081) of C:\windows\System32\taskhost.exe: 6.1.7601.17514 >= 6.1.7601.18010 (False)
    00:22.527: ERROR:   Couldn't create setup troubleshooting shortcut on the desktop. HRESULT: 0x80070002,
    00:22.589: INFO:    Setup exit code: 0x00009C47 (40007) - Required updates failed to download.
    00:22.714: INFO:    Scheduling upload to IE SQM server: http://sqm.microsoft.com/sqm/ie/sqmserver.dll
    00:26.302: INFO:    SQM Upload returned 403
    00:28.720: INFO:    Cleaning up temporary files in: C:\windows\TEMP\IE1D242.tmp
    00:28.845: INFO:    Unable to remove directory C:\windows\TEMP\IE1D242.tmp, marking for deletion on reboot.
    00:28.938: INFO:    Released Internet Explorer Installer Mutex

    • Edited by RickS2 Monday, April 15, 2013 9:04 PM
    Monday, April 15, 2013 8:22 PM

Answers

  • Notwithstanding Clarence's note that this is actually an installation issue and belongs in the IE10 or Win7 forums...

    I believe this is the key issue:

    00:03.604: INFO:    Version Check for (KB2786081) of C:\windows\System32\taskhost.exe: 6.1.7601.17514 >= 6.1.7601.18010 (False)

    Is KB2786081 installed???

    In an ideal world the IE10 package would actually have that update defined as a Prerequisite and report as NotApplicable when that update is not installed -- but it's a no-win world .. when updates actually do test for the stuff they need, and that stuff isn't there, nobody knows what's missing because the stuff never gets properly documented. <sigh>.


    Lawrence Garvin, M.S., MCITP:EA, MCDBA, MCSA
    SolarWinds Head Geek
    Microsoft MVP - Software Distribution (2005-2013)
    My MVP Profile: http://mvp.support.microsoft.com/profile/Lawrence.Garvin
    The views expressed on this post are mine and do not necessarily reflect the views of SolarWinds.

    Tuesday, April 23, 2013 10:45 PM
    Moderator
  • Hi,

    Here is the WSUS forum.It seems that the IE 10 has been in the installation process which indicates it has been published thru the WSUS successfully,then the attention should be focused on why it failed.Pls refer to IE forum or the win7 client forum for the further troubleshooting.

    Thanks for your understanding.

    regards,

    Clarence


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Thursday, April 18, 2013 6:18 AM
    Moderator

All replies

  • Hi,

    Here is the WSUS forum.It seems that the IE 10 has been in the installation process which indicates it has been published thru the WSUS successfully,then the attention should be focused on why it failed.Pls refer to IE forum or the win7 client forum for the further troubleshooting.

    Thanks for your understanding.

    regards,

    Clarence


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Thursday, April 18, 2013 6:18 AM
    Moderator
  • Notwithstanding Clarence's note that this is actually an installation issue and belongs in the IE10 or Win7 forums...

    I believe this is the key issue:

    00:03.604: INFO:    Version Check for (KB2786081) of C:\windows\System32\taskhost.exe: 6.1.7601.17514 >= 6.1.7601.18010 (False)

    Is KB2786081 installed???

    In an ideal world the IE10 package would actually have that update defined as a Prerequisite and report as NotApplicable when that update is not installed -- but it's a no-win world .. when updates actually do test for the stuff they need, and that stuff isn't there, nobody knows what's missing because the stuff never gets properly documented. <sigh>.


    Lawrence Garvin, M.S., MCITP:EA, MCDBA, MCSA
    SolarWinds Head Geek
    Microsoft MVP - Software Distribution (2005-2013)
    My MVP Profile: http://mvp.support.microsoft.com/profile/Lawrence.Garvin
    The views expressed on this post are mine and do not necessarily reflect the views of SolarWinds.

    Tuesday, April 23, 2013 10:45 PM
    Moderator
  • Edit: I've moved my post to a new thread, as it's not an answer; I am having the same issue, and have found no resolution yet.

    Monday, May 06, 2013 6:32 PM