none
RRAS and FTP server conflicting

    Question

  • Hi,

    I just set up a new Windows 2008 R2 server. I set up an FTP server in IIS which was working fine until i configured a VPN server in RRAS. Once i started the RRAS service, the FTP server was unreachable and any clients connected were disconnected. Any ideas on where the conflict can be?

    Thanks,

    Alan

    Wednesday, December 05, 2012 2:18 AM

Answers

  • Hi,


    Would you please let us know the detailed configuration of RRAS. How do you connect your external network to your internal network? Do you use NAT?


    Meanwhile, please try the following:

    1. Temporary disable your firewall or make sure the ports 20 and 21 are open.

    2. Setup RRAS without NAT and see how it works.


    Hope this helps.


    Jeremy Wu
    TechNet Community Support

    Thursday, December 06, 2012 8:55 AM

All replies

  • Seems, it is because of both RRAS and FTP use SSL. So I suggest keep this in mind and configure roles accordingly.

    Try to configure FTP with no SSL and check for the difference.


    Regards, Ravikumar P

    Wednesday, December 05, 2012 11:58 AM
  • Hi Ravikumar,

    I don't see an option to disable SSL for the FTP site, only options to 'allow' or 'require'.

    Thanks,

    Al

    Wednesday, December 05, 2012 1:36 PM
  • Hi,


    Would you please let us know the detailed configuration of RRAS. How do you connect your external network to your internal network? Do you use NAT?


    Meanwhile, please try the following:

    1. Temporary disable your firewall or make sure the ports 20 and 21 are open.

    2. Setup RRAS without NAT and see how it works.


    Hope this helps.


    Jeremy Wu
    TechNet Community Support

    Thursday, December 06, 2012 8:55 AM
  • Hi Ravikumar,

    I don't see an option to disable SSL for the FTP site, only options to 'allow' or 'require'.

    Thanks,

    Al

    Search for SSL Certificate element in FTP settings console and Selecting an SSL certificate enables SSL for a specific FTP site or FTP server. To disable SSL, select Not Selected from the drop-down list.

    More details can be found in http://technet.microsoft.com/en-us/library/dd722748(v=ws.10).aspx


    Regards, Ravikumar P

    Thursday, December 06, 2012 11:49 AM