none
How do I resolve the issue: This computer is not configured properly to connect to "DNS server"

    Question

  • I have installed an AD DS on a Windows Server 2008.
    I get the following error when I do Windows Network Diagnostics...
    This computer is not configured properly to connect to "DNS server"

    I have added the DNS entries of my local machine (i.e. 127.0.0.1 and 2 other IPs which I want to use for resolving internet addresses).
    Any advice on how I can resolve this issue?
    Tuesday, December 15, 2009 3:21 PM

Answers

  • First of all disable IPv6 if you are not using it. Provide another DNS server as preferred one and then try promoting the machine.

    If this also fails,
    Try and run a diagnostic test on the network adapter. See if you recieve the same error.

    • Marked as answer by ajay_g_m Wednesday, December 16, 2009 4:47 AM
    Tuesday, December 15, 2009 4:02 PM

All replies

  • Can you please give us ipconfig /all output?

    Another question: Was this server a DNS before you installed ADDS or you installed DNS during the ADDS setup?
    Tuesday, December 15, 2009 3:47 PM
  • ipconfig /all output:

    Windows IP Configuration

       Host Name . . . . . . . . . . . . : WIN-ZHSOL64AR4V
       Primary Dns Suffix  . . . . . . . : test.mdc.ncr
       Node Type . . . . . . . . . . . . : Hybrid
       IP Routing Enabled. . . . . . . . : No
       WINS Proxy Enabled. . . . . . . . : No
       DNS Suffix Search List. . . . . . : test.mdc.ncr
                                           mdc.ncr

    Ethernet adapter Local Area Connection:

       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : Broadcom NetXtreme 57xx Gigabit Controller
       Physical Address. . . . . . . . . : 00-13-20-17-82-4D
       DHCP Enabled. . . . . . . . . . . : No
       Autoconfiguration Enabled . . . . : Yes
       Link-local IPv6 Address . . . . . : fe80::fc5f:12ce:cc75:e672%10(Preferred)
       IPv4 Address. . . . . . . . . . . : 153.58.26.123(Preferred)
       Subnet Mask . . . . . . . . . . . : 255.255.255.0
       Default Gateway . . . . . . . . . : 153.58.26.1
       DHCPv6 IAID . . . . . . . . . . . : 251663136
       DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-12-8C-CA-C7-00-13-20-17-82-4D
       DNS Servers . . . . . . . . . . . : ::1
                                           127.0.0.1
                                           192.127.26.102
                                           131.222.138.30
       NetBIOS over Tcpip. . . . . . . . : Enabled

    Tunnel adapter Local Area Connection* 8:

       Media State . . . . . . . . . . . : Media disconnected
       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : isatap.{746AE8ED-9331-44FA-9813-3D2B78CFD074}
       Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
       DHCP Enabled. . . . . . . . . . . : No
       Autoconfiguration Enabled . . . . : Yes

    Tunnel adapter Local Area Connection* 9:

       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : 6TO4 Adapter
       Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
       DHCP Enabled. . . . . . . . . . . : No
       Autoconfiguration Enabled . . . . : Yes
       IPv6 Address. . . . . . . . . . . : 2002:993a:1a7b::993a:1a7b(Preferred)
       Default Gateway . . . . . . . . . : 2002:c058:6301::c058:6301
       DNS Servers . . . . . . . . . . . : ::1
                                           127.0.0.1
                                           192.127.26.102
                                           131.222.138.30
       NetBIOS over Tcpip. . . . . . . . : Disabled


    I installed DNS during AD DS setup.
    Tuesday, December 15, 2009 3:53 PM
  • First of all disable IPv6 if you are not using it. Provide another DNS server as preferred one and then try promoting the machine.

    If this also fails,
    Try and run a diagnostic test on the network adapter. See if you recieve the same error.

    • Marked as answer by ajay_g_m Wednesday, December 16, 2009 4:47 AM
    Tuesday, December 15, 2009 4:02 PM
  • Thanks for your suggestion!!
    It resolved my issue.
    I disabled IPv6 and now that error has gone.

    Any ideas why was I getting that error with IPv6 enabled?
    Wednesday, December 16, 2009 4:47 AM
  • If IPv6 becomes the preferred communication address, this happens.. Anyways its good that it resolved your issue.

    Thanks

    Arun.

    Wednesday, December 16, 2009 10:06 AM