none
How to reduce DWM.EXE due to memory over committed

    Question

  • Hyper-V OS: WS2012 Std

    Guest OS: WS2012 Std

    Physical memory: 12 GB

    Virtual Memory assign: 8GB (Dynamic Memory)

    Recently I installed WS2012 Std edition into my Hyper-V. I'm planning to install SCOM 2012 Sp1 in my VM. I encounter an issue with memory over commit. On resource monitor I found "DWM.exe" cummit up to 19,844KB. I wonder why every time I increase the memory the available memory still got not enough.

    Below is the details memory usage:

    In Use: 7.8GB

    Available: 181MB

    Committed: 7.8/9.2 GB

    Cache: 175MB

    Paged pool: 72.3MB

    Non-paged pool: 23.4MB

    Appropriated it to any expert will answer my question.

    Thanks.

    Sunday, December 09, 2012 7:51 PM

All replies

  • Hello

    just a try..

    did you have the lastest integration services installed.. was out few days ago..

    Sunday, December 09, 2012 10:36 PM
  • That specific service isn't really  eating a lot of your memory. 19MB really isn't that much in the grand scheme of your server. However, if you want to minimize the memory consumption of that specific service, turn down the desktop affects that run inside your VM. DWM is the Desktop Window Manager. Resource consumption will increase when themes or graphics (for example, aero) are applied to a desktop. If you want to completely remove it, you can certainly disable the service, but you will be limited to the most basic of desktop visual themes.
    Monday, December 10, 2012 12:36 AM
  • Just a follow-up here. Looking at one of my VM's, my DWM service uses 19.7 MB pretty consistently. I use a very basic theme, so that may just be how much it uses natively. You can still try the disabling option though.

    --

    Ted

    Monday, December 10, 2012 12:38 AM
  • Hi Ales75,

    Thanks for reply,

    Yep. by default Hyper-V WS2012 use latest integration services installed. But the memory resource still over committed and affected my VM goes down.

    Tuesday, December 11, 2012 4:24 AM
  • Ted,

    Im using WS2012 Std edition, I'm not recommended to use basic theme. I believe there are some bugs in WS2012.

    Tuesday, December 11, 2012 4:26 AM
  • Maybe some screen shots of your task manager (graphs and running processes) would help. Did you install SQL anywhere on the host for SCOM?

    --

    Also, I think my answer for DWM still stands and probably isn't a significant contributor to your overall problem.

    Tuesday, December 11, 2012 6:20 AM
  • Actually, what you are describing sounds pretty typical, particularly if you installed SQL Server for use by SCOM.  You aren't really overcommitted, any more than you would be with a physical machine that is using virtual memory.  This line:

    Committed: 7.8/9.2 GB

    simply says that your machine is actively using 7.8 GB of the RAM available to it, but it has some other tasks, that if memory were available, would add another 1.4 GB of memory.  That's simply the virtual memory system doing its job like it is supposed to.  I have seen this on physical machines, too.

    But Ted gives a good hint.  SQL and dynamic memory are not good bedfellows.  By default, SQL tries to go out and grab everything it can.  When using dynamic memory, you need to set your SQL installation to NOT use all the memory it can.  Generally, when I am running SQL in a VM, I simply make the VM fixed size instead of bothering with dynamic memory.  Yes, you can use it, but you need to follow the best practices defined here - http://msdn.microsoft.com/en-us/library/hh372970.aspx


    tim

    Tuesday, December 11, 2012 9:28 PM
  • Hi Ted,

    I have not install SQL server yet in my server. there is only base OS. after fix it I will planning to install SCVMM or SCOM.

    Wednesday, December 12, 2012 4:51 AM
  • got any idea anyone ? my problem still not resolve.
    Sunday, December 16, 2012 5:27 PM