locked
DHCP Server Does Not Check/Ping IP Before Offering

    Question

  •    Our DHCP server is running Windows Server 2008 SP1.  After applying the June patches we're running into a problem with DHCP that did not occur previously.
       Our DHCP server has a pool of 250 or so addresses it's using to lease out with a 2-day lease period.  Due to an bug in a DHCP client (separate problem with Polycom 330 IP phone), the client is keeping it's assigned address after the DHCP lease has expired.  Our DHCP server doesn't know this and is then marking that IP as available for re-issue in the database.
       When a new client requests an IP address the Windows 2008 DHCP server is not pinging the IP address it's offering before offering it to verify it's not already in use.  According to RFC 2131 (http://tools.ietf.org/html/rfc2131), the most current RFC for DHCP, the offering server should do so:

    As a consistency check, the allocating
       server SHOULD probe the reused address before allocating the address,
       e.g., with an ICMP echo request, and the client SHOULD probe the
       newly received address, e.g., with ARP.
     
       I've run a Wireshark capture on our system and verified it is not doing this.  As a result the DHCP server is offering an IP address that's already in use.  The DHCP client is ARPing and finding a conflict.  The DHCP client then declines the IP offer and requests a new one.  The DHCP server then offers the same IP again repeating the cycle forever.  Result is the client is not able to obtain an IP.
       Did something change with Windows Server 2008 DHCP in the June patches?  Can anyone at Microsoft explain why Server 2008 DHCP is not sending an ICMP ping request before offering an IP?

    Flow:

    Polycom DHCP Client:  DHCP Request
    W2k8 Server: DHCP Offer (10.250.100.9)
    Polycom DHCP Client: DHCP ACK (accepts 10.250.100.9)
    Polycom DHCP Client: ARPs 10.250.100.9 to make sure no one is using it, finds conflict
    Polycom DHCP Client: DHCP Decline (declines 10.250.100.9)
    Polycom DHCP Client: DHCP Request
    W2k8 Server: DHCP Offer (10.250.100.9)
    etc, etc, etc,

    Thursday, June 18, 2009 10:53 PM

Answers

  • Two things come to mind:

    1.  Check that conflict detection is enabled on the DHCP server object - right-click the IP4 object, go to Properties, then Advanced.  Put this value to 1 or 2.

    2.  A workaround:  If you have very few of the misbehaving clients, you might consider creating DHCP reservations for them.  That way, the DHCP server won't attempt to allocate those addresses to other clients.  If you have many misbehaving clients, this is probably more effort than you'd want to expend.

    I hope this gives you something to work with.

    Max
    Friday, June 19, 2009 6:13 AM
  • hi there,

    This forum is dedicated to windows server 2008 R2 generic queries, there is a dedicated forum to answer networking related queries, please do post your question under

    http://social.technet.microsoft.com/Forums/en-US/windowsserver2008r2networking/threads


    thanks for understanding.
    sainath !analyze
    Friday, June 19, 2009 9:34 AM
    Moderator

All replies

  • Two things come to mind:

    1.  Check that conflict detection is enabled on the DHCP server object - right-click the IP4 object, go to Properties, then Advanced.  Put this value to 1 or 2.

    2.  A workaround:  If you have very few of the misbehaving clients, you might consider creating DHCP reservations for them.  That way, the DHCP server won't attempt to allocate those addresses to other clients.  If you have many misbehaving clients, this is probably more effort than you'd want to expend.

    I hope this gives you something to work with.

    Max
    Friday, June 19, 2009 6:13 AM
  • hi there,

    This forum is dedicated to windows server 2008 R2 generic queries, there is a dedicated forum to answer networking related queries, please do post your question under

    http://social.technet.microsoft.com/Forums/en-US/windowsserver2008r2networking/threads


    thanks for understanding.
    sainath !analyze
    Friday, June 19, 2009 9:34 AM
    Moderator
  •    Thanks Maxxxie, I didn't know about that option!  I'll give that a try.  Strange, I thought this was automatic in W2k and NT 4 DHCP.  Thanks again for your help!
    Friday, June 19, 2009 3:48 PM