none
Mounting ISO : "sorry, there was a problem mounting the file"

    Question

  • Hello,

    when i try to mount a .iso a get the following eror on Server 2012 RTM:

    What to do to fix this?

    Tuesday, August 28, 2012 9:12 AM

All replies

  • Problem can be solved by copy the .iso to a local disk instead of using it over UNC-path.

    Is there fix available to mount .iso over UNC?

    Tuesday, August 28, 2012 9:40 AM
  • Hi,

    I mounted an ISO file on one Windows Server 2012 computer through UNC path from another Windows Server 2012 computer(or even a Windows Server 2008 R2 computer) without any issue. By the way, I just double clicked the ISO file.

     

    Wednesday, August 29, 2012 2:07 AM
    Moderator
  • It is working well over UNC-path, but NOT over a network-drive (z:\test.iso)

    Other people with same problem/error?

    • Proposed as answer by icbra Wednesday, October 23, 2013 8:00 PM
    Wednesday, August 29, 2012 7:00 AM
  • Hi,

    Unfortunately, I can’t reproduce the issue on a network-drive.

    By the way, how did you share the ISO file? What’s the operating system on both the computers?

    Wednesday, August 29, 2012 7:23 AM
    Moderator
  • operating systems : server 2012 both.

    Only working with unc-path and Not working with z:\windowsserver2012.iso. Then te error as above will appear.

    Thursday, August 30, 2012 10:25 AM
  • Hello,

    when i try to mount a .iso a get the following eror on Server 2012 RTM:

    What to do to fix this?

    I am running Enterprise and get the same error NOT RUNNING SERVER, and I did copy it to the local directory and still get the error.   

    I do see that it does mount the ISO but not recognized from other apps.  Meaning I can use the EXPLORER to view the files but Rosetta Stone cannot see that it was mounted.   Its weird.  I get the error yet it Visually or partly mounts the drive.  . 



    ~Just a boy and blob in a small town world.

    Sunday, September 09, 2012 2:35 AM
  • I'm getting the same problem.  It has NOTHING to do with remote/local/up your ass... It's a problem with this BULLSHIT that they're calling an OS these days...
    • Proposed as answer by mlawton18 Thursday, January 02, 2014 3:02 AM
    Tuesday, October 16, 2012 4:53 AM
  • Don't get so excited. By Service Pack 3 - in 2019 - it will be fixed.
     
    Powershell Nerds Rule!
    I'm getting the same problem.  It has NOTHING to do with remote/local/up your ass... It's a problem with this BULLSHIT that they're calling an OS these days...

    Tomás Mason
    Friday, October 19, 2012 7:55 AM
  • this bug was fixed by windows update recently
    Thursday, November 15, 2012 11:55 AM
  • No it wasn't. ISO's still won't mount.

    Andrew

    Wednesday, December 19, 2012 3:00 AM
  • I found a simple fix.  Right click on the image and choose open with "Choose default program.."  Then select "Windows Explorer".  

    It appears that the default application associated with the image causes the mount option to fail.


    Hope this help!

    • Proposed as answer by Bryan Tye Tuesday, January 01, 2013 8:31 PM
    • Unproposed as answer by Bryan Tye Tuesday, January 01, 2013 8:45 PM
    Tuesday, January 01, 2013 8:31 PM
  • Hello,

    when i try to mount a .iso a get the following eror on Server 2012 RTM:

    What to do to fix this?

    Use freeware CD emulator like Daemon Tools. It does support virtually any file format and not only ISO and does not suffer from any issues like the one you have now.

    StarWind iSCSI SAN & NAS

    Wednesday, January 02, 2013 1:54 PM
  • Greetings,

    try to copy the file and then mount the copy. We had the same Problem with an ISO file - the copy of it mounted without Problems.

    It turned out that the original ISO file was marked as sparse. This flag gets removed when the file is copied.

    You can check if this flag is set with the command  

    fsutil sparse queryflag <PathToYourISO>

    • Proposed as answer by radmantom Wednesday, March 13, 2013 10:41 AM
    Thursday, February 28, 2013 11:21 AM
  • I don't know if this is a bug or it is by design. Let me know if my workaround works for you. Worked for me after running Windows Updates.

    You won't be able to mount it if it is sitting on a network drive. i.e. T:\ISO\

    You would have to use the UNC path \\servername\ISO


    Please remember to click “Mark as Answer” on the post that helps you. This can be beneficial to other community members reading the thread.


    • Edited by Hans Lima Monday, March 18, 2013 4:29 PM
    Monday, March 18, 2013 4:20 PM
  • Greetings,

    try to copy the file and then mount the copy. We had the same Problem with an ISO file - the copy of it mounted without Problems.

    It turned out that the original ISO file was marked as sparse. This flag gets removed when the file is copied.

    You can check if this flag is set with the command  

    fsutil sparse queryflag <PathToYourISO>

    This seems to be correct, I just noticed it also, mounting an iso doesn't work if it is sparse.  Seems like a bug to me ... anyone know if Microsoft are aware / have any plans to fix?? 
    Monday, March 25, 2013 1:00 PM
  • I do have exactly the same problem. When I try to mount an ISO image using the Windows' built-in mounting function, it works when the the ISO is located on a local drive, but NOT if it is on a network drive (linked to my NAS). The latter case yields an error saying that mounting failed without further explanation. (YES, the Iso file type is associated to Windows Explorer and YES, there is a spare drive letter after the local drive letters; actually my local drives are from B: (DVD) to D:, and the network drives are between F: and Z:, so that a mounted ISO receives a virtual drive at E: .)

    It's hilarious that everybody uses NASs now that they have been pushed into the market over the last couple of years, but the most recent Windows version fails to implement a mounting feature that most other OSs have had a like time ago (like Mac OS) correctly.

    It would be good if Microsoft could give a statement as to whether this will be addressed or what the causes are. Is there a way to escalate this issue to the Microsoft Windows development team, or to know if they are aware of it?


    • Edited by Steve06 Monday, May 27, 2013 1:00 PM
    Monday, May 27, 2013 12:42 PM


  •     You should try changing the Virtual CD drive letter in Computer Management. Do you also have external drives or peripherals such as SD Cards inserted?
    Friday, September 13, 2013 7:28 AM
  • "hilarious"? I think I would have chosen the word "pathetic"
    Tuesday, September 17, 2013 8:26 PM
  • I downloaded the ISO to my D:\ drive.  When attempting to mount I received the same error.  Once moving the ISO to my C:\ drive, it mounted with no problems.
    • Proposed as answer by skumarr Wednesday, November 20, 2013 1:58 AM
    Saturday, November 16, 2013 6:15 PM
  • I tried all the above ways, but it got failed. Finally I have moved my file to C drive and it was working fine.

    Thanks for this information..

    • Proposed as answer by skumarr Wednesday, November 20, 2013 2:00 AM
    Wednesday, November 20, 2013 2:00 AM
  • Don't use Daemon Tools, it's bloated with crap these days. They trick people into agreeing to install unwanted software. 
    Saturday, December 07, 2013 12:29 AM
  • I agree with J.Zoidberg. Daemon Tools is not what it used to be and wouldn't recommend it especially on a server. I noticed today that sometimes I get this error when I have mounted too many ISOs. I guess you can mount multiple and you just have to eject. This may not always be the case. If anything I would recommend Virtual CloneDrive by SlySoft.


    Please remember to click “Mark as Answer” on the post that helps you. This can be beneficial to other community members reading the thread.

    Saturday, December 07, 2013 1:22 AM
  • I found that even though I was receiving this error, the file was mounted correctly.

    Using Surface Pro 2, Windows 8.1 Pro, up-to-date.  Just got it yesterday, so it's a relatively clean install. It's worth noting that the problem started happening after I received a dialog asking which application I wanted to associate with .iso files: Windows Explorer or Hex Edit Pro (an RT app). I selected Windows Explorer, and confirmed that it was the associated application. I also tried uninstalling Hex Edit Pro.  I'm having the problem with all ISOs from MSDN, which are in my local Downloads folder.

    • Edited by Zenexer Sunday, December 08, 2013 5:14 PM
    Sunday, December 08, 2013 5:07 PM
  • My ISO was already on the local disk and would not mount.  I copied the file to a different folder and the copy mounted fine.  Thanks Radmantom!
    Thursday, December 19, 2013 7:58 PM
  • Thanks for this.  Just spent an hour trying to figure out why Mount-DiskImage wasn't working against the Server 2012 R2 evaluation ISO, and why the copy of the file worked.

    Would be helpful if they let us know the Windows Server 2012 R2 evaluation ISO is marked as sparse, considering it breaks most functionality built around ISOs.  I was getting quite frustrated until I came across this post!


    Sunday, February 23, 2014 11:09 PM
  • Yes, this worked for me as well with my Project 2013 trial - thank you!
    Friday, March 14, 2014 5:19 PM
  • I'm using a Microsoft Surface Pro 2, windows 8.1 and received the same error.

    No matter what I tried based on suggestions here...fail.

    Out of curiosity, I removed my microSD card I inserted a few days ago. Once this was removed, the ISO (SQL Server 2012 DEV edition) mounted just fine.

    Unsure why, other than maybe the number of allocated Drive letters has a problem?

    Wednesday, May 07, 2014 3:11 AM
  • Thanks for the clue. . . When I removed the SDRAM from the laptop and right clicked to mount an ISO file, the error message did not pop up. Strange stuff, this Windows 8 debacle. . .
    Thursday, May 22, 2014 1:57 AM
  • For anyone still experiencing this issue - I hit this snag on 8.1 U1 and resolved it by removing the microSD card I have permanently inserted...
    • Proposed as answer by k1cotk Thursday, September 18, 2014 4:11 PM
    Thursday, May 22, 2014 7:31 PM
  • Thank you, a simple copy worked fine. The ISO of SQL Server 2014 evaluation was indeed marked as sparse (on Win8).
    Tuesday, May 27, 2014 8:09 PM
  • Is there a fix for this while _installing_ Server 2012 R2?

    I ask because - it's complicated - I'm presenting my LSI drivers to the guest OS via ISO file.  Which is _supposed_ to offer it to the installer as USB device, and it even gets a drive letter I can browse to and the 'problem mounting the file' error.

    Now, I could walk down there and put the files on USB flash drive, or a removable DVD but the servers are 40 miles away and I'd like to avoid the drive.

    Wednesday, June 04, 2014 10:33 PM
  • thanks, it worked
    Monday, June 16, 2014 12:32 PM
  • Just downloaded SQL 2014 and had the same issue. Copying the iso to another file solved the issue.

    Thank you.

    Monday, June 16, 2014 6:02 PM
  • Same here - just downloaded Hyper-V 2012 R2 and the ISO image is set to sparse:

    C:\TEMP>fsutil sparse queryflag 9600.16384.WINBLUE_RTM.130821-1623_X64FRE_SERVERHYPERCORE_EN-US-IRM_SHV_X64FRE_EN-US_DV5.ISO
    This file is set as sparse

    I was still able to burn the image to disc. Copying the file cleared the flag:

    C:\TEMP>fsutil sparse queryflag "9600.16384.WINBLUE_RTM.130821-1623_X64FRE_SERVERHYPERCORE_EN-US-IRM_SHV_X64FRE_EN-US_DV5 - Copy.ISO"
    This file is NOT set as sparse

    But I still couldn't mount the image:

    I have already checked the various file associations (Explorer, Windows System Image Burner), so I don't know what's going on here. I was able to mount ISO images in the past.  This is on a fully-patched installation of Windows 8.1 Pro.  The C: volume is encrypted using BitLocker, but that shouldn't matter.  I'm logged in using an unprivileged user account, not an administrator.  It could be a permissions issue, but I'd expect a UAC consent dialog to pop up if it was.

    Best wishes,
    Matthew

    Friday, June 20, 2014 2:54 PM
  • Move this response to the top - 'Mark as Answer'.  :-)
    Friday, July 11, 2014 5:55 PM
  • I'm on Windows 8.1 and having the same error. MagicDisc works on Windows 7 Pro no issues, but also fails on this OS.

    SOLUTION:
    VirtualCloneDrive 5.4.7.0

    It's lightware and WORKS!!! I hope someone engineering this new OS studies this app. Making me miss my XP right now!

    Thank you,

    Kent C.

    Thursday, August 07, 2014 11:19 PM
  • In my case my CD/DVD drive was disabled and seeing that the virtual drive capability is linked to this, I un-installed my dvd drive, re-installed it and was able to mount the iso immediately.
    • Proposed as answer by KobusDT_RSA Friday, August 08, 2014 1:28 PM
    Friday, August 08, 2014 1:28 PM
  • Bingo!!! You are right, specially if you download the iso from the Microsoft Evaluation Center. The iso files comes set as sparse.

    In the meantime if you don't a make a copy of the file (this process change the flag to NO set sparse) or change the flag using the command shown out below the issue will be present, no matter what you do.

    fsutil sparse setflag <PathToYouISO> 0

    After change the flag you can verify the file before mounting using the command:

    fsutil sparse queryflag <PathToYouISO>

    Result: This file is NOT set as sparse

    Then you can mounting the ISO, not problem at all.

    Unbelievable, Microsoft always with surprises.

    Monday, September 15, 2014 4:48 PM
  • How is this still not patched?
    Sunday, September 21, 2014 5:46 AM
  • it seems the ISO file you are using to mount directly downloaded to C:\ Root .. (OS drive), so there must be a permission glitch going on.. though the error message is not friendly.

    A very simple and quick fix will be.. make a folder on C:\root .. for example : "Evaluation-ISO" then just copy your ISO file to that folder and then run from there...


    ja


    • Edited by Me-Mine Monday, September 22, 2014 10:20 AM
    Monday, September 22, 2014 10:19 AM