none
Error 1719. The Windows Installer Service could not be accessed

    General discussion

  • Trying to install or uninstall any programs gives me the following error:

    Error 1719.The Windows Installer Service could not be accessed. This can occur if the Windows Installer is not correctly installed. Contact your support personnel for assistance. It seems everyone was provided a file fix from Microsoft but none of those links work any more. Can someone point me to a correct fix?

     

    Log Name:      Application

    Source:        MsiInstaller
    Date:          21/03/2011 15:07:08
    Event ID:      11719
    Task Category: None
    Level:         Error
    Keywords:      Classic
    User:          omitted for security
    Computer:      MYCOMPUTER
    Description:
    Product: Error 1719.The Windows Installer Service could not be accessed. This can occur if the Windows Installer is not correctly installed. Contact your support personnel for assistance.
    Event Xml:
    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
      <System>
        <Provider Name="MsiInstaller" />
        <EventID Qualifiers="0">11719</EventID>
        <Level>2</Level>
        <Task>0</Task>
        <Keywords>0x80000000000000</Keywords>
        <TimeCreated SystemTime="2011-03-21T15:07:08.000Z" />
        <EventRecordID>902</EventRecordID>
        <Channel>Application</Channel>
        <Computer>R250W2K8SEX64SW</Computer>
        <Security UserID="S-1-5-21-1920811272-4283777713-3440243368-500" />
      </System>
      <EventData>
        <Data>Product: VMware Tools -- Error 1719.The Windows Installer Service could not be accessed. This can occur if the Windows Installer is not correctly installed. Contact your support personnel for assistance.</Data>
        <Data>(NULL)</Data>
        <Data>(NULL)</Data>
        <Data>(NULL)</Data>
        <Data>(NULL)</Data>
        <Data>
        </Data>
        <Data>
        </Data>
        <Binary>7B46453246364132432D313936452D343231302D394330342D3242314243323146303745467D</Binary>
      </EventData>
    </Event>

    Monday, March 21, 2011 3:04 PM

All replies

  • Hi,

     

    Which operating system are you running, Windows Server 2003, Windows Server 2008 or Windows Server 2008 R2?

     

    Tim Quan

     

    Tuesday, March 22, 2011 4:01 AM
  • I had this problem after trying to uninstall a corrupted iTunes.

    I finally came across this Microsoft Support tool "Fixit" ->  http://support.microsoft.com/mats/Program_Install_and_Uninstall

    It worked perfectly for me.

    Thursday, September 15, 2011 8:33 PM
  • Hi

    I have the same issue on a Windows server 2008R2 I have looked for the same Mr Fixit, however I cannot find one, have either of you found one for Windows 2008R2 server?

    dave


    DJH

    Wednesday, March 20, 2013 12:38 PM