none
Group Policy

    Question

  • I have a problem with the Internet explorer policy.
    We have terminal server environment (Citrix) 
    The users who logion to the terminal server get a separate set of group Policies . However i am not able to understand some policies .

    Here is the situation.

    When i installed Windows 2008 R2 i needed to activate windows , so i manually put in the proxy in IE Under Connections > LAN Settings > Use this Proxy Server

    this was required as without proxy ( servers couldn't access the Internet)

    Windows got activated and then i joined the servers to domain ,installed Remote desktop services and then citrix .

    We created separate set of group policies for Terminal servers , just to be in control of the TS environment.

    In our normal desktop environment we have GPO for IE settings which , has all the settings configured through Internet Explorer maintenance Policy

    However when we applied this policy on the Citrix servers , some users were facing issue with Login On and Internet Explorer maintenance . I had opened a case with Microsoft which they were taking ages to solve. So i decided on TS environment i will make new polies and not use Internet Explorer maintenance policy of GPO

    I searched a lot to find how to do stuff with Group policy preferences etc for favourites , Proxy etc 

    I have 2 problems.

    >>>
    In the beginning i mentioned i put the Proxy server manually so that i could activate the windows.
    I dint remove that even after windows got activated.

    Also the Internet explorer maintenance policy that we have for users in Desktop environment has the following configured under 

     > Connections > Automatic Browser Configuration
    It used a .pac file and Automatically detect settigs check box

    Now that we have removed the Internet Explorer maintenance policy , i used the Windows Preferences for Internet Settings to set connection settings for IE 8 (we are running IE8)

    What i think is in my case users have different Proxy setting , some have the pac file , some have pac file and manual one , some have only manul one

    the problem is with manual proxy. I need to clear / reset the policy so that all users use the .pac fuile while they logon.

    i am not sure if i can explain this any bette
    Tuesday, November 13, 2012 11:26 AM

Answers

  • I had done that when i removed the internet Explorer maintenance Policy.

    What  i  have done now is setup a Registry setting preference in GPO to delete

     HKCU\Software\Microsoft\Windows\CurrentVersion\Internet Settings  

    ProxyServer

    Also i Updated the following 

    HKCU\Software\Microsoft\Windows\CurrentVersion\Internet Settings

    ProxyEnable 0000000

    I think this is helping .. Although i would want to reg query all the users to get the data and see how effective it is.

    Monday, November 19, 2012 1:56 PM

All replies

  • Hi ,

    Thank you for posting your issue in the forum.

    I am trying to involve someone familiar with this topic to further look at this issue. There might be some time delay. Appreciate your patience.

    Thank you for your understanding and support.

    Best Regards,

    Andy Qi

    Thursday, November 15, 2012 8:04 AM
  • hi,

    Please perform the following step to clear the IE settings set by  Internet Explorer Maintenance.
    1) Please edit the GPO where you configure the old proxy settings .
    Note: From the event log, I just assume if you configure the old proxy setting on Default Domain policy.
    2) Navigate to User Configuration\Policies\Windows Settings\.
    3) Right click Internet Explorer Maintenance, click Preference Mode.
    4) Right click Internet Explorer Maintenance, click Reset Browse Settings.


    Best regards, Jason Mei Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Thursday, November 15, 2012 9:19 AM
  • I had done that when i removed the internet Explorer maintenance Policy.

    What  i  have done now is setup a Registry setting preference in GPO to delete

     HKCU\Software\Microsoft\Windows\CurrentVersion\Internet Settings  

    ProxyServer

    Also i Updated the following 

    HKCU\Software\Microsoft\Windows\CurrentVersion\Internet Settings

    ProxyEnable 0000000

    I think this is helping .. Although i would want to reg query all the users to get the data and see how effective it is.

    Monday, November 19, 2012 1:56 PM
  • Hi,

    Do you mean the GPP is working for you?

    "Although i would want to reg query all the users to get the data and see how effective it is" Do you want to know all the registry used for IE settings applied from IE Maintenance?


    Best regards, Jason Mei Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Wednesday, November 21, 2012 10:16 AM
  • Hi,

    Any updates? Please let me know.


    Best regards, Jason Mei Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Thursday, December 06, 2012 9:18 AM
  • Thanks Jason. 

    I think it worked for me , but i didnt reset the IE maintenance policy , because that was already done and the GPO is not linked to the OU 

    Sunday, December 09, 2012 7:18 AM