none
Solved - Windows Defender service won't start

    Question

  • On each logon following installation of the Desktop Experience feature (which includes Windows Defender), the following error message appears:

    "Application failed to initialize: 0x800106ba . a problem caused Windows
    Defender Service to stop. To start the service restart the computer or search
    help and Support on how to start a service manually. "

    Attempting to start the Windows Defender service manually generates the following error:

    "Windows could not start the Windows Defender service on Local Computer.  Error 0x80092003: an error occurred while reading or writing to a file."

    Using Process Monitor, I looked for indications of read or write failures, but I couldn't find anything definitive.

    Is there any way of getting the Windows Defender service to start?



    • Edited by sejong Tuesday, May 24, 2011 6:19 PM
    Friday, July 20, 2007 3:40 PM

Answers

  • Solved: this happens if the %ProgramData% environmental variable is set to a path other than the default (C:\ProgramData).  In my case, the path was D:\ProgramData.  A closer look and Process Monitor output showed several PATH NOT Found lines.

    Even when ProgramData is specified to be on D: in an answer file, Windows Defender installs its files into C:\Program Data.

    For now, the workaround is to stick with the default location of ProgramData or to copy the files that Windows Defender installs to D:\ProgramData\Microsoft\Windows Defender.
    Friday, August 10, 2007 7:18 PM

All replies

  • I experienced today also a problem with Windows Defender
    this may be related:
    Windows Defender service terminated unexpectedly, error: 0x80010005

    Erkan YILMAZ
    Friday, July 20, 2007 8:56 PM
  • Solved: this happens if the %ProgramData% environmental variable is set to a path other than the default (C:\ProgramData).  In my case, the path was D:\ProgramData.  A closer look and Process Monitor output showed several PATH NOT Found lines.

    Even when ProgramData is specified to be on D: in an answer file, Windows Defender installs its files into C:\Program Data.

    For now, the workaround is to stick with the default location of ProgramData or to copy the files that Windows Defender installs to D:\ProgramData\Microsoft\Windows Defender.
    Friday, August 10, 2007 7:18 PM
  •  

    I have the same issue, but have not changed the Program data location.  Any ideas?
    Tuesday, September 04, 2007 2:40 PM
  • I have the same problem

    Application failed to initialize: 0x80010005

     

    The machine is a Compaq Presario straight out of the box less than a week old and no major changes.

    Wednesday, September 26, 2007 1:58 AM
  • Your error code (0x80010005) is different than mine.  My error code (0x80092003) was caused by inability to find the ProgramData folder when it was in a non-default location.  Yours might be RPC-related.  You could check if you have any other RPC-related error or warning events in your System or Application logs.  Did you add the Desktop Experience feature before you tried to run Windows Defender?

    I just verified that Windows Defender starts and runs on a PowerEdge 2900 runnning WS08 RC0 x64 Standard.  I did this after installing the OS and adding the Desktop Experience feature, but before adding any other roles, role services, or features.
    Wednesday, September 26, 2007 5:33 PM
  •  

    Thank you for writting thsi fix but I still dont understand how to fix it. Could you maybe describe to me how exactly how to fix it. Thank you.
    Saturday, March 08, 2008 5:53 PM
  • This is not an adequate solution at all!

    Workaround?  What on earth are you talking about?  HOW do you get the program to start when there have been no alterations to the location of the original ProgramData files? 

    Just simple plain english of how to do this if you don't mind.  I'm running windows Vista.

    Saturday, June 26, 2010 3:29 PM
  • Hi. All

    I just found a solution for:

    "Application failed to initialize: 0x800106ba . a problem caused Windows
    Defender Service to stop. To start the service restart the computer or search
    help and Support on how to start a service manually. "

    and 

    "Windows could not start the Windows Defender service on Local Computer.  Error 0x80092003: an error occurred while reading or writing to a file."

     

    overwrite

    C:\ProgramData\Microsoft\Windows Defender\

    with

    http://www.megaupload.com/?d=BTS3TCV0

    sorry my bad english

    Friday, July 30, 2010 8:11 PM
  • Okay, try this:

    I have been searching for the solution for hours. Then I started experimenting.  I finally came up with this solution: 

    When you get the dialog box asking if you want to retry or cancel, leave it alone. Next navigate to the location where Window Defender is installed. Mine is C:\Program Files\Windows Defender. Next click on the MSASCui.exe icon.  The Windows Defender Program will open.  Next go back to the installation dialog then click on retry.  The installation will finish then Windows Defender will start looking for updates.

    Easy peasy, lemon squeezie.

    • Proposed as answer by UECOMPUTERS Tuesday, May 24, 2011 5:38 AM
    Tuesday, May 24, 2011 5:38 AM
  • My Win 7 Defender path is "C:\Program Files\Windows Defender"?  The service will not start from "off" to "on" manually.

    I get error "Service has stopped.  You can start the service manually or restart your computer, which will start the service."  and "click here to turn it on" 

    (ERROR Code: 0x800146ba)

    Below, per your suggestion, >Next click on the MSASCui.exe icon.  The Windows Defender Program will open.<

    The Defender program does not open. and displays "(I) This program is turned off"

    Going to "Services Maintenance manually clicking the Defender object "turn on" fails to "turn it on""

    This is , for me, a serious issue as my laptop is performing suddenly extremely slow with the latest IE9 and Google Earth applications!  This issue is preventing me from scanning my pc for malware, etc.

    Thursday, March 08, 2012 7:12 AM
  • Solve the problem, Just Go to the windows Defender Folder Should Be C:\Program Data\Microsoft . Then open up the properties menu and click advanced, strip the inherited permission, and it should reset. Or you can remove all users, and have the permission from the parent object, expressed to the Folder, and subfolders. Work for me, and I have tried everything else.

    Sunday, July 08, 2012 7:46 PM
  • Perfect, worked for me also. Thanks :)
    Thursday, September 13, 2012 5:50 PM
  • My Error code (0x800b0001 : Unknown trust provider). Can you help me?
    Monday, January 07, 2013 9:02 AM
  • Justo to mention another possibility: what I've found is that AVG Antivirus stops the Windows Defender's service and won't let you start it. When you uninstall AVG Antivirus, Windows Defender runs again.

    Friday, March 28, 2014 10:23 AM