none
Change IE Temporary Internet Files Setting batchly

    Question

  • For business application purpose, I'd like to make all IE9 clients using the following "Every time I visit the webpage" instead of the default setting (Automatically).

    The preferred way is to use a GPO, but I can't find a setting for this, any idea? or how to make a script to change this setting?


    阿导

    Monday, April 01, 2013 3:28 AM

Answers

  • Hello 阿导,

    Since you couldn't use GPP, Ok, then please try this:

    1. Navigate to User Configuration\Windows Settings\Internet Explorer Maintenance
    2. Right click Internet Explorer Maintenance and then click Preference Mode. Afterwards, the Advanced folder appears under Internet Explorer Maintenance in the console tree.
    3. Select "Advanced" folder, double-click "Corporate Settings" in the right area of the console.
    4. In the dialog box of "Corporate Settings Properties", expand "corporate settings" and then select "Temporary Internet Files (Users)", in the right side of the dialog box, you may modify the settings as you wish.

    Run gpupdate /force command to make it apply.

    Regards,
    Cicely

    • Marked as answer by 阿导 Tuesday, April 02, 2013 9:54 AM
    Tuesday, April 02, 2013 4:49 AM

All replies

  • Hello 阿导,

    What's the OS of your domain controller? If you can use GPP, you can take advantage of below policy:
    User Configuration\Preferebces\Control Panel Settings\Internet Settings

    In order to make GPP apply to IE9, you need to edit the XML file of Group policy preference settings, a step-by-step guide you can find from the below link:

    Internet Explorer 9(IE9) Group Policy Preferences (GPP)
    http://blogs.technet.com/b/asiasupp/archive/2011/03/30/internet-explorer-9-ie9-group-policy-preferences-gpp.aspx
    How to enable Group Policy Preferences support for IE9
    http://www.grouppolicy.biz/2011/03/how-to-enable-group-policy-preferences-support-for-ie9/

    Regards,
    Cicely

    Tuesday, April 02, 2013 1:37 AM
  • Hello Cicely,

    we are using 2003 DC with 2003 native domain & forest function level, our clients are already Win7 Enterprise 64bit with SP1. Any further idea?

    I'll also look into GPP anyway.

    Thanks so much.


    阿导

    Tuesday, April 02, 2013 3:07 AM
  • Hello 阿导,

    Since you couldn't use GPP, Ok, then please try this:

    1. Navigate to User Configuration\Windows Settings\Internet Explorer Maintenance
    2. Right click Internet Explorer Maintenance and then click Preference Mode. Afterwards, the Advanced folder appears under Internet Explorer Maintenance in the console tree.
    3. Select "Advanced" folder, double-click "Corporate Settings" in the right area of the console.
    4. In the dialog box of "Corporate Settings Properties", expand "corporate settings" and then select "Temporary Internet Files (Users)", in the right side of the dialog box, you may modify the settings as you wish.

    Run gpupdate /force command to make it apply.

    Regards,
    Cicely

    • Marked as answer by 阿导 Tuesday, April 02, 2013 9:54 AM
    Tuesday, April 02, 2013 4:49 AM
  • Hello Cicely,

    that's great!

    Great thanks for your solution! :-)


    阿导

    Tuesday, April 02, 2013 9:55 AM
  •  
    > Since you couldn't use GPP, Ok, then please try this:
     
    Why not? GPP does not depend on DC OS version, only on client OS.
     
    > 1. Navigate to User Configuration\Windows Settings\Internet Explorer
    > Maintenance
    >
     
    Please remember: IE Maintenance is gone after IE 10 is installed. And
    "gone" means "completely gone"...
     

    NO THEY ARE NOT EVIL, if you know what you are doing: Good or bad GPOs?
    Wenn meine Antwort hilfreich war, freue ich mich über eine Bewertung! If my answer was helpful, I'm glad about a rating!
    Thursday, April 04, 2013 10:04 PM
  • Hi Cicely,

    I've tried this advanced setting and it actually works. But while I'd like to verify it via GPMC or Rsop.msc, I can't see the desired result. You can see in GPMC this setting is even regarded as "No settings defined", while in rsop.msc, the settings remain "Automatically". Is there something I missed in a view or any other ways to verify from management view if the GPO really works?


    阿导

    Tuesday, April 16, 2013 6:40 AM
  • Are both screenshots taken on the same computer?
     

    NO THEY ARE NOT EVIL, if you know what you are doing: Good or bad GPOs?
    Wenn meine Antwort hilfreich war, freue ich mich über eine Bewertung! If my answer was helpful, I'm glad about a rating!
    Tuesday, April 16, 2013 11:47 AM
  • Yes, on my own PC (Win7 Enterprise 64bit), and I also verify rsop.msc on other clients, same situatio.

    What's more, I also found using this "Internet Explorer Maintenance", the first time "gpupdate /force" will make the setting works. But if I manually change the setting back to "Automatically", then try "gpupdate /force" again, it will never refresh back.


    阿导

    Wednesday, April 17, 2013 1:21 PM
  • First - not related to your problem, but for the files only - thanks to
    MS that they decided to abandon IE Maintenance in Win8, finally... ;-)
     
    > Yes, on my own PC (Win7 Enterprise 64bit), and I also verify rsop.msc
    > on other clients, same situatio.
    >
     
    Strange, but I cannot really help. All my computers are either Win8/2012
    or already have IE10 installed - IE Maintenance is gone...
     
    > What's more, I also found using this "Internet Explorer Maintenance",
    > the first time "gpupdate /force" will make the setting works. But if I
    > manually change the setting back to "Automatically", then try
    > "gpupdate /force" again, it will never refresh back.
    >
     Are you using IE Maintenance Preference Mode?
     

    NO THEY ARE NOT EVIL, if you know what you are doing: Good or bad GPOs?
    Wenn meine Antwort hilfreich war, freue ich mich über eine Bewertung! If my answer was helpful, I'm glad about a rating!
    Wednesday, April 17, 2013 3:37 PM