none
Net Framework 3.5 sp1. where i can find the hotfix KB976898?

    Question

  • My machine is Windows server 2008 R2 Enterprise sp1 x64 version and has .net framework 3.5 sp1. 

    therefore update path "Windows6.1-KB976898-v2-x64.msu " applies.

    but on installing it gives a message "this update is not for this computer"

    how can i get the fix and why he gives me this msg?

    Eliran

    Sunday, December 02, 2012 10:57 AM

Answers

  • KB976898 is actually for the .NET Framework v2.0 component (which is a required component for v3.5.x), you can check the file version number of your v2.0 components, to see if yours are later build version than those offered by KB976898.

    KB976898 ships files dated ~November 2009, and there are many critical patches issued since that time - I can't imagine you would be needing such an old hotfix?

    (but maybe you should check in a VS.NET forum on MSDN to be sure?)


    Don
    (Please take a moment to "Vote as Helpful" and/or "Mark as Answer", where applicable.
    This helps the community, keeps the forums tidy, and recognises useful contributions. Thanks!)

    Sunday, December 02, 2012 11:48 AM

All replies

  • Hi,

    I think you will find that Windows Server 2008R2 SP1 actually includes .NET Framework 3.5.1, not 3.5SP1 ?
    v3.5.1 includes later versions of the .NET Framework (compared to v3.5SP1)
    So this hotfix should not be necessary?

    refer: http://blogs.msdn.com/b/astebner/archive/2007/03/14/mailbag-what-version-of-the-net-framework-is-included-in-what-version-of-the-os.aspx


    Don
    (Please take a moment to "Vote as Helpful" and/or "Mark as Answer", where applicable.
    This helps the community, keeps the forums tidy, and recognises useful contributions. Thanks!)

    Sunday, December 02, 2012 11:31 AM
  • Hi

    My net framwork version that i have at all my servers is: 3.5.30729.5420

    So what you said is that if i have this version i don't need this hotfix bcz it's already included at the 3.5.30729.5420 version

    Right?

    Eliran

    Sunday, December 02, 2012 11:41 AM
  • KB976898 is actually for the .NET Framework v2.0 component (which is a required component for v3.5.x), you can check the file version number of your v2.0 components, to see if yours are later build version than those offered by KB976898.

    KB976898 ships files dated ~November 2009, and there are many critical patches issued since that time - I can't imagine you would be needing such an old hotfix?

    (but maybe you should check in a VS.NET forum on MSDN to be sure?)


    Don
    (Please take a moment to "Vote as Helpful" and/or "Mark as Answer", where applicable.
    This helps the community, keeps the forums tidy, and recognises useful contributions. Thanks!)

    Sunday, December 02, 2012 11:48 AM