none
How do I selectively disable VSS for a specific volume?

    Question

  • Here is my predicament: I have a server running Windows Server 2008 R2 x64 Standard with Hyper-V. Hosted on that machine is another instance of Windows Server 2008 R2 x64 Standard.

    The virtual machine connects to an external SAN through iSCSI to a 22TB NTFS volume. Now, I have set up Windows Backup on the host machine to back up the entire server (including all VMs) every night. The problem is that the backup always seems to fail.

    I've diagnosed the problem and discovered that the reason the backup fails is because VSS errors out when trying to back up the VM. The Event Log inside the VM indicates that this is because it's trying to create a volume snapshot of the 22TB LUN, which fails:

    Volume Shadow Copy Service error: Volume/disk not connected or not found. Error context: DeviceIoControl(\\?\Volume{61c5e8e4-171f-4e4c-9d42-059427b61044} - 0000000000000100,0x0053c06c,00000000002CE770,0,00000000002CD760,4096,[0]).

    Running "vssadmin list volumes" inside the VM returns this:

    <tt>PS C:\Users\Administrator> vssadmin list volumes
    vssadmin 1.1 - Volume Shadow Copy Service administrative command-line tool
    (C) Copyright 2001-2005 Microsoft Corp.

    Volume path: \\?\Volume{9a7c84ab-4a3e-11e1-a5db-806e6f6e6963}\
        Volume name: \\?\Volume{9a7c84ab-4a3e-11e1-a5db-806e6f6e6963}\
    Volume path: E:\
        Volume name: \\?\Volume{61c5e8e4-171f-4e4c-9d42-059427b61044}\
    Volume path: C:\
        Volume name: \\?\Volume{9a7c84ac-4a3e-11e1-a5db-806e6f6e6963}\

    </tt>

    E: is the 22TB NTFS volume connected via iSCSI. Is there some way to selectively disable VSS for that specific volume?

    Sunday, February 26, 2012 6:24 PM

All replies

  •  

    Hi,

     

    According to the description, this error indicates that it may be caused by the connection problem from the disk on SAN to computer.

    Please ensure that you had enabled Windows Server Backup support for the Hyper-V VSS Writer.

    http://blogs.technet.com/b/askcore/archive/2008/08/20/how-to-enable-windows-server-backup-support-for-the-hyper-v-vss-writer.aspx

    Backing Up Hyper-V Virtual Machines Using Windows Server Backup

    http://blogs.msdn.com/b/taylorb/archive/2008/08/20/backing-up-hyper-v-virtual-machines-using-windows-server-backup.aspx

    by the way, can you try to back up Hyper-V to a local disk or an external USB hard disk? And see if it can works.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.



    Tuesday, February 28, 2012 9:06 AM
  • Hi, sorry for the late reply.

    I have already enabled Windows Server Backup on the Hyper-V host, otherwise the backup would not have been able to start in the first place.

    The problem comes when backing up one specific VM when VSS tries to access the iSCSI volume. As you mentioned, this does seem to be a problem caused by the connection to the SAN - the VM loses connectivitiy to the SAN while the backup is progressing. The cause for that is complex and cannot be fixed without great cost, so I'm looking for a way to selectively disable VSS on that iSCSI volume so that it doesn't cause the backup to fail.

    Thursday, March 01, 2012 3:11 AM
  •  

    Any updates for your issue?

    I suspect it is most likely caused by the connection problem from the disk on SAN to computer, please try to back up the date to local disk and see it works smoothly.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Thursday, March 08, 2012 2:16 AM
  • I think you may be misunderstanding my issue - the backup is being made to a local drive. The SAN is not actually involved in the backup but for some reason it's still causing VSS to fail in the VM. That is why I want to find a way to selectively disable VSS for the SAN volume - so it won't interfere with the backup.
    Thursday, March 08, 2012 5:15 AM