none
Some GPO settings not applying to RDP/Terminal server

    Question

  • Hello all and thanks in advance for your time and expertise.  Here's my scenario:  I'm running server 2008 r2 sp1.  I have remote desktop services/terminal services as the role.  I'm using loopback replace and then a standard terminal server enviornment gpo with all of the computer and user settings.  This server will support two computer labs.  These labs connect to the server via ncomputing devices which establish virtual sessions to this server.  And now the problem.  When I connect to this server via RDP sessions from a workstation or logon directly to the host - the settings apply great.  However, when the users connect to the server via the virtual sessions, inevitably - some of the settings don't apply.  I have zero GPO warnings/errors in the event log of this terminal server.  However, in the app log - we get a lot of event ids 1530 user profile service warnings and the culprit is the winlogon process.   I have worked with Microsoft and Ncomputing techs for three weeks and they have no clue.

    Please note I have no problems gettings settings to apply in my enviornemnt except with this terminal server\ncomputing enviornment.  I would appreciate any help or recommendations.  Am I missing something in terms of the terminal server setup.  For example should I enable Network Level Authentication from the remote tab to force user authentication ealier in the process or will this have no effect on my GPO settings not getting applied.  I'm just at a loss.  Thanks in advance for any help you can provide.

    Tuesday, June 05, 2012 3:15 PM

Answers

  • Hi,

    1530 warning is Profile related, won't afffect the GPO applying.

    The issue occurs on every user connecting via the virtual sessions? and can be reproduced everytime?

    Yes, authentication could be made before the connection is fully ready, that causes GPOs not obtained. So, how about running GPUPDATE /FORCE command? Will it let you get the settings?

    What do you mean "some of the settings don't apply"? Please list the exact the settings and could you paste the GPRESULT /V here?

    Thanks, Brian


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Wednesday, June 06, 2012 2:29 PM

All replies

  • Please use GPO forum for better assistance.
    http://social.technet.microsoft.com/Forums/en/winserverGP/threads

    Best Regards,

    Sandesh Dubey.

    MCSE|MCSA:Messaging|MCTS|MCITP:Enterprise Adminitrator | My Blog

    Disclaimer: This posting is provided "AS IS" with no warranties or guarantees , and confers no rights.

    Tuesday, June 05, 2012 3:39 PM
  • Hi,

    1530 warning is Profile related, won't afffect the GPO applying.

    The issue occurs on every user connecting via the virtual sessions? and can be reproduced everytime?

    Yes, authentication could be made before the connection is fully ready, that causes GPOs not obtained. So, how about running GPUPDATE /FORCE command? Will it let you get the settings?

    What do you mean "some of the settings don't apply"? Please list the exact the settings and could you paste the GPRESULT /V here?

    Thanks, Brian


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Wednesday, June 06, 2012 2:29 PM
  •  

    Hi,

    I would like to confirm what is the current situation? Have you resolved the problem?

    If there is anything that we can do for you, please do not hesitate to let us know, and we will be happy to help.


    Lawrence

    TechNet Community Support

    Wednesday, June 13, 2012 6:27 AM
    Moderator
  • Hi,

    As this thread has been quiet for a while, we assume that the issue has been resolved. At this time, we will mark
    it as ‘Answered’ as the previous steps should be helpful for many similar scenarios.

    If the issue still persists and you want to return to this question, please reply this post directly so we will be
    notified to follow it up. You can also choose to unmark the answer as you wish.

    In addition, we'd love to hear your feedback about the solution. By sharing your experience you can help other
    community members facing similar problems.

    Thanks!


    Lawrence

    TechNet Community Support

    Monday, June 18, 2012 2:29 AM
    Moderator