none
2012 RemoteApp Domain PC fails, remote or local workgroup PC works

    Question

  • Hi

    Ive recently installed a 2012 RDS server with quick install (all services on same server), I have configured all the services with a external SSL certificate and domain name and access the server internally and external via machine.externaldomain.com.

    Everything works. Externally I can connect to https://machine.externaldomain.com/rdweb, login once and the apps load. I can even goto control panel, remoteapps and attached to https://machine.externaldomain.com/rdweb/feeds/webfeed.aspx and it all works.

    Internally I can goto https://machine.externaldomain.com/rdweb on a domain machine and on a workgroup machine and login and the icons work (no second login).

    On an internal workgroup machine the remoteapps works BUT on a internal domain machine I get the event 1000, error An Error Occurred Contact you workplace administrator  for assistance.

    I can even take the .rdp file from the internal workgroup machine and run it on a domain machine all be it with it asking me for my username and password.

    Can anyone point me in the right direction?

    Thanks

    Tim


    • Edited by Tim Guy Thursday, April 04, 2013 5:54 PM
    Thursday, April 04, 2013 5:53 PM

Answers

All replies

  • Hi,

    Thanks for your post.

    You may enable Single Sign-On by edit the Computer Configuration\Administrative Templates\System\Credentials Delegation, to see if the issue still persists. It will enable using the credentials of the currently logged on user to log on RDS server.

    For more detailed information, please check the below article.

    How to enable Single Sign-On for my Terminal Server connections
    http://blogs.msdn.com/b/rds/archive/2007/04/19/how-to-enable-single-sign-on-for-my-terminal-server-connections.aspx

    Best Regards,
    Aiden

    If you have any feedback on our support, please click here


    Aiden Cao
    TechNet Community Support

    • Marked as answer by Tim Guy Wednesday, April 10, 2013 8:55 AM
    • Unmarked as answer by Tim Guy Wednesday, April 10, 2013 8:55 AM
    Friday, April 05, 2013 3:13 AM
  • Thanks for your reply

    Your post has solved the issue of clicking on the .rdp icons and it not asking for a login name and password however I still can not get the Remoteapp control panel working on a domain machine to assign the icons locally. Currently Im having to use a workgroup machine to get the icons and then copy them around the domain machines.

    An internal workgroup machine works after logging on but on a domain machine when typing in https://machine.externaldomain.com/rdweb/feeds/webfeed.aspx (I have to do that as all the SSL certificates point to that, all be it with a local DNS server pointing to the local ip) I get the following

    An error occurred. Contact your workplace administrator for assistance.

    Connection name:

    Connection URL: https://machine.externaldomain.com/rdweb/feeds/webfeed.aspx

    Error code: 0x80072F78, 0x0

    Friday, April 05, 2013 9:00 AM
  • That error code is ERROR_WINHTTP_INVALID_SERVER_RESPONSE. According to http://msdn.microsoft.com/en-us/library/windows/desktop/aa384105(v=vs.85).aspx, it seems to indicate that there was an error parsing an HTTP response from your RDWeb server. Could there be some kind of misconfigured proxy or something on your domain that is mucking with the HTTPS traffic?


    Travis Howe | RDS Blog: http://blogs.msdn.com/rds/default.aspx

    • Marked as answer by Tim Guy Wednesday, April 10, 2013 8:55 AM
    Friday, April 05, 2013 7:51 PM
  • Thanks Travis

    Does look like it was a proxy issue. They had a proxy.pac file I wasn't aware of. I suck a local bypass in that and all is good.

    Thanks

    Wednesday, April 10, 2013 8:55 AM