none
No Remote Desktop license server is available.

    Question

  • I have installed Server 2012 in a test environment and keep getting the following message:

    No Remote Desktop license server is available.
    Remote Desktop Services will stop working in 72 days if this computer does not contact at least a valid Windows Server 2008 licence server. On the RD Connection Broker server, use Server Manager to verity or configure licensing settings.

    The Server is a single tower and is in a workgroup, the server has hyper-v installed and is hosting two VMs that are currently working okay.


    Graham


    • Edited by GrahamUK3 Wednesday, March 06, 2013 10:15 AM
    Wednesday, March 06, 2013 10:12 AM

All replies

  • Hi,

    You install the Remote Desktop Services. If you don't install this role. You can access to your server with rdp. You don't install this role to access to your server. You can enable rdp like windows 2008 R2.


    Un saludo Vicente Claramunt

    Wednesday, March 06, 2013 12:13 PM
  • In the Server Manager Dashboard of Server 2012 I can see Remote Desktop Services listed.

    When I select Remote Desktop Services I am presented with Overview and Servers.

    Overview – shows the following message “You are currently logged on as local administrator on the computer. You must be logged on as a domain user to manage server and collections”.

    Servers – shows my Local Server is online and activated.

    Please note: My server is a single tower running Server 2012 in a Workgroup and not on a Domain.


    Graham

    Wednesday, March 06, 2013 5:28 PM
  • Remote Desktop Services as a role requires a domain and a licensing server.

    But, as Vicente pointed out, if all that you want is administrative access to the machines via the Remote Desktop Connection, that is built into the operating system without enabling anything other than remote access.  This provides up to two connections for system management purposes.

    What are your trying to do in your environment?


    .:|:.:|:. tim

    Thursday, March 07, 2013 11:46 PM
  • I am using Server 2012 Standard with Hyper-V as the host. I have Server 2012 Essentials and Server 2012 Standard with Exchange 2013 as two VMS. The third VM is Windows 8 Pro.

    What I have been doing lately is gaining access to the VMs via Remote Desktop Connection to use Windows 8 Pro as this seems to be the only way I can use sound.


    Graham

    Tuesday, March 19, 2013 12:43 PM
  • I am using Server 2012 Standard with Hyper-V as the host. I have Server 2012 Essentials and Server 2012 Standard with Exchange 2013 as two VMS. The third VM is Windows 8 Pro.

    What I have been doing lately is gaining access to the VMs via Remote Desktop Connection to use Windows 8 Pro as this seems to be the only way I can use sound.


    Graham


    Im not quite sure what I need to do to stop the error keep coming up. Do I have to uninstall something?

    Graham

    Thursday, April 04, 2013 10:52 AM
  • Is there any further fixes to solve this issue, I still have the issue and only have 9 days remaining.

    Graham

    Wednesday, May 08, 2013 9:31 AM
  • Is there any further fixes to solve this issue, I still have the issue and only have 9 days remaining

    Graham, it seems that at least one of your servers has the RDS role installed and the absence of an RDS Licensing Server role is causing the issue.

    I expect that your Exchange Server must be installed upon a domain-member server (as I think that is a mandatory requirement), so that would suggest you do have an AD Domain in existence somewere.

    This blog walks through the RDS setup, so might be useful for you to determine where you have the (unlicensed) RDS role installed:
    http://blogs.technet.com/b/askperf/archive/2012/10/30/windows-8-windows-server-2012-remote-desktop-management-server.aspx

    You should be able to remove the unlicensed/unneeded role by using the blog as a guide.

    If you are not using a Windows Server as an RDS host (hosting many RD sessions), then I can't see why you would need as RDS role?

    Windows machines (both client editions and server editions) provide up to 2 RD sessions "for free" without the requirement for an RDS host, therefore no RDS Licensing server is needed for that scenario.


    Don
    (Please take a moment to "Vote as Helpful" and/or "Mark as Answer", where applicable.
    This helps the community, keeps the forums tidy, and recognises useful contributions. Thanks!)

    Wednesday, May 08, 2013 10:39 AM
  • I would uninstall Remote Desktop Services. You don't need this unless you are setting up 'terminal services'.  Remote desktop services is a role that is not needed. You can remote desktop your server without that role being installed.
    • Proposed as answer by star avatar Tuesday, May 28, 2013 3:25 PM
    Tuesday, May 28, 2013 3:25 PM
  • Hi

    We are haveing similar issue. The difference is we only have one win 2012 R2 server. We have about 10 staff using Remote Desktop Connection access the server at the same time. Therefore, the built in 2 RD sessions is not enough.

    We purchased 10 RD license. My question is do we need to set up second server as licensing server. Can the server itself work as licensing server?

    Thanks

    Lizzy

    Thursday, March 06, 2014 1:47 AM
  • Can the server itself work as licensing server?

    Yes it can

    Don
    (Please take a moment to "Vote as Helpful" and/or "Mark as Answer", where applicable.
    This helps the community, keeps the forums tidy, and recognises useful contributions. Thanks!)

    Thursday, March 06, 2014 7:43 AM
  • Thanks for your reply.

    I have installed the 10 RD licenses from RD Licensing Manager successfully.

    However, the warming message of Remote Desktop licensing mode is not configured doesn't go away.

    Have I missed some settings?

    Where can I do the setting?

    Thanks

    Lizzy

    Friday, March 07, 2014 12:54 AM
  • Were you able to get your problem fixed?

    I too have a single Windows Server 2012 machine with about 6 Remote Desktop licenses.  Everything is configured correctly and Active, but I'm still getting the message that says:  "Remote Desktop licensing mode is not configured" and I have 5 days left.

    I've checked and everything looks fine.  I have it defined as "Per User" and it says they never expire, etc.

    UPDATE:  Moments after I posted the above message, I think I found MY fix... I went into GPEDIT.MSC and under ... 

    Computer Configuration\ Administrative Templates\ Windows Components\ Remote Desktop Services\ Remote Desktop Session Host\ Licensing

    I enabled the following and specified an answer for them.

    Use the specified Remote Desktop license servers

    Set the Remote Desktop licensing mode

    • Edited by bitzpc.com Thursday, April 24, 2014 8:00 PM
    Thursday, April 24, 2014 7:53 PM