none
DHCP renewal does not work on windows 7

    Question

  • I am an IT Dir with over 25 years experience and am not new to networking...This is a business computer/environment and our company uses dhcp...  just config'd my Windows 7 laptop on Monday - LAN adapter worked fine...getting on the network/internet until today (3.5 days later)... adapter just says "Identifying..."  Our dhcp lease expiration is 7 days so my guess is that it tried to check in with the dhcp server as normal behavior and couldn't keep it's same lease for some reason... I know there are plenty of leases available.  It works if I statically assign the IP but that's not a good solution.  I tried a reservation for the same IP but that does not work like it does on all other computers.  I have applied all windows updates.  I have verified my drivers are current.  Interestingly enough, I tried the WIFI adapter and it connected fine giving me the correct IP but then I disconnect and the LAN adapter still does not get an IP.  I've tried disabling and enabling the adapter and a number of things and this seems like a common problem in the forums with no answers.

    I want to roll this out to my company but cannot until these issues are resolved.

    Brenda

    My dhcp server runs on a Windows2003 server.
    • Moved by Srinivas RMicrosoft Support Sunday, March 07, 2010 1:45 PM computer in domain network (From:Networking, Mail, and Getting Online)
    Thursday, March 04, 2010 7:34 PM

Answers


  • Brenda, you were NEARLY RIGHT.

    The issue of the IP address failing to be assigned correctly by DHCP was actually due to the WAKE ON LAN functionality enabled by default.

    To turn this off, simply disable the "Allow this device to wake the computer" on the NIC in question.

     

    Now, you might ask how I discovered this ?

    Well by sheer accident actually,
    I noticed my LED on my ethernet switch had Connectivity even when my machine was Sleeping !!!
    This is becuase WakeOnLAN (WOL) is waiting for a "WOL-MagicPacket" to wake the system, meaning the last IP is still leased.
    So when you wake up your system, Windows will request for an IP; but since the old IP is being used, your DHCPserver assigns a new (different) IP !!!

    It took me weeks of sniffing packets and trawling Google (and Bing) before I stumbled upon this, so I hope this helps everyone!

    - Jo
    Sydney, Australia

    Wednesday, December 15, 2010 12:21 PM

All replies

  • Hi Brenda,

     

    Sometimes Windows 7 cannot obtain an IP address from certain routers or from certain non-Microsoft DHCP servers. To resolve this issue, disable the DHCP BROADCAST flag in Windows 7.

     

    To do this, follow these steps:
    1. Click Start, type regedit in the Start Search box, and then click regedit in the Programs list.
    2. If you are prompted for an administrator password or for confirmation, type your password, or click Continue.
    3. Locate and then click the following registry subkey:
    4. HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\{GUID}
    5. In this registry path, click the (GUID) subkey that corresponds to the network adapter that is connected to the network.
    6. On the Edit menu, point to New, and then click DWORD (32-bit) Value.
    7. In the New Value #1 box, type DhcpConnEnableBcastFlagToggle, and then press ENTER.
    8. Right-click DhcpConnEnableBcastFlagToggle, and then click Modify.
    9. In the Value data box, type 1, and then click OK.
    10. Close Registry Editor.
     
    By setting this registry key to 1, Windows Vista will first try to obtain an IP address by using the BROADCAST flag in DHCP Discover packets. If that fails, it will try to obtain an IP address without using the BROADCAST flag in DHCP Discover packets.

    Note: Serious problem might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs.

     

    You may also try to uninstall and reinstall the Network adapter drivers and check if it helps.

    Also let us know if the computer is on a Domain network.

    Hope this helps. Let us know the status.

                                                                   

    Thanks and Regards,

     

    Srinivas R Microsoft Support.

    Visit our Microsoft Answers Feedback Forum and let us know what you think.

    Friday, March 05, 2010 3:03 PM
  • I will try the registry settings and report back.  Please note that this laptop was working fine the first 3 days on my network and received it's IP from our Windows2003 dhcp server.  ]

    This laptop is part of a local Windows2003 domain.
    Friday, March 05, 2010 8:41 PM
  • I tried the registry setting (after trying to determine the right guid our of 4 possible choices..) rebooted, did not work.

    I then deleted the device from my laptop, rebooted and when I logged in, it rediscovered and reinstalled:  using the Broadcom NetXtreme57xx Gigabit Controller, dated 4/26/09, 10.100.4.0.

    My network is flat and the only router in the mix is going out to the internet.  All was working this week under Thursday morning.  No changes to the system or network.  I am the only Windows7 device right now but I have my tech's installing their copy to start testing.  It will be interesting to see if we duplicate the problem on another computer.

    In the meantime, it works if I statically assign the ip.  Any more suggestions?  This just seems like a bug.
    Friday, March 05, 2010 9:25 PM
  • Hi Brenda,

     

    I am moving this thread to TechNet support forum,  IT Pro support for further support on this issue,  since the computer is on a domain environment.  

     

    Thanks and Regards,

     

    Srinivas R Microsoft Support.

    Visit our Microsoft Answers Feedback Forum and let us know what you think.

    Sunday, March 07, 2010 1:43 PM
  • What's the easiest way for me to find that thread?  I will keep searching for it but new to this forum.
    Monday, March 08, 2010 5:28 PM
  • Hi ,

     

    I would suggest you to save the below link and access it, so that you can easily access the thread.

    http://social.technet.microsoft.com/Forums/en-US/winserverNAP/thread/2a18bb78-211a-42e4-809a-8be4133149e6

     

    Thanks and Regards,

     

    Srinivas R Microsoft Support.

    Visit our Microsoft Answers Feedback Forum and let us know what you think.

    Wednesday, March 10, 2010 2:47 PM
  • Not to say me too... but Me too!.

     

    I am in the same boat with this issue. 2 Different windows 7 systems with 2 different types of NICs are having the same issue. The only thing I have noticed on my end is if the system is part of the domain then I have no problems. If they are not then I get the APIPA.

     

    Thanks for posting this I've been wrestling for days now.

    Monday, March 22, 2010 3:28 PM
  • Hi,

    I've read through this thead and it seems it was moved to the NAP forum by mistake. Rather than move it immediately to another forum, I would like to try and help. If I can't come up with a solution then perhaps I can find experts that are more familiar with DHCP issues.

    To restate the problem, a computer with a LAN adapter using the driver: Broadcom NetXtreme57xx Gigabit Controller, dated 4/26/09, 10.100.4.0 is unable to acquire a DHCP lease. The original poster (Brenda) indicated that she would test with some other client computers and see if the same problem occurs. I am curious as to the results of this test.

    Obviously the majority of Windows 7 systems can obtain obtain DHCP leases with no problem. However, a search for: DHCP Windows 7 problem does yield several hits. I was able to find one article that seems to have a possible solution that I'd like you to try please. I am including a link to the article below and also copying it below just in case the article is moved or removed. Essentially, the problem that is described here is that Windows 7 enables power management but the adapter doesn't support it. A speed and duplex mismatch is also suspected and autonegotiate is disabled. I don't recommend doing this first, however because it isn't advisable to hard-code speed and duplex settings.

    http://windows7forums.com/windows-7-networking/6777-solution-netgear-fa311-v1-no-internet-rc-build-7100-a.html

    Excerpt from article:

    Went to DM, right clicked on my NIC, Selected properties. Then Clicked Advanced, Under the property, there were 3 entries,
    1. Network Address - Not present selected
    2. Speed & Duplex settings - Auto sense
    3. Transmit buffers - 160

    Went to Power Management,
    Both the check boxes were selected.

    When I went to Netgear website, the v1 doesnt support wake-on LAN and it has a speed of 100Tx.

    So, In Advanced tab, Selected Speed & Duplex settings, selected 100Tx in the place of Auto sense.
    Went to Power Management, Unchecked both the check boxes. Clicked Ok.

    Went to command prompt, ipconfig..

    VOILA!!!!!! Got my DHCP IP address.

    Saturday, April 10, 2010 6:17 AM
    Owner
  • Thanks Greg for looking into this issue.  Here is an update on my issue:

    The 3 other Windows7 machines in my same environment have NOT had this issue but they are all HP desktops and they have the 64-bit version of Windows 7 installed.

    I since found out that (since my laptop was the first) my tech installed the 32-bit version of Windows7 on my 64-bit Dell D630 laptop.  I really had not noticed until I started getting messages that said my Windows7 was not a genuine copy.  I had been using a static IP up until then...so, last Monday, I backed up my system and formatted it and installed a 64-bit legal copy of Windows7 on my machine.  At first, I thought I had the same problem, but then I went and deleted the DHCP reservation for my laptop and re-added it and it picked up it's reserved address.

    It has been 1 week now and I have not had the problem.

    I checked under DM and have several options under the Advanced Properties, but noticed that on the Power Management tab, it only has 1 box checked and does not have the "Allow this device to wake the computer" checked.  I really don't remember what the previous setting was.

    I could try checking this box and see of problem comes back, then at least we will have more info.

    If "ADangerous" could also try this solution since he is still having the problem, that would also be helpful and we can mark as the ANSWER.

    You could be on to something.

    Brenda

    Monday, April 12, 2010 3:10 PM

  • Brenda, you were NEARLY RIGHT.

    The issue of the IP address failing to be assigned correctly by DHCP was actually due to the WAKE ON LAN functionality enabled by default.

    To turn this off, simply disable the "Allow this device to wake the computer" on the NIC in question.

     

    Now, you might ask how I discovered this ?

    Well by sheer accident actually,
    I noticed my LED on my ethernet switch had Connectivity even when my machine was Sleeping !!!
    This is becuase WakeOnLAN (WOL) is waiting for a "WOL-MagicPacket" to wake the system, meaning the last IP is still leased.
    So when you wake up your system, Windows will request for an IP; but since the old IP is being used, your DHCPserver assigns a new (different) IP !!!

    It took me weeks of sniffing packets and trawling Google (and Bing) before I stumbled upon this, so I hope this helps everyone!

    - Jo
    Sydney, Australia

    Wednesday, December 15, 2010 12:21 PM
  • Dear all,

    Unfortunately I am having the same problem, windows 7 PCs not acquiring IPs from a DHCP server running on Windows server 2003. My NIC is Broadcom NetExtreme Gigabit adapter with latest driver v14.2.0.5. For the PC to connect to network (and internet) I have to assign a static IP!

    I have tried everything in this thread to no avail.

    The windows PC assigns itself address 169.254.189.176 with mask 255.255.0.0

    Please help!

     


    kwayu
    • Edited by kwayu Tuesday, October 25, 2011 5:54 AM added text
    Tuesday, October 25, 2011 4:45 AM
  • Hi, today I just solved this problem on my colleague's notebook

    It's because his MAC address is invalid (00-00-00-00-00-00), and I must manually set the MAC address on his notebook.

    I hope this might help someone

    Wednesday, December 21, 2011 8:46 AM
  • I ran in to this today as well. Fresh install of Win7 64bit Ultimate after having done it successfully and connected successfully 3x in the past 2 weeks.

    After having done Dell Tech Support when Vista rolled out and a year of ISP tech support when every senior citizen walked into WalMart and bout a laptop so they could get on Facebook, I have a routine for troubleshooting Vista, and now Win7, when connected but not acquiring IP from a LAN DHCP is to:

    1. Powercycle Router
    2. Uninstall/Reinstall adapter
    3. Router to Factory/Reboot
    4. Uninstall/Reinstall adapter (this fixed nearly EVERY little old lady XP call)
    5. Turn off IPv6, reboot adapter - 90% fix when Vista rolled out and people connected directly to an old cable modem or new routers with IPv6 support (hah!) or old routers that people updated firmware (so fail for 2 years)
    6. Turn off both Discovery, reboot adapter - again, Vista rolled out to users with already aging home networks. Usually fixed and then turn back on and was fine
    7. Turn on Multicast protocol - found this by accident. It's intent is to help ensure streaming, but I believe the way it goes about doing it on the network is pretty intrusive like "HEY! I'M HERE AND YOU HAVE TO SEE ME!"

    By this time if a Vista machine was not connected, it was usually something in the stack and would have to be rebuilt, although it was fairly common with when ISP's starting rolling out modem/router combos instead of just modems.

    Coincidentally, mine was fixed today when I toggled the Multicast. Dunno why. But its working just fine, so I wont be interested until my next install that i can replicate the issue.

    Good luck!

    Monday, January 02, 2012 10:54 PM
  • Try disabling IP-V6 on your adapter, and any unwanted protocols, clients listed under the Wireless network connection properties tab, which can be accessed by right clicking on the wireless connection and selecting properties from the drop down menu.

    Thursday, March 22, 2012 12:10 PM