none
RDP audio issues with Windows Server 2008

    Question

  • I have a server with an M-Audio 1010LT audio card installed, running audio playback software.  This software needs to stay running and playing at all times.
     
    We were previously running Windows Server 2003 and when we RDPed into the box for maintenance, we simply made sure that 'Leave at remote computer" was selected under Remote Desktop's sound settings.  This allowed us to control the console of the server while the audio continued to play through the server's audio card.
     
    Now, with Windows Server 2008, even with this option selected when we remote into this server all audio stops and Windows shows no available audio devices.  If I end my RDP session and phyically go to the server, I see the audio devices and am able to re-start the audio playback.
     
    Is this a bug, or something that has changed in 2008?  Any workarounds?

    Thanks
    Monday, April 27, 2009 4:42 PM

Answers

  • Hello,

    Yes this is a change from WS2003 to WS2008. Leave at remote computer has the same effect as Do not Play. Unfortunately there is no work around.

    Thanks.

    Shuba Iyer
    MSFT

    Wednesday, April 29, 2009 4:45 PM

All replies

  • Hi,

    By default audio redirection is disabled on server side in server SKU.

    To enable it, run tsconfig.msc on server, double click the connection, go to “Client Settings” tab, uncheck the “Audio” checkbox.

    Thanks.

    This posting is provided "AS IS" with no warranties, and confers no rights.
    • Proposed as answer by BootMagic Monday, November 12, 2012 1:15 PM
    Tuesday, April 28, 2009 8:03 AM
  • I tried this previously, and it did not make a differnece - but keep in mind I DON'T want audio redirection - I simply want the audio to stay at the server.
    • Proposed as answer by Ethan Phyo Saturday, August 18, 2012 7:53 AM
    Wednesday, April 29, 2009 1:14 AM
  • Hello,

    Yes this is a change from WS2003 to WS2008. Leave at remote computer has the same effect as Do not Play. Unfortunately there is no work around.

    Thanks.

    Shuba Iyer
    MSFT

    Wednesday, April 29, 2009 4:45 PM
  • Horrible!  But thanks for the reply.
    Friday, May 01, 2009 11:28 AM
  • Will this bug be fixed anytime? Otherwise I have to install an other OS like Windows Server 2003 or Linux.
    Sunday, June 28, 2009 9:49 AM
  • Yes, this is quite annnoying when trying to play sound out of a remote server.  I just tried utilizing the physical soundcard of the server to play back music and it does not work.  However, I can get iTunes to playback (via the server) through airtunes.


    I didn't realize that at the time, the intitial error mesage I got in the blog post is because windows server disables the sound output on the server for RDP sessions.

    Cheers,
    Jon
    Friday, July 24, 2009 12:45 PM
  • Hello, has this been fixed in Windows 2008 R2? Seems to have the same problem!!

    Im not going to upgrade to 2008 until this issue is fixed..please microsoft make a patch.

    Thankyou
    Sunday, September 13, 2009 8:19 AM
  • hello,
    well is this really so hard to offer on a server os? I jumped to 2008 too while the 2003 had no problems at all. I can't go back to 2003 though but I do need the music to be played always server side. Can't there be an extra option so that I can rdp and change tracks and stuff on my server?

    can any1 give an official answer to this one please?
    Saturday, October 24, 2009 3:22 AM
  • hello,
    well is this really so hard to offer on a server os? I jumped to 2008 too while the 2003 had no problems at all. I can't go back to 2003 though but I do need the music to be played always server side. Can't there be an extra option so that I can rdp and change tracks and stuff on my server?

    can any1 give an official answer to this one please?
    I agree with you that this is in fact a big problem that Microsoft overlooked.  If they are going to implement these kinds of feature changes, the should provide a method of being backward compatible.  A simple search on Google shows that this is clearly an issue that many people are having.

    I imagine that this is something relatively easy to patch and provide as an option.



    *****************IF YOU HAVE THIS ISSUE *****************

    Please reply to this thread to hopefully get more attention to this issue and thus a [faster] resolution.

    *********************************************************
    Sunday, November 01, 2009 3:50 AM
  • *****************I AM HAVING THIS ISSUE *****************

    I reply to this thread to hopefully get more attention to this issue and thus a [faster] resolution.

    *********************************************************
    Sunday, November 01, 2009 10:35 AM
  • *****************I AM HAVING THIS ISSUE *****************

    I reply to this thread to hopefully get more attention to this issue and thus a [faster] resolution. 

    *********************************************************

    MS, usually I like you.
    this time you sucked.
    this (mis)feature means that I cannot use server 2008 as an audio/video capture server,
    because RDPing into the server magically "removes" the audio capture devices.
    until fixed  I have to keep with 2003

    Monday, November 02, 2009 1:20 PM
  • *****************I AM HAVING THIS ISSUE *****************

    I reply to this thread to hopefully get more attention to this issue and thus a [faster] resolution.

    *********************************************************
    Friday, November 06, 2009 8:27 PM
  • *****************I AM HAVING THIS ISSUE *****************

    I reply to this thread to hopefully get more attention to this issue and thus a [faster] resolution.

    *********************************************************
    some links:

    but please fix this or provide a workaround!!
    Wednesday, November 11, 2009 4:14 AM
  • *****************I AM HAVING THIS ISSUE *****************

    I reply to this thread to hopefully get more attention to this issue and thus a [faster] resolution.

    *********************************************************

    need to configure remotly sound card in media application on 2008 !!!
    Wednesday, November 25, 2009 2:40 PM
  • *****************I AM HAVING THIS ISSUE *****************

    I reply to this thread to hopefully get more attention to this issue and thus a [faster] resolution. 

    *********************************************************
    Tuesday, December 01, 2009 4:43 PM
  • *****************I AM HAVING THIS ISSUE *****************

    I reply to this thread to hopefully get more attention to this issue and thus a [faster] resolution. 

    *********************************************************
    Thursday, December 03, 2009 11:35 AM
  • *****************IF YOU HAVE THIS ISSUE *****************

    Please reply to this thread to hopefully get more attention to this issue and thus a [faster] resolution. 

    *********************************************************

    I desperately would like a fix for this. I use my laptop connected to my server all the time which is attached to a stereo system, this used to work amazing in xp, server 2003, and im sure it is amazing for those home users that have windows vista/7. why cant we enjoy the same features? why do people who upgrade from server 03 take a loss of features by upgrading their OS? cant this be disabled by default and be enabled for those server users that don't use the software for strictly corporate environments? someone at microsoft has to know how this is disabled, and how to workaround it. Seriously, it cant take that much time or money to fix this can it? 

    WE WANT A FIX!

    I don't even post on forums just read them normally, this being an exception, most issues similar to this have a workaround, why doesn't this one?


    Sunday, December 06, 2009 12:31 AM
  • *****************IF YOU HAVE THIS ISSUE  *****************

    I reply to this thread to hopefully get more attention to this issue and thus a [faster] resolution.  

    *********************************************************

    Shuba Iyer, thanks for the heartfelt response to everyone here, but since you work on the RDC team, can you give us any idea if you guys are actually working to resolve this bug? By the tone of your post it seems like this is just the way it is, so live with it.

    I, like many others, use Windows Server as a media server among other things, and need this functionality. I will be forced to remove Server 2008 very soon if this is not resolved.

    Thanks,

    Tony
    Saturday, December 12, 2009 4:59 AM

  • *****************IF YOU HAVE THIS ISSUE  *****************

    I reply to this thread to hopefully get more attention to this issue and thus a [faster] resolution.  

    *********************************************************

    Microsoft, please fix this. I can't tell you how much time I've spent trying to fix this only to finally stumble across this thread.
    Wednesday, December 30, 2009 6:42 PM
  • *****************IF YOU HAVE THIS ISSUE  *****************

    I reply to this thread to hopefully get more attention to this issue and thus a [faster] resolution.  

    *********************************************************
    time to fix this annoying bug/feature/whatever
    Saturday, January 09, 2010 12:43 AM
  • *****************IF YOU HAVE THIS ISSUE  *****************

    I reply to this thread to hopefully get more attention to this issue and thus a [faster] resolution.  

    *********************************************************
    I'm sorry to see that the same issue exists for Windows 7 too.

    Why, Microsoft, it seems so unneccesary? And why isn't there an official reply and explanation yet?? It seems that this has been an issue for SEVERAL months now?
    Friday, January 15, 2010 9:15 PM
  • *****************IF YOU HAVE THIS ISSUE *****************

    Please reply to this thread to hopefully get more attention to this issue and thus a [faster] resolution.

    *********************************************************
    I am also disappointed with this aspect of W2008 server. It sits there, with 8gig of ram and a quad core processor, serving email and files. That was a ridiculaously complex install with the internet mail role requiring a second installation of the server in a hyperV environment. Days of work to download and install all the updates ... twice. Now I have it working, the last piece of the puzzle is to have it serve the sound, lift music for the masses, background music to the good people on hold, but it doesn't - won't.

    I can set it up to play stuff, but it stops the moment I connect remotely ...  by design!

     So change the design!

    Don't tell me the server doesn't do this! It always has, so it should now!
    Thursday, February 04, 2010 12:02 AM
  • *****************I HAVE THIS ISSUE *****************

    Please reply to this thread to hopefully get more attention to this issue and thus a [faster] resolution.

    *********************************************************
    We are using Wyse V10L thin clients, connecting to TS2003 and can run Flash video & audio with no problem.  Have enabled sound on TS2008 test servers but it will not sync with Flash video.  We are a school district wanting to upgrade to 2008 but this is a deal breaker at this point.  Very disappointed that no fix has been made for 2008 TS sound support.
    Thursday, February 11, 2010 5:02 PM
  • *****************I AM HAVING THIS ISSUE  *****************

    I reply to this thread to hopefully get more attention to this issue and thus a [faster] resolution.  

    *********************************************************

    I'm also "a little bit" tired of the fact, that I can't play sound at the server, while connected via rdp. Would be really nice, if this could be fixed somehow...
    Sunday, February 14, 2010 2:32 PM
  • *****************I AM HAVING THIS ISSUE  *****************

    I reply to this thread to hopefully get more attention to this issue and thus a [faster] resolution.  

    *********************************************************
    Sunday, February 21, 2010 4:16 PM
  • I have same problem. Any solution?

    Tuesday, March 09, 2010 3:58 PM
  • *****************I AM HAVING THIS ISSUE   *****************

    I reply to this thread to hopefully get more attention to this issue and thus a [faster] resolution.   

    *********************************************************
    <button class="ws"></button>
    Wednesday, March 24, 2010 2:16 AM
  • ale225 I dont understand you. Have you got solution?
    Wednesday, March 24, 2010 6:52 PM
  • *****************I AM HAVING THIS ISSUE *****************

    I reply to this thread to hopefully get more attention to this issue and thus a [faster] resolution.

    *********************************************************
    I am very surprised, that such an issue can t be fixed by MS.
    We are using Server 2008 with Windows Media Encoder including some osprey cards to stream for customers. Unlikely I dont want to connect to our servers every time direct fromm the serverroom were all our servers are. Usually I connect from everywhere via the RDP to controle the wme.
    There must be a workaround or something to fix this issue. Can someone from MS please give us a forecast if there is someone working on that issue?
    Otherwise I have to downgrade all our streaming servers to server 2003. That couldn t be the answer to such a problem guys.
    Thanks.
    Wednesday, April 14, 2010 11:27 AM
  • Let me get this straight ... we can use Windows Aero via RDP between Win7 and 2008 R2 but we can't play audio?
    I like pie!
    Thursday, April 15, 2010 4:06 PM
  • Let me get this straight ... we can use Windows Aero via RDP between Win7 and 2008 R2 but we can't play audio? Brilliant!

    Though I don't think this is a bug, more a questionable "design decision."  Audio works fine (play local and play on remote) between Win7 PCs.  Just that pesky 2008 [R2] RDP implementation that's an issue.

    I guess someone didn't realize that IT pros, devs and admins use server 2008 as workstations to get their hands on Hyper-V for testing, research, development and study and will often use "consumer" hardware to do it.  Consumer hardware with things like ... sound cards, which I hear people like using.


    I like pie!
    Thursday, April 15, 2010 4:12 PM
  • That is precisely what I'm using my server for. It's a dev box running various VM's. Yet it's sitting in my stereo rack in an older HTPC case. Silly me, I thought I could run Pandora, Windows Media, iTunes, etc, via an RDP session...

    I can't believe this is a problem via Windows 7. Is that true? If so, that has to be the most absurd thing I've ever heard. Frankly I can almost understand the argument this functionality doesn't have to be in Server but not in the desktop OS? REALLY?

    • Proposed as answer by bschaberg21 Wednesday, April 28, 2010 10:25 PM
    Friday, April 16, 2010 12:41 AM
  • Try creating and logging on a standard user. You will need to add the user to "remote desktop users group".  Worked for me.
    Wednesday, April 28, 2010 10:26 PM
  • Try creating and logging on a standard user. You will need to add the user to "remote desktop users group".  Worked for me.

    ? Please Explain

    I'm running Windows Server 2008 R2, and no matter what I try (including logging on as a standard user, even with "mstsc.exe /console /admin"), I get "No audio devices are installed" despite trying to activate remote playback with every possible registry hack etc on the server.

    I dont know why microsoft would remove this feature, because the option is right there in the RDP client "Play on remote computer" - so why would the most recent OS with the most recent service pack be void of this basic feature which could be critically important to many users, such as myself? We desperately need a hotfix/patch for this. As you can see there's quite a demand - please, Microsoft!

    Thursday, May 20, 2010 12:55 PM
  • Try creating and logging on a standard user. You will need to add the user to "remote desktop users group".  Worked for me.
    This also did not work for me. I'd also like to mention that windows 7 does support the "play on remote computer" option. It seems that the problem is specific to windows server 2008 [r2].
    Monday, May 31, 2010 5:43 AM
  • Hi,

    I think I just found a solution for 2008 R2 and Win 7. As I have the german version I'll try to translate:

    - go to something like "configuration of remotedesktop-sessionhost" (Konfiguration des Remotedesktop-Sitzungshosts)

    - in the center you should see somethink like "connections" (Verbingungen) with "RDP-Tcp"

    - right-click on that entry

    - go to the tab "clientsettings" (Clienteinstellungen)

    - untick "audio- and video..."

    It works for me - now I have sound via RDP from Win 7 to my 2008 R2.

    Wednesday, June 02, 2010 6:40 PM
  •  Hi

    Thanks for the fix but this is only a fix to bring the audio to the remote machine it still does not allow us to leave the audio local or even return local audio after terminating a remote session which is what many of us need urgently!

    so again it is

     

    *****************I AM HAVING THIS ISSUE *****************

    I reply to this thread to hopefully get more attention to this issue and thus a [faster] resolution.

    *********************************************************

    hoping this can be resolved soon.

    Sunday, June 06, 2010 2:33 PM
  •  

    *****************I AM HAVING THIS ISSUE *****************

    I reply to this thread to hopefully get more attention to this issue and thus a [faster] resolution. 

    *********************************************************

    Tuesday, June 15, 2010 8:36 AM
  • It's just amazing how much functionality Microsoft removes from each successive generation of operating systems.  In many ways, especially with regard to user interfaces, Server 2008 and Windows 7 are crippled versions of older operating systems in that there is a lot that we can't do that we got used to doing before.
    Sunday, July 04, 2010 7:50 AM
  • *****************IF YOU HAVE THIS ISSUE  *****************

    I reply to this thread to hopefully get more attention to this issue and thus a [faster] resolution.  

    *********************************************************

    another ms "we dont need that" POLICY! go microsoft :)

    Sunday, July 04, 2010 3:15 PM
  • I also had this issue... the workaround I used was to install UltraVNC and use that instread of RDP. That way the sound is not disconnected or interrupted... not the best solution but it works..!
    Monday, July 05, 2010 8:28 PM
  • I agree, and that's what I've done.  It's yet another example how how the problem is not that Microsoft's customers aren't smart enough to figure out how to use their products.  The problem is that Microsoft's products are becoming too inflexible to meet their customers' needs.
    Tuesday, July 06, 2010 4:46 AM
  • What a bunch of junk.  This needs to be fixed.  (Microsoft reps: note that I said "fixed", and not "changed" ... you broke my Windows experience.)  Incidentally, it seems like installing the "desktop experience" doesn't ACTUALLY provide a "desktop experience."  (For users who haven't yet encountered that proposition, you can find the option under "Features" in your server manager.)  

    Sunday, July 11, 2010 11:45 PM
  • *****************IF YOU HAVE THIS ISSUE  *****************

    I reply to this thread to hopefully get more attention to this issue and thus a [faster] resolution.  

    *********************************************************
    Thursday, July 15, 2010 10:25 AM
  • *****************IF YOU HAVE THIS ISSUE  *****************

    I reply to this thread to hopefully get more attention to this issue and thus a [faster] resolution.  

    *********************************************************

    What a great assumption MS made that no one would EVER need to do this.

    Friday, July 16, 2010 1:48 AM
  • *****************IF YOU HAVE THIS ISSUE  *****************

    I reply to this thread to hopefully get more attention to this issue and thus a [faster] resolution.  

    *********************************************************
    Friday, July 30, 2010 12:51 AM
  • *****************I HAVE THIS ISSUE  *****************

    I reply to this thread to hopefully get more attention to this issue and thus a [faster] resolution.  

    *********************************************************

    This is a major issue since we do video/audio streams for our business and this makes it difficult to use newer rack dense servers to provide these services since the new servers are not supported in XP or 2003 due to system drivers. The option to not move audio is there in RDP, so it sounds like just not taking control of the audio driver at the time any RDP session starts is the issue. Should be like 2 lines of code for MS to change to make it function the way it says it does.

    Monday, August 02, 2010 7:09 PM
  • I too have this problem. PLEASE FIXXXXXXXX
    Wednesday, August 04, 2010 7:26 PM
  • This is another "I have this issue, too!" reply. My use case is probably similar to most other people who request the old behaviour: my computer acts both as server and as living room PC. While I want to RDP into it to work on it, the audio output should continue to play at the server. I struggle to understand why I should "downgrade" to Win 7 in order to get the good old behaviour back. Please consider to make it an option!

    Saturday, August 07, 2010 1:50 PM
  • Guys, I think the most important thing to note here is that Microsoft knew that this outcome would occur.  They did not, however, expect that so many people might be relying on this ever-so-basic functionality, which has otherwise been available to us since XP/Srv03.  Ouch!!  

    I'm still attempting to find a workaround, but for now it seems that we are limited to using third-party software--VNC free edition should do the trick.  

    I am, however, encountering a few errors with that setup as well.  Namely, the issue I'm seeing now is that incoming VNC connections invoke an "Unable to connect session to Console: Access is Denied." error within the server's application error logs.  I have not spent more than even 5 minutes on troubleshooting this error, but I might as well post it here ASAP for others' benefit.  (I realize it might appear unrelated, and worthy of a separate thread, but since it is the only known temporary workaround to our notorious RDC audio-disable issue, I think that I should just post it here.)

    Sunday, August 08, 2010 1:55 AM
  • Man,

    Having the same issue. MS, please fix. "Play audio at host" does not mean "Disable audio at host". It's an amazing experience to go through budgeting, planning, buying new hardware, setting up OS, moving apps over, and then being stuck with one last tool on the old server, that just won't work on the new one.

     

    So, should I tell my users to use VNC? Should I tell my manager that we can't complete the move to 2008 yet because I overlooked this problem? Should I ask the developers to come up with some kind of proprietary mapping service to work around? Or should I tell the users to run some tools on the new server, and some tools on the old server?

     

    Please fix this, or are we shouting in the wind out here?

    Monday, August 09, 2010 11:11 AM
  • ShubaI (or another mod..?), could you kindly please confirm if there is any intention to fix this 'bug', and perhaps include an ETA when we could expect a hotfix ? It's been way over a year since this was first reported, and clearly (despite this post being tough for most users to even find) there's a lot of activity about it: a lack of functionality where that functionality should exist. Essentially, you confirmed the issue, but did not acknowledge that the resulting effect is not normal (which is of course the case) - nor did you give any indication on when or how it will be addressed, or even if it will be addressed at all, which we'd at least expect.

    Thank you

    • Proposed as answer by rmb2000 Thursday, September 09, 2010 1:50 PM
    Monday, August 16, 2010 3:07 PM
  • *****************I AM HAVING THIS ISSUE   *****************

    I reply to this thread to hopefully get more attention to this issue and thus a [faster] resolution.   

    *********************************************************
    Thursday, September 09, 2010 1:51 PM
  • *****************I AM HAVING THIS ISSUE   *****************

    I reply to this thread to hopefully get more attention to this issue and thus a [faster] resolution.   

    *********************************************************

     

    Pretty please.... allow admins to play sound on the local 2008 R2 server while using RDP.

     

    I have applications that take advantage of this.

    Friday, October 15, 2010 12:30 AM
  • This needs to be fixed ASAP. We should not have to use third party software for remote desktop to get full functionality.
    Friday, October 15, 2010 9:34 PM
  • Hmmm,

    I read the complete tread on this isseu because I have the same problem. I found the answer to my question and I found the reason why MS did change this. I'm not happy with their discission and I think I have to look into an alternative way to connect to my server. I doubt that MS will ever change this back...

    Tuesday, October 19, 2010 9:24 PM
  • *****************I AM HAVING THIS ISSUE    *****************

    I reply to this thread to hopefully get more attention to this issue and thus a [faster] resolution.    

    *********************************************************
    Tuesday, November 02, 2010 11:10 AM
  • *****************I AM HAVING THIS ISSUE *****************

    I reply to this thread to hopefully get more attention to this issue and thus a [faster] resolution.

    *********************************************************
    Monday, November 15, 2010 9:23 PM
  • *****************I AM HAVING THIS ISSUE *****************

    I reply to this thread to hopefully get more attention to this issue and thus a [faster] resolution.

    *********************************************************

    Friday, November 19, 2010 1:18 PM
  • *****************I AM HAVING THIS ISSUE *****************

    I reply to this thread to hopefully get more attention to this issue and thus a [faster] resolution.

    *********************************************************

    • Proposed as answer by Soundmaker Saturday, November 27, 2010 7:28 PM
    Tuesday, November 23, 2010 5:06 AM
  • So, what's the fuss?

    Just run tsconfig.msc, click RD Session Host Configuration.

    Under "connections" right click RDP-Tcp, under Properties choose "Client settings" tab

    and uncheck "Audio and video playback".

    Works for me :)

    Saturday, November 27, 2010 7:31 PM
  • This must've changed recently because I tried that before and it wouldn't work. It does now. Thanks for the hint!

    BTW in Server 2008 it's just called "Audio".

    Saturday, November 27, 2010 8:19 PM
  • @SoundMaker, what version of 2008 do you have? I'm on Server 2008 Enterprise R2, x64 (V6.0 -- 6002 SP2). Under my "Client Settings" tab, I don't see "Audio and video playback", I just see "Audio", and it's disabled (greyed/grayed out) so I can't uncheck it. I've got all MS updates applied through Windows Update... Clearly this still hasn't been resolved.

    As a sidenote, I found a workaround to at least make the "Play on this computer" Remote Audio function work, by following Gary Snyder's comment at http://www.cyberciti.biz/faq/windows-2003-2008-enable-audio-over-rdp/ - but that's not really what I want: I need the "Play on remote computer" to actually work as it's designed to work if I want it to do so.

    I run a Skype call host which depends on a working soundcard to host a conference, and would like to give employees access to a specifically limited terminal services account to start these calls on demand, but this isn't possible using Server 2008 because of this limitation so I've had to tediously and seemingly unnecessarily set up a separate XP machine to do this instead

    When will someone from Microsoft properly address this for us ?

    Thursday, December 02, 2010 1:55 PM
  • I run Windows Server 2008 Standard SP2 and Soundmaker's solution worked. It used to be greyed out on mine as well but it no longer is. No idea what's changed, if it's on Microsoft's end or if some of the fooling around with drivers I did trying to get this resolved eventually un-greyed the option.
    Thursday, December 02, 2010 10:00 PM
  • *****************I AM HAVING THIS ISSUE *****************

    I reply to this thread to hopefully get more attention to this issue and thus a [faster] resolution.

    *********************************************************

     

    Wednesday, December 15, 2010 9:32 AM
  • *****************I AM HAVING THIS ISSUE *****************

    I reply to this thread to hopefully get more attention to this issue and thus a [faster] resolution.

    *********************************************************

    I have the same issue.  I need Server 2008 to keep playing music over it's box's sound card when I initiate an RDP session.  I have been using VNC as a local workaround, but don't want to use it over the internet.  RDP is just better than VNC anyway.  RDP session kills audio playback about 3 seconds after I connect and no playback devices are available under sound or when I open a playback application.
    • Proposed as answer by pacenv Thursday, December 16, 2010 3:02 AM
    Thursday, December 16, 2010 2:01 AM
  • I have come up with a workaround for some users depending on what you're intended use of playing audio from your server is.  I use my server to play "music on hold" for my phone system.

    As many have mentioned, it's no problem to play audio from a console or VNC session, but as soon as an RDP session is initiated the audio cuts out.

    I will rarely if ever need to modify the music that is playing from iTunes so this is what I did:

    -Create user (such as 'media') just for playing music and add to the 'Server Operators' group.

    -Initiate either a physical console session or a VNC session and log on using this new user account.  Start the media application of choice (such as iTunes).

    -Lock the workstation/switch user if a physical console session or close your VNC connection.  Server 2008 allows multiple physical sessions like Vista and 7 under a domain environment (Fast User Switching).

    -Connect using RDP with any user except for the one you just made ('media') without interrupting audio playback.

    Unfortunately this solution won't work for folks who want to use RDP to change the music that's currently playing.  It really helps me out because it won't stop my music on hold from playing every time I RDP using my administrator account.  I plan on transitioning away from iTunes because it is a huge resource hog (28 MB RAM and .5% CPU on my server) just for playing music.

    Microsoft really needs to fix this issue!!!!

    Hope this helps some people out!

    -Steve
    • Proposed as answer by pacenv Thursday, December 16, 2010 3:07 AM
    Thursday, December 16, 2010 3:07 AM
  • *****************I AM HAVING THIS ISSUE *****************

    I reply to this thread to hopefully get more attention to this issue and thus a [faster] resolution.

    *********************************************************
    Monday, January 03, 2011 1:43 AM
  • To all that post **************************I AM Having this.....

    Please, go to Microsoft Connect and VOTE for a resolution

    http://connect.microsoft.com/WindowsServerFeedback/feedback/details/357040/rdp-session-option-leave-audio-at-remote-seems-not-to-work-when-connection-to-server-2008-64#details

    Tuesday, January 04, 2011 10:21 PM
  • To all that post **************************I AM Having this.....

    Please, go to Microsoft Connect and VOTE for a resolution

    http://connect.microsoft.com/WindowsServerFeedback/feedback/details/357040/rdp-session-option-leave-audio-at-remote-seems-not-to-work-when-connection-to-server-2008-64#details

    Tuesday, January 04, 2011 10:23 PM
  • run -> tsconfig.msc
    properties of your RDP-tcp
    under client settings if your audio is checked here the remote desktop sound will not work.

     

    Ironic that I seek fixes for other audio issues on server 2008.

    Thursday, January 06, 2011 10:20 PM
  • *****************IF YOU HAVE THIS ISSUE  *****************

    I reply to this thread to hopefully get more attention to this issue and thus a [faster] resolution.  

    ********************************************************

    Please remember to mark the replies as answers if they help and unmark them if they provide no help. Raise Yourself To Help Mankind (RYTHM)
    Monday, January 10, 2011 4:35 PM
  • *****************I AM HAVING THIS ISSUE *****************

    I reply to this thread to hopefully get more attention to this issue and thus a [faster] resolution.

    *********************************************************
    Tuesday, February 08, 2011 3:11 PM
  • *****************I AM HAVING THIS ISSUE *****************

    I reply to this thread to hopefully get more attention to this issue and thus a [faster] resolution.

    *********************************************************
    Friday, February 11, 2011 8:24 AM
  • *****************I AM HAVING THIS ISSUE *****************

    I reply to this thread to hopefully get more attention to this issue and thus a [faster] resolution.

    *********************************************************
    Friday, February 11, 2011 12:51 PM
  • Hello All,

    We hear loud and clear the effect of the regression introduced in WS2008 regarding "Play audio at remote computer" (AKA Leave Audio at Remote computer).

    In the meantime there is a workaround (albeit not perfect).

    On the server go to Start -> All Programs -> Administrative Tools -> Remote Desktop Services (Terminal Services) and Remote Desktop Session Host Configuration (Terminal Services configuration)

    Click on "Restrict each user to a single session". In the UI panel uncheck "Restrict each user to a single session"

    Connect to the server with "Play (Leave) audio at the remote computer" Use the same user credentials. You will be connected to a duplicate session and audio playing back through the server's audio card on the original console session will not be interrupted. This is not perfect as you will not be able to add/modify the music you are currently playing.

    Shuba

    [MSFT]


    This posting is provided "AS IS" with no warranties, and confers no rights -- Shuba Iyer
    • Proposed as answer by caveRrr Sunday, August 21, 2011 12:41 PM
    Tuesday, February 15, 2011 1:21 AM
  • Shuba: Thanks very much for the feedback, on behalf of myself and everyone else who's raised this issue. Hoping/looking forward to see this remedied fully in future :-)
    Wednesday, March 09, 2011 4:35 PM
  • Hello,

    Yes this is a change from WS2003 to WS2008. Leave at remote computer has the same effect as Do not Play. Unfortunately there is no work around.

    Thanks.

    Shuba Iyer
    MSFT


    REALLY???   That is the answer from MS? There is no workaround. I convinced several clients to upgrade to Server 2008 and this is a huge issue for some of them. They depend on sound to do their work and I keep telling them MS is working on it. Now I have to go back and tell them that they are screwed??  Come on MS! Get your act together.
    Wednesday, March 09, 2011 5:59 PM
  • Is there any ETA on a solution to this problem? I just bought an upgrade to SBS 2011 and got the nasty surprise that my sound doesn't work anymore.

    I can't use Windows 7 because I use DFS replication, and I apparently can't use Windows Server any longer because I require the sound to play on the local server over RDP. Now I can choose between trying to get DFS to work on Windows 7 (that'll be fun) or go back to 2003. That's far from ideal.

    I'm sure there are n+1 good reasons for why this was changed, but sometimes options that are stupid in most cases can be ideal in a select few. So please put in some obscure option somewhere so that your customers that really, really, want the behavior from 2003 back can have it.

    Together the people having this problem in this thread alone have coughed up a shitload of money for your product, surely that isn't too much to ask?

    Thursday, March 24, 2011 1:03 AM
  • I really need this to work, I was caught by complete surprise when I racked a new Win 2008 Server R2, I didn't expect functionality to be reomoved....for what seems like no reason at all...

     

    I need to move forward with a new Terminal Server running 2008, but sound must be available...I told my supervisor it wouldn't be a problem...a fix would be greatly appreciated...

    This problem seems so odd to me, more random gotchas for IT professionals... I will vote for a fix.

    Monday, April 04, 2011 4:17 PM
  • Just a hunch but give this hotfix a try

    http://support.microsoft.com/kb/973062

    Tuesday, April 05, 2011 12:42 PM
  • *****************I AM HAVING THIS ISSUE *****************


    I reply to this thread to hopefully get more attention to this issue and thus a [faster] resolution. 

    *********************************************************

    I can use Shuba's workaround in the mean time.

    Wednesday, April 06, 2011 12:40 AM
  • *****************I AM HAVING THIS ISSUE *****************


    I reply to this thread to hopefully get more attention to this issue and thus a [faster] resolution. 

    *********************************************************

    Monday, April 11, 2011 10:38 AM
  • *****************I AM HAVING THIS ISSUE *****************


    I reply to this thread to hopefully get more attention to this issue and thus a [faster] resolution. 

    *********************************************************

    Tuesday, April 12, 2011 6:02 PM
  • Given up on finding a resolution to this.  Here is what I suggest: 1) Get an iPhone/iPod/iPad 2) Install iTunes on W2008 R2 3) Install Remote on iPhone/iPod/iTouch 4) Control iTunes library from iPhone/iPod/iPad.  Done.

    What else can you do to get me off your products and services.  So far I have 1) stopped using MSN due to continually losing my stock quotes 2) switched company to using Google for all mail services thanks to Outlook crashing and inability to search mail 3) switched completely off iTunes thanks to this problem 4) nothing to do with anything MS mobile 5) contemplating other development platforms due to outrageous cost of using Visual Studio/MSDN (how can you make debugging a added feature by MSDN level!!!).

    Beautiful strategy.  Keep it up; eventually I'll be done with everything MS.

    Wednesday, April 13, 2011 7:20 PM
  • *****************I AM HAVING THIS ISSUE *****************

    I reply to this thread to hopefully get more attention to this issue and thus a [faster] resolution. 

    *********************************************************
    Saturday, April 16, 2011 9:07 PM
  • *****************I AM HAVING THIS ISSUE *****************

    I reply to this thread to hopefully get more attention to this issue and thus a [faster] resolution. 

    *********************************************************
    Wednesday, April 20, 2011 9:26 AM
  • does anyone has this problem? When connecting to RDP audio works with Media Player but not works when i play youtube both from Mozilla and Internet Explorer????

     

     

    Wednesday, April 20, 2011 10:00 AM
  • *****************I AM HAVING THIS ISSUE *****************

    I reply to this thread to hopefully get more attention to this issue and thus a [faster] resolution. 

    *********************************************************
    Saturday, June 04, 2011 9:49 AM
  • *****************I AM HAVING THIS ISSUE *****************

    I reply to this thread to hopefully get more attention to this issue and thus a [faster] resolution. 

    *********************************************************
    Wednesday, June 08, 2011 1:37 AM
  • *****************I AM HAVING THIS ISSUE *****************

    I reply to this thread to hopefully get more attention to this issue and thus a [faster] resolution. 

    *********************************************************
    Thursday, June 16, 2011 9:01 PM
  • At this point it's pretty clear, MS does not care about this issue and does not plan to support/fix it.  It would be nice to get an answer from MS, but after this long I have no reason to expect one.
    Friday, July 22, 2011 1:20 AM
  • *****************I AM HAVING THIS ISSUE *****************

    I reply to this thread to hopefully get more attention to this issue and thus a [faster] resolution. 

    *********************************************************

    Thursday, August 11, 2011 9:14 PM
  • We are running a radio station here and need Server 2008 to record broadcasts for logging. This is working as long as nobody logs into the Server using rdp. Regardless of which sound settings are configured for the rdp session.  If necessary, we can life with the fact that we can only manage the recording while sitting in front of the machine, but there are a lot of other tasks which need to be done remotely. It is really a strange feature that the audio support stops on the local machine when someone logs in to it remotely.
    Is there a solution yet? 
    Thursday, August 18, 2011 8:10 AM
  • *****************I AM HAVING THIS ISSUE *****************

    I reply to this thread to hopefully get more attention to this issue and thus a [faster] resolution. 

    *********************************************************
    Thursday, August 18, 2011 6:21 PM
  • *****************I AM HAVING THIS ISSUE *********************************************

    I reply to this thread to hopefully get more attention to this issue and thus a [faster] resolution.

    *************************************************************************************
    Friday, August 19, 2011 12:18 PM
  • in addition to the sugested work around by Shuba Iyer, when you are connected to the dublicate session and you want to administrate something running as another user, use the taskmanager, users tab, right click on the user you want to connect to and select remote control. prior to this you have to configure the remote control to auto accept remote control requests since the default value is to deny. this will allow you to keep audio running without interuption. remember to watch out for duplicated startup items, I had to do some scripting to avoid things starting up again.

     


    • Edited by caveRrr Sunday, August 21, 2011 1:00 PM more details
    Sunday, August 21, 2011 12:45 PM
  • *****************I AM HAVING THIS ISSUE *****************

    I reply to this thread to hopefully get more attention to this issue and thus a [faster] resolution. 

    *********************************************************

    Friday, August 26, 2011 11:58 AM
  • *****************I AM HAVING THIS ISSUE *****************

    I reply to this thread to hopefully get more attention to this issue and thus a [faster] resolution. 

    *********************************************************
    Sunday, August 28, 2011 9:20 PM
  • I am also having this issue.  I need an audio output device for audio monitoring on my system.

     

    Monday, August 29, 2011 11:49 PM
  • *****************I AM HAVING THIS ISSUE *****************

    I reply to this thread to hopefully get more attention to this issue and thus a [faster] resolution. 

    *********************************************************

    Emmett
    Saturday, September 03, 2011 12:53 AM
  • To enable audio  rediection when connecting to a 2008 server
    Run: tsconfig on server.
     
    Click on the connect to change to open it's properties window.
     
    Click on "Client Setting tab"
     
    Under Redirection grouping:
       Deselect: Audio and Video playback
       Deselect: Auto recording
    Click Apply button
     
     
     
     
    Wednesday, September 07, 2011 7:12 PM
  • Hello Steve

     

    I have done that and restarted and tried to reinstall drivers for my Creative Sound Card. There must be something else preventing me from using the sound card when I remote in.

     

    Emmett


    Emmett
    Wednesday, September 07, 2011 9:23 PM
  • try not to remove any permissions on the security tab. just leave the default security and then give a try. add RDP user groups under the remote desktop group locally on the server.

     

    hope this works

    • Proposed as answer by Ricky Wallace Monday, October 10, 2011 11:04 AM
    Monday, October 10, 2011 11:04 AM
  • Hello Ricky

     

    Did this get yours working? I saw you had the same problem at one time.

     

    Emmett


    Emmett
    Monday, October 10, 2011 10:30 PM
  • Yes Emmeet. I get mine working without changing permissions.

    Hope this working also for you

    Tuesday, October 11, 2011 8:23 AM
  • *****************I AM HAVING THIS ISSUE ***************** I reply to this thread to hopefully get more attention to this issue and thus a [faster] resolution. *********************************************************
    Monday, November 28, 2011 12:12 PM
  • *****************I AM HAVING THIS ISSUE ***************** I reply to this thread to hopefully get more attention to this issue and thus a [faster] resolution. *********************************************************

    Thursday, December 15, 2011 12:21 AM
  • *****************I AM HAVING THIS ISSUE *****************

    I reply to this thread to hopefully get more attention to this issue and thus a [faster] resolution. 

    *********************************************************
    Sunday, December 25, 2011 7:07 PM
  • *****************I AM HAVING THIS ISSUE ***************** I reply to this thread to hopefully get more attention to this issue and thus a [faster] resolution. *********************************************************
    Sunday, January 01, 2012 11:00 PM
  • Help !! having the same problem any third party have a solution like elusive sound over RDP server and workstation? Bill *****************I AM HAVING THIS ISSUE ***************** I reply to this thread to hopefully get more attention to this issue and thus a [faster] resolution. *********************************************************
    Tuesday, January 31, 2012 10:15 PM
  • What a mess this is .... We have several hundred servers in remote locations that have no access for a "local" console.  We must be able to log into the machines remotely to perform such things as updates/ and patches and new software. 

    Now I'm told that this was indeed a design decision by MS as a security plug to prevent a virus that infects the remote audio driver via a remote connecton from spreading to the entire machine. 

    A person would think that if that is the case, Microsoft would have a work around ( a way to disable that "feature") while letting a customer assume the risk of the Virus infection, especially since the people working with these issues will know what 3rd party security they are using to prevent such an attack.

    As it is right now, there is no way that we would be able to use Windows 2008 R2 for our purposes, which means that we have to go looking for another solution and incure enormous expense in doing so, this is completely unacceptable!!!!!

    Friday, February 10, 2012 6:33 PM
  • Youre right. Microsoft should have at least thought about this being a HOME SERVER. To not allow me to Remote in from my pc and control my music on my Server in my house is not right and unacceptable.

    Now will they do something about it. NO. Not unless a lot more people complain about it than what I see.


    Emmett

    Friday, February 10, 2012 10:18 PM
  • *****************I AM HAVING THIS ISSUE ***************** (Windows Server 2008 R2)

    I reply to this thread to hopefully get more attention to this issue and thus a [faster] resolution. 

    *********************************************************
    Tuesday, February 21, 2012 9:39 PM
  • *****************I AM HAVING THIS ISSUE ***************** (Windows Server 2008 R2)

    I reply to this thread to hopefully get more attention to this issue and thus a [faster] resolution. 

    *********************************************************
    Tuesday, March 06, 2012 1:02 PM
  • *****************I AM HAVING THIS ISSUE ***************** (Windows Server 2008 R2)

    I reply to this thread to hopefully get more attention to this issue and thus a [faster] resolution.

    *********************************************************
    Wednesday, March 21, 2012 4:04 AM
  • Ich habe das selbe Problem! *grrrrrr*
    Sunday, April 15, 2012 10:20 AM
  • Ich habe jetzt Tight VNC installiert. Hier funktioniert es.

    Das hilft wahrscheinlich nicht jedem.

    In meinem Fall wollt ich Spotify auf dem WHS abspielen und Remote per App steuern.

    Sunday, April 15, 2012 10:28 AM
  • I came across this same issue with Windows Homer Server 2011 which is based on 2008 R2.  Thankfully though, I wanted to play iTunes through to my stereo and this software lets me do it by running iTunes as a background service - and the audio works!  I can't play it through an RDP session but this works a treat.

    http://www.bizmodeller.com/iHomeServer_for_iTunes.aspx

    Monday, April 16, 2012 8:56 PM
  • My Workaround is based on MS Mesh, but I realy appreciate a solution with RDP
    Sunday, May 06, 2012 7:18 PM
  • Add me to this list.  My current solution is to repurpose an old ipad, but I'd like nothing more than to be able to uninstall itunes.
    Tuesday, June 19, 2012 2:25 AM
  • Arrghhh, this needs to be fixed.  MS, please, for the love of God, fix this....
    Thursday, June 21, 2012 3:23 PM
  • Hello,

    Yes this is a change from WS2003 to WS2008. Leave at remote computer has the same effect as Do not Play. Unfortunately there is no work around.

    Thanks.

    Shuba Iyer
    MSFT

    Same problem on WHS2011. I gave up on finding a solution.. I propose to install windows live mesh on the server. It works perfectly. As long as mesh stays around... 

    Bass and treble are inseparable. Music sounds bad with either absent. The same applies to us The Oh Brothers.

    Thursday, July 05, 2012 7:51 PM
  • Same problem with Windows Home Server 2011. No solution by Microsoft? Server is a sh**
    Sunday, July 29, 2012 10:51 PM
  • The TSconfig thing works, I can run winamp from 2k8R2, though it can be jerky if I'm doing too much on my crappy TWC cable modem, which isn't MSFT's fault.

    Make sure your mstsc.exe is configured to play on the remote computer, not local.  Run the tsconfig.msc and ensure audio isn't disabled.  Ensure audio is enabled in your 2k8 server.

    I attached a screenshot of my winamp options, though I did change the waveout to remote audio (it worked before with the MS Sound Mapper too)


    As far as I am concerned, this isn't a 2k8 limitation, as it runs for me.

    Good luck.

    Friday, August 10, 2012 4:44 PM
  • You guys better use Real VNC Remote Software. It is the best solution for you guys. 

    Cheers,

    Ethan

    Saturday, August 18, 2012 7:21 AM
  • I have a server with an M-Audio 1010LT audio card installed, running audio playback software.  This software needs to stay running and playing at all times.
     
    We were previously running Windows Server 2003 and when we RDPed into the box for maintenance, we simply made sure that 'Leave at remote computer" was selected under Remote Desktop's sound settings.  This allowed us to control the console of the server while the audio continued to play through the server's audio card.
     
    Now, with Windows Server 2008, even with this option selected when we remote into this server all audio stops and Windows shows no available audio devices.  If I end my RDP session and phyically go to the server, I see the audio devices and am able to re-start the audio playback.
     
    Is this a bug, or something that has changed in 2008?  Any workarounds?

    Thanks

    You better use Real VNC Remote Software. It is the best solution for you guys. 

    Cheers,

    Ethan

    Saturday, August 18, 2012 7:52 AM
  • Hey Guys,

    I've just installed Windows server 2012 and this is no longer an issue, I'm able to play sound out of the sever's sound card when in a RDP session, I can stop the music, select different tracks, all works with no issues.

    I realise the upgrade to 2012 is a big task for many, but if leaving audio at the remote machine for an RDP connection is a deal breaker, it's the way to go.

    Just wanted to share the good news


    • Edited by stevenajack Monday, November 26, 2012 11:44 PM Spelling and grammar
    Monday, October 01, 2012 1:34 PM
  • I suppose no updates on this?

    I've installed RDS on a 2008 R2 machine for external access and internal use to record video conferences via third party software that depends on audio.

    Looks like we'll be using 2003 R2 for TS.

    This is absurdly bloody rediculous!

    And for all those that say it's a non issue or fixed now, please read carefully, we want to Play on remote computer, not Play on this computer.

    With 2012 released now, any original posters tried it?

    (I may next week for the halibut)

    Friday, October 05, 2012 6:19 PM
  • I reply to this thread to hopefully get more attention to this issue and thus a [faster] resolution.
    Monday, October 15, 2012 7:32 PM
  • The resolution is an upgrade to Windows Server 2012,  As I understand the issue it's a security "Feature" which Microsoft introduced to stop a maliciously crafted audio driver on a remote machine from infecting the network.  Clearly they have found away around this in Server 2012, it's a big upgrade I know and clearly will cost money both in the licence and in the time spent managing the upgrade but server 2012 rocks.  The fact that this issue is fixed , plus a whole load of revamped admin tools make it well worth a look.
    Monday, November 26, 2012 11:49 PM
  • hello all,

    four years... thats a long time. i found this thead a few days ago, because i was looking for a solution for this problem with my itunes-server running on 2008 r2. this is my workaround and maybe someones solution too?!

    www.howwe.de/itunesserver2008r2.pdf

    i wrote it in german, but the pictures are international... :-)

    Thursday, February 07, 2013 4:10 PM

  • Ok guys I got er figured! First off set your audio preference in your RDP session to what ever you like. ( Leave on remote computer or bring to local computer). Whether your using active directory or not, open a run window and type mmc.exe. Then under file menu click Add/Remove snapin, click "Configure Remote Desktop Session Host settings" and click "add", select local computer and click "ok", then "ok", then double click RD Session host configuration, then double click "RDP-TCP" on the client setting tab unselect (Audio and Video Playback, and audio Recording) then click "ok", then under the file menu click "save as".(name it something you'll remember then save it to default location). If you have Active directory installed you have one more step. Click start,administrative tools, group policy management. Now right click the GPO that you are currently using and click "edit", then expand computer configuration\administrative templates\windows components\remote desktop services\remote desktop session host\device and resource redirection, double click "Allow Audio and video playback redirection". select enable, then click "ok". Restart System! That should be it! Cheers!
    • Proposed as answer by jasonabbott69 Sunday, March 24, 2013 7:52 AM
    Sunday, March 24, 2013 7:51 AM
  • In case anyone else finds this thread and suffers though this issue, there is a hotfix available:

    http://support.microsoft.com/kb/973062

    There are 32-bit and 64-bit versions of this hotfix but you have to "unhide" the 64-bit version.  I will never understand Microsoft's logic and decision making as long as I live :/

    ONLY this fixed the issue for me.  None of the suggestions above worked or were suitable.

    Good luck!!

    Sunil

    Saturday, August 03, 2013 2:08 AM
  • Nah! This is a hotfix for Mac-RDP Client. My solution until now: I use a soundcard that supports ASIO. Microsoft did not manage to f*ck up ASIO. For example Foobar2000 can play audio throug ASIO. This works fine for me.
    Thursday, May 22, 2014 2:50 PM
  • So, what's the fuss?

    Just run tsconfig.msc, click RD Session Host Configuration.

    Under "connections" right click RDP-Tcp, under Properties choose "Client settings" tab

    and uncheck "Audio and video playback".

    Works for me :)

    This does not work for keeping the audio at the remote computer (server). 

    It does however enable the audio to be brought to the RDP client computer. 

    I need to keep the audio at the remote computer and not have it killed when I connect to the server via RDP what was the solution for that? 

    Thanks

    Tuesday, June 24, 2014 2:43 PM
  • Hello All,

    We hear loud and clear the effect of the regression introduced in WS2008 regarding "Play audio at remote computer" (AKA Leave Audio at Remote computer).

    In the meantime there is a workaround (albeit not perfect).

    On the server go to Start -> All Programs -> Administrative Tools -> Remote Desktop Services (Terminal Services) and Remote Desktop Session Host Configuration (Terminal Services configuration)

    Click on "Restrict each user to a single session". In the UI panel uncheck "Restrict each user to a single session"

    Connect to the server with "Play (Leave) audio at the remote computer" Use the same user credentials. You will be connected to a duplicate session and audio playing back through the server's audio card on the original console session will not be interrupted. This is not perfect as you will not be able to add/modify the music you are currently playing.

    Shuba

    [MSFT]


    This posting is provided "AS IS" with no warranties, and confers no rights -- Shuba Iyer

    This work around works, when you RDP in to the server the music playback on the server continues and you then have access to the server desktop for administration purposes etc.

    However as Shuba said if you wanted to control the music application you cannot as your in a different session.

    Looks like VNC is the answer then? 

    Cheers

    Tuesday, June 24, 2014 3:04 PM