none
How to upgrade to RDP 8.0 on Windows 7 Home Premium?

    Question

  • I recently saw the Microsoft blog entry describing the new features of RDP 8.0 and how to enable this new functionality.  (This blog suggested posting to this forum, although I see this forum appears to be a server forum ... so possible apologies in advance)

    http://support.microsoft.com/kb/2592687

    I successfully upgraded a Win7 Ultimate (x64) and Win7 Enterprise (x64) machine following these instructions. I also have a Win7 Home Premium (x64) machine which obviously does not have the "Local Group Policy Editor" and the instructions only reference policies and not registry entries.

    I eventually took snapshots of my registry on my Win7 Ultimate machine before and after changing the policies to determine the registries keys changed. Here are the keys I noted and tried incorporating into my Win7 Home Premium machine which did not work.



    [HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows NT\TerminalServices]

    "fServerEnableRDP8"=dword:00000001
    "SelectTransport"=dword:00000000

    [HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Policies\Microsoft\Windows NT\Terminal Services]

    "fServerEnableRDP8"=dword:00000001
    "SelectTransport"=dword:00000000



    Any thoughts, ideas, or instructions for next steps would be appreciated. (UDP support and a resizable connection bar alone make this a worthwhile update for me!)

    Sincerely,
    Mike

    Thursday, November 01, 2012 10:27 PM

Answers

  • Hi Mike,

    To get resizable connection bar and RD Client UDP support when connecting to RDP 8.0 hosts all you need to do is install the two updates (no reg edits).  If you want to get RemoteFX Dynamic USB redirection you would need to try adding the necessary policy registry entries.

    -TP

    • Marked as answer by TurdBurgler Friday, November 02, 2012 12:28 AM
    Thursday, November 01, 2012 11:13 PM

All replies

  • Hi Mike,

    To get resizable connection bar and RD Client UDP support when connecting to RDP 8.0 hosts all you need to do is install the two updates (no reg edits).  If you want to get RemoteFX Dynamic USB redirection you would need to try adding the necessary policy registry entries.

    -TP

    • Marked as answer by TurdBurgler Friday, November 02, 2012 12:28 AM
    Thursday, November 01, 2012 11:13 PM
  • Thanks TP.

    Your response got me thinking about the order in which the 2 updates were applied.  I uninstalled both updates and reapplied them in the correct order and everything is working as intended now.  (Woot!)

    One quick clarification.  How do you know that UDP support is enabled by default when the original policy changes specifically call out updating that policy to use both TCP and UPD?

    Sincerely,
    Mike

    Friday, November 02, 2012 12:28 AM
  • Hi Mike,

    The update may be categorized two different ways:

    RDP Server capabilities.  This applies when another computer makes an incoming Remote Desktop connection to the machine.  For example, the PC is running Windows 7 SP1 Ultimate/Enterprise with RDP 8.0 update, and you use Remote Desktop Connection on a Windows 8 PC to make a connection to it.  In this example the PC is considered a server.

    RDP Client capabilities.  This applies when Remote Desktop Connection client makes an outgoing connection to another computer.  For example, the PC is running Windows 7 SP1 Home Premium with RDP 8.0 update, and you use Remote Desktop Connection 8.0 (6.2.9200) to connect to a Server 2012.  In this example the PC is considered a client.

    To put it in context, Windows 7 Home Premium can only be a RDP Client, so the server capabilities of the update do not apply.  By default, the RD Client 8.0 supports UDP and TCP when connecting to a RDP 8.0 endpoint, therefore, no registry edits are necessary.

    Both the Enable Remote Desktop Protocol 8.0 and Select RDP transport protocols group policy settings only apply to RDP servers (Win7 Ult/Ent with RDP 8.0 update, Win8, Server 2012).

    -TP

    Friday, November 02, 2012 2:53 AM
  • Thanks TP ... your explanation was very clear and makes sense!  I appreciate you taking the time to respond.
    Friday, November 02, 2012 2:01 PM